On Tue, Jan 31, 2017 at 07:16:04AM -0500, Frediano Ziglio wrote:
> > 
> > From: Victor Toso <m...@victortoso.com>
> > 
> > As there is a need to iterate over every encoder:codec pair and we do
> > a check for every encoder and every codec, g_strsplit() is less
> > complex and easier to follow.
> > 
> > This change makes much easier to extend the input which is currently a
> > list of tuples encoder:video-codec.
> > 
> > Signed-off-by: Victor Toso <victort...@redhat.com>
> 
> I had a though this morning about the syntax.
> 
> We are moving from a set or "encoder:codec" separated with ";" to
> a set of "encoder:codec:priority". All this to allow same priority in
> the list. Why not having a "light" separator, something like
> 
> "gstreamer:vp8 gstreamer:h264;gstreamer:h264;spice:mjpeg"
> 
> (not the space). So the first 2 will have same "priority" while
> the others less (but different) ?

Do we need to have an extra-smart string-based syntax like this? Or can
we side-step this problem by having a higher-level API?

Christophe

Attachment: signature.asc
Description: PGP signature

_______________________________________________
Spice-devel mailing list
Spice-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/spice-devel

Reply via email to