CVSROOT: /cvs Module name: src Changes by: [email protected] 2026/09/02 13:01:29
Modified files:
sys/arch/amd64/amd64: vmm_machdep.c
sys/dev/vmm : vmm.c vmm.h
Log message:
Centralize vmm(4) vcpu yield logic.
Put all checks for "should the vcpu yield?" into the same function
and rename it to better fit semantics ("stop" -> "yield"). This
pulls in some scheduler flag checks that were duplicated between
amd64 cpu-dependent code paths.
sure, mlarkin@
