On Mon, 4 Nov 2024 02:12:40 GMT, David Holmes <dhol...@openjdk.org> wrote:

>> Patricio Chilano Mateo has updated the pull request incrementally with one 
>> additional commit since the last revision:
>> 
>>   Use lazySubmitRunContinuation when blocking
>
> src/hotspot/share/classfile/javaClasses.cpp line 2107:
> 
>> 2105: 
>> 2106: jlong java_lang_VirtualThread::waitTimeout(oop vthread) {
>> 2107:   return vthread->long_field(_timeout_offset);
> 
> Not sure what motivated the name change but it seems odd to have the method 
> named differently to the field it accesses. ??

It was initially parkTimeout and waitTimeout but it doesn't require two fields 
as you can't be waiting in Object.wait(timeout) and LockSupport.parkNanos at 
the same time. So the field was renamed, the accessors here should probably be 
renamed too.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/21565#discussion_r1827219720

Reply via email to