On Sat, 22 Mar 2025 20:38:19 GMT, Volodymyr Paprotski <vpaprot...@openjdk.org> 
wrote:

>> Ferenc Rakoczi has updated the pull request incrementally with two 
>> additional commits since the last revision:
>> 
>>  - Further readability improvements.
>>  - Added asserts for array sizes
>
> src/hotspot/cpu/x86/stubGenerator_x86_64_dilithium.cpp line 119:
> 
>> 117: static address dilithiumAvx512PermsAddr() {
>> 118:   return (address) dilithiumAvx512Perms;
>> 119: }
> 
> Hear me out..  ...
> enums!!
> 
> enum nttPermOffset {
>   montMulPermsIdx = 0,
>   nttL4PermsIdx = 64,
>   nttL5PermsIdx = 192,
>   nttL6PermsIdx = 320,
>   nttL7PermsIdx = 448,
>   nttInvL0PermsIdx = 704,
>   nttInvL1PermsIdx = 832,
>   nttInvL2PermsIdx = 960,
>   nttInvL3PermsIdx = 1088,
>   nttInvL4PermsIdx = 1216,
> };
> static address dilithiumAvx512PermsAddr(nttPermOffset offset) {
>   return (address) dilithiumAvx512Perms + offset;
> }

belay that comment.. now that I looked at 
`generate_dilithiumAlmostInverseNtt_avx512`, I see why thats not the 'entire 
picture'..

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/23860#discussion_r2008978604

Reply via email to