Hi,
Questions and comments below...
Thanks.
On 10/9/19 3:53 AM, Daniel Kiper wrote:
> Suggested-by: H. Peter Anvin
> Signed-off-by: Daniel Kiper
> Reviewed-by: Konrad Rzeszutek Wilk
> Reviewed-by: Ross Philipson
> ---
> ---
> Documentation/x86/boot.rst | 121
> +++
On 10/10/19 2:43 AM, Daniel Kiper wrote:
> On Wed, Oct 09, 2019 at 05:43:31PM -0700, Randy Dunlap wrote:
>> Hi,
>>
>> Questions and comments below...
>> Thanks.
>>
>> On 10/9/19 3:53 AM, Daniel Kiper wrote:
>>
>>> Suggested-by: H. Peter A
On 05/10/2018 01:06 AM, Jiri Slaby wrote:
> ---
> Documentation/asm-annotations.rst | 218
> arch/x86/include/asm/linkage.h| 10 +-
> include/linux/linkage.h | 257
> --
> 3 files changed, 475 insertions(+), 10 d
Hi,
On 03/20/2018 12:18 PM, Maran Wilson wrote:
> In order to pave the way for hypervisors other then Xen to use the PVH
than
> entry point for VMs, we need to factor the PVH entry code into Xen specific
> and hypervisor agnostic components. The f
On 07/23/2018 02:34 PM, Mark Railton wrote:
> Fixed issue with multi line comment
Fix [not Fixed]
>
> Signed-off-by: Mark Railton
> ---
> drivers/xen/xlate_mmu.c | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/xen/xlate_mmu.c b/drivers/xen/xlate_mmu.c
> i
On 07/23/2018 02:40 PM, Mark Railton wrote:
> On Mon, Jul 23, 2018 at 02:38:20PM -0700, Randy Dunlap wrote:
>> On 07/23/2018 02:34 PM, Mark Railton wrote:
>>> Fixed issue with multi line comment
>>
>> Fix [not Fixed]
>>
>>>
>>> Signed-off-by:
On 07/23/2018 02:48 PM, Mark Railton wrote:
> On Mon, Jul 23, 2018 at 02:44:28PM -0700, Randy Dunlap wrote:
>> On 07/23/2018 02:40 PM, Mark Railton wrote:
>>> On Mon, Jul 23, 2018 at 02:38:20PM -0700, Randy Dunlap wrote:
>>>> On 07/23/2018 02:34 PM, Mark Railton wrote
On 05/23/2018 12:54 PM, Thomas Garnier wrote:
> Provide an option to have a PROVIDE_HIDDEN (linker script) entry for
> each weak symbol. This option solve an error in x86_64 where the linker
solves
> optimizes pie generate code to be non-pie because --emit-relocs w
Hi,
(for several patches in this series:)
The commit message is confusing. See below.
On 05/23/2018 12:54 PM, Thomas Garnier wrote:
> Adapt module loading to support PIE relocations. Generate dynamic GOT if
> a symbol requires it but no entry exist in the kernel GOT.
On 05/23/2018 03:01 PM, Thomas Garnier wrote:
> On Wed, May 23, 2018 at 2:27 PM Randy Dunlap wrote:
>
>> Hi,
>
>> (for several patches in this series:)
>> The commit message is confusing. See below.
>
> Thanks for the edits, I will change the different comm
On 11/15/18 7:45 AM, Souptick Joarder wrote:
> Previouly drivers have their own way of mapping range of
> kernel pages/memory into user vma and this was done by
> invoking vm_insert_page() within a loop.
>
> As this pattern is common across different drivers, it can
> be generalized by creating a
On 11/16/18 12:15 AM, Souptick Joarder wrote:
> On Fri, Nov 16, 2018 at 12:11 PM Matthew Wilcox wrote:
>>
>> On Fri, Nov 16, 2018 at 11:00:30AM +0530, Souptick Joarder wrote:
>>> On Thu, Nov 15, 2018 at 11:44 PM Randy Dunlap wrote:
>>>> On 11/15/18 7:45 AM,
On 11/9/20 11:26 PM, Mauro Carvalho Chehab wrote:
> Hi Jonathan,
>
> Let's view ABI from the PoV of a system admin that doesn't know
> yet about a certain ABI symbol.
>
> He'll try to seek for the symbol, more likely using the HTML
> documentation. Only very senior system admins might try to tak
On 11/13/20 3:52 PM, Daniel Kiper wrote:
> Hey,
>
>
> Here is the description (pseudocode) of the structures which will be
> used to store the log data.
>
> Anyway, I am aware that this is not specification per se.
Yes, you have caveats here. I'm sure that you either already know
or would lear
On 2/3/21 11:58 AM, Shuah Khan wrote:
> I am seeing the following compile error on Linux 5.11-rc6.
> No issues on 5.11.0-rc5 with the same config.
>
> ld: arch/x86/built-in.a: member arch/x86/kernel/pci-swiotlb.o in archive is
> not an object
> make: *** [Makefile:1170: vmlinux] Error 1
>
> CONF
Drop the repeated word "of" in a comment.
Signed-off-by: Randy Dunlap
Cc: Boris Ostrovsky
Cc: Juergen Gross
Cc: xen-devel@lists.xenproject.org
---
include/uapi/xen/gntdev.h |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- linux-next-20200717.orig/include/uapi/xe
Change the repeated word "as" to "as a".
Signed-off-by: Randy Dunlap
Cc: Boris Ostrovsky
Cc: Juergen Gross
Cc: xen-devel@lists.xenproject.org
---
arch/x86/include/asm/xen/hypercall.h |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- linux-next-20200720.orig/
On 8/12/20 7:57 AM, Randy Dunlap wrote:
> On 8/11/20 9:22 PM, Stephen Rothwell wrote:
>> Hi all,
>>
>
>
> on x86_64:
>
> ../arch/x86/pci/xen.c: In function ‘pci_xen_init’:
> ../arch/x86/pci/xen.c:410:2: error: implicit declaration of function
> ‘acpi_no
From: Randy Dunlap
Fix build error when CONFIG_ACPI is not set/enabled:
../arch/x86/pci/xen.c: In function ‘pci_xen_init’:
../arch/x86/pci/xen.c:410:2: error: implicit declaration of function
‘acpi_noirq_set’; did you mean ‘acpi_irq_get’?
[-Werror=implicit-function-declaration
Hi Konrad,
ping.
I am still seeing this build error. It looks like this is
in your territory to merge...
On 8/13/20 4:00 PM, Randy Dunlap wrote:
> From: Randy Dunlap
>
> Fix build error when CONFIG_ACPI is not set/enabled:
>
> ../arch/x86/pci/xen.c: In function ‘pci_xen_init’
m_op.h:63:1: error: type defaults to ‘int’ in
declaration of ‘DEFINE_GUEST_HANDLE_STRUCT’ [-Werror=implicit-int]
../include/xen/interface/hvm/hvm_op.h:63:1: warning: parameter names (without
types) in function declaration
Full randconfig file is attached.
--
~Randy
Reported-by: Randy D
It is better/preferred not to include file names in source files
because (a) they are not needed and (b) they can be incorrect,
so just delete this incorrect file name.
Signed-off-by: Randy Dunlap
Cc: Boris Ostrovsky
Cc: Juergen Gross
Cc: Stefano Stabellini
Cc: xen-devel@lists.xenproject.org
Add missing ioctl "magic numbers" for various Xen interfaces
(xenbus_dev.h, gntalloc.h, gntdev.h, and privcmd.h).
Signed-off-by: Randy Dunlap
Cc: Boris Ostrovsky
Cc: Juergen Gross
Cc: Stefano Stabellini
Cc: xen-devel@lists.xenproject.org
---
Documentation/userspace-api/ioctl/ioctl-
On 1/30/22 22:46, Juergen Gross wrote:
> On 30.01.22 20:17, Randy Dunlap wrote:
>> It is better/preferred not to include file names in source files
>> because (a) they are not needed and (b) they can be incorrect,
>> so just delete this incorrect file name.
>>
>
Hi--
On 1/30/22 22:55, Juergen Gross wrote:
> On 30.01.22 20:23, Randy Dunlap wrote:
>> Add missing ioctl "magic numbers" for various Xen interfaces
>> (xenbus_dev.h, gntalloc.h, gntdev.h, and privcmd.h).
>>
>> Signed-off-by: Randy Dunlap
>> Cc: B
Add missing ioctl "magic numbers" for various Xen interfaces
(xenbus_dev.h, gntalloc.h, gntdev.h, and privcmd.h).
Signed-off-by: Randy Dunlap
Cc: Boris Ostrovsky
Cc: Juergen Gross
Cc: Stefano Stabellini
Cc: xen-devel@lists.xenproject.org
---
v2: fix copy-pasta error: change 'E&
On 8/30/22 14:49, Suren Baghdasaryan wrote:
> From: Kent Overstreet
>
> This adds a new fault injection capability, based on code tagging.
>
> To use, simply insert somewhere in your code
>
> dynamic_fault("fault_class_name")
>
> and check whether it returns true - if so, inject the error
On 8/30/22 14:49, Suren Baghdasaryan wrote:
> diff --git a/lib/Kconfig.debug b/lib/Kconfig.debug
> index b7d03afbc808..b0f86643b8f0 100644
> --- a/lib/Kconfig.debug
> +++ b/lib/Kconfig.debug
> @@ -1728,6 +1728,14 @@ config LATENCYTOP
> Enable this option if you want to use the LatencyTOP
Hi,
Please look at
https://lore.kernel.org/lkml/caa42ikx2f2lsaq9c5rxnctphob6n+l35winc5wk1k2eysaj...@mail.gmail.com/T/#u
and see if that matches what you thought you sent as a patch.
The gmail web interface is notorious for dropping tabs in emails.
On 12/13/22 09:35, Seija K. wrote:
> There
r Documentation/doc-guide/kernel-doc.rst
* Allocate all required structures to mange shared buffer.
xen-front-pgdir-shbuf.c:510: warning: This comment starts with '/**', but isn't
a kernel-doc comment. Refer Documentation/doc-guide/kernel-doc.rst
* Allocate a new instance of a
On 4/27/22 15:49, Guilherme G. Piccoli wrote:
> + crash_kexec_post_notifiers
> + This was DEPRECATED - users should always prefer the
This is DEPRECATED - users should always prefer the
> + parameter "panic_notifiers_level" -
ing_vfree
xenbus_client.c:727: warning: No description found for return value of
'xenbus_unmap_ring_vfree'
xenbus_client.c:919: warning: missing initial short description on line:
* xenbus_read_driver_state
xenbus_client.c:926: warning: No description found for return value of
'xenbus_read_drive
On 12/7/23 01:27, Juergen Gross wrote:
> On 06.12.23 19:17, Randy Dunlap wrote:
>> Correct function kernel-doc notation to prevent warnings from
>> scripts/kernel-doc.
>>
>>
>> Signed-off-by: Randy Dunlap
>> Cc: Juergen Gross
>> Cc: Stefano Stabel
On 1/24/24 19:43, Stephen Rothwell wrote:
> Hi all,
>
> News: there will be no linux-next release on Friday
>
> Changes since 20240124:
>
on x86_64:
when CONFIG_VMCORE_INFO is not set:
ld: arch/x86/xen/mmu_pv.o: in function `paddr_vmcoreinfo_note':
mmu_pv.c:(.text+0x468d): undefined referen
On 3/24/21 11:55 AM, Stefano Stabellini wrote:
> On Wed, 24 Mar 2021, Bhaskar Chowdhury wrote:
>> s/acrros/across/
>>
>> Signed-off-by: Bhaskar Chowdhury
>
> Reviewed-by: Stefano Stabellini
>
>
Hi,
It seems to me like some of those "page" should be "pages".
>> ---
>> arch/arm/xen/mm.c | 2 +
On 3/24/21 9:35 PM, Bhaskar Chowdhury wrote:
> s/acrros/across/
>
> Plus some words need prural version...so did it.(page->pages)
>
> Signed-off-by: Bhaskar Chowdhury
Acked-by: Randy Dunlap
> ---
> Changes from V1:
> Randy's findings incorporated.
>
36 matches
Mail list logo