Re: [Xen-devel] [Qemu-devel] [PATCH v3 1/5] elf: Add optional function ptr to load_elf() to parse ELF notes

2019-01-15 Thread BALATON Zoltan
_elf already seems to have too many usually NULL parameters so not adding one more which needs changing so many files seems like a good idea to me and it seems previously adding wrappers for this was the preferred way.. Regards, BALATON Zoltan which needs to read the XEN_ELFNOTE_PHYS

Re: [PATCH 1/5] hw/pci-host/bonito: Make PCI_ADDR() macro more readable

2020-10-12 Thread BALATON Zoltan
) << 8) + (regno)) Are you missing a << 8 somewhere before + (regno) or both of these are equally unreadable and I've missed something? This seems to be completely replaced by next patch so what's the point of this change? Regards, BALATON Zoltan typedef struct BonitoState BonitoState;

Re: [PATCH v2 04/11] hw/arm: Restrit KVM to the virt & versal machines

2021-02-22 Thread BALATON Zoltan
On Fri, 19 Feb 2021, Philippe Mathieu-Daudé wrote: Restrit KVM to the following ARM machines: Typo: "Restrict" (also in patch title). Regards, BALATON Zoltan - virt - xlnx-versal-virt Signed-off-by: Philippe Mathieu-Daudé --- hw/arm/virt.c | 5 + hw/arm/xlnx-ver

Re: [PATCH 22/26] hw/usb/usb-hcd: Use OHCI type definitions

2020-07-04 Thread BALATON Zoltan
uot;hw/usb" headers. Suggested-by: BALATON Zoltan Signed-off-by: Philippe Mathieu-Daudé --- hw/usb/hcd-ohci.h| 2 +- include/hw/usb/usb-hcd.h | 16 I wonder if we need a new header for this or these could just go in the new public hw/usb/usb.h as machines creating

Re: [PATCH 23/26] hw/usb/usb-hcd: Use EHCI type definitions

2020-07-04 Thread BALATON Zoltan
uot;hw/usb" headers. Suggested-by: BALATON Zoltan Signed-off-by: Philippe Mathieu-Daudé --- hw/usb/hcd-ehci.h | 11 +-- include/hw/usb/chipidea.h | 2 +- include/hw/usb/usb-hcd.h | 11 +++ hw/arm/allwinner-h3.c | 1 - hw/arm/exynos4210.c | 2 +- hw

Re: [PATCH 24/26] hw/usb/usb-hcd: Use UHCI type definitions

2020-07-04 Thread BALATON Zoltan
uot;hw/usb" headers. Suggested-by: BALATON Zoltan Signed-off-by: Philippe Mathieu-Daudé --- include/hw/usb/usb-hcd.h | 6 ++ hw/i386/pc_piix.c| 3 ++- hw/i386/pc_q35.c | 13 +++-- hw/isa/piix4.c | 3 ++- hw/mips/fuloong2e.c | 5 +++-- hw/usb/hcd-uhc

Re: [PATCH 25/26] hw/usb/usb-hcd: Use XHCI type definitions

2020-07-04 Thread BALATON Zoltan
uot;hw/usb" headers. Suggested-by: BALATON Zoltan Signed-off-by: Philippe Mathieu-Daudé --- hw/usb/hcd-xhci.h| 2 +- include/hw/usb/usb-hcd.h | 3 +++ hw/ppc/spapr.c | 2 +- 3 files changed, 5 insertions(+), 2 deletions(-) diff --git a/hw/usb/hcd-xhci.h b/hw/usb/hcd-xhci.h i

Re: [PATCH 24/26] hw/usb/usb-hcd: Use UHCI type definitions

2020-07-04 Thread BALATON Zoltan
On Sat, 4 Jul 2020, Philippe Mathieu-Daudé wrote: On 7/4/20 7:17 PM, BALATON Zoltan wrote: On Sat, 4 Jul 2020, Philippe Mathieu-Daudé wrote: Various machine/board/soc models create UHCI device instances with the generic QDEV API, and don't need to access USB internals. Simplify h

Re: [PATCH 8/9] softmmu/physmem: Let SysBusState absorb memory region and address space singletons

2022-09-20 Thread BALATON Zoltan
ough SysBusState anyway instead of accessing globals so is there a performance impact? Regards, BALATON Zoltan }; #define TYPE_SYS_BUS_DEVICE "sys-bus-device" diff --git a/softmmu/physmem.c b/softmmu/physmem.c index 0ac920d446..07e9a9171c 100644 --- a/softmmu/physmem.c ++

Re: [PATCH 9/9] exec/address-spaces: Inline legacy functions

2022-09-20 Thread BALATON Zoltan
maybe it's OK and only confusing because of misnaming sysemu as softmmu. Reagrds, BALATON Zoltan /** * Get the root memory region. This is a legacy function, provided for * compatibility. Prefer using SysBusState::system_memory directly. */ -MemoryRegion *get_system_memory(v

Re: [PATCH] bulk: Rename TARGET_FMT_plx -> HWADDR_FMT_plx

2023-01-10 Thread BALATON Zoltan
DR_PRIx PRIx64 Why are there both TARGET_FMT_plx and HWADDR_PRIx? Why not just use HWADDR_PRIx instead? Regards, BALATON Zoltan

Re: [RFC PATCH-for-9.1 09/29] hw/i386/pc: Pass PCMachineState argument to acpi_setup()

2024-03-28 Thread BALATON Zoltan
8 #define ACPI_PCIHP_BNMR_BASE 0x10 -void acpi_setup(void); +void acpi_setup(PCMachineState *pcms); This is changed to PcPciMachineState * in a following patch so can't you already introduce it here to avoid some churn? Regards, BALATON Zoltan Object *acpi_get_i386_pci_host(void); #endif

Re: [RFC PATCH-for-9.1 13/29] hw/i386/pc: Remove non-PCI code from pc_system_firmware_init()

2024-03-28 Thread BALATON Zoltan
r PCI PC machine now? Regards, BALATON Zoltan int i; BlockBackend *pflash_blk[ARRAY_SIZE(pcms->flash)]; -if (!pc_machine_is_pci_enabled(pcms)) { -x86_bios_rom_init(MACHINE(pcms), "bios.bin", rom_memory, true); -return; -} +assert(pc_machine_is_pci_e

Re: [RFC PATCH-for-9.1 14/29] hw/i386/pc: Move pc_system_flash_create() to pc_pci_machine_initfn()

2024-03-28 Thread BALATON Zoltan
;system.flash0", "pflash0"); +pcms->flash[1] = pc_pflash_create(pcms, "system.flash1", "pflash1"); } This could just be inlined as it's called once, then no need for assert and a separate function. Regards, BALATON Zoltan void pc_system_flash_cleanup_unused(PCMachineState *pcms)

Re: [PATCH v2 1/2] net: Provide MemReentrancyGuard * to qemu_new_nic()

2024-04-26 Thread BALATON Zoltan
' It seems to actually be commit a2e1753b8054344f32cf94f31c6399a58794a380 Regards, BALATON Zoltan

Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock()

2023-11-30 Thread BALATON Zoltan
h some comments and docs explainig here and there what bql stands for should be enough for new people to quickly find out. If we want to be more verbose how about "qemu_global_mutex" which is self describing but longer and does not resemble BQL so then comments may be needed to explain this

Re: [PATCH v3 01/29] bulk: Access existing variables initialized to &S->F when available

2024-01-29 Thread BALATON Zoltan
he adb_bus local is used so maybe can drop the local and chnage next line to use &s->adb_bus instead. Regards, BALATON Zoltan dev, "adb.0"); adb_register_autopoll_callback(adb_bus, pmu_adb_poll, s); }

Re: [RFC PATCH 6/7] accel/hvf: Use CPU_FOREACH_HVF()

2025-01-07 Thread BALATON Zoltan
rate macro is needed for each accel (and they cannot get inconsistent by changing only one of them in the future). Regards, BALATON Zoltan

Re: [PATCH 0/9] hw/sysbus/platform-bus: Introduce TYPE_DYNAMIC_SYS_BUS_DEVICE

2025-01-28 Thread BALATON Zoltan
and not the device so properties on the device to set these does not really help unless the board can somehow query it and instantiate the devices based on that. Otherwise whatever handles the -device option to create the device would need knowledge about the board. (E.g. the e500 devices are mapped in the CCSR memory region so one can't just use system address space for them.) Regards, BALATON Zoltan

Re: [PATCH 00/16] make system memory API available for common code

2025-03-10 Thread BALATON Zoltan
On Mon, 10 Mar 2025, Pierrick Bouvier wrote: On 3/10/25 09:28, Pierrick Bouvier wrote: Hi Zoltan, On 3/10/25 06:23, BALATON Zoltan wrote: On Sun, 9 Mar 2025, Pierrick Bouvier wrote: The main goal of this series is to be able to call any memory ld/st function from code that is *not* target

Re: [PATCH 00/16] make system memory API available for common code

2025-03-10 Thread BALATON Zoltan
On Mon, 10 Mar 2025, Pierrick Bouvier wrote: On 3/10/25 12:40, BALATON Zoltan wrote: On Mon, 10 Mar 2025, Pierrick Bouvier wrote: On 3/10/25 09:28, Pierrick Bouvier wrote: Hi Zoltan, On 3/10/25 06:23, BALATON Zoltan wrote: On Sun, 9 Mar 2025, Pierrick Bouvier wrote: The main goal of this

Re: [PATCH 00/16] make system memory API available for common code

2025-03-10 Thread BALATON Zoltan
gards, BALATON Zoltan