On 02/12/2024 17:59, Carlo Nonato wrote:
>
>
> LLC coloring needs to know the last level cache layout in order to make the
> best use of it. This can be probed by inspecting the CLIDR_EL1 register,
> so the Last Level is defined as the last level visible by this register.
> Note that this excl
Hi Bertrand,
On Wed, Nov 27, 2024 at 5:08 PM Bertrand Marquis
wrote:
>
> Make use and required to have bit 15 convention respected by secure
> world (having bit 15 of IDs set for secure endpoints and non-set for
> non-secure ones).
> If any secure partition has an ID with bit 15 not set, it will
Hi Bertrand,
On Wed, Nov 27, 2024 at 5:08 PM Bertrand Marquis
wrote:
>
> Store the list of ABI we need in a list and go through the list instead
> of having a list of conditions inside the code.
>
> No functional change.
>
> Signed-off-by: Bertrand Marquis
> ---
> Changes in v3:
> - remove const
On Tue, Dec 03, 2024 at 05:06:41PM -0500, Jason Andryuk wrote:
> From: zithro / Cyril Rébert
>
> The xl command doesn't provide suspend/resume, so add them :
> xl suspend
> xl resume
>
> This patch follows a discussion on XenDevel: when you want the
> virtualized equivalent of "sleep"-ing a
Hi Bertrand,
On Wed, Nov 27, 2024 at 5:08 PM Bertrand Marquis
wrote:
>
> Rework firmware discovery during probe:
> - move prints into the probe
> - rename ffa_version to ffa_fw_version as the variable identifies the
> version of the firmware and not the one we support
> - add error prints when
On 05/12/2024 3:34 am, Volodymyr Babchuk wrote:
>>> diff --git a/xen/common/stack-protector.c b/xen/common/stack-protector.c
>>> new file mode 100644
>>> index 00..b258590d3a
>>> --- /dev/null
>>> +++ b/xen/common/stack-protector.c
>>> @@ -0,0 +1,10 @@
>>> +// SPDX-License-Identifier: GPL-2
On 03/12/2024 10:55, Michal Orzel wrote:
>
>
> On 02/12/2024 17:59, Carlo Nonato wrote:
>>
>>
>> Last Level Cache (LLC) coloring allows to partition the cache in smaller
>> chunks called cache colors.
>>
>> Since not all architectures can actually implement it, add a HAS_LLC_COLORING
>> Kconfi
On 03/12/2024 12:37, Jan Beulich wrote:
On 03.12.2024 12:12, Bernhard Kaindl wrote:
This the 2nd part of my submission to fix the NUMA node memsize
retured in xen_sysctl_meminfo[].memsize by the XEN_SYSCTL_numainfo
hypercall to not count MMIO memory holes etc but only memory pages.
For this, we
On 02/12/2024 17:59, Carlo Nonato wrote:
>
>
> Cache coloring requires Dom0 not to be direct-mapped because of its non
> contiguous mapping nature, so allocate_memory() is needed in this case.
> 8d2c3ab18cc1 ("arm/dom0less: put dom0less feature code in a separate module")
> moved allocate_memo
Hello,
Le 04/12/2024 à 14:01, Andrew Cooper a écrit :
> On 02/12/2024 9:49 am, Teddy Astie wrote:
>> In many places of x86 HVM code, constants integer are used to indicate in
>> what mode is
>> running the CPU (real, vm86, 16-bits, 32-bits, 64-bits). However, these
>> constants are
>> are writte
On 12/4/24 02:35, Maksym Planeta wrote:
> Function xen_pin_page calls xen_pte_lock, which in turn grab page
> table lock (ptlock). When locking, xen_pte_lock expect mm->page_table_lock
> to be held before grabbing ptlock, but this does not happen when pinning
> is caused by xen_mm_pin_all.
In chan
On 03/12/2024 11:16 pm, Julien Grall wrote:
> On Tue, 3 Dec 2024 at 22:00, Andrew Cooper wrote:
>> On 30/11/2024 1:10 am, Volodymyr Babchuk wrote:
>>> diff --git a/xen/arch/arm/setup.c b/xen/arch/arm/setup.c
>>> index 2e27af4560..f855e97e25 100644
>>> --- a/xen/arch/arm/setup.c
>>> +++ b/xen/arch/
Add Rafael and Len,
On 2024-12-05 00:42, Penny Zheng wrote:
When running as Xen dom0 PVH guest, processor logical id <-> physical
id map could not be properly set up. So the original function
cppc_get_perf_caps() fails to get correct cppc data for Xen ACPI
processor.
A new function xen_processo
Adding Rafael and Len. and again keeping the full patch.
On 2024-12-05 00:42, Penny Zheng wrote:
As Xen is uncapable of parsing the ACPI dynamic table, this commit
s/uncapable/incapable/
introduces a new sub-hypercall XEN_PM_CPPC to deliver CPPC perf
caps data.
Signed-off-by: Penny Zheng
-
Signed-off-by: Jason Andryuk
---
It only works for x86, but it isn't x86-specific. I chose to add it as
a generic entry instead of listing it as x86.
---
CHANGELOG.md | 1 +
1 file changed, 1 insertion(+)
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 8553b2e451..5e912b3759 100644
--- a/CHANGEL
Adding Rafael and Len, since the patch touches drivers/acpi/.
On 2024-12-05 00:42, Penny Zheng wrote:
When running as Xen dom0 PVH guest, MADT table is customized
and may have the "wrong" UID processor number, which is
inconsistent with the UID in Processor entry in native DSDT.
As a result, du
On 05/12/2024 2:08 pm, Anthony PERARD wrote:
> On Tue, Dec 03, 2024 at 05:06:41PM -0500, Jason Andryuk wrote:
>> From: zithro / Cyril Rébert
>>
>> The xl command doesn't provide suspend/resume, so add them :
>> xl suspend
>> xl resume
>>
>> This patch follows a discussion on XenDevel: when y
From: Denis Mukhin
Introduce domain_has_vuart() for RISC-V port to be used in the console driver.
Signed-off-by: Denis Mukhin
Reviewed-by: Oleksii Kurochko
---
xen/arch/riscv/include/asm/domain.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/xen/arch/riscv/include/asm/domain.h
b/xen/
From: Denis Mukhin
Move resource definitions to a new architecture-agnostic shared header file.
It will be used in follow on NS8250 emulator code to describe legacy
PC COM resources.
Signed-off-by: Denis Mukhin
---
xen/common/device-tree/device-tree.c | 21 +--
xen/drivers/pas
From: Denis Mukhin
Minor update related to virtual UART support.
Also:
s/pv/PV/g
s/hvm/HVM/g
Signed-off-by: Denis Mukhin
---
docs/misc/console.txt | 50 ++
1 file changed, 26 insertions(+), 24 deletions(-)
diff --git a/docs/misc/console.txt b
From: Denis Mukhin
Introduce new printk() variant for convenient printouts which skip '(XEN)'
prefix on xen console. This is needed for the case when physical console is
owned by a domain w/ in-hypervisor UART emulation enabled.
Signed-off-by: Denis Mukhin
---
automation/eclair_analysis/ECLAIR
From: Denis Mukhin
Introduce domain_has_vuart() for PPC port to be used in the console driver.
Signed-off-by: Denis Mukhin
---
xen/arch/ppc/include/asm/domain.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/xen/arch/ppc/include/asm/domain.h
b/xen/arch/ppc/include/asm/domain.h
index
3
From: Denis Mukhin
Use guest_printk() in all current in-hypervisor UART emulators.
That slightly improves the logging as guest_printk() already prints the
domain ID.
Signed-off-by: Denis Mukhin
---
xen/arch/arm/vpl011.c | 2 +-
xen/arch/arm/vuart.c | 2 +-
2 files changed, 2 insertions(+), 2
From: Denis Mukhin
Move max_init_domid to a public API and enable for all architectures.
That is pre-requisite change for console focus switch logic cleanup.
max_init_domid is updated in domain_create().
Signed-off-by: Denis Mukhin
---
xen/arch/arm/include/asm/setup.h | 2 --
xen/arch/arm/s
From: Denis Mukhin
Introduce domain_has_vuart() for x86 port to be used in the console driver.
Signed-off-by: Denis Mukhin
---
xen/arch/x86/include/asm/domain.h | 3 +++
1 file changed, 3 insertions(+)
diff --git a/xen/arch/x86/include/asm/domain.h
b/xen/arch/x86/include/asm/domain.h
index
From: Denis Mukhin
Move get_initial_domain_id() to a public API and enable for all architectures.
That is pre-requisite change for console focus switch logic cleanup.
Signed-off-by: Denis Mukhin
---
xen/arch/x86/include/asm/pv/shim.h | 4 ++--
xen/arch/x86/pv/shim.c | 4 ++--
xen
From: Denis Mukhin
Xen console driver has vpl011-related logic which shall belong vpl011 emulator
code. Move vpl011-related to vpl011.c.
Signed-off-by: Denis Mukhin
---
xen/arch/arm/include/asm/vpl011.h | 2 +-
xen/arch/arm/vpl011.c | 15 +++
xen/drivers/char/console.c
From: Denis Mukhin
The code now inspects d->is_console flag to decide whether the console focus
should move to the domain w/ console after administrator presses .
Console owner domain switch logic updated accordingly.
Signed-off-by: Denis Mukhin
---
xen/arch/arm/dom0less-build.c | 2 +-
xen/
From: Denis Mukhin
Print d->arch.emulation_flags on the console for better traceability while
debugging in-hypervisor hardware emulators.
Signed-off-by: Denis Mukhin
---
xen/arch/x86/domain.c | 8 ++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/xen/arch/x86/domain.c b/xe
From: Denis Mukhin
Updated the name to highlight the logic of selection the physical console
owner: existing code does not switch only serial console, it also switches
video console and debugging console (debug I/O port and console hypercall).
Signed-off-by: Denis Mukhin
---
xen/drivers/char/c
---
base-commit: dc8e1b33a525d31989c0d1ffe6ae7794484e1d99
change-id: 20241205-vuart-ns8250-45847bc04140
Best regards,
--
Denis Mukhin
From: Denis Mukhin
console_owner_domid() is introduced to obtain the "console owner" domain ID.
The call is used in NS8250 emulator to identify the case when physical xen
console focus is owned by the domain w/ NS8250 emulator, in which case,
messages from guest OS are formatted w/o '(XEN)' pref
From: Denis Mukhin
Preparation for the follow on change to switch console_owner to
domid_t address space.
Signed-off-by: Denis Mukhin
---
xen/drivers/char/console.c | 26 +-
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a/xen/drivers/char/console.c b/xen
From: Denis Mukhin
There are several console drivers which have same checks w.r.t. printable
characters. The check is moved to new isconsole() macro and re-used in
the console drivers.
Signed-off-by: Denis Mukhin
---
xen/arch/arm/vuart.c | 3 +--
xen/arch/x86/hvm/hvm.c | 3 +--
xen/d
From: Denis Mukhin
Introduce definition for IRQ resource checks.
Signed-off-by: Denis Mukhin
---
xen/include/xen/irq.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/xen/include/xen/irq.h b/xen/include/xen/irq.h
index
95034c0d6bb5f0aa7d5bb572aca59872508a438a..aee878293ecc0de6a938bcfea114
Hi Andrew,
Andrew Cooper writes:
> On 03/12/2024 11:16 pm, Julien Grall wrote:
>> On Tue, 3 Dec 2024 at 22:00, Andrew Cooper wrote:
>>> On 30/11/2024 1:10 am, Volodymyr Babchuk wrote:
diff --git a/xen/arch/arm/setup.c b/xen/arch/arm/setup.c
index 2e27af4560..f855e97e25 100644
--
From: Denis Mukhin
Move domain_has_vuart() to arch namespace as preparation code change for
architecture-agnostic way of forwarding physical console to the guest OS w/
in-hypervisor UART emulator.
Signed-off-by: Denis Mukhin
---
xen/arch/arm/dom0less-build.c | 2 ++
xen/arch/arm/domain.c
From: Denis Mukhin
There are few places which check pv_shim console under CONFIG_PV_SHIM in xen
console driver. Instead of #ifdef-ing, use new consoled_is_enabled() to
customize the logic.
Header file now can be included w/o CONFIG_X86.
Signature of consoled_guest_{rx,tx} has changed to account
From: Denis Mukhin
console_input_domain() takes an RCU lock to protect domain structure.
That implies call to rcu_unlock_domain() after use.
Rename console_input_domain() to rcu_lock_domain_console_owner() to
highlight the need of calling rcu_unlock_domain().
Signed-off-by: Denis Mukhin
---
x
From: Denis Mukhin
Enable console focus for domains w/ virtual NS8250.
Code change allows to capture the output from the guest OS now and send it to
the physical console device.
Signed-off-by: Denis Mukhin
---
xen/drivers/char/console.c | 5 +
1 file changed, 5 insertions(+)
diff --git a
From: Denis Mukhin
With introduction of NS8250 emulator for x86, the logic of switching console
focus gets more convoluted: HVM domain w/ NS8205 must be able to receive the
physical console input for guest VM debugging.
Also, existing code does not honor `hardware_dom=` xen command line paramete
From: Denis Mukhin
Add new emulation flag for virtual UART on x86 and plumb it through the stack.
This change enables NS8250 emulator initialization.
Signed-off-by: Denis Mukhin
---
tools/libs/light/libxl_x86.c | 6 +-
tools/ocaml/libs/xc/xenctrl.ml| 1 +
tools/ocaml/libs/xc/xe
From: Denis Mukhin
Add separate menu for configuring HVM build-time settings.
That will help organizing HVM-specific options under a separate menu.
Signed-off-by: Denis Mukhin
---
xen/arch/x86/Kconfig | 66 +++-
xen/arch/x86/hvm/Kconfig | 63
From: Denis Mukhin
Update the hint w/ the combination of keys to press to switch physical console
to the next owner.
Signed-off-by: Denis Mukhin
---
xen/drivers/char/console.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/xen/drivers/char/console.c b/xen/drivers/char/
On 2024-12-05 00:42, Penny Zheng wrote:
From: Roger Pau Monne
When running as a PVH dom0 the ACPI MADT is crafted by Xen in order to
report the correct numbers of vCPUs that dom0 has, so the host MADT is
not provided to dom0. This creates issues when parsing the power and
performance related d
Hello,
This is my first patch to the list; your feedback is much appreciated.
I am new to Xen; my aim is to improve my knowledge of virtualization.
While compiling from scratch, I came across these warnings. If this patch makes
sense, I will have a look at other ASL warnings I spotted.
Thank yo
From: Ariel Otilibili
* While compiling ASLs, iasl puts out deprecation warnings
```
tools/libs/light/mk_dsdt --debug=y --maxcpu any --dm-version none >>
tools/libs/light/dsdt_pvh.asl
/usr/bin/iasl -vs -p tools/libs/light/dsdt_pvh.tmp -tc
tools/libs/light/dsdt_pvh.asl
tools/libs/light/dsdt_pv
On 06/12/2024 12:00 am, Ariel Otilibili wrote:
> From: Ariel Otilibili
>
> * While compiling ASLs, iasl puts out deprecation warnings
>
> ```
> tools/libs/light/mk_dsdt --debug=y --maxcpu any --dm-version none >>
> tools/libs/light/dsdt_pvh.asl
> /usr/bin/iasl -vs -p tools/libs/light/dsdt_pvh.tmp
From: Denis Mukhin
Add new CONRING_LOG_SHIFT Kconfig parameter to specify the boot console buffer
size as a power of 2.
Bump default size to 32 KiB.
Link: https://gitlab.com/xen-project/xen/-/issues/185
Signed-off-by: Denis Mukhin
---
xen/drivers/char/Kconfig | 23 +++
x
From: Denis Mukhin
Messages printed before the serial and VGA consoles are initialized end up in
the internal console buffer (conring). Flush contents of conring to all
external consoles after external consoles are fully initialied.
Link: https://gitlab.com/xen-project/xen/-/issues/184
Signed-of
From: Denis Mukhin
Enable keyhandler mechanism for dumping state of emulated NS8250 on the
console.
Signed-off-by: Denis Mukhin
---
xen/arch/x86/hvm/vuart_ns8250.c | 122
1 file changed, 122 insertions(+)
diff --git a/xen/arch/x86/hvm/vuart_ns8250.c b/
From: Denis Mukhin
console_init_owner() is introduced for selecting the boot-time console owner.
Signed-off-by: Denis Mukhin
---
xen/drivers/char/console.c | 27 +--
1 file changed, 17 insertions(+), 10 deletions(-)
diff --git a/xen/drivers/char/console.c b/xen/drivers
From: Denis Mukhin
PV Linux kernel uses HYPERVISOR_console_io hypercall for early console which
ends up being handled by Xen's console driver's guest_console_write().
guest_console_write() duplicates the code from __putstr(), elimitate code
duplication.
Signed-off-by: Denis Mukhin
---
xen/dri
From: Denis Mukhin
Add initial in-hypervisor emulator for NS8250/NS16x50-compatible UARTs under
CONFIG_HAS_VUART_NS8250.
In parallel domain creation scenario (hyperlaunch), NS8520 emulator helps
early guest OS bringup debugging, because it eliminates dependency on the
external emulator being ope
From: Denis Mukhin
console_set_owner() is introduced for setting the new console owner.
Switches console owner to domain ID vs range of integer numbers mapped to
domain IDs.
This a public API to console driver, will be used in the follow on code change.
Signed-off-by: Denis Mukhin
---
xen/dr
From: Denis Mukhin
Added convenience wrappers for asserting/de-asserting interrupts in the
hardware emulation code.
That will be used for PCI-based NS8250 emulator.
Signed-off-by: Denis Mukhin
---
xen/arch/x86/hvm/irq.c | 24
xen/arch/x86/include/asm/hvm/i
From: Denis Mukhin
The new command line switch `hwdom_crashconsole=BOOL` allows to switch serial
console input focus to xen for machine state inspection using keyhandler
mechanism after the hardware domain crashes.
The new command line switch is aliased via `dom0=...,crashconsole` knob.
Such fu
From: Denis Mukhin
Added missing definitions needed for NS8250 UART emulator.
Signed-off-by: Denis Mukhin
---
xen/include/xen/8250-uart.h | 81 +
1 file changed, 60 insertions(+), 21 deletions(-)
diff --git a/xen/include/xen/8250-uart.h b/xen/includ
58 matches
Mail list logo