> From: Beulich
> Sent: Saturday, November 28, 2020 12:02 AM
>
> On 20.11.2020 14:24, Paul Durrant wrote:
> > @@ -709,20 +709,23 @@ static void dma_pte_clear_one(struct domain
> *domain, uint64_t addr,
> > page = (struct dma_pte *)map_vtd_domain_page(pg_maddr);
> > pte = page + address_l
On 20.11.2020 14:24, Paul Durrant wrote:
> @@ -709,20 +709,23 @@ static void dma_pte_clear_one(struct domain *domain,
> uint64_t addr,
> page = (struct dma_pte *)map_vtd_domain_page(pg_maddr);
> pte = page + address_level_offset(addr, 1);
>
> -if ( !dma_pte_present(*pte) )
> +i
From: Paul Durrant
As with a prior patch for context_entry, this removes the need for much
shifting, masking and several magic numbers.
Signed-off-by: Paul Durrant
---
Cc: Kevin Tian
v10:
- Remove macros in favour of direct field access
- Adjust field types
- Use write_atomic() to update t