Re: [PATCH 10/14] accel: Rename NVMM struct qemu_vcpu -> struct AccelvCPUState

2023-04-07 Thread Richard Henderson
On 4/5/23 03:18, Philippe Mathieu-Daudé wrote: -struct qemu_vcpu *qcpu = get_qemu_vcpu(cpu); +struct AccelvCPUState *qcpu = get_qemu_vcpu(cpu); With the typedef in hw/core/cpu.h, you can drop the 'struct' at the same time. Otherwise, Reviewed-by: Richard Henderson -qcpu = g_try_

[PATCH 10/14] accel: Rename NVMM struct qemu_vcpu -> struct AccelvCPUState

2023-04-05 Thread Philippe Mathieu-Daudé
We want all accelerators to share the same opaque pointer in CPUState. Rename NVMM 'qemu_vcpu' as 'AccelvCPUState'. Replace g_try_malloc0() by g_try_new0() for readability. Signed-off-by: Philippe Mathieu-Daudé --- target/i386/nvmm/nvmm-all.c | 34 +- 1 file chan