boun...@lists.xen.org [mailto:xen-devel-
>> >>> boun...@lists.xen.org] On Behalf Of Jan Beulich
>> >>> Sent: 08 July 2015 16:53
>> >>> To: Andrew Cooper; Paul Durrant
>> >>> Cc: xen-de...@lists.xenproject.org; Keir (Xen.or
> -Original Message-
> From: Jan Beulich [mailto:jbeul...@suse.com]
> Sent: 09 July 2015 07:54
> To: Andrew Cooper
> Cc: Paul Durrant; xen-de...@lists.xenproject.org; Keir (Xen.org)
> Subject: Re: [Xen-devel] [PATCH v6 02/16] x86/hvm: remove multiple open
> c
>>> To: Andrew Cooper; Paul Durrant
>>> Cc: xen-de...@lists.xenproject.org; Keir (Xen.org)
>>> Subject: Re: [Xen-devel] [PATCH v6 02/16] x86/hvm: remove multiple open
>>> coded 'chunking' loops
>>>
>>>>>> On 03.07.15 at 18:25,
@lists.xenproject.org; Keir (Xen.org)
>> Subject: Re: [Xen-devel] [PATCH v6 02/16] x86/hvm: remove multiple open
>> coded 'chunking' loops
>>
>>>>> On 03.07.15 at 18:25, wrote:
>>> +static int hvmemul_linear_mmio_access(
>>> +u
xen-de...@lists.xenproject.org; Keir (Xen.org)
>> Subject: Re: [Xen-devel] [PATCH v6 02/16] x86/hvm: remove multiple open
>> coded 'chunking' loops
>>
>> >>> On 03.07.15 at 18:25, wrote:
>> > +static int hvmemul_linear_mmio_access(
>> >
evel] [PATCH v6 02/16] x86/hvm: remove multiple open
> coded 'chunking' loops
>
> >>> On 03.07.15 at 18:25, wrote:
> > +static int hvmemul_linear_mmio_access(
> > +unsigned long gla, unsigned int size, uint8_t dir, uint8_t *buffer,
> > +uint32
>>> On 03.07.15 at 18:25, wrote:
> +static int hvmemul_linear_mmio_access(
> +unsigned long gla, unsigned int size, uint8_t dir, uint8_t *buffer,
> +uint32_t pfec, struct hvm_emulate_ctxt *hvmemul_ctxt, bool_t known_gpfn)
> +{
> +struct hvm_vcpu_io *vio = ¤t->arch.hvm_vcpu.hvm_io;
> +
On 03/07/15 17:25, Paul Durrant wrote:
> ...in hvmemul_read/write()
>
> Add hvmemul_phys_mmio_access() and hvmemul_linear_mmio_access() functions
> to reduce code duplication.
>
> NOTE: This patch also introduces a change in 'chunking' around a page
> boundary. Previously (for example) an 8 b
...in hvmemul_read/write()
Add hvmemul_phys_mmio_access() and hvmemul_linear_mmio_access() functions
to reduce code duplication.
NOTE: This patch also introduces a change in 'chunking' around a page
boundary. Previously (for example) an 8 byte access at the last
byte of a page would g