On 2015/3/6 20:50, Joe Perches wrote:
On Fri, 2015-03-06 at 17:33 +0800, Chentao (Boby) wrote:
#ifdef pr_fmt
#undef pr_fmt
#endif
#define pr_fmt(fmt) "xen-pvscsi: " fmt
No, just use add
#define pr_fmt(fmt) "xen-pvscsi: " fmt
before the first #include.
The #ifdef/#undef/#endif isn't necessary
On Fri, 2015-03-06 at 17:33 +0800, Chentao (Boby) wrote:
> #ifdef pr_fmt
> #undef pr_fmt
> #endif
> #define pr_fmt(fmt) "xen-pvscsi: " fmt
No, just use add
#define pr_fmt(fmt) "xen-pvscsi: " fmt
before the first #include.
The #ifdef/#undef/#endif isn't necessary.
> Then replace all DPRINTK with p
On 2015/3/4 18:34, David Vrabel wrote:
On 04/03/15 18:32, Tao Chen wrote:
Defined the string of {xen-pvscsi: } as DRV_PFX, then use it in the pr
sentences and DPRINTK.
Also fixed up some comments just as eliminate redundant white spaces and format
the code.
These will make the code easier to
On 2015/3/5 0:32, Joe Perches wrote:
On Wed, 2015-03-04 at 18:32 +, Tao Chen wrote:
Defined the string of {xen-pvscsi: } as DRV_PFX, then use it in the pr
sentences and DPRINTK.
Also fixed up some comments just as eliminate redundant white spaces and format
the code.
These will make the
On Wed, 2015-03-04 at 18:32 +, Tao Chen wrote:
> Defined the string of {xen-pvscsi: } as DRV_PFX, then use it in the pr
> sentences and DPRINTK.
> Also fixed up some comments just as eliminate redundant white spaces and
> format the code.
> These will make the code easier to read.
It'd proba
On 04/03/15 18:32, Tao Chen wrote:
> Defined the string of {xen-pvscsi: } as DRV_PFX, then use it in the pr
> sentences and DPRINTK.
> Also fixed up some comments just as eliminate redundant white spaces and
> format the code.
> These will make the code easier to read.
I have already said you ne
Defined the string of {xen-pvscsi: } as DRV_PFX, then use it in the pr
sentences and DPRINTK.
Also fixed up some comments just as eliminate redundant white spaces and format
the code.
These will make the code easier to read.
Signed-off-by: Tao Chen
---
drivers/xen/xen-scsiback.c | 70 +