Re: [Xen-devel] [PATCH 2/3] grant-table: refactor grant copy to reduce duplicate code

2015-01-29 Thread Tim Deegan
At 10:43 + on 23 Jan (1422006226), David Vrabel wrote: > Much of the grant copy operation is identical for the source and > destination buffers. Refactor the code into per-buffer functions. > > Signed-off-by: David Vrabel Reviewed-by: Tim Deegan ___

Re: [Xen-devel] [PATCH 2/3] grant-table: refactor grant copy to reduce duplicate code

2015-01-23 Thread Jan Beulich
>>> On 23.01.15 at 11:43, wrote: > Much of the grant copy operation is identical for the source and > destination buffers. Refactor the code into per-buffer functions. > > Signed-off-by: David Vrabel Reviewed-by: Jan Beulich ___ Xen-devel mailing

[Xen-devel] [PATCH 2/3] grant-table: refactor grant copy to reduce duplicate code

2015-01-23 Thread David Vrabel
Much of the grant copy operation is identical for the source and destination buffers. Refactor the code into per-buffer functions. Signed-off-by: David Vrabel --- xen/common/grant_table.c | 289 +- xen/include/public/grant_table.h |2 +- 2 files

Re: [Xen-devel] [PATCH 2/3] grant-table: refactor grant copy to reduce duplicate code

2015-01-22 Thread Tim Deegan
Hi, At 18:19 + on 20 Jan (1421774388), David Vrabel wrote: > +static s16 gnttab_copy_lock_domains(const struct gnttab_copy *op, > +struct gnttab_copy_buf *src, > +struct gnttab_copy_buf *dest) > +{ > +s16 rc; > + > +

Re: [Xen-devel] [PATCH 2/3] grant-table: refactor grant copy to reduce duplicate code

2015-01-22 Thread Jan Beulich
>>> On 22.01.15 at 15:42, wrote: > On 22/01/15 14:24, Jan Beulich wrote: > On 20.01.15 at 19:19, wrote: >>> +static int gnttab_copy_buf(const struct gnttab_copy *op, >>> + struct gnttab_copy_buf *dest, >>> + const struct gnttab_copy_buf *src

Re: [Xen-devel] [PATCH 2/3] grant-table: refactor grant copy to reduce duplicate code

2015-01-22 Thread David Vrabel
On 22/01/15 14:24, Jan Beulich wrote: On 20.01.15 at 19:19, wrote: >> +static int gnttab_copy_buf(const struct gnttab_copy *op, >> + struct gnttab_copy_buf *dest, >> + const struct gnttab_copy_buf *src) >> +{ >> +s16 rc; > > An s16 loca

Re: [Xen-devel] [PATCH 2/3] grant-table: refactor grant copy to reduce duplicate code

2015-01-22 Thread Jan Beulich
>>> On 20.01.15 at 19:19, wrote: > +static int gnttab_copy_buf(const struct gnttab_copy *op, > + struct gnttab_copy_buf *dest, > + const struct gnttab_copy_buf *src) > +{ > +s16 rc; An s16 local variable used as return value in a function re

[Xen-devel] [PATCH 2/3] grant-table: refactor grant copy to reduce duplicate code

2015-01-20 Thread David Vrabel
Much of the grant copy operation is identical for the source and destination buffers. Refactor the code into per-buffer functions. Signed-off-by: David Vrabel --- xen/common/grant_table.c | 286 +- xen/include/public/grant_table.h |2 +- 2 files