Re: [Xen-devel] [PATCH] x86/hpet: Improve handling of timer_deadline

2017-06-01 Thread Jan Beulich
>>> On 31.05.17 at 16:14, wrote: > Update hpet_broadcast_{enter,exit}() to use this_cpu() rather than per_cpu() > for clarity, I'm afraid this makes things worse in other respects (see below). > @@ -697,8 +696,9 @@ void hpet_broadcast_enter(void) > { > unsigned int cpu = smp_processor_id()

[Xen-devel] [PATCH] x86/hpet: Improve handling of timer_deadline

2017-05-31 Thread Andrew Cooper
timer_deadline is only ever updated via this_cpu() in timer_softirq_action(), so is not going to change behind the back of the currently running cpu. Update hpet_broadcast_{enter,exit}() to use this_cpu() rather than per_cpu() for clarity, and cache the value in a local variable to avoid the repea