Good for me as well.
-Thadeus
On Sun, Mar 7, 2010 at 8:44 PM, mr.freeze wrote:
> Perfect for me.
>
> On Mar 7, 8:43 pm, mdipierro wrote:
>> Tuesday evening. What about 10pm Central Time?
>>
>> On Mar 7, 8:32 pm, "mr.freeze" wrote:
>>
>> > Are we still on for Tuesday? What time? I am anxiou
Perfect for me.
On Mar 7, 8:43 pm, mdipierro wrote:
> Tuesday evening. What about 10pm Central Time?
>
> On Mar 7, 8:32 pm, "mr.freeze" wrote:
>
> > Are we still on for Tuesday? What time? I am anxious to get the plugin
> > spec finalized!
>
> > On Mar 2, 6:04 pm, "mr.freeze" wrote:
>
> > > Sou
Tuesday evening. What about 10pm Central Time?
On Mar 7, 8:32 pm, "mr.freeze" wrote:
> Are we still on for Tuesday? What time? I am anxious to get the plugin
> spec finalized!
>
> On Mar 2, 6:04 pm, "mr.freeze" wrote:
>
> > Sounds good to me. I'm available anytime after 6pm CST.
>
> > On Mar 2,
Are we still on for Tuesday? What time? I am anxious to get the plugin
spec finalized!
On Mar 2, 6:04 pm, "mr.freeze" wrote:
> Sounds good to me. I'm available anytime after 6pm CST.
>
> On Mar 2, 1:19 pm, mdipierro wrote:
>
> > OK, let do this next week. It will be better for everybody. Tuesday
Sounds good to me. I'm available anytime after 6pm CST.
On Mar 2, 1:19 pm, mdipierro wrote:
> OK, let do this next week. It will be better for everybody. Tuesday
> night?
>
> On Mar 2, 10:44 am, Thadeus Burgess wrote:
>
> > I too am swamped during the days. I would have to get permission from
>
OK, let do this next week. It will be better for everybody. Tuesday
night?
On Mar 2, 10:44 am, Thadeus Burgess wrote:
> I too am swamped during the days. I would have to get permission from
> the powers at be to participant in an afternoon chat.
>
> Evenings would be best, the later the better. I
I too am swamped during the days. I would have to get permission from
the powers at be to participant in an afternoon chat.
Evenings would be best, the later the better. I just moved, so I have
not got my PC back up and running (hopefully I will by Friday)
-Thadeus
On Tue, Mar 2, 2010 at 6:2
Would it be possible to do in the evening or on the weekend? I'm hosed
during business hours (even lunch). No worries if not, I can just send
you my notes on some discoveries I've made while coding my own folder
based plugin system.
On Mar 1, 10:31 pm, mdipierro wrote:
> It is a bad week. Probab
It is a bad week. Probably Friday around lunchtime (chicago time)
On Mar 1, 6:31 pm, "mr.freeze" wrote:
> When is a good time for an IRC discussion?
>
> On Feb 25, 8:22 pm, mdipierro wrote:
>
> > When I am back home Perhaps we should an IRC discussion on this. Email
> > will not do. Start prepar
When is a good time for an IRC discussion?
On Feb 25, 8:22 pm, mdipierro wrote:
> When I am back home Perhaps we should an IRC discussion on this. Email
> will not do. Start preparing your proposals.
>
> On Feb 25, 4:34 pm, pistacchio wrote:
>
> > i'm late in the whole "plugin" discussion, i did
When I am back home Perhaps we should an IRC discussion on this. Email
will not do. Start preparing your proposals.
On Feb 25, 4:34 pm, pistacchio wrote:
> i'm late in the whole "plugin" discussion, i didn't really follow it
> from start (being new to web2py).
> my only question is: what is the _
i'm late in the whole "plugin" discussion, i didn't really follow it
from start (being new to web2py).
my only question is: what is the _scope_ of plugins? as i got it
correctly, there's an ongoing debate on the form of plugins, classes
vs directories.
if we're talking about small things like "dis
Yes we can resurrect 100's of posts on this topic of plugins in sub folders :)
There are two reasons Massimo does not support folder contained
plugins, from what I have read.
1. Execution overhead. Having to scan yet another folder will add that
much more overhead to the execution of a web2py app
>I fully agree that plugins should exist in
>their own folders
I defend it some time ago and still think it is a good idea
2010/2/25 mr.freeze
> >>>What are you trying to accomplish with plugins?
> I'm trying to created packaged chunks of reusable code that are easily
> installed ,upgraded or r
I can't stress enough. web2py plugins should be geared towards
developers, not end-users. (Someone who runs their own wordpress blog
would be an end-user of wordpress).
Plugins should be there to provide a standard for common functionality
so that everyone who comes along to web2py does not have t
A simple approach would be to adopt the naming convention
'plugin_object' for any objects the developer wants to expose to the
plugin system then just create global labels:
>>>class Plugins(object):
>>>def __init__(self,globals,**kargs):
>>>for k,v in kargs.items():
>>>glob
This may be a good idea. What should go into plugins?
On Feb 24, 10:41 am, Thadeus Burgess wrote:
> I also am in favor of a class based plugin system that works like crud/auth.
>
> Plugins would not pollute your global namespace. And they would be
> configurable.
>
> Though the loss is of having
I also am in favor of a class based plugin system that works like crud/auth.
Plugins would not pollute your global namespace. And they would be configurable.
Though the loss is of having plugins with their own controllers since
the module would be the controller instead.
-Thadeus
On Wed, Fe
Alternately you could simply create another container class for
plugins to use and pass the preferred DAL instance to it just like you
can with auth and crud:
db = DAL('...')
db2 = DAL('...')
auth = Auth(globals(),db)
crud = Crud(globals(),db)
plugins = Plugins(globals(),db2)
This seems more cons
Then no auth would mean no plugins. What if an attribute was added to
DAL to let the user specify:
db = DAL('...')
db.plugin_db = True
Then create a global plugin_db object for the plugins to use. All
plugins could then assume:
db = plugin_db
or just use plugin_db directly
There may be a better
what if plugins were to use auth.db ? they rely on auth anyway. Or
should we relax that?
On Feb 23, 11:32 pm, mdipierro wrote:
> OK but the I would call that variable db because that is what it is
> called in welcome/models/db.py
>
> On Feb 23, 11:25 pm, "mr.freeze" wrote:
>
> > I think the most
OK but the I would call that variable db because that is what it is
called in welcome/models/db.py
On Feb 23, 11:25 pm, "mr.freeze" wrote:
> I think the most important thing is that users can install plugins
> without needing to modify the plugin. This would make upgrades a real
> problem. I'm s
I think the most important thing is that users can install plugins
without needing to modify the plugin. This would make upgrades a real
problem. I'm sure you've heard this all before but if the plugin
system was initialized in some way by the user with their preferred
instance of a DAL object the
when I said "yes" I mean current plugins assume it.
I agree we need a superstructure to manage conventions. Instead of a
new global vars, I would prefer that each plugins has its own
plugin__settings.db and users can customize each individual
plugin.
On Feb 23, 11:12 pm, "mr.freeze" wrote:
> Tha
That still feels wrong to me. What about making a plugin_db parameter
in option_std.py for the database instance name you want to use for
the plugin subsystem?
On Feb 23, 10:29 pm, mdipierro wrote:
> yes
>
> On Feb 23, 10:18 pm, "mr.freeze" wrote:
>
> > What about the second question? Is 'db' a
yes
On Feb 23, 10:18 pm, "mr.freeze" wrote:
> What about the second question? Is 'db' a required naming convention
> for the plugin system?
>
> On Feb 23, 6:41 pm, mdipierro wrote:
>
> > I think so. The only think is that we will build a super structure on
> > top of it for better management of
What about the second question? Is 'db' a required naming convention
for the plugin system?
On Feb 23, 6:41 pm, mdipierro wrote:
> I think so. The only think is that we will build a super structure on
> top of it for better management of plugins metadata.
>
> Massimo
>
> On Feb 23, 6:37 pm, "mr.f
I think so. The only think is that we will build a super structure on
top of it for better management of plugins metadata.
Massimo
On Feb 23, 6:37 pm, "mr.freeze" wrote:
> Is the plugin system considered backwards compatible at this point? I
> am considering converting some modules into plugins
28 matches
Mail list logo