在 2021/10/30 上午2:35, Eugenio Pérez 写道:
This iova tree function allows it to look for a hole in allocated
regions and return a totally new translation for a given translated
address.
It's usage is mainly to allow devices to access qemu address space,
remapping guest's one into a new iova space w
在 2021/10/30 上午2:35, Eugenio Pérez 写道:
+/**
+ * Enable or disable shadow virtqueue in a vhost vdpa device.
+ *
+ * This function is idempotent, to call it many times with the same value for
+ * enable_svq will simply return success.
+ *
+ * @v Vhost vdpa device
+ * @enable True to set SVQ
On Sat, Oct 30, 2021 at 2:44 AM Eugenio Pérez wrote:
>
> This allows it to test if the guest has aknowledge an invalid transport
> feature for SVQ. This will include packed vq layout or event_idx,
> where VirtIO device needs help from SVQ.
>
> There is not needed at this moment, but since SVQ will
On Sat, Oct 30, 2021 at 2:36 AM Eugenio Pérez wrote:
>
> Implementation of RFC of device state capability:
> https://lists.oasis-open.org/archives/virtio-comment/202012/msg5.html
Considering this still requires time to be done, we need to think of a
way to go without this.
Thanks
>
> With
On 19-10-21, 09:46, Vincent Whitchurch wrote:
> The driver currently assumes that the notify callback is only received
> when the device is done with all the queued buffers.
>
> However, this is not true, since the notify callback could be called
> without any of the queued buffers being completed
在 2021/10/30 上午2:34, Eugenio Pérez 写道:
This series enable shadow virtqueue (SVQ) for vhost-vdpa devices. This
is intended as a new method of tracking the memory the devices touch
during a migration process: Instead of relay on vhost device's dirty
logging capability, SVQ intercepts the VQ datapl
On Tue, Nov 2, 2021 at 11:22 AM Xuan Zhuo wrote:
>
> On Wed, 27 Oct 2021 10:21:04 +0800, Jason Wang wrote:
> > This patch validate the used buffer length provided by the device
> > before trying to use it. This is done by record the in buffer length
> > in a new field in desc_state structure duri
On Mon, Nov 1, 2021 at 10:11 PM Jason Gunthorpe wrote:
>
> On Thu, Mar 26, 2020 at 10:01:23PM +0800, Jason Wang wrote:
> > From: Tiwei Bie
> >
> > This patch introduces a vDPA-based vhost backend. This backend is
> > built on top of the same interface defined in virtio-vDPA and provides
> > a gen
On 01-11-21, 05:11, Michael S. Tsirkin wrote:
> Declaring the struct packed here is mostly harmless,
> but gives a bad example for people to copy.
> As the struct is packed and aligned manually,
> let's just drop the attribute.
>
> Signed-off-by: Michael S. Tsirkin
> ---
> include/uapi/linux/vir
On 01-11-21, 13:24, Jie Deng wrote:
> Due to changes in my work, I'm passing the virtio-i2c driver
> maintenance to Conghui.
>
> Signed-off-by: Jie Deng
> ---
> MAINTAINERS | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/MAINTAINERS b/MAINTAINERS
> index 3b79fd4..8c9a67
On Wed, 27 Oct 2021 10:21:04 +0800, Jason Wang wrote:
> This patch validate the used buffer length provided by the device
> before trying to use it. This is done by record the in buffer length
> in a new field in desc_state structure during virtqueue_add(), then we
> can fail the virtqueue_get_buf
Borislav Petkov writes:
> On Mon, Sep 13, 2021 at 05:55:52PM +0200, Joerg Roedel wrote:
>> From: Joerg Roedel
>>
>> Allow a runtime opt-out of kexec support for architecture code in case
>> the kernel is running in an environment where kexec is not properly
>> supported yet.
>>
>> This will be
On Mon, Oct 18 2021 at 12:40P -0400,
Christoph Hellwig wrote:
> Replace the dax_host_hash with an xarray indexed by the pointer value
> of the gendisk, and require explicitl calls from the block drivers that
> want to associate their gendisk with a dax_device.
>
> Signed-off-by: Christoph Hellwi
On Wed, Oct 27 2021 at 9:41P -0400,
Dan Williams wrote:
> On Sun, Oct 17, 2021 at 9:41 PM Christoph Hellwig wrote:
> >
> > Add a helper to perform the entire remapping for DAX accesses. This
> > helper open codes bdev_dax_pgoff given that the alignment checks have
> > already been done by the
On Wed, Oct 27 2021 at 9:36P -0400,
Dan Williams wrote:
> On Sun, Oct 17, 2021 at 9:41 PM Christoph Hellwig wrote:
> >
> > Add a helper to perform the entire remapping for DAX accesses. This
> > helper open codes bdev_dax_pgoff given that the alignment checks have
> > already been done by the
On Wed, Oct 27 2021 at 9:32P -0400,
Dan Williams wrote:
> On Sun, Oct 17, 2021 at 9:41 PM Christoph Hellwig wrote:
> >
> > Add a helper to perform the entire remapping for DAX accesses. This
> > helper open codes bdev_dax_pgoff given that the alignment checks have
> > already been done by the
On Wed, Oct 27 2021 at 8:16P -0400,
Dan Williams wrote:
> I am going to change the subject of this patch to:
>
> dax: remove ->dax_supported()
>
> On Sun, Oct 17, 2021 at 9:41 PM Christoph Hellwig wrote:
> >
>
> I'll add a bit more background to help others review this.
>
> The ->dax_suppor
On Wed, Oct 27 2021 at 4:53P -0400,
Dan Williams wrote:
> On Sun, Oct 17, 2021 at 9:41 PM Christoph Hellwig wrote:
> >
> > The device mapper DAX support is all hanging off a block device and thus
> > can't be used with device dax. Make it depend on CONFIG_FS_DAX instead
> > of CONFIG_DAX_DRIVE
On Mon, Sep 13, 2021 at 05:55:52PM +0200, Joerg Roedel wrote:
> From: Joerg Roedel
>
> Allow a runtime opt-out of kexec support for architecture code in case
> the kernel is running in an environment where kexec is not properly
> supported yet.
>
> This will be used on x86 when the kernel is run
Move destination-buffer clipping from all format-helper conversion
functions into callers. Support destination-buffer pitch. Only
distinguish between system and I/O memory, but use same logic
everywhere.
Simply harmonize the interface and semantics of the existing code.
Not all conversion helpers
Add additional information on the semantics of the size fields in
struct drm_mode_config. Also add a TODO to review all driver for
correct usage of these fields.
Signed-off-by: Thomas Zimmermann
---
Documentation/gpu/todo.rst| 15 +++
include/drm/drm_mode_config.h | 13 ++
Add destination-buffer pitch as argument to drm_fb_swab(). Done for
consistency with the rest of the interface.
v2:
* update documentation (Noralf)
Signed-off-by: Thomas Zimmermann
Tested-by: Noralf Trønnes
Reviewed-by: Noralf Trønnes
---
drivers/gpu/drm/drm_format_helper.c | 21 +
Add constants for the maximum size of the shadow-plane surface
size. Useful for shadow planes with virtual screen sizes. The
current sizes are 4096 scanlines with 4096 pixels each. This
seems reasonable for current hardware, but can be increased as
necessary.
In simpledrm, set the maximum framebuf
Enable the FB_DAMAGE_CLIPS property to reduce display-update
overhead. Also fixes a warning in the kernel log.
simple-framebuffer simple-framebuffer.0: [drm]
drm_plane_enable_fb_damage_clips() not called
Fix the computation of the blit rectangle. This wasn't an issue so
far, as simpledrm alway
Move destination-buffer clipping from all format-helper memcpy
function into callers. Support destination-buffer pitch. Only
distinguish between system and I/O memory, but use same logic
everywhere.
Signed-off-by: Thomas Zimmermann
Tested-by: Noralf Trønnes
Reviewed-by: Noralf Trønnes
---
driv
Move destination-buffer clipping from format-helper blit function into
caller. Rename drm_fb_blit_rect_dstclip() to drm_fb_blit_toio(). Done for
consistency with the rest of the interface. Remove drm_fb_blit_dstclip(),
which isn't required.
Signed-off-by: Thomas Zimmermann
Reviewed-by: Noralf Trø
Allocating a shadow buffer of the height of the buffer object does
not support fbdev overallocation. Use surface height instead.
Signed-off-by: Thomas Zimmermann
Reviewed-by: Noralf Trønnes
---
drivers/gpu/drm/drm_fb_helper.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/d
Enable FB_DAMAGE_CLIPS with simpledrm for improved performance and/or
less overhead. With this in place, add support for virtual screens
(i.e., framebuffers that are larger than the display resolution). This
also enables fbdev panning and page flipping.
After the discussion and bug fixing wrt to f
Provide a function that computes the offset into a blit destination
buffer. This will allow to move destination-buffer clipping into the
format-helper callers.
v2:
* provide documentation (Sam)
* return 'unsigned int' (Sam, Noralf)
Signed-off-by: Thomas Zimmermann
---
drivers/gp
Hi
Am 24.10.21 um 13:32 schrieb Noralf Trønnes:
Den 22.10.2021 15.28, skrev Thomas Zimmermann:
Move destination-buffer clipping from all format-helper conversion
functions into callers. Support destination-buffer pitch. Only
distinguish between system and I/O memory, but use same logic
everyw
On Mon, Nov 01, 2021 at 04:11:59PM +0800, Wu Zongyong wrote:
> On Mon, Nov 01, 2021 at 03:02:52PM +0800, Jason Wang wrote:
> > On Mon, Nov 1, 2021 at 2:23 PM Wu Zongyong
> > wrote:
> > >
> > > On Mon, Nov 01, 2021 at 11:31:15AM +0800, Jason Wang wrote:
> > > > On Fri, Oct 29, 2021 at 5:15 PM Wu Z
Declaring the struct packed here is mostly harmless,
but gives a bad example for people to copy.
As the struct is packed and aligned manually,
let's just drop the attribute.
Signed-off-by: Michael S. Tsirkin
---
include/uapi/linux/virtio_gpio.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(
Hi
Am 24.10.21 um 17:20 schrieb Noralf Trønnes:
Den 22.10.2021 15.28, skrev Thomas Zimmermann:
Enable the FB_DAMAGE_CLIPS property to reduce display-update
overhead. Also fixes a warning in the kernel log.
simple-framebuffer simple-framebuffer.0: [drm]
drm_plane_enable_fb_damage_clips()
On Sun, Oct 31, 2021 at 06:59:57AM +0200, Andrew Melnychenko wrote:
> Now minimal virtual header length is may include the entire v1 header
> if the hash report were populated.
>
> Signed-off-by: Andrew Melnychenko
subject isn't really descriptive. changed it how?
And I couldn't really decypher
Hi
Am 23.10.21 um 09:49 schrieb Sam Ravnborg:
Hi Thomas,
On Fri, Oct 22, 2021 at 03:28:21PM +0200, Thomas Zimmermann wrote:
Provide a function that computes the offset into a blit destination
buffer. This will allow to move destination-buffer clipping into the
format-helper callers.
Signed-of
On Sun, Oct 31, 2021 at 06:59:56AM +0200, Andrew Melnychenko wrote:
> The header v1 provides additional info about RSS.
> Added changes to computing proper header length.
> In the next patches, the header may contain RSS hash info
> for the hash population.
>
> Signed-off-by: Andrew Melnychenko
>
On Thu, Oct 28, 2021 at 06:49:17PM +0800, Xuan Zhuo wrote:
> In the case of using indirect, indirect desc must be allocated and
> released each time, which increases a lot of cpu overhead.
>
> Here, a cache is added for indirect. If the number of indirect desc to be
> applied for is less than VIRT
On Thu, Oct 28, 2021 at 06:49:19PM +0800, Xuan Zhuo wrote:
> If the VIRTIO_RING_F_INDIRECT_DESC negotiation succeeds, and the number
> of sgs used for sending packets is greater than 1. We must constantly
> call __kmalloc/kfree to allocate/release desc.
>
> In the case of extremely fast package de
On Fri, Oct 29, 2021 at 05:14:41PM +0800, Wu Zongyong wrote:
> This series implements the vDPA driver for Alibaba ENI (Elastic Network
> Interface) which is built based on virtio-pci 0.9.5 specification.
In the future pls do not send v7 as a reply to v6.
Start a new thread with each version.
> Ch
On Fri, Oct 29, 2021 at 05:14:50PM +0800, Wu Zongyong wrote:
> The Kconfig symbol was misspelled, which leads to randconfig link
> failures:
>
> ld.lld: error: undefined symbol: vp_legacy_probe
> >>> referenced by eni_vdpa.c
> >>> vdpa/alibaba/eni_vdpa.o:(eni_vdpa_probe) in archive
On Mon, Nov 01, 2021 at 01:24:50PM +0800, Jie Deng wrote:
> Due to changes in my work, I'm passing the virtio-i2c driver
> maintenance to Conghui.
>
> Signed-off-by: Jie Deng
Seeing as Conghui co-developed the driver, seems reasonable.
Acked-by: Michael S. Tsirkin
> ---
> MAINTAINERS | 2 +-
On Mon, Nov 1, 2021 at 2:23 PM Wu Zongyong wrote:
>
> On Mon, Nov 01, 2021 at 11:31:15AM +0800, Jason Wang wrote:
> > On Fri, Oct 29, 2021 at 5:15 PM Wu Zongyong
> > wrote:
> > >
> > > This series implements the vDPA driver for Alibaba ENI (Elastic Network
> > > Interface) which is built based on
42 matches
Mail list logo