Em Fri, 18 Dec 2009 07:23:03 -0200, Alessandro Bottoni
escreveu:
public class Register {
// this class is used by a BeanEditor-based page template
private String id = "Id From Register";
Never initialize a page class field in its declaration. It can lead to
very nasty bug
Am 18.12.2009 12:46, schrieb Ashwanth Kumar:
Well, did u try using @Persist for UserProfile page's UserID value?
This is going to break tabbed browsing.
- Stephan
-
To unsubscribe, e-mail: users-unsubscr...@tapestry.apache.o
Well, did u try using @Persist for UserProfile page's UserID value?
HTH
- Ashwanth
On Fri, Dec 18, 2009 at 2:53 PM, Alessandro Bottoni
wrote:
> I'm trying to pass a value from a page called "Register" to a page
> called "UserProfile" following the instruction supplied by A. Kolesnikov
> in his
On 18/12/2009, at 9:29 PM, Alessandro Bottoni wrote:
> Il 18/12/2009 10:33, Stephan Windmüller ha scritto:
>> It is passed to the second page, but after that the page is being
>> passivated. You need to implement onActive(String) and onPassivate().
>> Please have a look at page 66 of your book.
>
Il 18/12/2009 10:33, Stephan Windmüller ha scritto:
> It is passed to the second page, but after that the page is being
> passivated. You need to implement onActive(String) and onPassivate().
> Please have a look at page 66 of your book.
Thanks Stephan, thanks Inge and thanks Olle. Now it works.
Am 18.12.2009 10:23, schrieb Alessandro Bottoni:
The Id Value is not passed from the first page to the second one (that
is: I always get the default string "Id from UserProfile" as the Id
rendered on the UserProfile page).
It is passed to the second page, but after that the page is being
pass
http://202.177.217.122:8080/jumpstart/examples/state/passingdatabetweenpages1
On Fri, Dec 18, 2009 at 10:23 AM, Alessandro Bottoni
wrote:
> I'm trying to pass a value from a page called "Register" to a page
> called "UserProfile" following the instruction supplied by A. Kolesnikov
> in his Tape
A long-shot in the dark...
Try to rename UserId to userId to comply with JavaBean naming conventions.
Olle Hallin
Senior Java Developer and Architect
olle.hal...@crisp.se
www.crisp.se
http://www.linkedin.com/in/ollehallin
2009/12/18 Alessandro Bottoni
> I'm trying to pass a value from a page