On 09/12/2021 05:32, Simon Glass wrote:
> On Tue, 7 Dec 2021 at 13:31, Alper Nebi Yasak
> wrote:
>> On 03/12/2021 06:31, Simon Glass wrote:
>>> On Thu, 25 Nov 2021 at 10:40, Alper Nebi Yasak
>>> wrote:
>>>> The RK3399 SoC needs to know the voltage val
nges those would
require, this patch solves things by dynamically allocating a list of
structs (one per instance) in the provider's uclass-private area.
Signed-off-by: Alper Nebi Yasak
---
drivers/phy/allwinner/phy-sun4i-usb.c | 9 ---
drivers/phy/phy-uclass.c | 104 ++
On 08/12/2021 12:31, Peter Robinson wrote:
> I thought there was a different process for the chtomebooks than the
> usual rockchip route. Do the rockchip chomebooks support writing to a
> space in SPI and chainloading like some of the other arm chtomebooks
> did (I think tegra/samsung but my memory
st/?series=273848
Alper Nebi Yasak (2):
rockchip: gru: Set up SoC IO domain registers
rockchip: bob: Enable more configs
Marty E. Plummer (1):
rockchip: rk3399: Add support for chromebook_kevin
Simon Glass (1):
rockchip: gru: Add more devicetree settings
arch/arm/dt
The RK3399 SoC needs to know the voltage value provided by some
regulators, which is done by setting relevant register bits. Configure
these the way other RK3399 boards do, but with the same values as are
set in the equivalent code in coreboot.
Signed-off-by: Alper Nebi Yasak
---
There is a
d-off-by: Simon Glass
[Alper: move to -u-boot.dtsi, rewrite commit message, add more nodes]
Co-developed-by: Alper Nebi Yasak
Signed-off-by: Alper Nebi Yasak
---
Kept sign-off and author as Simon based on the aforementioned commit.
(no changes since v1)
arch/arm/dts/rk3399-gru-u-boot.dtsi | 55
ust
be operable by U-Boot. Enable the relevant config option to allow this.
Bob boards also use the Winbond W25Q64DW SPI flash chip, enable support
for Winbond SPI flash chips in the board config so U-Boot can boot with
this chip.
Signed-off-by: Alper Nebi Yasak
---
(no ch
eMMC and USB issues.
Cc: Marty E. Plummer
Cc: Simon Glass
[Alper: commit message, resync config with Bob, update MAINTAINERS,
add to Rockchip doc, add Kconfig help message, set regulator]
Co-developed-by: Alper Nebi Yasak
Signed-off-by: Alper Nebi Yasak
---
Marty had signed-off an earl
On 19/12/2021 20:14, Simon Glass wrote:
> Thanks for the info. I tested on kevin and bob again, with the eMMC
> series. I see an MMC problem on bob but kevin seems to be OK
> (intermittent?)
I have no idea why you get different results with bob vs kevin. But I
can disable the higher-speed configs
On 15/12/2021 06:26, Simon Glass wrote:
> On Sat, 11 Dec 2021 at 02:02, Alper Nebi Yasak
> wrote:
>> diff --git a/drivers/phy/phy-uclass.c b/drivers/phy/phy-uclass.c
>> index 59683a080cd7..48b4b24db674 100644
>> --- a/drivers/phy/phy-uclass.c
>> +++ b/drivers/phy/ph
nges those would
require, this patch solves things by dynamically allocating a list of
structs (one per instance) in the provider's uclass-private area.
Signed-off-by: Alper Nebi Yasak
---
Changes in v2:
- Rename {phy_,}id_priv -> {phy_,}counts
- Split phy_get_uclass_priv -> phy_{alloc
/list/?series=273848
Alper Nebi Yasak (2):
rockchip: gru: Set up SoC IO domain registers
rockchip: bob: Enable more configs
Marty E. Plummer (1):
rockchip: rk3399: Add support for chromebook_kevin
Simon Glass (1):
rockchip: gru: Add more devicetree settings
arch/arm/dts/Makefile
The RK3399 SoC needs to know the voltage value provided by some
regulators, which is done by setting relevant register bits. Configure
these the way other RK3399 boards do, but with the same values as are
set in the equivalent code in coreboot.
Signed-off-by: Alper Nebi Yasak
Reviewed-by: Kever
d-off-by: Simon Glass
[Alper: move to -u-boot.dtsi, rewrite commit message, add more nodes]
Co-developed-by: Alper Nebi Yasak
Signed-off-by: Alper Nebi Yasak
Reviewed-by: Kever Yang
---
Kept sign-off and author as Simon based on the aforementioned commit.
Changes in v3:
- Add tag: "Rev
DW SPI flash chip, enable support
for Winbond SPI flash chips in the board config so U-Boot can boot with
this chip.
Signed-off-by: Alper Nebi Yasak
Reviewed-by: Kever Yang
---
Changes in v3:
- Unset configs MMC_IO_VOLTAGE, MMC_UHS_SUPPORT, MMC_HS400_SUPPORT,
MMC_HS400_ES_SUPPORT, MMC_SDHCI_S
eMMC and USB issues.
Cc: Marty E. Plummer
Cc: Simon Glass
[Alper: commit message, resync config with Bob, update MAINTAINERS,
add to Rockchip doc, add Kconfig help message, set regulator]
Co-developed-by: Alper Nebi Yasak
Signed-off-by: Alper Nebi Yasak
Reviewed-by: Kever Yang
---
Marty
On 28/02/2022 14:48, Jan Kiszka wrote:
> On 23.02.22 23:59, Simon Glass wrote:
>> On Tue, 22 Feb 2022 at 11:58, Alper Nebi Yasak
>> wrote:
>>> I've also managed to somewhat fix the rest of the issues I wrote, so now
>>> I can replace a FIT entry with a m
On 24/02/2022 01:58, Simon Glass wrote:
> Hi Alper,
>
> On Tue, 15 Feb 2022 at 04:52, Alper Nebi Yasak
> wrote:
>>
>> On 08/02/2022 21:49, Simon Glass wrote:
>>> These symbols are incorrect, meaning that binman cannot find the
>>> associated entry.
On 24/02/2022 01:58, Simon Glass wrote:
> On Tue, 15 Feb 2022 at 04:53, Alper Nebi Yasak
> wrote:
>> On 08/02/2022 21:49, Simon Glass wrote:
>>> diff --git a/tools/dtoc/fdt.py b/tools/dtoc/fdt.py
>>> index 32a7aa9829..e7197f8f12 100644
>>> --- a/tools/
On 24/02/2022 01:58, Simon Glass wrote:
> On Tue, 15 Feb 2022 at 04:53, Alper Nebi Yasak
> wrote:
>>> diff --git a/tools/dtoc/fdt_util.py b/tools/dtoc/fdt_util.py
>>> index 19eb13aef3..59e065884f 100644
>>> --- a/tools/dtoc/fdt_util.py
>>> +++ b/to
On 24/02/2022 01:59, Simon Glass wrote:
> On Tue, 15 Feb 2022 at 04:53, Alper Nebi Yasak
> wrote:
>> On 08/02/2022 21:50, Simon Glass wrote:
>>> +fit,load
>>> +Generates a `load = <...>` property with the load address of the
>>&
ff-by: Simon Glass
> Suggested-by: Alper Nebi Yasak
> ---
>
> Changes in v2:
> - Add new patch to make GetArgs() more flexible
>
> tools/dtoc/fdt_util.py | 8 ++--
> tools/dtoc/test/dtoc_test_simple.dts | 2 ++
> tools/dtoc/test_fdt.py
On 24/02/2022 02:00, Simon Glass wrote:
> This is not necessary if simpler code is used. Use the split function and
> drop the unnecessary []
>
> Signed-off-by: Simon Glass
> Suggested-by: Alper Nebi Yasak
> ---
>
> Changes in v2:
> - Add new patch to remove rem
, 2 insertions(+), 2 deletions(-)
Reviewed-by: Alper Nebi Yasak
> diff --git a/tools/moveconfig.py b/tools/moveconfig.py
> index dea60f4661..4b0e2e250b 100755
> --- a/tools/moveconfig.py
> +++ b/tools/moveconfig.py
> @@ -1610,8 +1610,8 @@ def defconfig_matches(configs, re_match):
&g
On 24/02/2022 02:00, Simon Glass wrote:
> Fix the help which should refer to TPL, not SPL.
>
> Signed-off-by: Simon Glass
> Suggested-by: Alper Nebi Yasak
> ---
>
> Changes in v2:
> - Add new patch to correct Kconfig help for TPL_BINMAN_SYMBOLS
>
> common/sp
On 24/02/2022 02:00, Simon Glass wrote:
> Refactor this to avoid a loop. Also add a test for an empty string.
>
> Signed-off-by: Simon Glass
> Suggested-by: Alper Nebi Yasak
> ---
>
> Changes in v2:
> - Add new patch to tidy up implementaiton of AddStringList()
>
&g
On 24/02/2022 02:00, Simon Glass wrote:
> Rename this function to make it clear that it only reads loadable
> segments. Also update the error for missing module to better match the
> message emitted by Python.
>
> Signed-off-by: Simon Glass
> Suggested-by: Alper Nebi Yasak
>
On 24/02/2022 02:00, Simon Glass wrote:
> Update the return value of this function, fix the 'create' typo and
> update the documentation for clarity.
>
> Signed-off-by: Simon Glass
> Suggested-by: Alper Nebi Yasak
> ---
>
> Changes in v2:
> - Add new pa
| 8
> tools/binman/test/088_expand_size.dts | 8
> tools/binman/test/089_expand_size_bad.dts | 2 +-
> tools/binman/test/225_expand_size_bad.dts | 10 ++
> 7 files changed, 34 insertions(+), 14 deletions(-)
> create mode 100644 tools/binman/t
5 files changed, 8 insertions(+), 8 deletions(-)
Reviewed-by: Alper Nebi Yasak
| 6 +++---
> tools/binman/etype/gbb.py| 4 ++--
> tools/binman/etype/intel_ifwi.py | 4 ++--
> tools/binman/etype/mkimage.py| 4 ++--
> tools/binman/etype/section.py| 4 ++--
> tools/binman/etype/vblock.py | 4 ++--
> 7 files changed, 15 insertions(+), 15 deletions(-)
Reviewed-by: Alper Nebi Yasak
igned-off-by: Simon Glass
> ---
>
> Changes in v2:
> - Add new patch to refactor fit to generate output at the end
>
> tools/binman/etype/fit.py | 178 ++---
> tools/binman/ftest.py | 13 +-
> tools/binman/test/224_fit_
py | 7 ---
> tools/binman/etype/blob_ext_list.py | 2 +-
> 4 files changed, 13 insertions(+), 8 deletions(-)
I feel a bit uneasy about all this fake file stuff, but can't figure out
exactly why. I guess the patch doesn't make it that worse.
Reviewed-by: Alper Nebi
; tools/binman/entry.py | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
> diff --git a/tools/binman/entry.py b/tools/binman/entry.py
Reviewed-by: Alper Nebi Yasak
Later on, I think adding 'min-size' and 'max-size' properties for
entries could be useful for a few things including this.
mkimage_missing.dts
I don't exactly like this, but can't think of a nice alternative either.
Reviewed-by: Alper Nebi Yasak
> [...]
>
> diff --git a/tools/binman/etype/mkimage.py b/tools/binman/etype/mkimage.py
> index 9f4717e4ea..5f6def2287 100644
> --- a/tools/binma
It was one of
the things I was planning to fix as well, thanks!
Reviewed-by: Alper Nebi Yasak
> diff --git a/tools/binman/etype/fit.py b/tools/binman/etype/fit.py
> index 2b82955226..7b0c94dfee 100644
> --- a/tools/binman/etype/fit.py
> +++ b/tools/binman/etype/fit
insertions(+), 25 deletions(-)
Reviewed-by: Alper Nebi Yasak
e v1)
>
> tools/binman/etype/fit.py | 33 +
> tools/binman/ftest.py | 2 +-
> 2 files changed, 26 insertions(+), 9 deletions(-)
Reviewed-by: Alper Nebi Yasak
I don't like entry.Raise(msg) in general, if it were me I would define
Exception s
lass
> ---
>
> (no changes since v1)
>
> tools/binman/etype/fit.py | 16
> 1 file changed, 8 insertions(+), 8 deletions(-)
Reviewed-by: Alper Nebi Yasak
; includes removed generator entries too.
>
> Signed-off-by: Simon Glass
> ---
>
> (no changes since v1)
I'm more and more convinced that generator nodes needs a thorough
redesign, but the patch is consistent with status quo, so:
Reviewed-by: Alper Nebi Yasak
> tools/
On 24/02/2022 02:00, Simon Glass wrote:
> Some boards need to load an ELF file using the 'loadables' property, but
> the file has segments at different memory addresses. This means that it
> cannot be supplied as a flat binary.
>
> Allow generating a separate node in the FIT for each segment in th
arch/arm/dts/rk3328-u-boot.dtsi| 2 ++
> arch/arm/dts/rk3368-u-boot.dtsi| 1 +
> arch/arm/dts/rk3399-u-boot.dtsi| 5 +++--
> arch/arm/dts/rk3568-u-boot.dtsi| 2 ++
> arch/arm/mach-rockchip/Kconfig | 6 ++
> 8 files cha
On 03/03/2022 01:16, Peter Geis wrote:
> On Wed, Feb 23, 2022 at 6:04 PM Simon Glass wrote:
>> diff --git a/arch/arm/dts/rockchip-u-boot.dtsi
>> b/arch/arm/dts/rockchip-u-boot.dtsi
>> index eae3ee715d..64e4466489 100644
>> --- a/arch/arm/dts/rockchip-u-boot.dtsi
>> +++ b/arch/arm/dts/rockchip-u-b
On 01/03/2022 05:48, Peter Geis wrote:
> Good Evening,
>
> I successfully tested your v2 patch series to create a bootable sdcard
> image out of the box for rockpro64-rk3399.
> Unfortunately, rk356x and rk3399-spi modes are broken, due to the
> inability to pass multiple images to mkimage at the s
On 06/03/2022 17:44, Peter Geis wrote:
> On Sat, Mar 5, 2022 at 10:08 PM Simon Glass wrote:
>> On Fri, 4 Mar 2022 at 12:56, Peter Geis wrote:
>>> mkimage has the ability to process two files at the same time.
>>> This is necessary for rk356x support as both TPL and SPL need to be
>>> hashed indiv
On 06/03/2022 06:08, Simon Glass wrote:
> On Thu, 3 Mar 2022 at 14:16, Alper Nebi Yasak
> wrote:
>> On 24/02/2022 02:00, Simon Glass wrote:
>>> +- Put faked files into a separate subdir and remove them on start-up, to
>>> avoid
>>> + seeing them as '
On 06/03/2022 06:08, Simon Glass wrote:
> On Thu, 3 Mar 2022 at 14:16, Alper Nebi Yasak
> wrote:
>>> def ObtainContents(self):
>>> +# Use a non-zero size for any fake files to keep mkimage happy
>>> data, input_fname, uni
On 06/03/2022 06:08, Simon Glass wrote:
> On Thu, 3 Mar 2022 at 14:17, Alper Nebi Yasak
> wrote:
>>> This is a bit clumsy. We cannot build the image more than once, since the
>>> generator entries are lost during the first build. Binman requires that
>>> calling
On 06/03/2022 06:19, Simon Glass wrote:
> This should not be done in the constructor. Move it.
>
> Signed-off-by: Simon Glass
> Suggested-by: Alper Nebi Yasak
> ---
>
> (no changes since v1)
>
> tools/binman/etype/fit.py | 10 --
> 1 file changed
te mode 100644 tools/binman/test/226_fit_split_elf.dts
> create mode 100644 tools/binman/test/227_fit_bad_dir.dts
> create mode 100644 tools/binman/test/228_fit_bad_dir_config.dts
I still can't like this enough to add a Reviewed-by, but I guess you'll
apply the series up to and maybe including this, so:
Acked-by: Alper Nebi Yasak
On 06/03/2022 06:19, Simon Glass wrote:
> This boards uses SPL_FIT so does not need to support loading a raw image.
This sounds OK to me, but...
> Drop it to avoid binman trying to insert a symbol which has no value.
I couldn't figure out how it leads to this in the code. I guess some
ifdefs or
Hi Tom,
I have a few Rockchip-related series [1] that I was expecting to land
for v2022.04 (including improvements for chromebook_bob, support for the
chromebook_kevin board, rk3399 eMMC fixes) but there hasn't been a
u-boot-rockchip pull request since the one for v2022.01 [2]. There's
also more p
On 11/03/2022 18:43, Tom Rini wrote:
> On Fri, Mar 11, 2022 at 12:05:42AM +0300, Alper Nebi Yasak wrote:
>> I have a few Rockchip-related series [1] that I was expecting to land
>> for v2022.04 (including improvements for chromebook_bob, support for the
>> chromebook_kevin boa
On 11/03/2022 21:18, Simon Glass wrote:
> On Fri, 11 Mar 2022 at 11:16, Alper Nebi Yasak
> wrote:
>> I haven't been paying enough attention to others' patches. For those of
>> mine, I think I can only call my RK3399 eMMC fix [1] a regression fix.
>> IIRC it has
On 11/03/2022 22:01, Tom Rini wrote:
> On Fri, Mar 11, 2022 at 09:56:59PM +0300, Alper Nebi Yasak wrote:
>> On 11/03/2022 21:18, Simon Glass wrote:
>>> Apler, would you be interested in being a co-maintainer for Rockchip?
>>
>> I can try. Not sure how much I
On 11/03/2022 22:25, Alper Nebi Yasak wrote:
> On 11/03/2022 22:01, Tom Rini wrote:
>> On Fri, Mar 11, 2022 at 09:56:59PM +0300, Alper Nebi Yasak wrote:
>>> On 11/03/2022 21:18, Simon Glass wrote:
>>>> Apler, would you be interested in being a co-maintainer for Ro
On 12/03/2022 08:02, Simon Glass wrote:
> On Thu, 10 Mar 2022 at 12:36, Alper Nebi Yasak
> wrote:
>> On 06/03/2022 06:08, Simon Glass wrote:
>>> On Thu, 3 Mar 2022 at 14:16, Alper Nebi Yasak
>>> wrote:
>>>> Do we need to create actual files, or is
On 12/03/2022 08:02, Simon Glass wrote:
> On Thu, 10 Mar 2022 at 12:36, Alper Nebi Yasak
> wrote:
>> On 06/03/2022 06:19, Simon Glass wrote:
>>> This boards uses SPL_FIT so does not need to support loading a raw image.
>>
>> This sounds OK to me, but...
>>
On 11/03/2022 22:49, Jagan Teki wrote:
> On Fri, Dec 24, 2021 at 7:14 PM Alper Nebi Yasak
> wrote:
>>
>> The RK3399 SoC needs to know the voltage value provided by some
>> regulators, which is done by setting relevant register bits. Configure
>> these the way other
On 11/03/2022 23:01, Jagan Teki wrote:
> On Fri, Dec 24, 2021 at 7:14 PM Alper Nebi Yasak
> wrote:
>> The Bob board has two USB 3.0 Type-C ports and one USB 2.0 Type-A port
>> on its right side. Enable the configs relevant to USB devices so these
>> can be used.
>
On 12/03/2022 16:38, Kever Yang wrote:
> On 2022/3/12 02:15, Alper Nebi Yasak wrote:
>> I haven't been paying enough attention to others' patches. For those of
>> mine, I think I can only call my RK3399 eMMC fix [1] a regression fix.
>
> The eMMC driver is always
On 11/03/2022 23:02, Jagan Teki wrote:
> On Fri, Dec 24, 2021 at 7:14 PM Alper Nebi Yasak
> wrote:
>> [...] The rk3399-gru-kevin devicetree
>> has an unknown event code reference which has to be defined, set it
>> to the Linux counterpart.
>>
>> [...]
>&
hanced_strobe
- Let set_enhanced_strobe() unset the ES bit if mode is not HS400_ES
- Rewrote cover letter
v1: https://patchwork.ozlabs.org/project/uboot/list/?series=269768&state=*
Alper Nebi Yasak (3):
mmc: sdhci: Add HS400 Enhanced Strobe support
rockchip: sdhci: Add HS400 Enhanced Str
Delegate setting the Enhanced Strobe configuration to individual drivers
if they set a function for it. Return -ENOTSUPP if they do not, like
what the MMC uclass does.
Signed-off-by: Alper Nebi Yasak
Reviewed-by: Jaehoon Chung
---
(no changes since v4)
Changes in v4:
- Add comment for SDHCI
().
This is mostly ported from Linux's Arasan SDHCI driver which happens
to be the underlying IP. (drivers/mmc/host/sdhci-of-arasan.c in Linux
tree).
Signed-off-by: Alper Nebi Yasak
Reviewed-by: Jaehoon Chung
---
Changes in v5:
- Add tag: "Reviewed-by: Jaehoon Chung "
Changes in v4
ifeng Zhao
Signed-off-by: Yifeng Zhao
Signed-off-by: Alper Nebi Yasak
---
This is a fixed version I received off-list from Yifeng. I didn't modify
the diff, but added a paragraph in the commit message mentioning their
changes and adjusted the signoffs in the end.
Didn't add the Reviewe
401 - 466 of 466 matches
Mail list logo