On Fri, 2021-08-20 at 07:41 +0200, Heiko Thiery wrote:
>
> ...
>
> When building from a clean checkout I see the following warnings. It
> seems that there are some dependency checks that are looking for the
> files in mkimage config file.
>
> AR arch/arm/lib/lib.a
> AS arch/arm/lib
On Fri, Aug 20, 2021 at 2:58 AM Tom Rini wrote:
>
> This driver uses the CONFIG namespace to set the chips internal CONFIG
> namespace related bits. However, CONFIG is reserved for the top-level
> Kconfig based configuration system. Use CFG as the namespace here
> instead to avoid pollution.
>
>
On Fri, Aug 20, 2021 at 3:15 AM Tom Rini wrote:
>
> Update the comment here to refer to PCI_CONFIG_ADDRESS rather than
> CONFIG_ADDRESS.
>
> Signed-off-by: Tom Rini
> ---
> include/mpc83xx.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
Reviewed-by: Bin Meng
On Fri, Aug 20, 2021 at 3:08 AM Tom Rini wrote:
>
> This driver is currently unused. Remove.
>
> Signed-off-by: Tom Rini
> ---
> drivers/video/Makefile|1 -
> drivers/video/ati_ids.h | 211
> drivers/video/ati_radeon_fb.c | 761 -
> drivers/video/ati_radeon_
On Fri, Aug 20, 2021 at 3:07 AM Tom Rini wrote:
>
> The value CONFIG_ALTERA_SPI_IDLE_VAL is never re-defined by a board.
> Rename this to ALTERA_SPI_IDLE_VAL.
>
> Signed-off-by: Tom Rini
> ---
> drivers/spi/altera_spi.c | 6 ++
> 1 file changed, 2 insertions(+), 4 deletions(-)
>
Reviewed-by
On Fri, Aug 20, 2021 at 1:56 AM Tom Rini wrote:
>
> This driver uses the CONFIG namespace to set the chips internal CONFIG
> namespace related bits. However, CONFIG is reserved for the top-level
> Kconfig based configuration system. Use CFG as the namespace here
> instead to avoid pollution.
>
>
On 19/08/2021 14:37, Nishanth Menon wrote:
> On 14:03-20210819, Roger Quadros wrote:
>> Hi,
>>
>> If the device tree node has status="ok" then the u-boot DM will treat the
>> device as disabled.
>> There are still quite many devices using "ok" instead of "okay" or no status
>> and those device
As per Device Tree core schema [1], status parameter of nodes can be either
"okay" or "disabled".
U-boot Driver Model does not recognize status="ok" and treats
the node as disabled.
Signed-off-by: Roger Quadros
---
arch/arm/dts/am3517-evm-ui.dtsi | 4 ++--
arch/arm/dts/am3517-ev
Hi Heiko and Marcel,
On Fri, Aug 20, 2021 at 4:31 AM Marcel Ziswiler
wrote:
>
> On Fri, 2021-08-20 at 07:41 +0200, Heiko Thiery wrote:
> >
> > ...
> >
> > When building from a clean checkout I see the following warnings. It
> > seems that there are some dependency checks that are looking for the
Hi Fabio,
> > Yes, I believe it really requires explicitly setting the filename as I
> > previously suggested.
> >
> >
> > https://marc.info/?l=u-boot&m=162940109314578
>
> Peng Fan has sent a patch fixing this:
> https://www.mail-archive.com/u-boot@lists.denx.de/msg414966.html
Ah ok. Thanks
--
Hi Tom,
As the Dockerfile used for U-Boot CI testing is now integrated into
the U-Boot source tree, I suggest we remote the gitlab-ci-runner repo
to avoid confusion.
https://source.denx.de/u-boot/gitlab-ci-runner
Regards,
Bin
LS1046A-QDS board requires updation in few environment configs in TFA
defconfigs of the board.
Following are the changes:
- Update CONFIG_ENV_ADDR
- Update CONFIG_ENV_SECT_SIZE
- Enable CONFIG_SYS_RELOC_GD_ENV_ADDR
Signed-off-by: Kuldeep Singh
---
configs/ls1046aqds_tfa_defconfig | 5 +++--
1 f
Add the SOC ID for the S905Y2 to board info, see below for before/after
tested with a Radxa Zero board:
SoC: Amlogic Meson G12A (Unknown) Revision 28:b (30:2)
SoC: Amlogic Meson G12A (S905Y2) Revision 28:b (30:2)
Signed-off-by: Christian Hewitt
---
arch/arm/mach-meson/board-info.c | 1 +
1
This series add support for Macronix octal DTR flash, add second time
Softreset with "INVERT" command extension type and follow linux kernel
to enable 4byte opcode when possible.
JaimeLiao (4):
mtd: spi-nor: macronix: add support for Macronix Octal flash
mtd: spi-nor-core: Adding different typ
Follow patch "f6adec1af4b2f5d3012480c6cdce7743b74a6156" for adding
Macronix flash in Octal DTR mode.
Enable Octal DTR mode with 20 dummy cycles to allow running at the
maximum supported frequency.
-https://www.mxic.com.tw/Lists/Datasheet/Attachments/7841/MX25LM51245G,%203V,%20512Mb,%20v1.1.pdf
Power-on-Reset is a method to restore flash back to 1S-1S-1S mode from 8D-8D-8D
in the begging of probe.
Command extension type is not standardized across flash vendors in DTR mode.
For suiting different vendor flash devices, having second times Softreset with
different types is clumsy but useful
Following linux kernel to check address width and 4byte flag to enable
4byte opcode setting.
Signed-off-by: JaimeLiao
---
drivers/mtd/spi/spi-nor-core.c | 4
1 file changed, 4 insertions(+)
diff --git a/drivers/mtd/spi/spi-nor-core.c b/drivers/mtd/spi/spi-nor-core.c
index 707eb9c1d2..069c6
Adding Macronix Octal flash for Octal DTR support.
The octaflash series can be divided into the following types:
MX25 series : Serial NOR Flash.
MX66 series : Serial NOR Flash with stacked die.(Size larger than 1Gb)
LM/UM series : Up to 250MHz clock frequency with both DTR/STR operation.
LW/UW se
On 19/08/2021 21.02, Tom Rini wrote:
> This removes a number of spots of dead code based on symbols that start
> with CONFIG_[0-9] or CONFIG_A.
How did you find those symbols? I suppose the actual patch is just
generated with unifdef or similar.
> include/configs/vexpress_common.h | 3
On Thu, 2021-08-19 at 12:32 +0200, Frieder Schrempf wrote:
> On 16.08.21 05:48, Peng Fan (OSS) wrote:
> > From: Peng Fan
> >
> > After switch to use binman, no need to use the bash script
> > to check file exsiting or not. And there is bug that
> > the script will be executed everytime Makefile i
On Fri, Aug 20, 2021 at 03:01:19PM +0200, Rasmus Villemoes wrote:
> On 19/08/2021 21.02, Tom Rini wrote:
> > This removes a number of spots of dead code based on symbols that start
> > with CONFIG_[0-9] or CONFIG_A.
>
> How did you find those symbols? I suppose the actual patch is just
> generated
On Fri, 2021-08-20 at 12:47 +0200, Heiko Thiery wrote:
> Hi Fabio,
>
> > > Yes, I believe it really requires explicitly setting the filename as I
> > > previously suggested.
> > >
> > >
> > > https://marc.info/?l=u-boot&m=162940109314578
> >
> > Peng Fan has sent a patch fixing this:
> > https
On 8/19/21 4:53 PM, Peter Hoyes wrote:
From: Peter Hoyes
The use of ARMv8.3 pointer authentication (PAuth) is governed by fields
in HCR_EL2, which trigger a 'trap to EL2' if not enabled. The reset
value of these fields is 'architecturally unknown' so we must ensure
that the fields are enabled (
Hi Wolfgang,
On Thu, 19 Aug 2021 at 08:58, Wolfgang Denk wrote:
>
> Dear Simon,
>
> In message
> you
> wrote:
> >
> > - programming errors
> > - security errors where user input is insufficiently checked
> >
> > IMO the former should not be present if you have sufficient tests and
> > trying t
Hi,
Am 2021-08-20 16:44, schrieb Andre Przywara:
On 8/19/21 4:53 PM, Peter Hoyes wrote:
From: Peter Hoyes
The use of ARMv8.3 pointer authentication (PAuth) is governed by
fields
in HCR_EL2, which trigger a 'trap to EL2' if not enabled. The reset
value of these fields is 'architecturally unk
On 8/19/21 4:53 PM, Peter Hoyes wrote:
Hi,
From: Peter Hoyes
Armv8r64 is the first Armv8 platform that only has a PMSA at the
current exception level. The architecture supplement for Armv8r64
describes new fields in ID_AA64MMFR0_EL1 which can be used to detect
whether a VMSA or PMSA is presen
Hi everyone.
First, I hope you are fine and the same for your relatives.
This series introduces C tests for hush.
The main goal of these tests is to act as regression tests in case of hush being
modified.
During their writings some bugs were found, unfortunately I did not write
patches to fix th
This commit introduces a new subcommand to ut: ut hush.
For the moment, this command does nothing, future commits will add tests which
will be run on command call.
Note that CONFIG_HUSH_PARSER must be defined to compile this new subcommand.
Signed-off-by: Francis Laniel
---
include/test/hush.h
As asked in commit 9c6bf1715f6a ("test/py: hush_if_test: Add tests to cover
octal/hex values"), this commit translates test_hush_if_test.py to a C test.
Signed-off-by: Francis Laniel
---
test/hush/Makefile | 1 +
test/hush/if.c | 308 +
2 files c
Commit 9087ab2cc4 ("test/py: hush_if_test: Remove the test file.") translated
this test to a C test, so this python file is no more needed.
Signed-off-by: Francis Laniel
---
test/py/tests/test_hush_if_test.py | 192 -
1 file changed, 192 deletions(-)
delete mode 1006
This commit ensures shell variables are replaced by their values.
Signed-off-by: Francis Laniel
---
test/hush/Makefile | 1 +
test/hush/dollar.c | 188 +
2 files changed, 189 insertions(+)
create mode 100644 test/hush/dollar.c
diff --git a/test/hus
This commit ensures behavior of commands separated by ';', '&&' and '||'.
Signed-off-by: Francis Laniel
---
test/hush/Makefile | 1 +
test/hush/list.c | 79 ++
2 files changed, 80 insertions(+)
create mode 100644 test/hush/list.c
diff --git a/test
The added tests ensure correct behavior of for, while and until loops.
Signed-off-by: Francis Laniel
---
test/hush/Makefile | 1 +
test/hush/loop.c | 64 ++
2 files changed, 65 insertions(+)
create mode 100644 test/hush/loop.c
diff --git a/test/hu
Hi.
I hope you are fine and the same for your family and friends.
In July, a proposal to add a new shell for U-Boot was posted on the mailing
list [1].
The community discussed a lot about this changes, some people did not agree
with it because the new shell is not compatible with the actual on
On Tue, Aug 10, 2021 at 11:27 AM Siew Chin Lim
wrote:
>
> Add device tree for N5X.
>
> Signed-off-by: Siew Chin Lim
> Signed-off-by: Tien Fong Chee
>
> ---
> v6:
> - Sort the node name in alphanumeric order in socfpga_n5x_socdk-u-boot.dtsi
> - Remove duplicated qspi node from socfpga_n5x_socdk-u
On 8/19/21 4:53 PM, Peter Hoyes wrote:
Hi,
From: Peter Hoyes
Use the environment variable armv8_switch_to_el1 to determine whether
to switch to EL1 at runtime. This is an alternative to the
CONFIG_ARMV8_SWITCH_TO_EL1 compile-time option.
This might be useful outside of the v8-R64 FVP. I can
On Fri, Aug 20, 2021 at 05:57:51PM +0100, Andre Przywara wrote:
> On 8/19/21 4:53 PM, Peter Hoyes wrote:
>
> Hi,
>
> > From: Peter Hoyes
> >
> > Use the environment variable armv8_switch_to_el1 to determine whether
> > to switch to EL1 at runtime. This is an alternative to the
> > CONFIG_ARMV8_
In the list of mainline U-boot supported Rockchip boards
rk3188 is placed below under the name rv3188. Give back it's
original name and sort the list in alphabetical order.
Signed-off-by: Johan Jonker
---
doc/board/rockchip/rockchip.rst | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Brand names are supposed to be written with a capital,
so change them all.
Signed-off-by: Johan Jonker
---
doc/board/rockchip/rockchip.rst | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/doc/board/rockchip/rockchip.rst b/doc/board/rockchip/rockchip.rst
index
On 13:41-20210820, Roger Quadros wrote:
> As per Device Tree core schema [1], status parameter of nodes can be either
> "okay" or "disabled".
>
> U-boot Driver Model does not recognize status="ok" and treats
> the node as disabled.
>
Did
Hi Harm,
On Wed, 18 Aug 2021 at 08:09, Harm Berntsen wrote:
>
> On Thu, 2021-05-13 at 19:39 -0600, Simon Glass wrote:
> > When the default clocks cannot be set, the clock is silently probed and
> > the error is ignored. This is incorrect, since having the clocks at the
> > correct speed may be im
Hi Rasmus,
On Fri, 20 Aug 2021 at 00:22, Rasmus Villemoes
wrote:
>
> On 19/08/2021 14.32, Wolfgang Denk wrote:
>
> > The existence of bad code is not a justification to add more of it.
>
> Obviously true and I agree.
>
> However, it is at the same time completely irrelevant in this context,
> bec
Hi Takahiro,
On Thu, 19 Aug 2021 at 21:15, AKASHI Takahiro
wrote:
>
> Hi Simon,
>
> On Thu, Aug 19, 2021 at 08:25:33AM -0600, Simon Glass wrote:
> > Hi Tom,
> >
> > On Thu, 19 Aug 2021 at 07:59, Tom Rini wrote:
> > >
> > > On Wed, Aug 18, 2021 at 09:45:33PM -0600, Simon Glass wrote:
> > >
> > >
Hi Francis,
On Fri, 20 Aug 2021 at 10:12, Francis Laniel
wrote:
>
> Hi.
>
>
> I hope you are fine and the same for your family and friends.
>
> In July, a proposal to add a new shell for U-Boot was posted on the mailing
> list [1].
> The community discussed a lot about this changes, some people d
Hi Heiko,
On Fri, 20 Aug 2021 at 00:49, Heiko Thiery wrote:
>
> Hi Simon,
>
> During the discussion on [1] I had the idea if binman could create a
> list of all output files, so that it is possible to do a real clean in
> the u-boot makefile.
>
> Currently there are not all binaries listed in the
On Wed, Jun 30, 2021 at 7:32 AM Adam Ford wrote:
>
> On Fri, Jun 4, 2021 at 12:27 PM Sean Anderson wrote:
> >
> >
> >
> > On 6/4/21 1:26 PM, Adam Ford wrote:
> > > The driver is based on the Versaclock driver from the Linux code, but
> > > due differences in the clock API between them, some piece
On 8/20/21 2:27 PM, Adam Ford wrote:
On Wed, Jun 30, 2021 at 7:32 AM Adam Ford wrote:
On Fri, Jun 4, 2021 at 12:27 PM Sean Anderson wrote:
>
>
>
> On 6/4/21 1:26 PM, Adam Ford wrote:
> > The driver is based on the Versaclock driver from the Linux code, but
> > due differences in the clock
Hello Tom,
Ilias will be back on Monday. Then he can clarify with Simon the series
"efi: Minimal revert to rodata change"
https://patchwork.ozlabs.org/project/uboot/list/?series=256272.
The following changes since commit a0da2dda4ed9d0aee5265e9cd8876734f9f80e09:
Prepare v2021.10-rc2 (2021-08-
Hi Heinrich,
On Fri, 20 Aug 2021 at 13:07, Heinrich Schuchardt wrote:
>
> Hello Tom,
>
> Ilias will be back on Monday. Then he can clarify with Simon the series
> "efi: Minimal revert to rodata change"
> https://patchwork.ozlabs.org/project/uboot/list/?series=256272.
I think I already asked for
From: Marcel Ziswiler
An assortment of fixes and improvements like a legacy image generation
fix, an Ethernet PHY configuration fix, DEK blob encapsulation
preparation, migration to using binman to pack images, SLEEP_MOCI#
enablement and dropping of V1.0 hardware support [1].
One last issue I a
From: Marcel Ziswiler
While most boards meanwhile migrated to using binman a few like the
verdin-imx8mm are still using the legacy image generation.
Unfortunately, the legacy image generation is currently broken which is
especially bad for any kind of bisection attempts.
Anyway, this fixes it eve
From: Marcel Ziswiler
Replace spurious spaces with proper tabs.
Signed-off-by: Marcel Ziswiler
---
arch/arm/mach-imx/imx8m/Kconfig | 20 ++--
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/arch/arm/mach-imx/imx8m/Kconfig b/arch/arm/mach-imx/imx8m/Kconfig
index
From: Marcel Ziswiler
Turns out Microship (formerly Micrel) meanwhile integrated proper
support for the DLL setup on their KSZ9131. Unfortunately, this
conflicts with our previous board code doing that.
Fix this by getting rid of our board code and just relying on the
generic implementation relyi
From: Marcel Ziswiler
Prepare for DEK blob encapsulation support through "dek_blob" command.
On ARMv8, u-boot runs in non-secure, thus cannot encapsulate a DEK blob
for encrypted boot.
The DEK blob is encapsulated by OP-TEE through a trusted application
call. U-boot sends and receives the DEK and
From: Max Krummenacher
This powers some peripherals on the carrier board e.g. the USB hub.
Related-to: ELB-3206
Signed-off-by: Max Krummenacher
Signed-off-by: Marcel Ziswiler
---
arch/arm/dts/imx8mm-verdin.dts | 18 ++
configs/verdin-imx8mm_defconfig | 1 +
2 files changed,
From: Marcel Ziswiler
Use binman to pack images.
Signed-off-by: Marcel Ziswiler
---
arch/arm/dts/imx8mm-verdin-u-boot.dtsi | 122 ++-
arch/arm/mach-imx/imx8m/Kconfig | 1 +
board/toradex/verdin-imx8mm/imximage.cfg | 11 +-
configs/verdin-imx8mm_defconfig
From: Max Krummenacher
We drop support for Verdin iMX8M Mini V1.0B.
Related-to: ELB-3551
Signed-off-by: Max Krummenacher
Signed-off-by: Marcel Ziswiler
---
board/toradex/verdin-imx8mm/verdin-imx8mm.c | 13 +
1 file changed, 5 insertions(+), 8 deletions(-)
diff --git a/board/tor
From: Chris Morgan
The devicetree submitted and approved for the mainline linux kernel is
slightly different than the one present here. This syncs both
devicetrees (for the Rockchip SFC node at least) present on the PX30
and the Odroid Go Advance. Changes include renaming the flash node,
reorderi
58 matches
Mail list logo