%s/efi_simple_input_interface/efi_simple_text_input_protocol/
We should be consistent in the naming of the EFI protocol interface
structures. The protocol is called EFI_SIMPLE_TEXT_INPUT_PROTOCOL.
%s/ExtendedVerification/extended_verification/
Use consistent naming of function parameters. Do not
Add the missing SPDX-License-Identifier based on Linux kernel commit
b24413180f56 ("License cleanup: add SPDX GPL-2.0 license identifier to
files with no license").
Correct formatting errors.
Signed-off-by: Heinrich Schuchardt
---
include/efi_api.h | 28 ++--
1 file chan
Add the missing SPDX-License-Identifier based on Linux kernel commit
b24413180f56 ("License cleanup: add SPDX GPL-2.0 license identifier to
files with no license").
Signed-off-by: Heinrich Schuchardt
---
include/efi.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/include/efi.h b/include/ef
make mrproper && make efi-x86_app_defconfig && make
results in
CC common/image.o
{standard input}: Assembler messages:
{standard input}:21662: Error: junk at end of line, first unrecognized
character is `@'
{standard input}:21707: Error: junk at end of line, first unrecognized
character is
The arm, xtensa and mips version of atomic.h were already very similar
(the mips one was a copy of xtensa). Combine these implementations
together to produce a generic atomic.h that can be included by these
architectures (and any others that need it in future).
Signed-off-by: Chris Packham
---
Make use of asm-generic/atomic.h retaining the smp_mb_... definitions.
Signed-off-by: Chris Packham
---
arch/arm/include/asm/atomic.h | 147 +-
1 file changed, 1 insertion(+), 146 deletions(-)
diff --git a/arch/arm/include/asm/atomic.h b/arch/arm/include/asm/ato
This series applies on top of https://patchwork.ozlabs.org/patch/958286/
The intention is to rationalise most of the current implementations of
atomic.h. x86 remains as having an arch specific implementation which I
don't intend to touch.
Chris Packham (4):
Add include/asm-generic/atomic.h
AR
Make use of asm-generic/atomic.h.
Signed-off-by: Chris Packham
---
arch/mips/include/asm/atomic.h | 44 +-
1 file changed, 1 insertion(+), 43 deletions(-)
diff --git a/arch/mips/include/asm/atomic.h b/arch/mips/include/asm/atomic.h
index 7551bf6e6c2c..c4f08b7820
Make use of asm-generic/atomic.h.
Signed-off-by: Chris Packham
---
arch/xtensa/include/asm/atomic.h | 44 +---
1 file changed, 1 insertion(+), 43 deletions(-)
diff --git a/arch/xtensa/include/asm/atomic.h b/arch/xtensa/include/asm/atomic.h
index 42b32f5d3d6e..4e3ad5
With DM_GPIO and DM_MMC translating GPIO_ACTIVE_LOW, any boards
using the 'cd-invert' option will no longer need to do this. This
patch removes the support for 'invert' from the MMC driver.
Signed-off-by: Adam Ford
---
V2: Don't include patch 1 with xlate. It is not apparently needed.
Rem
With the omap_mmc driver no longer supporting cd-inverted, this
patch removes all these references since they are not needed.
Signed-off-by: Adam Ford
---
V2: No changes
diff --git a/arch/arm/dts/am3517-evm-u-boot.dtsi
b/arch/arm/dts/am3517-evm-u-boot.dtsi
index c02beaad77..59df819f9d 100644
--
On Wed, Sep 5, 2018 at 8:08 AM Tuomas Tynkkynen wrote:
>
> Hi Adam,
>
> On 09/03/2018 05:08 PM, Adam Ford wrote:
> > When re-syncing the DTS files from the kernel, something caused
> > the MMC driver to no longer detect the MMC card. Undoing the
> > CD-invert appears to fix the issue.
> >
> > Fixe
Four different boards had different options for enabling cache
that were virtually all the same. This consolidates these
common functions into arch/arm/cpu/arm926ejs/cache.c
This also has the positive side-effect of enabling cache on
the Davinci (da850) boards.
Signed-off-by: Adam Ford
---
V2:
Fix a few typos.
Signed-off-by: Heinrich Schuchardt
---
lib/efi_loader/efi_console.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/lib/efi_loader/efi_console.c b/lib/efi_loader/efi_console.c
index 6157c0251f..6ba55413cd 100644
--- a/lib/efi_loader/efi_console.c
+++
On Sat, Sep 8, 2018 at 2:39 AM, Chris Packham wrote:
> Make use of asm-generic/atomic.h.
>
> Signed-off-by: Chris Packham
> ---
>
> arch/xtensa/include/asm/atomic.h | 44 +---
> 1 file changed, 1 insertion(+), 43 deletions(-)
Acked-by: Max Filippov
--
Thanks.
-- M
Hi Georgii,
On 5 September 2018 at 09:44, Georgii Staroselskii
wrote:
>
> On Wed, Sep 05, 2018 at 09:24:40AM -0600, Simon Glass wrote:
> > Hi Georgi,
> >
> > On 4 September 2018 at 07:34, Georgii Staroselskii
> > wrote:
> > > This API is going to be used to configure some pins that are protecte
Preread the next key in the console timer event.
The EFI_SIMPLE_TEXT_INPUT_EX_PROTOCOL requires to trigger registered key
notification functions based on the prefetched key.
Signed-off-by: Heinrich Schuchardt
---
lib/efi_loader/efi_console.c | 204 ++-
1 file cha
We should test the WaitForKey event.
Testing for EFI_NOT_READY can be done after resetting the console.
Signed-off-by: Heinrich Schuchardt
---
lib/efi_selftest/efi_selftest_textinput.c | 27 ---
1 file changed, 24 insertions(+), 3 deletions(-)
diff --git a/lib/efi_selftest/e
Move reusable utility functions to efi_selftest_util.c.
Signed-off-by: Heinrich Schuchardt
---
include/efi_selftest.h| 16
lib/efi_selftest/efi_selftest_textinput.c | 109 +-
lib/efi_selftest/efi_selftest_util.c | 93 ++
3 files
Up to now the EFI_TEXT_INPUT_PROTOCOL only supported ASCII characters.
With the patch it can consume UTF-8 from the serial console or
codepage 437 special characters from the local keyboard.
Signed-off-by: Heinrich Schuchardt
---
lib/efi_loader/efi_console.c | 80 +++
This patch series contains fixes for the EFI_SIMPLE_TEXT_INPUT_PROTOCOL.
Support Unicode letters received as UTF-8 from the serial console.
Support code page 437 letters received from the local console.
Correct handling of the WaitForKey event.
Update unit test.
Heinrich Schuchardt (6):
efi_loa
Test that the Euro sign is correctly retrieved from the console via the
EFI_SIMPLE_TEXT_INPUT_PROTOCOL.
Signed-off-by: Heinrich Schuchardt
---
test/py/tests/test_efi_selftest.py | 7 +++
1 file changed, 7 insertions(+)
diff --git a/test/py/tests/test_efi_selftest.py
b/test/py/tests/test_ef
We require code page 437 both for text input and for the Unicode collation
protocol. We should have the translation table to Unicode only once.
Signed-off-by: Heinrich Schuchardt
---
include/charset.h | 6 ++
lib/charset.c | 3 +++
lib/efi_loader
23 matches
Mail list logo