There is no user calling this function, thus remove it.
Signed-off-by: Axel Lin
---
drivers/gpio/spear_gpio.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/gpio/spear_gpio.c b/drivers/gpio/spear_gpio.c
index d3c728e..5b5521e 100644
--- a/drivers/gpio/spear_gpio.c
+++ b/drivers/
Hi
Il giorno 30/giu/2013 06:18, "Axel Lin" ha scritto:
>
> 2013/6/21 Michael Trimarchi :
> > On 06/21/2013 06:40 AM, Vipin Kumar wrote:
> >> On 6/20/2013 7:26 PM, Axel Lin wrote:
> >>> 2013/6/20 Marek Vasut
>
> Dear Axel Lin,
>
> > In current gpio_set_value() implementation, it
2013/6/30 Michael Trimarchi :
> Hi
> Il giorno 30/giu/2013 06:18, "Axel Lin" ha scritto:
>
>
>>
>> 2013/6/21 Michael Trimarchi :
>> > On 06/21/2013 06:40 AM, Vipin Kumar wrote:
>> >> On 6/20/2013 7:26 PM, Axel Lin wrote:
>> >>> 2013/6/20 Marek Vasut
>>
>> Dear Axel Lin,
>>
>> >
CloudBox device is device tree compliant, but older LaCie kernel uses
machine ID method to boot.
Signed-off-by: Frédéric Leroy
---
arch/arm/include/asm/mach-types.h | 14 ++
board/LaCie/cloudbox/cloudbox.c | 7 ++-
include/configs/lacie_kw.h| 1 +
3 files changed, 21
The cloudbox device have a different ethernet phy setup than other ns2
devices. We get initialization value from the GPL LaCie source
Signed-off-by: Frédéric Leroy
---
board/LaCie/common/common.c | 13 ++---
include/configs/lacie_kw.h | 5 +
2 files changed, 15 insertions(+), 3 del
Signed-off-by: Frédéric Leroy
---
include/configs/lacie_kw.h | 26 +-
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a/include/configs/lacie_kw.h b/include/configs/lacie_kw.h
index e2b3b21..cac616a 100644
--- a/include/configs/lacie_kw.h
+++ b/include/config
This series adds support for the LaCie Cloudbox v2 device.
Changes in v2:
- sort unsorted #ifdef list in lacie_kw.h
- add entry to MAINTAINERS
- remove unused GPIO definitions
- remove empty misc_init_r()
- add Machine ID
- Use #define values for ethernet phy init
- checkpatch compliant
Frédéri
The LaCie CloudBox device is a Kirkwood based nas :
- SoC: Marvell 88F6702 1000Mhz
- SDRAM memory: 256MB DDR2 400Mhz
- Gigabit ethernet: PHY Marvell 88E1318
- Flash memory: SPI NOR 512KB (Macronix MX25L4005A)
- 1 push button
- 1 reset switch
- 1 SATA port
- 1 LED (bi-color, blue and red)
Signed-o
Latest changes to mkimage, Makefile and added proftool broke compilation on OS
X. This series makes u-boot build clean again with some little adoptions.
Patch 'lib/rsa/rsa-sig.c: compile on OS X' supersedes
http://patchwork.ozlabs.org/patch/255283/
Andreas Bießmann (3):
lib/rsa/rsa-sig.c: com
Some OS (like OS X) do not provide a generic readelf. We should enforce to use
the toochain provided readelf instead, to do so use $(CROSS_COMPILE)readelf.
Signed-off-by: Andreas Bießmann
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index b
BSD (like OS X) variants of regex.h do not declare REG_NOERROR, add a simple
define for them.
Signed-off-by: Andreas Bießmann
---
tools/proftool.c | 5 +
1 file changed, 5 insertions(+)
diff --git a/tools/proftool.c b/tools/proftool.c
index a48ed28..d910b50 100644
--- a/tools/proftool.c
+++
Interfaces exposed by error.h seems not to be used in rsa-sig.c, remove it.
This also fixes an compile error on OS X:
---8<---
u-boot/lib/rsa/rsa-sign.c:23:19: error: error.h: No such file or directory
--->8---
Signed-off-by: Andreas Bießmann
---
Supersedes http://patchwork.ozlabs.org/patch/2552
superseded by http://patchwork.ozlabs.org/patch/255877/
On 28.06.13 09:00, Andreas Bießmann wrote:
> Interfaces exposed by error.h seems not to be used in rsa-sig.c, remove it.
> This also fixes an compile error on OS X:
>
> ---8<---
> u-boot/lib/rsa/rsa-sign.c:23:19: error: error.h: No such file
Dear Stephen Warren,
> (Sorry to those on to/cc; I'm resending this so it goes to the correct
> mailing list)
>
> Commit 020bbcb "usb: hub: Power-cycle on root-hub ports" causes a
> regression on Tegra systems.
>
> The first time "usb start" is executed, it appears to work correctly.
> However,
On Sun, Jun 30, 2013 at 12:12:26PM +0200, Frédéric Leroy wrote:
> Signed-off-by: Frédéric Leroy
> ---
> include/configs/lacie_kw.h | 26 +-
> 1 file changed, 13 insertions(+), 13 deletions(-)
Acked-by: Simon Guinot
>
> diff --git a/include/configs/lacie_kw.h b/include/
On Sun, Jun 30, 2013 at 12:12:29PM +0200, Frédéric Leroy wrote:
> CloudBox device is device tree compliant, but older LaCie kernel uses
> machine ID method to boot.
>
> Signed-off-by: Frédéric Leroy
> ---
> arch/arm/include/asm/mach-types.h | 14 ++
> board/LaCie/cloudbox/cloudbox.c
On Sun, Jun 30, 2013 at 12:12:28PM +0200, Frédéric Leroy wrote:
> The cloudbox device have a different ethernet phy setup than other ns2
> devices. We get initialization value from the GPL LaCie source
>
> Signed-off-by: Frédéric Leroy
> ---
> board/LaCie/common/common.c | 13 ++---
> in
Acked-by: Sonic Zhang
On Fri, Jun 28, 2013 at 2:45 PM, Axel Lin wrote:
> The function return from P_FUNCT2MUX(per) takes 2 bits, however
> for BF537_FAMILY with offset != 1 the function is 1 bit.
>
> Also has small refactor for better readability.
> In portmux_setup(), it looks odd having "muxre
Hi Axel,
On Sat, Jun 29, 2013 at 8:34 AM, Axel Lin wrote:
> Current code uses gd->baudrate before setting its value.
> Besides, I got below build warning which is introduced by
> commit ddb5c5be "blackfin: add baudrate to bdinfo".
>
> board.c:235:3: warning: passing argument 1 of 'simple_strtoul'
2013/7/1 Sonic Zhang :
> Hi Axel,
>
> On Sat, Jun 29, 2013 at 8:34 AM, Axel Lin wrote:
>> Current code uses gd->baudrate before setting its value.
>> Besides, I got below build warning which is introduced by
>> commit ddb5c5be "blackfin: add baudrate to bdinfo".
>>
>> board.c:235:3: warning: passi
Gentle Reminder!!
Hi Wolfgang,
Can you please reply on this.
Regards,
Krishna
On Fri, Jun 28, 2013 at 10:20 AM, krishna dwivedi <
krishna.dwived...@gmail.com> wrote:
> Hi Wolfgang,
>
> I am using xlp832 mips64 netlogic board.I referred these steps from
> u-boot README file.
> Configuration:
Hi,
On Mon, Jul 1, 2013 at 1:08 PM, Chander Kashyap
wrote:
> On 28 June 2013 21:20, Simon Glass wrote:
> > Hi Inderpal,
> >
> > On Thu, Jun 20, 2013 at 12:10 AM, Inderpal Singh
> > wrote:
> >
> >> Hi Simon,
> >>
> >> Thanks for review.
> >>
> >>
> >> On 11 June 2013 19:57, Simon Glass wrote:
>
Hi Guys,
Due to personal circumstances I left the U-Boot community back in late
October 2012.
Now I find my circumstances have been completely flipped upside down (long
story) and I will soon have much more time on my hands. Unfortunately, I do
not have a dev machine yet (that may take a couple o
On 6/30/2013 2:27 PM, Axel Lin wrote:
2013/6/30 Michael Trimarchi:
Hi
Il giorno 30/giu/2013 06:18, "Axel Lin" ha scritto:
2013/6/21 Michael Trimarchi:
On 06/21/2013 06:40 AM, Vipin Kumar wrote:
On 6/20/2013 7:26 PM, Axel Lin wrote:
2013/6/20 Marek Vasut
Dear Axel Lin,
In current gpio
On 28 June 2013 21:20, Simon Glass wrote:
> Hi Inderpal,
>
> On Thu, Jun 20, 2013 at 12:10 AM, Inderpal Singh
> wrote:
>
>> Hi Simon,
>>
>> Thanks for review.
>>
>>
>> On 11 June 2013 19:57, Simon Glass wrote:
>>
>>> Hi,
>>>
>>> On Fri, Jun 7, 2013 at 4:56 AM, Inderpal Singh >> > wrote:
>>>
Hi Axel,
On Mon, Jul 1, 2013 at 12:11 PM, Axel Lin wrote:
> 2013/7/1 Sonic Zhang :
>> Hi Axel,
>>
>> On Sat, Jun 29, 2013 at 8:34 AM, Axel Lin wrote:
>>> Current code uses gd->baudrate before setting its value.
>>> Besides, I got below build warning which is introduced by
>>> commit ddb5c5be "bl
Current code uses gd->baudrate before setting its value.
Besides, I got below build warning which is introduced by
commit ddb5c5be "blackfin: add baudrate to bdinfo".
board.c:235:3: warning: passing argument 1 of 'simple_strtoul' makes pointer
from integer without a cast [enabled by default]
incl
>
> The questions raised here are valid and it forced me to re-read the
> datasheet. For your convenience, I must tell you that the device is actually
> pl061 from ARM, so the driver can also be named so.
>
> The datasheet is here
> http://infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.ddi019
On 7/1/2013 11:02 AM, Axel Lin wrote:
The questions raised here are valid and it forced me to re-read the
datasheet. For your convenience, I must tell you that the device is actually
pl061 from ARM, so the driver can also be named so.
The datasheet is here
http://infocenter.arm.com/help/index.j
On Thu, 27 Jun 2013 21:36:09 + (UTC), Tormod Volden wrote:
Hi Tormod,
> Lukasz Majewski writes:
> >
> > This commit fixes problems with some non-standard requests send with
> > device address instead of interface address
> > (bmRequestType.Receipent field).
> >
> > This happens with dfu-uti
30 matches
Mail list logo