Hi Heinrich,
Thank you for your review.
On dim., juin 16, 2024 at 09:38, Heinrich Schuchardt wrote:
> On 6/4/24 17:15, Mattijs Korpershoek wrote:
>> According to [1], we should use bootmeth when describing the
>> struct bootmeth:
>>
>> """
>> For version 2, a new naming scheme is used as above:
On Jun 17, 2024 at 09:48:42 +0530, Prasad Kummari wrote:
> Add support for ISSI 128MB flash IS25LP01GG. This part
Can we have the datasheet link for this part?
I am assuming it's this?
https://www.issi.com/WW/pdf/25LP-WP01GG.pdf
Better to add it to the commit message.
> supports 4byte opcodes. I
Hi Robert and Bryan,
On Jun 15, 2024 at 21:30:55 -0500, Robert Nelson wrote:
> On Sat, Jun 15, 2024 at 8:55 PM Bryan Brattlof wrote:
> >
> > On June 13, 2024 thus sayeth Dhruva Gole:
> > > The Kernel Image and DTB files are supposed to be picked from the rootfs
> > > of the SD Card, this fails in
Hi Dhruva,
On 17:34-20240614, Dhruva Gole wrote:
> Add symlinks for both tiboot3.bin and tispl.bin because a user has to
> anyway rename these files to get the platform to boot up.
> This just makes it more intuitive and convenient.
>
> Signed-off-by: Dhruva Gole
> ---
>
> This is just a RESEND
On 6/14/24 4:02 PM, Patrice CHOTARD wrote:
On 6/14/24 15:06, Marek Vasut wrote:
On 6/14/24 2:00 PM, Patrice CHOTARD wrote:
On 4/20/24 00:03, Marek Vasut wrote:
Make sure the OS would not get any spurious IWDG pretimeout IRQ
right after the system wakes up. This may happen in case the SoC
g
Add support for ISSI 128MB flash IS25LP01GG. This part
supports 4byte opcodes. It also supports dual and quad
read.
Signed-off-by: Prasad Kummari
---
drivers/mtd/spi/spi-nor-ids.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/mtd/spi/spi-nor-ids.c b/drivers/mtd/spi/spi-nor-ids.c
On Fri, Jun 14, 2024 at 10:43:09AM +0200, Quentin Schulz wrote:
> Hi Vasileios,
>
> On 6/14/24 12:02 AM, Vasileios Amoiridis wrote:
> > Move to the new documentation style with rST formatting.
> >
> > Signed-off-by: Vasileios Amoiridis
> > ---
> > doc/README.bootcount | 53 ---
Signed-off-by: Martin Kurbanov
---
cmd/ubi.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/cmd/ubi.c b/cmd/ubi.c
index 0a6a80bdd1..a9c5560182 100644
--- a/cmd/ubi.c
+++ b/cmd/ubi.c
@@ -249,7 +249,7 @@ static int ubi_create_vol(char *volume, int64_t size, int
dy
If 0 is passed to the 'bytes' parameter in the ubi_start_update(),
there is no need to call the ubi_more_update_data(). Otherwise,
there will be a double-free of 'vol->upd_buf'.
Also check that the ubi_start_update() was called before calling
the ubi_more_update_data().
Signed-off-by: Martin Kurb
If 0 is passed to the 'bytes' parameter in the ubi_start_update(),
there is no need to call the ubi_more_update_data(). Otherwise,
there will be a double-free of 'vol->upd_buf'.
Also check that the ubi_start_update() was called before calling
the ubi_more_update_data().
Martin Kurbanov (2):
cmd
>
> Hey,
>
> After going from Vendor SPL/OpenSBI/U-Boot to OpenSBI v1.4++ plus
> v2024.07-rc4 SPL/U-Boot I ran into a boot loop problem relating to
> PCI:
> U-Boot 2024.07-rc4 (Jun 13 2024 - 15:09:34 +0100)
>
> CPU: sifive,u74-mc
> Model: StarFive VisionFive 2 v1.2A
>
Hi,
On 6/16/24 18:24, Jonas Karlman wrote:
On 2024-06-15 09:46, FUKAUMI Naoki wrote:
add USB GADGET related configs for USB OTG port on ROCK 3A/5A/5B.
Signed-off-by: FUKAUMI Naoki
---
configs/rock-3a-rk3568_defconfig | 6 ++
configs/rock5a-rk3588s_defconfig | 6 ++
configs/rock5b-
Hi Marek,
On 2024-06-16 17:04, Marek Vasut wrote:
> Extend generic_setup_phy() parameter list with PHY mode and submode and
> call generic_phy_set_mode() in generic_setup_phy(), so the generic PHY
> setup function can configure the PHY into correct mode before powering
> the PHY up.
>
> Update al
If multiple weak implementations of a weak function exist, it is unclear
which one the linker should chose. cmd/cache.c already defines a weak
invalidate_icache_all().
We don't need a call to invalidate_icache_all() on x86.
ARM, RISC-V, and Sandbox provide an implementation.
Signed-off-by: Heinri
In EFI sub-system we rely on invalidate_icache_all() to invalidate the
instruction cache after loading binaries. Add the missing implementation on
ARM1136, ARM1176.
Signed-off-by: Heinrich Schuchardt
---
arch/arm/cpu/arm11/cpu.c | 12
1 file changed, 12 insertions(+)
diff --git a/a
If we have multiple weak implementations of functions, the linker might
choose any of these. ARM and RISC-V already provide a weak implementation
of flush_dcache_all().
Signed-off-by: Heinrich Schuchardt
---
cmd/cache.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/cmd/cache.c b/cmd/cac
If we have multiple weak implementations of functions, the linker might
choose any of these.
ARM and RISC-V already provide a weak implementation of flush_dcache_all()
but cmd/cache.c provides another implementation. Add an #ifdef to avoid
the duplication.
The EFI sub-systems uses invalidate_icac
On 6/16/24 15:06, Jiaxun Yang wrote:
在2024年6月16日六月 下午12:01,Heinrich Schuchardt写道:
On 5/22/24 17:34, Jiaxun Yang wrote:
Add some common library routines for the architecture.
Signed-off-by: Jiaxun Yang
---
arch/loongarch/lib/Makefile | 7
arch/loongarch/lib/asm-offsets.c | 66
Drop all duplicate newlines from config headers.
No functional change.
Signed-off-by: Marek Vasut
---
Cc: Francesco Dolcini
Cc: Sean Anderson
Cc: Simon Glass
Cc: Tom Rini
Cc: u-boot@lists.denx.de
---
include/configs/M5208EVBE.h| 1 -
include/configs/M5235EVB.h | 1 -
The current init operation also sets the PHY into USB host mode.
Split the mode configuration into set_mode callback instead and
implement support for device and OTG modes as well.
The OTG mode performs auto-detection and selects either host or
device mode. In case the OTG mode is configured, subm
Extend generic_setup_phy() parameter list with PHY mode and submode and
call generic_phy_set_mode() in generic_setup_phy(), so the generic PHY
setup function can configure the PHY into correct mode before powering
the PHY up.
Update all call sites of generic_setup_phy() as well, all of which are
U
In case the cyclic framework is enabled, poll the card detect of already
initialized cards and deinitialize them in case they are removed. Since
the card initialization is a longer process and card initialization is
done on first access to an uninitialized card anyway, avoid initializing
newly dete
在2024年6月16日六月 下午12:01,Heinrich Schuchardt写道:
> On 5/22/24 17:34, Jiaxun Yang wrote:
>> Add some common library routines for the architecture.
>>
>> Signed-off-by: Jiaxun Yang
>> ---
>> arch/loongarch/lib/Makefile | 7
>> arch/loongarch/lib/asm-offsets.c | 66 ++
On 5/22/24 17:34, Jiaxun Yang wrote:
Add some common library routines for the architecture.
Signed-off-by: Jiaxun Yang
---
arch/loongarch/lib/Makefile | 7
arch/loongarch/lib/asm-offsets.c | 66
arch/loongarch/lib/boot.c| 14
On 5/22/24 17:34, Jiaxun Yang wrote:
Allocate the next value to IH_ARCH_LOONGARCH.
Signed-off-by: Jiaxun Yang
Reviewed-by: Heinrich Schuchardt
---
boot/image.c| 1 +
include/image.h | 1 +
2 files changed, 2 insertions(+)
diff --git a/boot/image.c b/boot/image.c
index 073931cd7a3f
On 5/22/24 17:34, Jiaxun Yang wrote:
They all come from glibc's elf.h
Signed-off-by: Jiaxun Yang
Reviewed-by: Heinrich Schuchardt
---
include/elf.h | 9 -
1 file changed, 8 insertions(+), 1 deletion(-)
diff --git a/include/elf.h b/include/elf.h
index a4ba74d8abeb..cb3bb20c4f2e
Hi
Can this be merged?
Let me know if I missed any process.
Thanks,
Ravi
On 5/21/24 13:15, Michael Nazzareno Trimarchi wrote:
> Hi Dario
>
> Can you add to next pull?
>
> Michael
>
> On Tue, May 21, 2024, 4:31 PM Ravi Minnikanti
> wrote:
>
>> Hi,
>>
>> Can you please merge this PR, if there
Dear Tom,
The following changes since commit 2248c96ea1cf0b65377040d9f87ce7d8cf534c63:
Merge tag 'u-boot-stm32-20240614' of
https://source.denx.de/u-boot/custodians/u-boot-stm (2024-06-14 08:13:54
-0600)
are available in the Git repository at:
https://source.denx.de/u-boot/custodians/u-boo
Hi Tom,
please pull the following watchdog & cyclic related patches:
- misc cyclic infrastructure improvements (Rasmus)
- watchdog_reset cleanup (Rasmus)
Here the Az
On 5/28/24 13:13, Rasmus Villemoes wrote:
watchdog_reset is no more. That is, it is no longer called from
anywhere, so any leftover definitions are just dead weight, and
references in comments need to be updated.
I don't have access to any m68k, sh or powerpc boards. Only lightly
compile-tested.
On 5/21/24 10:46, Rasmus Villemoes wrote:
A bit of a mixed bag. I've been wanting to submit something like 3/3
for a while. So when I stumbled on Marek's patch
https://lore.kernel.org/u-boot/20240316201416.211480-1-marek.vasut+rene...@mailbox.org/
, I got reminded of that plan, and I think that p
On 5/28/24 13:13, Rasmus Villemoes wrote:
watchdog_reset is no more. That is, it is no longer called from
anywhere, so any leftover definitions are just dead weight, and
references in comments need to be updated.
I don't have access to any m68k, sh or powerpc boards. Only lightly
compile-tested.
On 2024-06-15 09:46, FUKAUMI Naoki wrote:
> enable USB3 OTG (upper) port for ums and rockusb commands on ROCK 5A.
>
> Signed-off-by: FUKAUMI Naoki
> ---
> arch/arm/dts/rk3588s-rock-5a-u-boot.dtsi | 16
> 1 file changed, 16 insertions(+)
>
> diff --git a/arch/arm/dts/rk3588s-roc
On 2024-06-15 09:46, FUKAUMI Naoki wrote:
> add USB GADGET related configs for USB OTG port on ROCK 3A/5A/5B.
>
> Signed-off-by: FUKAUMI Naoki
> ---
> configs/rock-3a-rk3568_defconfig | 6 ++
> configs/rock5a-rk3588s_defconfig | 6 ++
> configs/rock5b-rk3588_defconfig | 1 +
> 3 files c
Update all required Python packages to current release.
Signed-off-by: Heinrich Schuchardt
---
doc/sphinx/requirements.txt | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/doc/sphinx/requirements.txt b/doc/sphinx/requirements.txt
index 54eb70aa92c..306b05a995e
On 6/13/24 21:04, Jon Humphreys wrote:
Ilias Apalodimas writes:
Hi Jon,
On Sat, 8 Jun 2024 at 02:44, Jonathan Humphreys wrote:
Add to the capsule update porting documentation that when capsule
authentication is enabled (via EFI_CAPSULE_AUTHENTICATE), a public key
certificate corresponding
On 6/4/24 17:15, Mattijs Korpershoek wrote:
According to [1], we should use bootmeth when describing the
struct bootmeth:
"""
For version 2, a new naming scheme is used as above:
- bootdev is used instead of bootdevice, because 'device' is overused,
is everywhere in U-Boot, can be
37 matches
Mail list logo