CONFIG_IS_ENABLED() takes the kconfig name without the CONFIG_ prefix,
e.g. CONFIG_IS_ENABLED(CLK) for CONFIG_CLK. Make including the prefix
an error in checkpatch.pl so calls in the wrong format aren't
accidentally reintroduced.
Signed-off-by: Alper Nebi Yasak
---
Changes in v2:
- Add patman te
CONFIG_IS_ENABLED() takes the kconfig name without the CONFIG_ prefix,
e.g. CONFIG_IS_ENABLED(CLK) for CONFIG_CLK. Some of these were being
fixed every now and then, see:
commit 71ba2cb0d678 ("board: stm32mp1: correct CONFIG_IS_ENABLED usage for
LED")
commit a5ada25e4213 ("rockchip: clk:
On Sat, Oct 03, 2020 at 03:12:30PM +0200, Ard Biesheuvel wrote:
> On Sat, 3 Oct 2020 at 13:16, François Ozog wrote:
>
> >
> >> that looks super interesting.
[...]
> >> I propose something (in the latest desk preparing oct 14th) similar
> >> except the an efi application boots the FIT.
> >> I view
Sphinx documentation is only available for enums not for #defines.
Anyway it is better to keep related definitions in an enum.
Signed-off-by: Heinrich Schuchardt
Reviewed-by: Simon Glass
---
v3:
no change
v2:
enum gd_flags must not be exposed to assembler code
---
include/asm-ge
Add the description of the global data pointer to the generated HTML
documentation.
Signed-off-by: Heinrich Schuchardt
Reviewed-by: Simon Glass
---
v3:
no change
v2:
no change
---
doc/develop/global_data.rst | 53 +
doc/develop/index.rst
Add the missing Sphinx documentation for struct global_data and
gd_board_type().
Signed-off-by: Heinrich Schuchardt
---
v3:
Avoid duplicate comments: comments replaced by Sphinx documentation
should be removed.
v2:
no change
---
include/asm-generic/global_data.h | 372 +++
Add the description of the global data pointer to the generated HTML
documentation.
The first patch converts the GD_FLG_* constants to an enum.
The second adds move Sphinx comments.
The third finally provides the HTML documentation.
v3:
do not duplicate comments
v2:
_flags must no
On 01.10.20 11:52, Jan Kiszka wrote:
> On 30.09.20 11:51, Jan Kiszka wrote:
>> [BCC'ed TF-A only, migrating to u-boot, including folks involved there]
>>
>> On 30.09.20 11:20, Yann GAUTIER wrote:
>>> Hi Jan,
>>>
>>> After discussing with my colleagues, it seems there are 2 issues there.
>>> One pat
On Mon, 28 Sep 2020 at 03:31, Patrick Delaunay wrote:
>
> Done with:
> ./tools/moveconfig.py VIDEO_BMP_RLE8
>
> Signed-off-by: Patrick Delaunay
> ---
>
> README | 6 --
> configs/apalis_imx6_defconfig | 1 +
> configs/aristainetos2_defconfig
On Mon, 28 Sep 2020 at 03:31, Patrick Delaunay wrote:
>
> Done with:
> ./tools/moveconfig.py BMP_16BPP BMP_24BPP BMP_32BPP
>
> Signed-off-by: Patrick Delaunay
> ---
>
> configs/apalis_imx6_defconfig | 1 +
> configs/aristainetos2_defconfig| 1 +
> configs/arist
Hi Alper,
On Wed, 30 Sep 2020 at 05:46, Alper Nebi Yasak wrote:
>
> CONFIG_IS_ENABLED() takes the kconfig name without the CONFIG_ prefix,
> e.g. CONFIG_IS_ENABLED(CLK) for CONFIG_CLK. Make including the prefix
> an error in checkpatch.pl so calls in the wrong format aren't
> accidentally reintro
On Mon, 28 Sep 2020 at 03:30, Patrick Delaunay wrote:
>
> Done with:
> ./tools/moveconfig.py VIDEO_BMP_GZIP
>
> The 3 suspicious migration because CMD_BMP and SPLASH_SCREEN
> are not activated in these defconfigs:
> - trats_defconfig
> - s5pc210_universal_defconfig
> - trats2_defconfig
>
> Signed-
On Wed, 30 Sep 2020 at 05:46, Alper Nebi Yasak wrote:
>
> CONFIG_IS_ENABLED() takes the kconfig name without the CONFIG_ prefix,
> e.g. CONFIG_IS_ENABLED(CLK) for CONFIG_CLK. Some of these were being
> fixed every now and then, see:
>
> commit 71ba2cb0d678 ("board: stm32mp1: correct CONFIG_IS_
On Fri, 25 Sep 2020 at 01:41, Patrick Delaunay wrote:
>
> Add unitary test for phandle access functions
> - ofnode_count_phandle_with_args
> - ofnode_parse_phandle_with_args
> - dev_count_phandle_with_args
> - dev_read_phandle_with_args
>
> Signed-off-by: Patrick Delaunay
> ---
>
> arch/sandbox/
On Fri, 25 Sep 2020 at 01:41, Patrick Delaunay wrote:
>
> The cell_count argument is required when cells_name is NULL.
>
> This patch adds this parameter in live tree API
> - of_count_phandle_with_args
> - ofnode_count_phandle_with_args
> - dev_count_phandle_with_args
>
> This parameter solves iss
On Fri, 25 Sep 2020 at 01:41, Patrick Delaunay wrote:
>
> The result of fdt_node_offset_by_phandle is negative for error,
> so this patch corrects the check of this result in
> fdtdec_parse_phandle_with_args.
>
> This patch allows to have the same behavior with or without OF_LIVE
> for the functio
Hi Heinrich,
On Mon, 28 Sep 2020 at 19:11, Heinrich Schuchardt wrote:
>
> Without resizing the SDL window showed by
>
> ./u-boot -D -l
>
> is not legible on a high resolution screen.
>
> Start with a maximized window and allow resizing.
>
> Signed-off-by: Heinrich Schuchardt
> ---
> arch/sa
This driver doesn't use DM (in the correct places), so we use a device and
not a udevice. We also need to include device_compat.h
Signed-off-by: Sean Anderson
---
drivers/usb/musb-new/mt85xx.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers/usb/musb-new/mt85xx
On Mon, 28 Sep 2020 at 19:56, Heinrich Schuchardt wrote:
>
> When using SDL for input the SDL key codes are first converted to Linux key
> codes and then to matrix entries of the cross wired keyboard.
>
> We must not map any key code to two different places on the keyboard. So
> comment out one ba
On Mon, 28 Sep 2020 at 17:41, Heinrich Schuchardt wrote:
>
> Add missing SDL key scan codes, e.g.
>
> * shift, ctrl, meta, alt
> * brace/bracket
>
> Signed-off-by: Heinrich Schuchardt
> ---
> arch/sandbox/cpu/sdl.c | 156 +++--
> 1 file changed, 89 insertions(
Now that linux/compat.h does not define these macros, we do not need to
undefine them.
Signed-off-by: Sean Anderson
---
include/dm/device_compat.h | 20
1 file changed, 20 deletions(-)
diff --git a/include/dm/device_compat.h b/include/dm/device_compat.h
index 8f26053b45..8
Hi Heinrich,
On Tue, 22 Sep 2020 at 16:03, Simon Glass wrote:
>
> Hi Heinrich,
>
> On Tue, 22 Sep 2020 at 13:10, Heinrich Schuchardt wrote:
> >
> > On 9/22/20 8:48 PM, Simon Glass wrote:
> > > Hi Heinrich,
> > >
> > > On Thu, 17 Sep 2020 at 06:19, Heinrich Schuchardt
> > > wrote:
> > >>
> > >>
Necessary for dev_xxx.
Signed-off-by: Sean Anderson
---
drivers/timer/timer-uclass.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/timer/timer-uclass.c b/drivers/timer/timer-uclass.c
index e9802c8b43..f8a092b8cb 100644
--- a/drivers/timer/timer-uclass.c
+++ b/
This was included, but was ifdef'd out. We also need dm.h for struct
udevice.
Signed-off-by: Sean Anderson
---
drivers/usb/musb-new/musb_core.c | 2 ++
drivers/usb/musb-new/musb_dsps.c | 2 ++
drivers/usb/musb-new/musb_gadget.c | 2 ++
drivers/usb/musb-new/musb_gadget_ep0.c | 4
All users of these functions now include dm/device_compat.h directly.
Signed-off-by: Sean Anderson
---
include/linux/compat.h | 28
1 file changed, 28 deletions(-)
diff --git a/include/linux/compat.h b/include/linux/compat.h
index d129780312..38549baa25 100644
---
Necessary for dev_xxx.
Signed-off-by: Sean Anderson
---
drivers/tee/optee/core.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/tee/optee/core.c b/drivers/tee/optee/core.c
index 5260dab3ac..66ade37cd4 100644
--- a/drivers/tee/optee/core.c
+++ b/drivers/tee/optee/core.c
@@ -5,6 +5,7
This header is necessary for the dev_xxx macros.
Signed-off-by: Sean Anderson
---
drivers/usb/host/xhci-mtk.c | 5 +++--
drivers/usb/host/xhci.c | 7 ---
2 files changed, 7 insertions(+), 5 deletions(-)
diff --git a/drivers/usb/host/xhci-mtk.c b/drivers/usb/host/xhci-mtk.c
index f3f181
Necessary for dev_xxx.
Signed-off-by: Sean Anderson
---
drivers/spi/nxp_fspi.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers/spi/nxp_fspi.c b/drivers/spi/nxp_fspi.c
index c507437f2e..5a639cce30 100644
--- a/drivers/spi/nxp_fspi.c
+++ b/drivers/spi/nxp_fspi.c
Necessary for dev_xxx.
Signed-off-by: Sean Anderson
---
drivers/spi/fsl_qspi.c | 9 +
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/spi/fsl_qspi.c b/drivers/spi/fsl_qspi.c
index eec968e5ec..128f95877f 100644
--- a/drivers/spi/fsl_qspi.c
+++ b/drivers/spi/fsl_qspi
Necessary for dev_xxx.
Signed-off-by: Sean Anderson
---
drivers/phy/phy-uclass.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/phy/phy-uclass.c b/drivers/phy/phy-uclass.c
index 8f456f33d2..df06cc1196 100644
--- a/drivers/phy/phy-uclass.c
+++ b/drivers/phy/phy-uclas
Necessary for dev_xxx.
Signed-off-by: Sean Anderson
---
drivers/net/ldpaa_eth/ldpaa_eth.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/net/ldpaa_eth/ldpaa_eth.c
b/drivers/net/ldpaa_eth/ldpaa_eth.c
index 67da549fdb..42eaf49d71 100644
--- a/drivers
Necessary for dev_xxx.
Signed-off-by: Sean Anderson
---
drivers/ram/imxrt_sdram.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/ram/imxrt_sdram.c b/drivers/ram/imxrt_sdram.c
index 765a2141d1..b6ee02d227 100644
--- a/drivers/ram/imxrt_sdram.c
+++ b/drivers/ram/imxrt_sdram.c
@@ -7,6
This includes device_compat.h, and fixes several calls to dev_xxx.
Signed-off-by: Sean Anderson
---
drivers/mtd/nand/raw/mxs_nand.c | 30 --
1 file changed, 16 insertions(+), 14 deletions(-)
diff --git a/drivers/mtd/nand/raw/mxs_nand.c b/drivers/mtd/nand/raw/mxs_nan
Necessary for dev_xxx.
Signed-off-by: Sean Anderson
---
drivers/clk/sifive/fu540-prci.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/clk/sifive/fu540-prci.c b/drivers/clk/sifive/fu540-prci.c
index c5148e9a37..1b4d81d4f0 100644
--- a/drivers/clk/
We call log_debug, but do not have a category set.
Signed-off-by: Sean Anderson
---
drivers/core/syscon-uclass.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/core/syscon-uclass.c b/drivers/core/syscon-uclass.c
index 5be1d527a0..509b09845a 100644
--- a/drivers/core/syscon-uclass
This header is necessary for the dev_xxx macros.
Signed-off-by: Sean Anderson
---
drivers/firmware/scmi/mailbox_agent.c | 1 +
drivers/firmware/scmi/scmi_agent-uclass.c | 1 +
drivers/firmware/scmi/smt.c | 1 +
3 files changed, 3 insertions(+)
diff --git a/drivers/firmware/sc
dev_xxx is now defined to something other than debug, so its redefinition in
linux/compat.h is problematic. This series mostly adds includes for
dm/device_compat.h, if only linux/compat.h had previously been included. Some
patches also fix remaining cases where dev_xxx had been called without a dev
Hi,
I have a Variscite iMX8MQ NXP based board which I am trying to load
u-boot into RAM and then run it via JTAG.
I start by loading the DDR training binaries into SRAM along with SPL. I
then execute SPL which runs without issue until the spl_dram_init
function. During this function I can se
Hello Heinrich,
On Sat, Oct 03, 2020 at 10:51:24AM +0200, Heinrich Schuchardt wrote:
> Hello Ilias, hello Christian,
>
> with commit ec80b4735a59 ("efi_loader: Implement FileLoad2 for initramfs
> loading") Ilias provided the possibility to specify a device path
> (CONFIG_EFI_INITRD_FILESPEC) from
This matches the naming scheme of other timer drivers.
Signed-off-by: Sean Anderson
---
arch/riscv/cpu/ax25/Kconfig | 2 +-
drivers/timer/Kconfig | 2 +-
drivers/timer/Makefile | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch/riscv/cpu/ax25/Kconfig b/arch/r
Now that mtime sources are regular timers, they can go in with the rest of the
timer drivers. I have assigned maintenance of these drivers to Rick Chen, as
they were previous under his purview. This series is based off of -next.
Passing CI located at [1].
[1]
https://dev.azure.com/seanga2/9603e4
This is a regular timer driver, and should live with the other timer
drivers.
Signed-off-by: Sean Anderson
---
MAINTAINERS| 1 +
arch/riscv/Kconfig | 7 ---
arch/riscv/lib/Makefile
Half of this driver is a DM-based timer driver, and half is RISC-V-specific
IPI code. Move the timer portions in with the other timer drivers. The
KConfig is not moved, since it also enables IPIs. It could also be split
into two configs, but no boards use the timer but not the IPI atm, so I
haven't
On 10/4/20 6:57 PM, Biju Das wrote:
Hi,
[...]
> /* PRR CPU IDs */
> #define RMOBILE_CPU_TYPE_SH73A00x37 #define
> RMOBILE_CPU_TYPE_R8A77400x40
> +#define RMOBILE_CPU_TYPE_R8A774A10x52
The problem here is that this is the same as
#define RMOBILE_CPU_TYPE_R8A7796
Hi Marek,
Thanks for the feedback.
> Subject: Re: [PATCH v4 1/2] arm: rmobile: Add PRR CPU ID macros for
> RZ/G2[HMNE]
>
> On 10/3/20 9:31 PM, Biju Das wrote:
>
> Hi,
>
> [...]
>
> >>> /* PRR CPU IDs */
> >>> #define RMOBILE_CPU_TYPE_SH73A00x37 #define
> >>> RMOBILE_CPU_TYPE_R8A77400x40
> >>>
On Sun, Oct 04, 2020 at 05:10:32PM +0200, Heinrich Schuchardt wrote:
> Am 4. Oktober 2020 16:55:32 MESZ schrieb Michael Walle :
> >Hi all,
> >
> >Am 2020-09-25 15:04, schrieb Wolfgang Denk:
> >> Dear Heinrich Schuchardt,
> >>
> >> In message you wrote:
> >>>
> >>> > Any so-called "watchdog" that
Am 4. Oktober 2020 16:55:32 MESZ schrieb Michael Walle :
>Hi all,
>
>Am 2020-09-25 15:04, schrieb Wolfgang Denk:
>> Dear Heinrich Schuchardt,
>>
>> In message you wrote:
>>>
>>> > Any so-called "watchdog" that can be disabled / switched off by
>>> > software is not really woth this name. As suc
Hi all,
Am 2020-09-25 15:04, schrieb Wolfgang Denk:
Dear Heinrich Schuchardt,
In message you wrote:
> Any so-called "watchdog" that can be disabled / switched off by
> software is not really woth this name. As such, the concept of
> disabling a watchdog in software, is misleading at best an
On 10/3/20 9:31 PM, Biju Das wrote:
Hi,
[...]
>>> /* PRR CPU IDs */
>>> #define RMOBILE_CPU_TYPE_SH73A00x37
>>> #define RMOBILE_CPU_TYPE_R8A77400x40
>>> +#define RMOBILE_CPU_TYPE_R8A774A10x52
>>
>> The problem here is that this is the same as
>> #define RMOBILE_CPU_TYPE_R8A7796 0x52
>>
>> S
Ping?
пн, 24 авг. 2020 г. в 21:00, Matwey V. Kornilov :
> Signed-off-by: Matwey V. Kornilov
> ---
> include/configs/am335x_evm.h | 7 +++
> 1 file changed, 7 insertions(+)
>
> diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
> index 9c4ef369c5..103c046137 100644
> --
50 matches
Mail list logo