Previously, the address of a requested capability is define like that
"#define PCI_DCR0x78"
But, the addresses of capabilities is different with regard to PCIe revs.
So this method is not flexible.
Now a function to get the address of a requested capability is added and used.
It ca
Hi Jagan,
Cc Tom.
On 10/11/2013 09:24, Bo Shen wrote:
Hi Jagan,
On 10/10/2013 22:14, Jagan Teki wrote:
Thanks for this.
On Thu, Oct 10, 2013 at 10:37 AM, Bo Shen wrote:
As the spi flash transfer to multiple parts, it is forgot to add
Atmel AT25DF321 spi flash support, which broken several
Dear Dan Murphy,
> V2 patchset for TI SoC's that support xHCI controllers
>
> Dan Murphy (6):
> usb: omap: Move the xhci-omap header file to common location
> usb: omap5: Update the board_usb_init api
> usb: omap: Move the usb phy code to the usb/phy directory
> usb: dra7xx: Add support f
Dear Dan Murphy,
[...]
> +
> + /* This is an undocumented Reserved register */
> + reg = 0x4a0086c0;
> + val = readl(reg);
> + val |= 0x100;
> + setbits_le32(reg, val);
> +}
Do you know what it's doing at least?
Best regards,
Marek Vasut
_
I am sorry Gerhard, I am newbie to the list.
I will keep in mind the etiquette of the list.
Thanks for the help.
On Thu, Oct 10, 2013 at 8:37 AM, Gerhard Sittig wrote:
> On Wed, Oct 09, 2013 at 09:07 -0700, djoker wrote:
>>
>> Hi Everyone,
>
> Why do you "re-send" your request without giving read
Piotr Wilczek writes:
> In this patch static variable and memcpy instead of an assignment
> are used to avoid unaligned access exception on some ARM platforms.
>
> Signed-off-by: Piotr Wilczek
> Signed-off-by: Kyungmin Park
> CC: Tom Rini
> ---
> disk/part_efi.c |6 --
> 1 file change
Hi Masahiro,
On Fri, Oct 11, 2013 at 5:29 AM, Masahiro Yamada
wrote:
> Hello experts, custodians.
>
> To sum up my suggestion,
>
> - Collect pre-built suitable crosstools for all architectures
>on U-boot ftp site.
Great idea. If you can organize a tarball (or more than one) and a
place to
Dear D Rambo,
In message
you wrote:
>
> Is there a policy that new source files upstreamed to u-boot contain
> registered SPDX license identifiers? I see that there are still about 1900
> source files that have no SPDX identifier, and about 6000 that do. The
This is still work in progress...
>
On Fri, Oct 11, 2013 at 04:13:03PM -0400, Tom Rini wrote:
> In some cases, such as arm multi-lib hardfloat (hf) toolchains, we will
> have multiple libgcc.a's available, and the arch needs to provide
> additional logic to determine the right file to use
> (-print-libgcc-file-name contains no CFLAG
In some cases, such as arm multi-lib hardfloat (hf) toolchains, we will
have multiple libgcc.a's available, and the arch needs to provide
additional logic to determine the right file to use
(-print-libgcc-file-name contains no CFLAG parsing logic).
Cc: Albert Aribaud
Signed-off-by: Tom Rini
---
On 10/11/2013 11:39 AM, Scott Wood wrote:
> On Fri, 2013-10-11 at 11:29 -0700, York Sun wrote:
>> Scott, et al.
>>
>> I'd like to start the discussion to increase u-boot image size for some
>> mpc85xx targets. As we all know the reset vector is at the very end and
>> linking process start from the
On Fri, Oct 11, 2013 at 11:07:58AM -0700, D Rambo wrote:
> Is there a policy that new source files upstreamed to u-boot contain
> registered SPDX license identifiers? I see that there are still about 1900
> source files that have no SPDX identifier, and about 6000 that do. The
> reason I'm asking
Is there a policy that new source files upstreamed to u-boot contain
registered SPDX license identifiers? I see that there are still about 1900
source files that have no SPDX identifier, and about 6000 that do. The
reason I'm asking is that our company has a dual license (for GPL2.0 or
Proprietary)
On Fri, 2013-10-11 at 11:29 -0700, York Sun wrote:
> Scott, et al.
>
> I'd like to start the discussion to increase u-boot image size for some
> mpc85xx targets. As we all know the reset vector is at the very end and
> linking process start from the top. This gives us no good choice but to
> use f
Scott, et al.
I'd like to start the discussion to increase u-boot image size for some
mpc85xx targets. As we all know the reset vector is at the very end and
linking process start from the top. This gives us no good choice but to
use fixed image size. While we have more and more features, the size
On Tue, Oct 08, 2013 at 08:17:01PM +0200, Wolfgang Denk wrote:
> Dear Tom,
>
> In message <20131008134456.GB15917@bill-the-cat> you wrote:
> >
> > > Well, if we have DDR such that we can use it for the malloc arena, we
> > > also should use it for the stack. Or is there a good reason for not
> >
On Fri, Oct 11, 2013 at 11:15:25AM +0200, Michael Trimarchi wrote:
> Hi Tom
>
> I have managed to boot dm3730 on usb (first stage), but looking at the code
> I have some comment
>
> in arch/arm/cpu/armv7/omap3/clock.c
>
> #ifdef CONFIG_SYS_NS16550
> /* Enable UART1 clocks */
> sr
On Fri, 2013-10-11 at 05:27 +, Gupta, Pekon wrote:
> > From: Scott Wood [mailto:scottw...@freescale.com]
> > On Thu, 2013-10-10 at 16:30 +0530, Pekon Gupta wrote:
> [snip]
> > > -#else
> > > + } else {
> > > /*
> > >* This ecc_size_config setting is for BCH sw library.
> > >*
> > > @@
V2 patchset for TI SoC's that support xHCI controllers
Dan Murphy (6):
usb: omap: Move the xhci-omap header file to common location
usb: omap5: Update the board_usb_init api
usb: omap: Move the usb phy code to the usb/phy directory
usb: dra7xx: Add support for dra7xx xhci USB host
usb: a
Add the support for the dra7xx xhci usb host.
dra7xx does not contain an EHCI controller so the headers
can be removed from the board file.
The xHCI host on dra7xx is connected to a usb2 phy so need to
add support to enable those clocks.
Signed-off-by: Dan Murphy
---
v2 - In omap_enable_usb2_ph
Add the support for the am437x xhci usb host.
The xHCI host on AM437 is connected to a usb2 phy so need to
add support to enable those clocks.
Signed-off-by: Dan Murphy
---
v2 - Changed int->const u32 for usb_otg_ss_clk_val -
http://patchwork.ozlabs.org/patch/281932/
arch/arm/include/asm/arc
Move the MAC creation from the USB init to an function
that is called on every boot. This will then populate the
usbethaddr mac that kernel driver can pick up from the
device tree blob.
Signed-off-by: Dan Murphy
---
v2 - No code changes - http://patchwork.ozlabs.org/patch/281930/
board/ti/oma
Recent patches declares board_usb_init function prototype for a new
usb architecture.
Turning on the OMAP_XHCI defines cause a redefinition compiler failure.
So update the board_usb_init to the latest prototype.
Signed-off-by: Dan Murphy
---
v2 - Adopted to board_usb_init and not create a new A
Moving the usb/phy code from xhci-omap to the usb/phy directory
and moving the associated phy code over to the new file.
Newer TI processors adding xHCI support will have different PHY configurations
so therefore abstracting this code away will prevent messing around with the
xhci-omap file itself
Moving the xhci-omap header to a more global location so that
other code can reference this code.
Signed-off-by: Dan Murphy
---
v2 - Reformatted patch with -M - http://patchwork.ozlabs.org/patch/281933/
drivers/usb/host/xhci-omap.c |2 +-
.../arch-omap5 => include/lin
2013/10/11 Albert ARIBAUD :
> (foreword: this is an RFC, and in any case, not intended for
> the upcoming 2013.10 release :) therefore I put notes here in the
> commit message whereas the first actual patch will have notes below
> the comment ('---') line of course.)
>
> Current LDS files /DISCARD/
- Remove duplicate doc/README.p1010rdb
- Rename README to README.P1010RDB-PA
- Add new README.P1010RDB-PB
P1010RDB-PB is a variation of previous P1010RDB-PA board.
Signed-off-by: Shengzhou Liu
---
v4: keep readme support for p1010rdb-pa
v3: add frequency combination support
v2: removed duplicate
Hi Piotr,
On Fri, 11 Oct 2013 15:31:10 +0200, Piotr Wilczek
wrote:
> In this patch static variable and memcpy instead of an assignment
> are used to avoid unaligned access exception on some ARM platforms.
>
> Signed-off-by: Piotr Wilczek
> Signed-off-by: Kyungmin Park
> CC: Tom Rini
> ---
>
(foreword: this is an RFC, and in any case, not intended for
the upcoming 2013.10 release :) therefore I put notes here in the
commit message whereas the first actual patch will have notes below
the comment ('---') line of course.)
Current LDS files /DISCARD/ a lot of sections when linking ELF
fil
Hello Tom,
The following changes since commit
572886af5984febafa6f083e6b8af0465f4f5764:
socfpga: Adding pin mux handoff files (2013-10-07 19:32:30 +0200)
are available in the git repository at:
git://git.denx.De/u-boot-arm master
for you to fetch changes up to 5a9120439416a9101dec7c7dc65bb
Hi Minkyu,
On Thu, 10 Oct 2013 10:46:19 +0900, Minkyu Kang
wrote:
> Dear Albert,
>
> The following changes since commit 12eba1b49380988fd87cc0b3af44014cca8b71c4:
>
> README: update ARM register usage (2013-09-23 18:00:36 +0200)
>
> are available in the git repository at:
>
> git://git.de
Curently memcpy copies string without null terminating char because
function strlen returns only number of characters excluding
null terminating character. Replace memcpy with strcpy.
Signed-off-by: Piotr Wilczek
Signed-off-by: Kyungmin Park
CC: Tom Rini
---
fs/fat/fat_write.c |2 +-
1 fil
In this patch static variable and memcpy instead of an assignment
are used to avoid unaligned access exception on some ARM platforms.
Signed-off-by: Piotr Wilczek
Signed-off-by: Kyungmin Park
CC: Tom Rini
---
disk/part_efi.c |6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On 10/11/2013 06:51 AM, Masahiro Yamada wrote:
> Hello Wolfgang, Simon
>
>
> I cannot build sandbox for the current u-boot/master.
> Could you check please?
>
>
> The error is like this:
>
> cmd_sandbox.c: In function 'do_sandbox_load':
> cmd_sand
On Fri, 11 Oct 2013 09:11:52 +0200, Albert ARIBAUD
wrote:
> Hi Tom,
>
> On Thu, 10 Oct 2013 18:52:57 -0400, Tom Rini wrote:
>
> > -BEGIN PGP SIGNED MESSAGE-
> > Hash: SHA1
> >
> > On 10/10/2013 06:10 PM, Scott Wood wrote:
> > > On Thu, 2013-10-10 at 15:18 -0400, Tom Rini wrote:
> > >>
Hi Masahiro,
On 11.10.2013 13:29, Masahiro Yamada wrote:
> My question is:
> Where can I get suitable toolchains for all architectures
> supported by U-Boot?
>
>
> Gerhard Sittig told me this site:
> ftp://ftp.kernel.org/pub/tools/crosstool/
>
> But I could not get the crosstool for some archit
Hello experts, custodians.
U-Boot Wiki page (http://www.denx.de/wiki/U-Boot/Patches)
says like follows:
> Before sending the patch, you must run the MAKEALL script on your patched
> source tree
> and make sure that no errors or warnings are reported for any of the boards.
> Well, at least not a
Hello Wolfgang, Simon
I cannot build sandbox for the current u-boot/master.
Could you check please?
The error is like this:
cmd_sandbox.c: In function 'do_sandbox_load':
cmd_sandbox.c:13:2: error: too many arguments to function 'do_load'
In file included from cmd_sandbox.c:8:0:
/home/yamada/wo
Hi Tom
I have managed to boot dm3730 on usb (first stage), but looking at the code
I have some comment
in arch/arm/cpu/armv7/omap3/clock.c
#ifdef CONFIG_SYS_NS16550
/* Enable UART1 clocks */
sr32(&prcm_base->fclken1_core, 13, 1, 0x1);
sr32(&prcm_base->iclken1_core, 13, 1,
Hi Curt,
Sorry for late reply.
> Hello,
>
> I have some questions about how U-Boot regression testing works. I am
> assuming some regression testing happens during the release period
> across some representative sample of boards and architectures.
I can only present my approach - I test the bo
If user uses the I2C in before the relocation, board of sh and rmobile
will not start. This will solve this problem.
Signed-off-by: Nobuhiro Iwamatsu
---
drivers/i2c/sh_i2c.c | 10 --
1 file changed, 8 insertions(+), 2 deletions(-)
diff --git a/drivers/i2c/sh_i2c.c b/drivers/i2c/sh_i2c.
Signed-off-by: Nobuhiro Iwamatsu
---
README | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/README b/README
index cee8e2f..77d2e80 100644
--- a/README
+++ b/README
@@ -1987,16 +1987,16 @@ CBFS (Coreboot Filesystem) support
offset CONFIG_SYS_FSL_I2C_
Previously, the address of a requested capability is define like that
"#define PCI_DCR0x78"
But, the addresses of capabilities is different with regard to PCIe revs.
So this method is not flexible.
Now a function to get the address of a requested capability is added and used.
It ca
Dear Egbert Eich,
> -Original Message-
> From: Egbert Eich [mailto:egbert.e...@gmail.com]
> Sent: Friday, October 04, 2013 6:53 PM
> To: u-boot@lists.denx.de
> Cc: Piotr Wilczek; Tom Rini; Egbert Eich; Egbert Eich
> Subject: [Patch v3] cmd/gpt: Support gpt command for all devices
>
> From
Hi Tom,
On Thu, 10 Oct 2013 18:52:57 -0400, Tom Rini wrote:
> -BEGIN PGP SIGNED MESSAGE-
> Hash: SHA1
>
> On 10/10/2013 06:10 PM, Scott Wood wrote:
> > On Thu, 2013-10-10 at 15:18 -0400, Tom Rini wrote:
> >> On 10/10/2013 03:00 PM, Albert ARIBAUD wrote:
> >>> On Thu, 10 Oct 2013 17:52:1
45 matches
Mail list logo