On 21:56 Sun 03 May , Magnus Lilja wrote:
> Signed-off-by: Magnus Lilja
> ---
> MAKEALL |3 +-
> Makefile|9 ++-
> board/freescale/mx31pdk/config.mk |4 +
> board/freescale/mx31pdk/lowlevel_init.S
> +++ b/board/freescale/mx31pdk/lowlevel_init.S
> @@ -0,0 +1,30 @@
> +/*
> + * (C) Copyright 2008 Magnus Lilja
> + *
> + * See file CREDITS for list of people who contributed to this
> + * project.
> + *
> + * This program is free software; you can redistribute it and/or
> + * modify it under the
On 21:56 Sun 03 May , Magnus Lilja wrote:
> This patch adds the NAND SPL framework needed to boot i.MX31 boards
> from NAND.
>
> The patch is based on the work by Maxim Artamonov
> (which was signed-off-by him).
so please add it too
and please fix the @
>
> Signed-off-by: Magnus Lilja
> ---
Instead of using a #define'd register offset, use a function that
provides the PATA controller's base address.
This allows us to get rid of all such register offset definitions
(at least for use in C files).
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
include/configs/mpc5121ads.h |4 ++
Move needed definitions (register descriptions etc.) from
include/mpc512x.h into include/asm-ppc/immap_512x.h.
All the rest of include/mpc512x.h are register offset definitions
which can be eliminated by proper use of C structures - of course in
combination with replacing pointer accesses by I/O
"ethernet_regs" in include/mpc512x.h duplicates "fec512x_t" in
include/asm-ppc/immap_512x.h; switch to using the latter so we can
remove include/mpc512x.h later.
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
drivers/net/mpc512x_fec.c | 17 -
1 files changed, 12 insertions(+)
Instead of using a #define'd register offset, use a function that
provides the PATA controller's base address.
This allows us to get rid of all such register offset definitions
(at least for use in C files).
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
include/configs/aria.h |4 ++--
1
remove include - it's not needed any more.
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/i2c.c |1 -
1 files changed, 0 insertions(+), 1 deletions(-)
diff --git a/cpu/mpc512x/i2c.c b/cpu/mpc512x/i2c.c
index 4f6bc86..812f24a 100644
--- a/cpu/mpc512x/i2c.c
+++ b/cpu/mpc512x/i2c
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/i2c.c | 25 +++--
1 files changed, 11 insertions(+), 14 deletions(-)
diff --git a/cpu/mpc512x/i2c.c b/cpu/mpc512x/i2c.c
index e9bb3e7..c8184cc 100644
--- a/cpu/mpc512x/i2c.c
+++ b/cpu/mpc512x/i2c.c
@@ -24,6 +24,7
* Use "u{8,16,32}" instead of "uint{8,16,32}" data types
* Drop use of include/mpc512x.h
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
drivers/net/mpc512x_fec.c | 49 +-
drivers/net/mpc512x_fec.h | 253 ++---
2 files changed, 148 insertions(+
After removing the last reference to it, we can finally ditch
include/mpc512x.h
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
include/common.h |1 -
include/mpc512x.h | 385 -
2 files changed, 0 insertions(+), 386 deletions(-)
delete
Use existing struct fec512x instead.
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
drivers/net/mpc512x_fec.c | 11 ++---
drivers/net/mpc512x_fec.h | 126 +
2 files changed, 5 insertions(+), 132 deletions(-)
diff --git a/drivers/net/mpc512x_fec.c
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
drivers/net/mpc512x_fec.c | 113 +---
1 files changed, 64 insertions(+), 49 deletions(-)
diff --git a/drivers/net/mpc512x_fec.c b/drivers/net/mpc512x_fec.c
index 10a78ab..fe28bdf 100644
--- a/drivers/net/mp
remove include - it's not needed any more.
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/speed.c |1 -
1 files changed, 0 insertions(+), 1 deletions(-)
diff --git a/cpu/mpc512x/speed.c b/cpu/mpc512x/speed.c
index 5992111..befcd14 100644
--- a/cpu/mpc512x/speed.c
+++ b/cpu/mpc
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/iopin.c |5 +++--
1 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/cpu/mpc512x/iopin.c b/cpu/mpc512x/iopin.c
index befa586..381ddca 100644
--- a/cpu/mpc512x/iopin.c
+++ b/cpu/mpc512x/iopin.c
@@ -23,6 +23,7 @@
#inclu
The following patch series includes a heavy rework of the existing
code for MPC512x processors. The changes include especially:
- move common files from mpc5121ads (so far ads5121) board to common
directory so they can be reused by other boards based on the same
CPU
- rename "ads5121" into "f
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/cpu_init.c | 24 +++-
1 files changed, 15 insertions(+), 9 deletions(-)
diff --git a/cpu/mpc512x/cpu_init.c b/cpu/mpc512x/cpu_init.c
index 6d765e8..1ad85f2 100644
--- a/cpu/mpc512x/cpu_init.c
+++ b/cpu/mpc512x/cpu
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/pci.c | 70
1 files changed, 43 insertions(+), 27 deletions(-)
diff --git a/cpu/mpc512x/pci.c b/cpu/mpc512x/pci.c
index 3c63592..41f5423 100644
--- a/cpu/mpc512x/pci.c
+++ b/cpu/mp
This already gets included by
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/iopin.c |1 -
1 files changed, 0 insertions(+), 1 deletions(-)
diff --git a/cpu/mpc512x/iopin.c b/cpu/mpc512x/iopin.c
index 381ddca..be20947 100644
--- a/cpu/mpc512x/iopin.c
+++ b/cpu/mpc512x/iopin.c
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/i2c.c | 33 -
1 files changed, 20 insertions(+), 13 deletions(-)
diff --git a/cpu/mpc512x/i2c.c b/cpu/mpc512x/i2c.c
index 812f24a..e9bb3e7 100644
--- a/cpu/mpc512x/i2c.c
+++ b/cpu/mpc512x/i2c.c
@@ -31,
- add GPIO module description
- add Address Latch Timing Register description
- add IO Control Memory Map
- add FEC Memory Map
Also change board/freescale/mpc5121ads/mpc5121ads.c and
cpu/mpc512x/iopin.c as needed.
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
board/freescale/mpc5121ads/mpc51
This commit and several others that will follow change the MPC512x
code to use I/O accessor calls (i.e. out_*() and in_*()) instead of
using deprecated pointer accesses.
The commits are kept separate to allow for easier tracking of any
potential regressions.
Signed-off-by: Wolfgang Denk
Cc: John
ARIA is a MPC5121E based COM Express module by Dave/DENX.
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
MAINTAINERS |2 +
MAKEALL |1 +
Makefile |4 +-
board/davedenx/aria/Makefile | 53
board/davedenx/aria/aria.
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/Makefile |7 +++
1 files changed, 3 insertions(+), 4 deletions(-)
diff --git a/cpu/mpc512x/Makefile b/cpu/mpc512x/Makefile
index 297d135..a78719d 100644
--- a/cpu/mpc512x/Makefile
+++ b/cpu/mpc512x/Makefile
@@ -25,11 +25,10 @@
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/serial.c | 62 +
1 files changed, 32 insertions(+), 30 deletions(-)
diff --git a/cpu/mpc512x/serial.c b/cpu/mpc512x/serial.c
index 7db87a8..2707047 100644
--- a/cpu/mpc512x/serial.c
+++
Get rid of variable declaration in the middle of the code.
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/pci.c |9 +++--
1 files changed, 3 insertions(+), 6 deletions(-)
diff --git a/cpu/mpc512x/pci.c b/cpu/mpc512x/pci.c
index 806c428..3c63592 100644
--- a/cpu/mpc512x/pci
remove include - it's not needed any more.
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/cpu_init.c |1 -
1 files changed, 0 insertions(+), 1 deletions(-)
diff --git a/cpu/mpc512x/cpu_init.c b/cpu/mpc512x/cpu_init.c
index fa753c8..6d765e8 100644
--- a/cpu/mpc512x/cpu_init.c
+
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/speed.c | 21 +++--
1 files changed, 15 insertions(+), 6 deletions(-)
diff --git a/cpu/mpc512x/speed.c b/cpu/mpc512x/speed.c
index befcd14..78df631 100644
--- a/cpu/mpc512x/speed.c
+++ b/cpu/mpc512x/speed.c
@@ -27,6 +
remove include - it's not needed any more.
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
common/cmd_ide.c |4
1 files changed, 0 insertions(+), 4 deletions(-)
diff --git a/common/cmd_ide.c b/common/cmd_ide.c
index 782ad1c..04f1cf4 100644
--- a/common/cmd_ide.c
+++ b/common/cmd_ide.c
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/diu.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/cpu/mpc512x/diu.c b/cpu/mpc512x/diu.c
index 58a8620..1550c8c 100644
--- a/cpu/mpc512x/diu.c
+++ b/cpu/mpc512x/diu.c
@@ -95,7 +95,7 @@ int mpc5121_diu_init(v
remove include - it's not needed any more.
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
cpu/mpc512x/cpu.c |1 -
1 files changed, 0 insertions(+), 1 deletions(-)
diff --git a/cpu/mpc512x/cpu.c b/cpu/mpc512x/cpu.c
index 8021bc1..42ccd81 100644
--- a/cpu/mpc512x/cpu.c
+++ b/cpu/mpc512x/cpu
We will soon see several new MPC521x based boards added. This patch
moves files that are not board specific to a common directory so they
can be shared by all such ports.
Signed-off-by: Wolfgang Denk
Cc: John Rigby
---
board/ads5121/Makefile |4 -
board/ads5121/ads5121.c |4 +-
On Wednesday 29 April 2009, Jean-Christophe PLAGNIOL-VILLARD wrote:
> On 22:11 Tue 28 Apr 2009, David Brownell wrote:
> >
> > Initial U-Boot support for the DaVinci DM355 EVM
> >
> > MAKEALL|1
> > Makefile |3
> > board/davinci
Dear Jean-Christophe PLAGNIOL-VILLARD,
In message <1241876118-27469-3-git-send-email-plagn...@jcrosoft.com> you wrote:
> Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD
> ---
> applied to arm/testing
How much of this patch has actually been tested yet?
Best regards,
Wolfgang Denk
--
DENX Sof
Hi
2009/5/9 Wolfgang Denk :
>> check all ubifs update
>
> What has ubifs to do with that? UBI is nowhere mentioned in this
> patch at all.
v1 of the patch touched some ubi stuff because of the global
search&replace, hence the comment above.
/Magnus
__
Dear Jean-Christophe PLAGNIOL-VILLARD,
In message <1241863009-26036-3-git-send-email-plagn...@jcrosoft.com> you wrote:
> actually the console API use the following naming convention
Please look up the difference in meaning between "actually" and "cur-
rently"; I think you usually mean "currently"
Dear Jean-Christophe PLAGNIOL-VILLARD,
In message <1241863009-26036-2-git-send-email-plagn...@jcrosoft.com> you wrote:
> actually the mpl's boards duplicate the printing current devices
> from common/console.c
>
> create stdio_print_current_devices() for this purpose
>
> Signed-off-by: Jean-Chri
Dear Jean-Christophe PLAGNIOL-VILLARD,
In message <1241863009-26036-1-git-send-email-plagn...@jcrosoft.com> you wrote:
> Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD
> ---
> include/console.h |2 --
> 1 files changed, 0 insertions(+), 2 deletions(-)
Please change commit message into: "re
Patch adds Support for DaVinci DM357.
It boots of a small page NAND on the EVM. It does not have NOR support.
This patch has been tested on the DM357 EVM.
The patch does not have Ethernet Support yet.
Ethernet Support will be added soon
Signed-off-by: Sandeep Paulraj
---
Makefile
All DaVinci SOC's use a CLE mask of 0x10 and an ALE mask of 0x8
except the DM646x. This was decided by the design team driving the design.
This patch updates the CLE and ALE values for DM646x.
Updated patches for DM646x will be sent shortly.
This applies to u-boot-nand-flash git
Signed-off-by: San
Patch adds base addresses for DaVinci DM365. Updated patches for DM365
will be posted soon.
Patch applies to arm/next
Signed-off-by: Sandeep Paulraj
---
include/asm-arm/arch-davinci/hardware.h |6 ++
1 files changed, 6 insertions(+), 0 deletions(-)
diff --git a/include/asm-arm/arch-davi
Jean-Christophe,
Please see inline
> -Original Message-
> From: Jean-Christophe PLAGNIOL-VILLARD [mailto:plagn...@jcrosoft.com]
> Sent: Saturday, May 09, 2009 10:08 AM
> To: Paulraj, Sandeep
> Cc: u-boot@lists.denx.de
> Subject: Re: [U-Boot] [PATCH v4] ARM DaVinci Addin
On 13:19 Tue 28 Apr , David Brownell wrote:
> From: David Brownell
>
> Remove CONFIG_SYS_DAVINCI_BROKEN_ECC option. It's not just nasty;
> it's also unused by any current boards, and doesn't even match the
> main U-Boot distributions from TI (which use soft ECC, or 4-bit ECC
> on newer chips
> +
> +#ifndef __CONFIG_H
> +#define __CONFIG_H
> +#include
> +
> +/*
> + *
> + */
> +#define DM357_EVM
> +#define CONFIG_SYS_NAND_SMALLPAGE
> +#define CONFIG_SYS_USE_NAND
> +/*
> + * SoC Configuration
> + */
> +#define CONFIG_ARM926EJS /* arm926ejs CPU core */
> +#define CONFI
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD
---
applied to arm/testing
Best Regards,
J.
cpu/arm720t/Makefile |4 +-
cpu/arm720t/s3c4510b/Makefile |1 +
cpu/arm720t/s3c4510b/interrupts.c | 85 +
cpu/arm720t/{interrupts.c =
move s3c44b0 to arch_cpu_init and as noone use cpu_init remove it
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD
---
applied to arm/testing
Best Regards,
J.
cpu/arm1136/cpu.c |5 -
cpu/arm1176/cpu.c |5 -
cpu/arm720t/cpu.c |5 -
cpu/arm920t/cpu.c |
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD
---
applied to arm/testing
Best Regards,
J.
cpu/arm920t/Makefile |8 +---
cpu/arm920t/interrupts.c |4 +---
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/cpu/arm920t/Makefile b/cpu/arm920t/Makefile
index e02bc6a..cb
all arm init the IRQ stack the same way
so unify it in lib_arm/interrupts.c and then call arch specific interrupt init
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD
---
applied to arm/testing
Best Regards,
J.
cpu/arm1136/cpu.c| 11 ---
cpu/arm720t/cpu.c|7
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD
---
applied to arm/testing
Best Regards,
J.
cpu/arm720t/lpc2292/Makefile | 11 +++--
cpu/arm720t/lpc2292/interrupts.c | 41 ++
cpu/arm720t/timer.c | 12 ---
3 files changed, 49
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD
---
applied to arm/testing
Best Regards,
J.
cpu/arm920t/interrupts.c |8 ++--
cpu/arm920t/s3c24x0/Makefile | 14 --
cpu/arm920t/{ => s3c24x0}/interrupts.c | 19 +--
cpu/arm920t/s3c24x0
actually the mpl's boards duplicate the printing current devices
from common/console.c
create stdio_print_current_devices() for this purpose
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD
---
board/mpl/common/common_util.c | 30 ---
board/mpl/common/common_util.h |1 -
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD
---
include/console.h |2 --
1 files changed, 0 insertions(+), 2 deletions(-)
diff --git a/include/console.h b/include/console.h
index 06ec32a..bc8b139 100644
--- a/include/console.h
+++ b/include/console.h
@@ -33,6 +33,4 @@
extern device_t
--
Get back to us for a lump sum pay out of £750,000 pounds sterlings.Provide
us with your:Name:Address:Sex for more details:(uk_d...@btinternet.com)
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
On 13:02 Fri 08 May , Tom Rix wrote:
> Port version 2.6.27 of the linux kernel's omap gpio interface to u-boot.
> The orignal source is in linux/arch/arm/plat-omap/gpio.c
>
> See doc/README.omap3 for instructions on use.
>
> Signed-off-by: Tom Rix
> ---
Applied to arm/next
Best Regards,
J.
On 08:42 Sat 09 May , Alessandro Rubini wrote:
> > Due to ML limitation
> > I've reduce the content of the patch to show only the Copyright
> > [...]
>
> Thanks. Could you please post Where the full patch is, in order to
> try it?
http://git.denx.de/?p=u-boot/u-boot-arm.git;a=commitdiff_plain;
Hello Daniel,
>> There are indeed 2 routes:
>> 1. If you need a serial console, you can still use it with the older
>> usbtty code.
>> 2. Adapt the new CDC layer such that it becomes suitable for console
>> purposes as well. I would be happy integrating patches for this in the
>> USB branch. That
Remy
>
> There are indeed 2 routes:
> 1. If you need a serial console, you can still use it with the older
> usbtty code.
> 2. Adapt the new CDC layer such that it becomes suitable for console
> purposes as well. I would be happy integrating patches for this in the
> USB branch. That would allow
The following changes since commit 6b8edfde22acc574b5532e9f086e6a7287a9bc78:
Wolfgang Denk (1):
Prepare v2009.06-rc1
are available in the git repository at:
git://www.denx.de/git/u-boot-blackfin.git master
Graf Yang (1):
Blackfin: bf518f-ezbrd: reset ethernet PHY during init
M
58 matches
Mail list logo