On 06:20 Thu 27 Nov , Dirk Behme wrote:
> Fix merge error.
>
> Signed-off-by: Dirk Behme <[EMAIL PROTECTED]>
>
> ---
> drivers/i2c/omap24xx_i2c.c |1 +
> 1 files changed, 1 insertion(+)
It's already fix
just not find time to push it last night
Best Regards,
J.
_
Hi Becky,
On Wednesday 26 November 2008, Becky Bruce wrote:
> We're going to be seeing more platforms with larger physical addresses
> (PA) than virtual addresses (VA) supported in u-boot, and this kind of
> ruins the current assumption inherent in much of u-boot that VA ==
> PA. On ppc, we've be
Hi ,
I am new to U boot and my ultimate goal is to port uC Linux on an ARM 9T
based board . I want to work on the cygwin environment . Is it possible to
use ELDK on Cygwin ?
Regards
Diptopal
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.den
Fix merge error.
Signed-off-by: Dirk Behme <[EMAIL PROTECTED]>
---
drivers/i2c/omap24xx_i2c.c |1 +
1 files changed, 1 insertion(+)
Index: u-boot-arm/drivers/i2c/omap24xx_i2c.c
===
--- u-boot-arm.orig/drivers/i2c/omap24xx_i2c.c
HI all,
can anybody will give any idea on IROM mode.
Thanks & Regards,
kishore.
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
Wolfgang Denk wrote:
> Dear Jerry,
>
> In message <[EMAIL PROTECTED]> you wrote:
>> How would xlat know which direction it is to translate?
>
> From the argument that is passed to it:
>
> xlat 1234
> or
> xlat 0x1234
>
> are taken as VA's (see discussion about default address
> inte
On Mon, 10 Nov 2008 17:05:00 +0100
Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]> wrote:
> > Please explain what exactly you are trying to change / fix here.
> >
> > > diff --git a/drivers/serial/usbtty.c b/drivers/serial/usbtty.c
> > > index e738c56..448defa 100644
> > > --- a/drivers/seri
Dear Andrew,
In message <[EMAIL PROTECTED]> you wrote:
>
> > - Initially, a xlat (or insert better name here) command-line command
> > will be added to give you a PA given a VA, and vice-versa.
>
> virt_to_phys and phys_to_virt?
C'me on, we actually have to *type* that command every now and the
Dear Jerry,
In message <[EMAIL PROTECTED]> you wrote:
>
> How would xlat know which direction it is to translate?
>From the argument that is passed to it:
xlat 1234
or
xlat 0x1234
are taken as VA's (see discussion about default address
interpretation), so "xlat" will print the
On Wed, Nov 26, 2008 at 4:11 PM, Becky Bruce <[EMAIL PROTECTED]> wrote:
> Folks,
>
> We're going to be seeing more platforms with larger physical addresses
> (PA) than virtual addresses (VA) supported in u-boot, and this kind of
> ruins the current assumption inherent in much of u-boot that VA ==
>
Hi Becky,
Becky Bruce wrote:
> Folks,
>
> We're going to be seeing more platforms with larger physical addresses
> (PA) than virtual addresses (VA) supported in u-boot, and this kind of
> ruins the current assumption inherent in much of u-boot that VA ==
> PA. On ppc, we've begin implement
Folks,
We're going to be seeing more platforms with larger physical addresses
(PA) than virtual addresses (VA) supported in u-boot, and this kind of
ruins the current assumption inherent in much of u-boot that VA ==
PA. On ppc, we've begin implementing the ability to actually
translate VA
Hello Jean-Christophe,
>> In message <[EMAIL PROTECTED]> you wrote:
>> > Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
>>
>> > diff --git a/drivers/serial/usbtty.c b/drivers/serial/usbtty.c
What are we going to do with this patch?
Kind Regards,
Remy
___
Graeme Russ wrote:
> Ben Warren wrote:
>
>> Graeme,
>>
>> Graeme Russ wrote:
>>
>>> Wolfgang Denk wrote:
>>>
>>>
I think this has been answered before: it doesn't work when the
functions are in libraries. It only works when the respective
functions are in explicitely
Ben Warren wrote:
> Graeme,
>
> Graeme Russ wrote:
>> Wolfgang Denk wrote:
>>
>>> I think this has been answered before: it doesn't work when the
>>> functions are in libraries. It only works when the respective
>>> functions are in explicitely linked object files.
>>>
>>>
>>>
>> This doesn
Graeme,
Graeme Russ wrote:
> Wolfgang Denk wrote:
>
>> Dear Remy,
>>
>> In message <[EMAIL PROTECTED]> you wrote:
>>
I have a very strange problem - I am trying to define a weak function, but
whether or not the function is overridden depends on where I put the
overriding fun
Wolfgang Denk wrote:
> Dear Remy,
>
> In message <[EMAIL PROTECTED]> you wrote:
>>> I have a very strange problem - I am trying to define a weak function, but
>>> whether or not the function is overridden depends on where I put the
>>> overriding function. Case in point:
>> You are not the only on
Simon Boman wrote:
> 2008/11/24 Simon Boman <[EMAIL PROTECTED]>:
[snip]
>> I can add that this occur after "Delete the old LMB reservation" in
>> bootm.c and the function fdt_resize(of_flat_tree) is executing. The
>> problem as I have understood it, is that the blob is resized so its
>> fits one
Initial support for Extreme Engineering Solutions XPedite5200 -
a MPC8548-based PMC single board computer.
Signed-off-by: Peter Tyser <[EMAIL PROTECTED]>
---
MAINTAINERS |1 +
MAKEALL |1 +
Makefile|3 +
b
Add define used to determine if PCI1 interface is in PCI or PCIX mode.
Signed-off-by: Peter Tyser <[EMAIL PROTECTED]>
---
include/asm-ppc/immap_85xx.h |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/include/asm-ppc/immap_85xx.h b/include/asm-ppc/immap_85xx.h
index 75b451d
These 2 patches add support for the XPedite5200 SBC -
a MPC8548-based PMC card made by Extreme Engineering
Solutions.
The patches require the following 2 patches to be applied first:
- pca953x: Add support for PCA953x I2C gpio devices
- XPedite5370 board support
changes since v1:
- Change alignme
Initial support for the DS4510, a CPU supervisor with
integrated EEPROM, SRAM, and 4 programmable non-volatile
GPIO pins. The CONFIG_DS4510 define enables support
for the device while the CONFIG_CMD_DS4510 define
enables the ds4510 command. The additional
CONFIG_DS4510_INFO, CONFIG_DS4510_MEM, and
Initial support for NXP's 4 and 8 bit I2C gpio expanders
(eg pca9537, pca9557, etc). The CONFIG_PCA953X define
enables support for the devices while the CONFIG_CMD_PCA953X
define enables the pca953x command. The CONFIG_CMD_PCA953X_INFO
define enables an 'info' sub-command which provides summary
inf
Hello,
This patch series adds support for the XPedite5370 SBC.
Its an MPC8572-based VPX card with a PMC/XMC site. The
XPedite5370 includes a significant number of I2C GPIO devices (5)
which are used for board configuration. I added support for
2 new I2C gpio devices in a new drivers/gpio director
Signed-off-by: Kumar Gala <[EMAIL PROTECTED]>
---
cpu/mpc85xx/tlb.c | 34 ++
include/asm-ppc/mmu.h |3 +++
lib_ppc/board.c |8
3 files changed, 45 insertions(+), 0 deletions(-)
diff --git a/cpu/mpc85xx/tlb.c b/cpu/mpc85xx/tlb.c
index a2
If we have addr map support enabled use the mapping functions to
implement virt_to_phys() and map_physmem().
Signed-off-by: Kumar Gala <[EMAIL PROTECTED]>
---
include/asm-ppc/io.h | 12
1 files changed, 12 insertions(+), 0 deletions(-)
diff --git a/include/asm-ppc/io.h b/include/a
Add a library that helps in translating between virtual and physical
addresses. This library can be useful as a simple means to implement
map_physmem() and virt_to_phys() for platforms that need functionality
beyond the simple 1:1 mapping.
Signed-off-by: Kumar Gala <[EMAIL PROTECTED]>
---
* Fixed
USB Code style patch
Signed-off-by: Michael Trimarchi <[EMAIL PROTECTED]>
---
common/cmd_usb.c | 595 +-
common/usb.c | 40 +++--
include/usb.h| 222 +++-
3 files changed, 465 insertions(+), 392 deletions(-)
diff --
Remove USB obsolete commmand
Signed-off-by: Michael Trimarchi <[EMAIL PROTECTED]>
---
common/cmd_usb.c |9 -
1 files changed, 0 insertions(+), 9 deletions(-)
diff --git a/common/cmd_usb.c b/common/cmd_usb.c
index 8a8dca9..8b19240 100644
--- a/common/cmd_usb.c
+++ b/common/cmd_usb.c
> It is nessary a grep with the full message? There are a lot of situation
> when the grep is impossible.
FWIW, I think it's not important to have the message in one line.
I prefer to grep for the message in the object files. This is
especially useful when the same message appears in different pl
2008-11-26 (수), 16:10 +0100, Michael Lawnick 쓰시길:
> Choe, Hyun-ho said the following:
> > My second workaround is strange, too.
> > In ARM code, mapping physical address to logical is actually does
> > nothing, except re-calculating pointer with sector no. and offset.
> > It just eating several pro
On Fri, Nov 21, 2008 at 08:09:20AM -0700, Grant Likely wrote:
> Juergen, I haven't seen this behaviour. Have you asked you Freescale FAE?
>
> Hey John, have you ever seen this sort of issue?
To keep you updated: It was the PHY which would drive the lines high if
the reset signal was "too long"
Dear Michael,
In message <[EMAIL PROTECTED]> you wrote:
>
> - printf(" NOTE: this command is obsolete and will be
> phased out\n");
> - printf(" please use 'usb storage' for USB storage
> devices information\n\n");
...
> At the end, can I break t
Dear Remy,
In message <[EMAIL PROTECTED]> you wrote:
>
> > I have a very strange problem - I am trying to define a weak function, but
> > whether or not the function is overridden depends on where I put the
> > overriding function. Case in point:
>
> You are not the only one, I have seen this al
Choe, Hyun-ho said the following:
> My second workaround is strange, too.
> In ARM code, mapping physical address to logical is actually does
> nothing, except re-calculating pointer with sector no. and offset.
> It just eating several processor cycles.
I actually have no ARM experience, but when
Hi,
I'm going to prepare the patch without the 80 chars strict.
Michael
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
USB Code style patch
---
common/cmd_usb.c | 595 +-
common/usb.c | 40 +++--
include/usb.h| 222 +++-
3 files changed, 465 insertions(+), 392 deletions(-)
diff --git a/common/cmd_usb.c b/common/cmd_usb.c
index 99e551
Wolfgang Denk wrote:
> Dear michael,
>
> In message <[EMAIL PROTECTED]> you wrote:
>
- printf(" NOTE: this command is obsolete and will be
phased out\n");
- printf(" please use 'usb storage' for USB storage devices
information\n\n");
+
Hello Graeme,
> I have a very strange problem - I am trying to define a weak function, but
> whether or not the function is overridden depends on where I put the
> overriding function. Case in point:
You are not the only one, I have seen this also with the LED interface
in U-boot.
My workaround w
Hi,
I want to know about the U-BOOT loading address in MPC8572DS development
board (boot flash Address map 0_F800_ to 0__ -> 128Mb). For
MPC8572 the default boot rom address is 0xff80, I also want to know
to which address I have to load the uboot first and once uboot gets
execu
2008-11-26 (수), 10:58 +0100, Wolfgang Denk 쓰시길:
> Dear "Choe, Hyun-ho",
>
> In message <[EMAIL PROTECTED]> you wrote:
> > I did several tests for my b'd that has CFI Nor erase/write problem.
> >
> > My main problem is that flash_toggle() function doesn't work properly,
> > it always returns 0 eve
Dear michael,
In message <[EMAIL PROTECTED]> you wrote:
>
> >> - printf(" NOTE: this command is obsolete and will be
> >> phased out\n");
> >> - printf(" please use 'usb storage' for USB storage devices
> >> information\n\n");
> >> + printf(" NOTE: t
Hi All,
I have a very strange problem - I am trying to define a weak function, but
whether or not the function is overridden depends on where I put the
overriding function. Case in point:
common.h defines reset_cpu() thusly:
voidreset_cpu (ulong addr);
in cpu/i386/reset.c I have:
void
"Hi, I am having problems..."
I am trying to modify u-boot to call my custom function to decide
whether to
silence the console or allow it, by calculating the SHA-1 hash of an
environment variable (password-based dev console). If my function is
called,
it succeeds, but all commandline comands repo
Hi,
Remy Bohmer wrote:
> Hello Michael,
>
> Nice work, but I have a few small comments:
>
>
>> + case USB_PROT_HID_MOUSE:
>> + printf("Mouse");
>> + break;
>> + default:
>> +
Hello Michael,
Nice work, but I have a few small comments:
> + case USB_PROT_HID_MOUSE:
> + printf("Mouse");
> + break;
> + default:
> + printf("reserved");
>
[PATCH] USB style patch
Signed-off-by: Michael Trimarchi <[EMAIL PROTECTED]>
---
common/cmd_usb.c | 591 -
common/usb.c | 40 +++--
include/usb.h| 222 -
3 files changed, 461 insertions(+), 392 deletions(-)
diff
Dear "Choe, Hyun-ho",
In message <[EMAIL PROTECTED]> you wrote:
> I did several tests for my b'd that has CFI Nor erase/write problem.
>
> My main problem is that flash_toggle() function doesn't work properly,
> it always returns 0 even while bus writing operation is proceeding.
> I mean, toggle
This patch add's the defines for port d I/Os on AT91RM9200 (BGA package)
Signed-off-by: Jens Scharsig <[EMAIL PROTECTED]>
---
diff --git a/include/asm-arm/arch-at91rm9200/AT91RM9200.h
b/include/asm-arm/arch-at91rm9200/AT91RM9200.h
index 95db017..308dea1 100644
--- a/include/asm-arm/arch-at91rm920
On Wednesday 26 November 2008, Kyungmin Park wrote:
> As usually fixed partition used for UBI.
> So it's defined at configuration and use it.
>
> Signed-off-by: Kyungmin Park <[EMAIL PROTECTED]>
Please find a few comment below.
> diff --git a/common/cmd_ubi.c b/common/cmd_ubi.c
> index 8446765..d
Hi!
I have a modifed MPC8360 platform with a U-boot git-version from October.
Now I'm trying to install a Linux kernel and everything looks fine
until it starts to execute the kernel in RAM, there is only some bad
assembler instructions and then a lot of Invalid Opcode. If I look at
the log_buf th
2008/11/24 Simon Boman <[EMAIL PROTECTED]>:
> 2008/11/21 Simon Boman <[EMAIL PROTECTED]>:
>> 2008/11/21 Jerry Van Baren <[EMAIL PROTECTED]>:
>>> Simon Boman wrote:
2008/11/20 Wolfgang Denk <[EMAIL PROTECTED]>:
>
> Dear "Simon Boman",
>>>
>>> [snip]
>>>
Thank you for your
52 matches
Mail list logo