Author: lwhsu
Date: Fri Feb 14 09:25:29 2020
New Revision: 357904
URL: https://svnweb.freebsd.org/changeset/base/357904
Log:
Properly fix GCC build in r357867
Submitted by: kib
Sponsored by: The FreeBSD Foundation
Modified:
head/tests/sys/net/randsleep.c
Modified: head/tests/sys/net/r
On Fri, Feb 14, 2020 at 5:33 AM Konstantin Belousov wrote:
> On Thu, Feb 13, 2020 at 07:05:19PM +, Li-Wen Hsu wrote:
> > -#define RANDOM_MAX ((1<<31) - 1)
> > +#define RANDOM_MAX (((long)1<<31) - 1)
> This still gives UB on ILP32 platforms. I believe the better fix would be
> (1u << 31) - 1.
Author: melifaro
Date: Fri Feb 14 09:36:35 2020
New Revision: 357905
URL: https://svnweb.freebsd.org/changeset/base/357905
Log:
Add basic IPDIVERT tests.
Reviewed by: lwhsu,kp
Differential Revision:https://reviews.freebsd.org/D23316
Added:
head/tests/sys/common/divert.py (co
On Fri, Feb 14, 2020 at 12:42 AM Konstantin Belousov wrote:
>
> Author: kib
> Date: Thu Feb 13 23:42:09 2020
> New Revision: 357895
> URL: https://svnweb.freebsd.org/changeset/base/357895
>
> Log:
> Handle non-plt IRELATIVE relocations, at least for x86.
>
> lld 10.0 seems to generate this rel
Author: mjg
Date: Fri Feb 14 11:20:25 2020
New Revision: 357906
URL: https://svnweb.freebsd.org/changeset/base/357906
Log:
lockmgr: retire the unused lockmgr_unlock_fast_path routine
Modified:
head/sys/kern/kern_lock.c
head/sys/sys/lockmgr.h
Modified: head/sys/kern/kern_lock.c
Author: mjg
Date: Fri Feb 14 11:22:12 2020
New Revision: 357908
URL: https://svnweb.freebsd.org/changeset/base/357908
Log:
fd: annotate finstall with prediction branches
Modified:
head/sys/kern/kern_descrip.c
Modified: head/sys/kern/kern_descrip.c
Author: mjg
Date: Fri Feb 14 11:21:28 2020
New Revision: 357907
URL: https://svnweb.freebsd.org/changeset/base/357907
Log:
lockmgr: rename lock_fast_path to lock_flags
The routine is not much of a fast path and the flags name better describes
its purpose.
Modified:
head/sys/kern/kern_l
On Fri, Feb 14, 2020 at 11:17:12AM +0100, Antoine Brodin wrote:
> On Fri, Feb 14, 2020 at 12:42 AM Konstantin Belousov wrote:
> >
> > Author: kib
> > Date: Thu Feb 13 23:42:09 2020
> > New Revision: 357895
> > URL: https://svnweb.freebsd.org/changeset/base/357895
> >
> > Log:
> > Handle non-plt
Author: mjg
Date: Fri Feb 14 11:56:50 2020
New Revision: 357909
URL: https://svnweb.freebsd.org/changeset/base/357909
Log:
lockmgr: add a change missed in r357907
Modified:
head/sys/kern/vfs_default.c
Modified: head/sys/kern/vfs_default.c
=
On Fri, Feb 14, 2020 at 12:51 PM Konstantin Belousov
wrote:
>
> On Fri, Feb 14, 2020 at 11:17:12AM +0100, Antoine Brodin wrote:
> > On Fri, Feb 14, 2020 at 12:42 AM Konstantin Belousov
> > wrote:
> > >
> > > Author: kib
> > > Date: Thu Feb 13 23:42:09 2020
> > > New Revision: 357895
> > > URL: h
On Fri, Feb 14, 2020 at 1:37 PM Antoine Brodin wrote:
>
> On Fri, Feb 14, 2020 at 12:51 PM Konstantin Belousov
> wrote:
> >
> > On Fri, Feb 14, 2020 at 11:17:12AM +0100, Antoine Brodin wrote:
> > > On Fri, Feb 14, 2020 at 12:42 AM Konstantin Belousov
> > > wrote:
> > > >
> > > > Author: kib
> >
Author: kib
Date: Fri Feb 14 12:59:27 2020
New Revision: 357910
URL: https://svnweb.freebsd.org/changeset/base/357910
Log:
r357895: fix typo in the relocation name for i386 IRELATIVE.
Reported by: antoine
Sponsored by: The FreeBSD Foundation
MFC after:6 days
Modified:
head/libexe
On Fri, Feb 14, 2020 at 01:37:40PM +0100, Antoine Brodin wrote:
> On Fri, Feb 14, 2020 at 12:51 PM Konstantin Belousov
> wrote:
> >
> > On Fri, Feb 14, 2020 at 11:17:12AM +0100, Antoine Brodin wrote:
> > > On Fri, Feb 14, 2020 at 12:42 AM Konstantin Belousov
> > > wrote:
> > > >
> > > > Author:
Author: mjg
Date: Fri Feb 14 13:08:46 2020
New Revision: 357911
URL: https://svnweb.freebsd.org/changeset/base/357911
Log:
Annotate branches in the syscall path
This in particular significantly shortens amd64_syscall, which otherwise
keeps jumping forward over 2KB of code in total.
N
Author: mjg
Date: Fri Feb 14 13:09:41 2020
New Revision: 357912
URL: https://svnweb.freebsd.org/changeset/base/357912
Log:
Merge audit and systrace checks
This further shortens the syscall routine by not having to re-check after
the system call.
Modified:
head/sys/kern/subr_syscall.c
Author: mjg
Date: Fri Feb 14 13:14:19 2020
New Revision: 357914
URL: https://svnweb.freebsd.org/changeset/base/357914
Log:
amd64: only check for error != 0 in the inlined part of l1d flush check
this replaces the following near the syscall exit:
cmp$0x39,%rax
ja 0x8108f8
Author: kevans
Date: Fri Feb 14 14:03:44 2020
New Revision: 357918
URL: https://svnweb.freebsd.org/changeset/base/357918
Log:
committers-ports: add koobs@ information, somewhat belatedly
Modified:
head/share/misc/committers-ports.dot
Modified: head/share/misc/committers-ports.dot
===
Author: mav
Date: Fri Feb 14 14:55:40 2020
New Revision: 357919
URL: https://svnweb.freebsd.org/changeset/base/357919
Log:
Add Hygon PCI ID and description for AHCI SATA controller.
Submitted by: Pu Wen
MFC after:1 week
Differential Revision:https://reviews.freebsd.org/D235
Author: mav
Date: Fri Feb 14 15:04:56 2020
New Revision: 357920
URL: https://svnweb.freebsd.org/changeset/base/357920
Log:
Add support for Hygon NTB PCI device in ntb_hw_amd driver.
Submitted by: Pu Wen
MFC after:1 week
Differential Revision:https://reviews.freebsd.org/D235
Author: kaktus
Date: Fri Feb 14 16:56:59 2020
New Revision: 357921
URL: https://svnweb.freebsd.org/changeset/base/357921
Log:
sysctl(9): properly use xor in ENFORCE_FLAGS macro
Assert on not specifying any of the (soon to be) required flags as well
as specifying both of them.
Pointe
Author: emaste
Date: Fri Feb 14 17:05:35 2020
New Revision: 357922
URL: https://svnweb.freebsd.org/changeset/base/357922
Log:
openssh: add a note about libwrap in config.h
LIBWRAP is defined by the Makefile based on MK_TCP_WRAPPERS and should
not be defined in config.h.
PR:
Author: kevans
Date: Fri Feb 14 18:46:34 2020
New Revision: 357923
URL: https://svnweb.freebsd.org/changeset/base/357923
Log:
Pull in latest fixes from dtc, up to 0060471
This includes a small battery of /memreserve/ fixes to make sure dtc is
properly writing these regions into the output
Author: kevans
Date: Fri Feb 14 18:50:03 2020
New Revision: 357924
URL: https://svnweb.freebsd.org/changeset/base/357924
Log:
dtc: re-apply r353961, r354115
I missed in final review of r357923's diff that these ones hadn't yet been
sent upstream and inadvertently reverted them. =-( Re-app
Author: emaste
Date: Fri Feb 14 18:59:50 2020
New Revision: 357925
URL: https://svnweb.freebsd.org/changeset/base/357925
Log:
sshd: add upgrade process note about TCP wrappers
We need to add user-facing deprecation notices for TCP wrappers; start
with a note in the upgrade process docment
Author: emaste
Date: Fri Feb 14 19:06:59 2020
New Revision: 357926
URL: https://svnweb.freebsd.org/changeset/base/357926
Log:
Upgrade to OpenSSH 7.9p1.
MFC after:2 months
Sponsored by: The FreeBSD Foundation
Added:
head/crypto/openssh/regress/misc/fuzz-harness/authopt_fuzz.cc
Author: dim
Date: Fri Feb 14 19:31:24 2020
New Revision: 357929
URL: https://svnweb.freebsd.org/changeset/base/357929
Log:
Remove /usr/include/ssp from BSD.include.dist after r356356
This avoids having to delete it every time with "make delete-old".
PR: 242950
MFC after:
On Fri, Feb 14, 2020 at 1:31 PM Dimitry Andric wrote:
>
> Author: dim
> Date: Fri Feb 14 19:31:24 2020
> New Revision: 357929
> URL: https://svnweb.freebsd.org/changeset/base/357929
>
> Log:
> Remove /usr/include/ssp from BSD.include.dist after r356356
>
> This avoids having to delete it every
Author: emaste
Date: Fri Feb 14 19:33:50 2020
New Revision: 357932
URL: https://svnweb.freebsd.org/changeset/base/357932
Log:
Update OpenSSH upgrade instructions to use https, not ftp
ftp://ftp.openbsd.org/ does not work.
Modified:
head/crypto/openssh/FREEBSD-upgrade
Modified: head/cryp
Author: kevans
Date: Fri Feb 14 20:25:04 2020
New Revision: 357935
URL: https://svnweb.freebsd.org/changeset/base/357935
Log:
mips: fix kernel build after r357804
Drop the padding down the size of a single uintptr_t to account for
pc_zpcpu_offset
Modified:
head/sys/mips/include/pcpu.h
Author: emaste
Date: Fri Feb 14 22:32:33 2020
New Revision: 357939
URL: https://svnweb.freebsd.org/changeset/base/357939
Log:
Update version in openssh FREEBSD-vendor metadata
It appears that FREEBSD-vendor is an idea that never really took off
and we should probably just remove it, but u
Author: mjg
Date: Fri Feb 14 23:15:41 2020
New Revision: 357940
URL: https://svnweb.freebsd.org/changeset/base/357940
Log:
Make atomic_load_ptr type-aware
Returned value has type based on the argument, meaning consumers no longer
have to cast in the commmon case.
This commit keeps th
Author: mjg
Date: Fri Feb 14 23:16:29 2020
New Revision: 357941
URL: https://svnweb.freebsd.org/changeset/base/357941
Log:
vm: remove no longer needed atomic_load_ptr casts
Modified:
head/sys/vm/vm_mmap.c
head/sys/vm/vm_page.c
head/sys/vm/vm_pageout.c
Modified: head/sys/vm/vm_mmap.c
Author: mjg
Date: Fri Feb 14 23:17:03 2020
New Revision: 357942
URL: https://svnweb.freebsd.org/changeset/base/357942
Log:
amd64: remove no longer needed atomic_load_ptr casts
Modified:
head/sys/amd64/amd64/trap.c
Modified: head/sys/amd64/amd64/trap.c
Author: mjg
Date: Fri Feb 14 23:17:18 2020
New Revision: 357943
URL: https://svnweb.freebsd.org/changeset/base/357943
Log:
arm64: remove no longer needed atomic_load_ptr casts
Modified:
head/sys/arm64/arm64/gicv3_its.c
Modified: head/sys/arm64/arm64/gicv3_its.c
==
Author: mjg
Date: Fri Feb 14 23:18:03 2020
New Revision: 357945
URL: https://svnweb.freebsd.org/changeset/base/357945
Log:
kcov: remove no longer needed atomic_load_ptr casts
Modified:
head/sys/kern/subr_coverage.c
Modified: head/sys/kern/subr_coverage.c
=
Author: mjg
Date: Fri Feb 14 23:17:37 2020
New Revision: 357944
URL: https://svnweb.freebsd.org/changeset/base/357944
Log:
i386: remove no longer needed atomic_load_ptr casts
Modified:
head/sys/i386/i386/trap.c
Modified: head/sys/i386/i386/trap.c
=
Author: mjg
Date: Fri Feb 14 23:18:32 2020
New Revision: 357947
URL: https://svnweb.freebsd.org/changeset/base/357947
Log:
vfs: remove no longer needed atomic_load_ptr casts
Modified:
head/sys/kern/vfs_subr.c
Modified: head/sys/kern/vfs_subr.c
Author: mjg
Date: Fri Feb 14 23:18:22 2020
New Revision: 357946
URL: https://svnweb.freebsd.org/changeset/base/357946
Log:
fd: remove no longer needed atomic_load_ptr casts
Modified:
head/sys/kern/kern_descrip.c
Modified: head/sys/kern/kern_descrip.c
=
Author: kib
Date: Fri Feb 14 23:27:45 2020
New Revision: 357948
URL: https://svnweb.freebsd.org/changeset/base/357948
Log:
Consolidate read code for timecounters and fix possible overflow in
bintime()/binuptime().
The algorithm to read the consistent snapshot of current timehand is
repe
Author: mjg
Date: Sat Feb 15 01:28:06 2020
New Revision: 357950
URL: https://svnweb.freebsd.org/changeset/base/357950
Log:
capsicum: add cap_rights_init_zero, cap_rights_init_one, cap_rights_set_one
... which allow the compiler to generate relevant code in place without
resorting to calli
Author: mjg
Date: Sat Feb 15 01:29:07 2020
New Revision: 357953
URL: https://svnweb.freebsd.org/changeset/base/357953
Log:
vm: use new capsicum helpers
Modified:
head/sys/vm/vm_mmap.c
Modified: head/sys/vm/vm_mmap.c
Author: mjg
Date: Sat Feb 15 01:28:42 2020
New Revision: 357951
URL: https://svnweb.freebsd.org/changeset/base/357951
Log:
vfs: use new capsicum helpers
Modified:
head/sys/kern/vfs_acl.c
head/sys/kern/vfs_extattr.c
head/sys/kern/vfs_lookup.c
head/sys/kern/vfs_syscalls.c
Modified: head/
Author: mjg
Date: Sat Feb 15 01:28:55 2020
New Revision: 357952
URL: https://svnweb.freebsd.org/changeset/base/357952
Log:
fd: use new capsicum helpers
Modified:
head/sys/kern/kern_descrip.c
Modified: head/sys/kern/kern_descrip.c
==
Author: mjg
Date: Sat Feb 15 01:29:40 2020
New Revision: 357954
URL: https://svnweb.freebsd.org/changeset/base/357954
Log:
sctp: use new capsicum helpers
Modified:
head/sys/netinet/sctp_syscalls.c
Modified: head/sys/netinet/sctp_syscalls.c
Author: mjg
Date: Sat Feb 15 01:30:13 2020
New Revision: 357956
URL: https://svnweb.freebsd.org/changeset/base/357956
Log:
kqueue: use new capsicum helpers
Modified:
head/sys/kern/kern_event.c
Modified: head/sys/kern/kern_event.c
==
Author: mjg
Date: Sat Feb 15 01:30:27 2020
New Revision: 357957
URL: https://svnweb.freebsd.org/changeset/base/357957
Log:
capsicum: use new helpers
Modified:
head/sys/kern/subr_capability.c
head/sys/kern/sys_capability.c
Modified: head/sys/kern/subr_capability.c
==
Author: mjg
Date: Sat Feb 15 01:29:58 2020
New Revision: 357955
URL: https://svnweb.freebsd.org/changeset/base/357955
Log:
cloudabi: use new capsicum helpers
Modified:
head/sys/compat/cloudabi/cloudabi_file.c
Modified: head/sys/compat/cloudabi/cloudabi_file.c
Author: jkim
Date: Sat Feb 15 03:47:25 2020
New Revision: 357959
URL: https://svnweb.freebsd.org/changeset/base/357959
Log:
MFV: r357927
Merge ACPICA 20200214.
Modified:
head/sys/contrib/dev/acpica/changes.txt
head/sys/contrib/dev/acpica/common/adisasm.c
head/sys/contrib/dev/acpica
48 matches
Mail list logo