On Tuesday, December 29, 2015 11:25:26 PM John Baldwin wrote:
> Author: jhb
> Date: Tue Dec 29 23:25:26 2015
> New Revision: 292894
> URL: https://svnweb.freebsd.org/changeset/base/292894
>
> Log:
> Add ptrace(2) reporting for LWP events.
>
> Add two new LWPINFO flags: PL_FLAG_BORN and PL_F
On Tue, Dec 29, 2015 at 11:59:52PM +0300, Gleb Smirnoff wrote:
> On Sun, Dec 27, 2015 at 02:42:39PM +, Konstantin Belousov wrote:
> K> Author: kib
> K> Date: Sun Dec 27 14:42:39 2015
> K> New Revision: 292772
> K> URL: https://svnweb.freebsd.org/changeset/base/292772
> K>
> K> Log:
> K> Add
Author: jhb
Date: Wed Dec 30 00:04:57 2015
New Revision: 292896
URL: https://svnweb.freebsd.org/changeset/base/292896
Log:
Document the recently added support for ptrace(2) LWP events.
Modified:
head/lib/libc/sys/ptrace.2
Modified: head/lib/libc/sys/ptrace.2
=
On Tue, 29 Dec 2015, John Baldwin wrote:
On Monday, December 28, 2015 01:01:26 PM Warner Losh wrote:
I'll look at that, but I don't think posix_memalign is the right way to go.
The alignment of FILE is more strict than posix_memalign will return. Ian's
idea of __alignof__ is the way to go. We a
Author: marius
Date: Wed Dec 30 00:17:37 2015
New Revision: 292897
URL: https://svnweb.freebsd.org/changeset/base/292897
Log:
Adapt CATR() to r283283.
Modified:
head/sys/sparc64/include/ktr.h
Modified: head/sys/sparc64/include/ktr.h
===
Author: dteske
Date: Wed Dec 30 02:15:12 2015
New Revision: 292899
URL: https://svnweb.freebsd.org/changeset/base/292899
Log:
Fix stack leak introduced by SVN r97201 (nextboot_conf support).
Fix erroneous error path in error messages when processing boot_conf.
Fixup stack comments for functi
Author: jhibbits
Date: Wed Dec 30 02:23:14 2015
New Revision: 292900
URL: https://svnweb.freebsd.org/changeset/base/292900
Log:
Rewrite tid_flush() in C.
There's no need for it to be in asm. Also, by writing in C, and marking it
static in pmap.c, it saves a branch to the function itself,
Author: jhibbits
Date: Wed Dec 30 02:26:04 2015
New Revision: 292901
URL: https://svnweb.freebsd.org/changeset/base/292901
Log:
Optimize zero_page for book-e mmu.
Instead of indirectly calling bzero() through mmu_booke_zero_page_area, zero
the
full page the same way as the AIM pmap logic
Author: imp
Date: Wed Dec 30 03:36:22 2015
New Revision: 292902
URL: https://svnweb.freebsd.org/changeset/base/292902
Log:
Use __alignof__ instead of assuming int64_t to get the right
alignment.
Differential Revision: https://reviews.freebsd.org/D4708
Modified:
head/lib/libc/stdio/find
Author: jhibbits
Date: Wed Dec 30 03:43:25 2015
New Revision: 292903
URL: https://svnweb.freebsd.org/changeset/base/292903
Log:
Add platform support for QorIQ SoCs.
This includes the following changes:
* SMP kickoff for QorIQ (tested on P5020)
* Errata fixes for some silicon revisions
On 30 Dec 2015, at 00:48, Bruce Evans wrote:
>
> - C++ apparently spells this as both _Alignof() and alignof() after 2011/03
This is not correct. C++ spells it alignof. C spells it _Alignof, unless you
include , in which case C spells it alignof and defines _
_alignof_is_defined.
On FreeBSD
On Wed, 30 Dec 2015, David Chisnall wrote:
On 30 Dec 2015, at 00:48, Bruce Evans wrote:
- C++ apparently spells this as both _Alignof() and alignof() after 2011/03
This is not correct. C++ spells it alignof. C spells it _Alignof, unless you
include , in which case C spells it alignof and
Author: delphij
Date: Tue Dec 29 08:19:43 2015
New Revision: 292861
URL: https://svnweb.freebsd.org/changeset/base/292861
Log:
hyperv: vmbus: run non-blocking message handlers in vmbus_msg_swintr()
We'll remove the per-channel control_work_queue because it can't properly
do serialization
Author: uqs
Date: Tue Dec 29 11:24:35 2015
New Revision: 292863
URL: https://svnweb.freebsd.org/changeset/base/292863
Log:
Fix type mismatches for malloc(3) and Co.
Found by: clang static analyzer
Reviewed by: ed
Differential Revision:https://reviews.freebsd.org/D4722
Modi
Author: uqs
Date: Tue Dec 29 11:24:41 2015
New Revision: 292864
URL: https://svnweb.freebsd.org/changeset/base/292864
Log:
Fix type mismatches for malloc(3) and Co.
This is rather pedantic, as for most architectures it holds that
sizeof(type *) == sizeof(type **)
Found by: clang
Author: hselasky
Date: Tue Dec 29 11:53:13 2015
New Revision: 292865
URL: https://svnweb.freebsd.org/changeset/base/292865
Log:
Update metadata for "tools/tools/bus_autoconf" after r292080. Use
BYTE_ORDER instead of _BYTE_ORDER due to 3rd party USB software for
now.
Modified:
head/sys/dev
On Tue, Dec 22, 2015 at 02:29:36PM -0800, NGie Cooper wrote:
>
> > On Dec 22, 2015, at 13:17, John Baldwin wrote:
> >
> > On Tuesday, December 22, 2015 09:07:33 PM Garrett Cooper wrote:
>
> …
>
> > It shouldn't be zero, I think == 1 would be best actually.
>
> I’ll boot up GENERIC and see whe
2015-12-28 1:35 GMT+03:00 Bruce Evans :
> On Sun, 27 Dec 2015, Ian Lepore wrote:
>
> On Sun, 2015-12-27 at 15:37 +, Dmitry Chagin wrote:
>>
>>> Author: dchagin
>>> Date: Sun Dec 27 15:37:07 2015
>>> New Revision: 292777
>>> URL: https://svnweb.freebsd.org/changeset/base/292777
>>>
>>> Log:
>>>
On Tue, 29 Dec 2015, Dmitry Chagin wrote:
So, my point was:
a) for a long time we have broken settimeofday() which does not allow us
to set the system time before the Epoch
We still have a broken settimeofday that doesn't allow us to set the system
time to the Epoch in the Western hemisphere
Author: ian
Date: Tue Dec 29 15:23:03 2015
New Revision: 292870
URL: https://svnweb.freebsd.org/changeset/base/292870
Log:
Correct the code for sign-extending a 16 bit value. As near as I can tell
this is effectively a no-op -- the addend term in MOVT/MOVW relocations
always seems to be zer
Author: miwi (doc,ports committer)
Date: Tue Dec 29 15:36:46 2015
New Revision: 292871
URL: https://svnweb.freebsd.org/changeset/base/292871
Log:
- Add myself to ports-secteam
Approved by: delphij (implicit)
Modified:
head/share/misc/organization.dot
Modified: head/share/misc/organizat
Author: pfg
Date: Tue Dec 29 15:51:52 2015
New Revision: 292872
URL: https://svnweb.freebsd.org/changeset/base/292872
Log:
ext2: recognize ext4 INCOMPAT_RECOVER flag
This is a flag specific for journalling in ext4.
Add it to the list of ext4 features we ignore for
read-only purposes.
Author: miwi (doc,ports committer)
Date: Tue Dec 29 15:54:34 2015
New Revision: 292873
URL: https://svnweb.freebsd.org/changeset/base/292873
Log:
- Sort ports-secteam
Modified:
head/share/misc/organization.dot
Modified: head/share/misc/organization.dot
===
Author: theraven
Date: Tue Dec 29 16:29:42 2015
New Revision: 292876
URL: https://svnweb.freebsd.org/changeset/base/292876
Log:
Improvements to BSD-licensed DTC.
- Added an expression parser so that expressions from headers are now working
- Fixed missing null terminators on cross referen
Author: pfg
Date: Tue Dec 29 16:31:28 2015
New Revision: 292877
URL: https://svnweb.freebsd.org/changeset/base/292877
Log:
pax: prevent possible buffer overflow
Or at least quiet down some static analyzers about it.
CID: 978835
MFC after:1 week
Obtained from:OpenBSD
M
Author: marius
Date: Tue Dec 29 17:07:28 2015
New Revision: 292878
URL: https://svnweb.freebsd.org/changeset/base/292878
Log:
- Add entries for the more prominent members of the Digi International
Neo series, which are based on Exar PCI chips.
- Mark some unused parameters as such.
- Fix
Author: jtl
Date: Tue Dec 29 19:20:39 2015
New Revision: 292881
URL: https://svnweb.freebsd.org/changeset/base/292881
Log:
When checking the inp_ip_minttl restriction for IPv6 packets, don't check
the IPv4 header.
CID: 1017920
Differential Revision:https://reviews.freebsd.org/D
Author: ngie
Date: Tue Dec 29 20:17:40 2015
New Revision: 292884
URL: https://svnweb.freebsd.org/changeset/base/292884
Log:
Fix getopt(3) argument after r290180; I forgot to change -r to -R
by accident
MFC after: 3 days
Pointyhat to: ngie
Reported by: vangyzen
Sponsored by: EMC / Is
Author: jilles
Date: Tue Dec 29 20:51:29 2015
New Revision: 292887
URL: https://svnweb.freebsd.org/changeset/base/292887
Log:
sh: Split subevalvar() in #/##/%/%% and =/? parts.
Modified:
head/bin/sh/expand.c
Modified: head/bin/sh/expand.c
=
On Monday, December 28, 2015 01:01:26 PM Warner Losh wrote:
> I'll look at that, but I don't think posix_memalign is the right way to go.
> The alignment of FILE is more strict than posix_memalign will return. Ian's
> idea of __alignof__ is the way to go. We allocate them in one block on
> purpose
On Sun, Dec 27, 2015 at 02:42:39PM +, Konstantin Belousov wrote:
K> Author: kib
K> Date: Sun Dec 27 14:42:39 2015
K> New Revision: 292772
K> URL: https://svnweb.freebsd.org/changeset/base/292772
K>
K> Log:
K> Add missed relpbuf() for a smallfs page-in.
K>
K> Reported by: Shawn Web
Author: ian
Date: Tue Dec 29 21:29:05 2015
New Revision: 292888
URL: https://svnweb.freebsd.org/changeset/base/292888
Log:
Fix the error checking for the ubenv command. This moves the check for an
empty ldvar (which amounts to the varname string starting with '=') into
the if block that man
On Tuesday, December 29, 2015, Gleb Smirnoff wrote:
> On Sun, Dec 27, 2015 at 02:42:39PM +, Konstantin Belousov wrote:
> K> Author: kib
> K> Date: Sun Dec 27 14:42:39 2015
> K> New Revision: 292772
> K> URL: https://svnweb.freebsd.org/changeset/base/292772
> K>
> K> Log:
> K> Add missed rel
Author: kib
Date: Tue Dec 29 22:14:21 2015
New Revision: 292890
URL: https://svnweb.freebsd.org/changeset/base/292890
Log:
Add standard extended feature bit 6 from the Intel SDM rev. 57, which
indicates that data-pointer in the saved x87 FPU state is only updated
on FPU exceptions.
Spon
Author: ian
Date: Tue Dec 29 22:18:35 2015
New Revision: 292891
URL: https://svnweb.freebsd.org/changeset/base/292891
Log:
Bring some of the recent locore-v4.S improvements into locore-V6...
- Map all 4GB as VA=PA so that args passed in from a bootloader can
be accessed regardless of
On Tue, 2015-12-29 at 11:37 -0800, John Baldwin wrote:
> On Monday, December 28, 2015 01:01:26 PM Warner Losh wrote:
> > I'll look at that, but I don't think posix_memalign is the right
> > way to go.
> > The alignment of FILE is more strict than posix_memalign will
> > return. Ian's
> > idea of __
Author: jhb
Date: Tue Dec 29 23:16:20 2015
New Revision: 292892
URL: https://svnweb.freebsd.org/changeset/base/292892
Log:
Call kern_thr_exit() instead of duplicating it.
This code is missing the racct_subr() call from kern_thr_exit() and would
require further code duplication in future c
On Tuesday, December 29, 2015 03:51:29 PM Ian Lepore wrote:
> On Tue, 2015-12-29 at 11:37 -0800, John Baldwin wrote:
> > On Monday, December 28, 2015 01:01:26 PM Warner Losh wrote:
> > > I'll look at that, but I don't think posix_memalign is the right
> > > way to go.
> > > The alignment of FILE is
Author: jhb
Date: Tue Dec 29 23:25:26 2015
New Revision: 292894
URL: https://svnweb.freebsd.org/changeset/base/292894
Log:
Add ptrace(2) reporting for LWP events.
Add two new LWPINFO flags: PL_FLAG_BORN and PL_FLAG_EXITED for reporting
thread creation and destruction. Newly created thread
39 matches
Mail list logo