> On Mar 12, 2017, at 04:26, Dag-Erling Smørgrav wrote:
>
> "Ngie Cooper (yaneurabeya)" writes:
>> Hi Bjoern,
>
> No, that was my father :)
:D..
>>Shouldn’t this be strrchr instead of strchr since you’re
>> scanning for the service from the right side of the host,
>> e.g. “foo:service” o
"Ngie Cooper (yaneurabeya)" writes:
> Hi Bjoern,
No, that was my father :)
> Shouldn’t this be strrchr instead of strchr since you’re
> scanning for the service from the right side of the host,
> e.g. “foo:service” or “[::1]:service”? This code would match index 3
> in the first example, b
> On Nov 22, 2016, at 05:30, Dag-Erling Smørgrav wrote:
>
> Author: des
> Date: Tue Nov 22 13:30:07 2016
> New Revision: 308996
> URL: https://svnweb.freebsd.org/changeset/base/308996
>
> Log:
> Refactor fetch_connect() and fetch_bind() to improve readability and avoid
> repeating the same DN
On Fri, Mar 03, 2017 at 01:29:26PM +0100, Dag-Erling Smørgrav wrote:
> "Bjoern A. Zeeb" writes:
> > Dag-Erling Smørgrav writes:
> >> + /* split address if necessary */
> >> + err = EAI_SYSTEM;
> >> + if ((sep = strchr(addr, ':')) != NULL) {
> >> + len = snprintf(hbuf, sizeof(hbuf),
>
"Bjoern A. Zeeb" writes:
> Dag-Erling Smørgrav writes:
>> +/* split address if necessary */
>> +err = EAI_SYSTEM;
>> +if ((sep = strchr(addr, ':')) != NULL) {
>> +len = snprintf(hbuf, sizeof(hbuf),
>> +"%.*s", (int)(sep - addr), addr);
> I believe this code
On 22 Nov 2016, at 13:30, Dag-Erling Smørgrav wrote:
Author: des
Date: Tue Nov 22 13:30:07 2016
New Revision: 308996
URL: https://svnweb.freebsd.org/changeset/base/308996
Log:
Refactor fetch_connect() and fetch_bind() to improve readability and
avoid
repeating the same DNS lookups.
MFC
Dag-Erling Smørgrav writes:
> conn_t *
> fetch_connect(const char *host, int port, int af, int verbose)
> {
[...]
> + fetch_info("resolved");
Can you hide it behind "verbose" flag to avoid confusion?
$ pkg
The package management tool is not yet installed on your system.
Do you wan