Author: imp
Date: Sat Oct 15 06:16:35 2016
New Revision: 307339
URL: https://svnweb.freebsd.org/changeset/base/307339
Log:
Implement -t. Use symbolic names in place of the magical 0x7.
Submitted by: ambrisko@
Modified:
head/usr.sbin/efivar/efivar.c
Modified: head/usr.sbin/efivar/efivar.
Author: imp
Date: Sat Oct 15 05:53:09 2016
New Revision: 307338
URL: https://svnweb.freebsd.org/changeset/base/307338
Log:
Create a pcibios-version environment FORTH word. This allows one to
conditionally compile forth code before using the pcibios- words.
Modified:
head/sys/boot/i386/libi3
Author: pkelsey
Date: Sat Oct 15 01:41:28 2016
New Revision: 307337
URL: https://svnweb.freebsd.org/changeset/base/307337
Log:
Fix cases where the TFO pending counter would leak references, and
eventually, memory.
Also renamed some tfo labels and added/reworked comments for clarity.
B
Thanks!
Yes, that was clearly an error on my part, and your patch is an obvious
solution. I committed it at r307336.
Thanks again!
Jonathan
On Fri, Oct 14, 2016 at 8:01 PM, Shawn Webb
wrote:
> On Wed, Oct 12, 2016 at 02:16:42AM +, Jonathan T. Looney wrote:
> > Author: jtl
> > Date: Wed Oc
Author: jtl
Date: Sat Oct 15 00:29:15 2016
New Revision: 307336
URL: https://svnweb.freebsd.org/changeset/base/307336
Log:
r307082 added the TCP_HHOOK kernel option and made some existing code only
compile when that option is configured. In tcp_destroy(), the error
variable is now only used
On Wed, Oct 12, 2016 at 02:16:42AM +, Jonathan T. Looney wrote:
> Author: jtl
> Date: Wed Oct 12 02:16:42 2016
> New Revision: 307082
> URL: https://svnweb.freebsd.org/changeset/base/307082
>
> Log:
> In the TCP stack, the hhook(9) framework provides hooks for kernel modules
> to add actio
Author: gonzo
Date: Fri Oct 14 22:23:03 2016
New Revision: 307335
URL: https://svnweb.freebsd.org/changeset/base/307335
Log:
Make BRCM2837 port conform FreeBSD/ARM64 guidelines
- Rename SOC_BCM2837 to SOC_BRCM_BCM2837, put it to opt_soc.h
- do not use files.XXX files, just move required s
Author: andrew
Date: Fri Oct 14 22:20:14 2016
New Revision: 307334
URL: https://svnweb.freebsd.org/changeset/base/307334
Log:
Create macros for the MAIR memory attributes. While here add an uncached
memory type, however the VM code still needs to be taught about this.
MFC after:1 week
Author: jhb
Date: Fri Oct 14 21:51:50 2016
New Revision: 307333
URL: https://svnweb.freebsd.org/changeset/base/307333
Log:
Reprogram I/O APIC interrupt pins when registering an I/O APIC.
All I/O APIC pins are masked when an I/O APIC is first probed. The
APIC enumerator (MP Table or MADT)
Author: jhb
Date: Fri Oct 14 20:01:07 2016
New Revision: 307332
URL: https://svnweb.freebsd.org/changeset/base/307332
Log:
Drop support for using mmap() with /dev/kmem.
Using the device pager with /dev/kmem is not stable since KVA mappings
are transient, but the device pager caches the PA
On Fri, 14 Oct 2016 20:55:30 +0200 Dimitry Andric wrote:
> On 14 Oct 2016, at 04:06, Ed Maste wrote:
>> On 14 October 2016 at 01:53, Bruce Evans wrote:
compiler-rt's complex division support routines contain calls to
compiler builtins such as `__builtin_scalbnl`. Unfortunately Clang
On 14 Oct 2016, at 04:06, Ed Maste wrote:
>
> Hi Bruce, thank you for the detailed response.
>
> On 14 October 2016 at 01:53, Bruce Evans wrote:
>>> compiler-rt's complex division support routines contain calls to
>>> compiler builtins such as `__builtin_scalbnl`. Unfortunately Clang
>>> turns
On Fri, Oct 14, 2016 at 12:25:54PM -0600, Warner Losh wrote:
|On Oct 14, 2016 11:55 AM, "Doug Ambrisko" <[1]ambri...@ambrisko.com>
|wrote:
|>
|> On Fri, Oct 14, 2016 at 10:33:15AM -0700, Ravi Pokala wrote:
|> | -Original Message-
|> | > From: <[2]owner-src-committ...
On Oct 14, 2016 11:55 AM, "Doug Ambrisko" wrote:
>
> On Fri, Oct 14, 2016 at 10:33:15AM -0700, Ravi Pokala wrote:
> | -Original Message-
> | > From: on behalf of Doug Ambrisko <
ambri...@ambrisko.com>
> | > Date: 2016-10-14, Friday at 10:27
> | > To: Warner Losh
> | > Cc: Doug Ambrisko ,
On Fri, Oct 14, 2016 at 10:33:15AM -0700, Ravi Pokala wrote:
| -Original Message-
| > From: on behalf of Doug Ambrisko
| > Date: 2016-10-14, Friday at 10:27
| > To: Warner Losh
| > Cc: Doug Ambrisko , src-committers
, "svn-src-...@freebsd.org"
, "svn-src-head@freebsd.org"
| > Subject
Author: gonzo
Date: Fri Oct 14 17:40:48 2016
New Revision: 307328
URL: https://svnweb.freebsd.org/changeset/base/307328
Log:
Remove redundant kern_clocksource.c. It is already in conf/files.arm64
Reported by: andrew
Modified:
head/sys/arm64/broadcom/bcm2837/files.bcm2837
Modified: head
-Original Message-
> From: on behalf of Doug Ambrisko
>
> Date: 2016-10-14, Friday at 10:27
> To: Warner Losh
> Cc: Doug Ambrisko , src-committers
> , "svn-src-...@freebsd.org"
> , "svn-src-head@freebsd.org"
>
> Subject: Re: svn commit: r307326 - head/sys/boot/efi/loader
>
> On Fri
On Fri, Oct 14, 2016 at 11:16:02AM -0600, Warner Losh wrote:
| Love the functionality, but don't like using the 'hint' namespace for
| this. Can we change it now before too many things depend on it? We had
| similar issues in ACPI and moved it to the 'acpi' space. Can we move
| this to the 'smbios'
> On Oct 14, 2016, at 1:37 AM, Andrew Turner wrote:
>
> On Fri, 14 Oct 2016 03:00:53 + (UTC)
> Oleksandr Tymoshenko wrote:
>
>> Author: gonzo
>> Date: Fri Oct 14 03:00:53 2016
>> New Revision: 307252
>> URL: https://svnweb.freebsd.org/changeset/base/307252
>>
>> Log:
>> Make bcm2835_mach
Author: sbruno
Date: Fri Oct 14 17:25:29 2016
New Revision: 307327
URL: https://svnweb.freebsd.org/changeset/base/307327
Log:
Update i386 build of loader.efi (but leave it disabled) so that we at
least build it now.
Reviewed by: emaste
Differential Revision:https://reviews.free
-Original Message-
> From: on behalf of Warner Losh
>
> Date: 2016-10-14, Friday at 10:16
> To: Doug Ambrisko
> Cc: src-committers , "svn-src-...@freebsd.org"
> , "svn-src-head@freebsd.org"
>
> Subject: Re: svn commit: r307326 - head/sys/boot/efi/loader
>
> Love the functionality,
> On Oct 14, 2016, at 1:31 AM, Andrew Turner wrote:
>
> On Fri, 14 Oct 2016 03:37:36 + (UTC)
> Oleksandr Tymoshenko mailto:go...@freebsd.org>> wrote:
>
>> Author: gonzo
>> Date: Fri Oct 14 03:37:35 2016
>> New Revision: 307257
>> URL: https://svnweb.freebsd.org/changeset/base/307257
>>
>>
Love the functionality, but don't like using the 'hint' namespace for
this. Can we change it now before too many things depend on it? We had
similar issues in ACPI and moved it to the 'acpi' space. Can we move
this to the 'smbios' space please?
The reason is that 'hint' is special and sometimes fi
Author: ambrisko
Date: Fri Oct 14 17:10:53 2016
New Revision: 307326
URL: https://svnweb.freebsd.org/changeset/base/307326
Log:
In UEFI mode expose the SMBIOS anchor base address via kenv so the kernel
etc. can find out where the SMBIOS entry point is located. In pure
UEFI mode the BIOS is
Author: emaste
Date: Fri Oct 14 17:04:07 2016
New Revision: 307325
URL: https://svnweb.freebsd.org/changeset/base/307325
Log:
Simplify logic for libproc and librtld_db in lib/Makefile
Modified:
head/lib/Makefile
Modified: head/lib/Makefile
Author: imp
Date: Fri Oct 14 16:23:05 2016
New Revision: 307323
URL: https://svnweb.freebsd.org/changeset/base/307323
Log:
Remove fetching of pInterp. Currently, there's no actual effect other
than to store the location of a forth word that is subsequently never
used. It was last used before
Author: imp
Date: Fri Oct 14 16:23:12 2016
New Revision: 307324
URL: https://svnweb.freebsd.org/changeset/base/307324
Log:
Create a new linker set, Xficl_compile_set which contains a list of
functions to call at the appropriate time to register new forth
words. In the past we've done this wi
Author: imp
Date: Fri Oct 14 16:05:44 2016
New Revision: 307322
URL: https://svnweb.freebsd.org/changeset/base/307322
Log:
The file /boot/boot.conf existed for the 3.0 release (r38764). It was
replaced by /boot/loader.rc for 3.1 (r42682). In May 2000, this was
documented as deprecated (r6194
Author: andrew
Date: Fri Oct 14 15:53:48 2016
New Revision: 307321
URL: https://svnweb.freebsd.org/changeset/base/307321
Log:
Rework how we store the VFP registers in the pcb. This will be used when
creating a floating-point context within the kernel without having to move
the stored values
Author: luigi
Date: Fri Oct 14 15:16:44 2016
New Revision: 307320
URL: https://svnweb.freebsd.org/changeset/base/307320
Log:
adjust picobsd script to work with HEAD
Modified:
head/release/picobsd/build/picobsd
Modified: head/release/picobsd/build/picobsd
=
Author: jtl
Date: Fri Oct 14 14:57:43 2016
New Revision: 307319
URL: https://svnweb.freebsd.org/changeset/base/307319
Log:
The code currently resets the keepalive timer each time a packet is
received on a TCP session that has entered the ESTABLISHED state. This
results in a lot of calls to r
On 14/10/2016 15:22, Alexander Motin wrote:
> On 14.10.2016 15:11, Andriy Gapon wrote:
>> On 14/10/2016 15:01, Alexander Motin wrote:
>>> Author: mav
>>> Date: Fri Oct 14 12:01:33 2016
>>> New Revision: 307317
>>> URL: https://svnweb.freebsd.org/changeset/base/307317
>>>
>>> Log:
>>> MFV r307313:
On 14/10/2016 5:01 AM, Alexander Motin wrote:
Author: mav
Date: Fri Oct 14 12:01:33 2016
New Revision: 307317
URL: https://svnweb.freebsd.org/changeset/base/307317
Log:
MFV r307313:
5120 zfs should allow large block/gzip/raidz boot pool (loader project)
Reviewed by: George Wilson
On 14.10.2016 15:11, Andriy Gapon wrote:
> On 14/10/2016 15:01, Alexander Motin wrote:
>> Author: mav
>> Date: Fri Oct 14 12:01:33 2016
>> New Revision: 307317
>> URL: https://svnweb.freebsd.org/changeset/base/307317
>>
>> Log:
>> MFV r307313:
>> 5120 zfs should allow large block/gzip/raidz boo
On 14/10/2016 15:01, Alexander Motin wrote:
> Author: mav
> Date: Fri Oct 14 12:01:33 2016
> New Revision: 307317
> URL: https://svnweb.freebsd.org/changeset/base/307317
>
> Log:
> MFV r307313:
> 5120 zfs should allow large block/gzip/raidz boot pool (loader project)
>
> Reviewed by: Geor
Author: mav
Date: Fri Oct 14 12:03:04 2016
New Revision: 307318
URL: https://svnweb.freebsd.org/changeset/base/307318
Log:
MFV r307314:
6988 spa_sync() spends half its time in dmu_objset_do_userquota_updates
Using a benchmark which creates 2 million files in one TXG, I observe
that the
Author: mav
Date: Fri Oct 14 12:01:33 2016
New Revision: 307317
URL: https://svnweb.freebsd.org/changeset/base/307317
Log:
MFV r307313:
5120 zfs should allow large block/gzip/raidz boot pool (loader project)
Reviewed by: George Wilson
Reviewed by: Yuri Pankov
Reviewed by: Andrew Sto
Author: bapt
Date: Fri Oct 14 11:57:08 2016
New Revision: 307316
URL: https://svnweb.freebsd.org/changeset/base/307316
Log:
Fix build WITHOUT_FORTH
MFC after:1 week
Sponsored by: Gandi.net
Modified:
head/sys/boot/userboot/userboot/Makefile
Modified: head/sys/boot/userboot/userboot
On Fri, 14 Oct 2016 03:00:53 + (UTC)
Oleksandr Tymoshenko wrote:
> Author: gonzo
> Date: Fri Oct 14 03:00:53 2016
> New Revision: 307252
> URL: https://svnweb.freebsd.org/changeset/base/307252
>
> Log:
> Make bcm2835_machdep.c optional
>
> bcm2835_machdep.c contains only bits enabled
On Fri, 14 Oct 2016 03:37:36 + (UTC)
Oleksandr Tymoshenko wrote:
> Author: gonzo
> Date: Fri Oct 14 03:37:35 2016
> New Revision: 307257
> URL: https://svnweb.freebsd.org/changeset/base/307257
>
> Log:
> Add initial Raspberry Pi 3 support
>
> RPI3 kernel config builds kernel compatibl
This work was done by franco_opnsense.org
I forgot to credit him in the commit message. Sorry Franco.
Regards,
Kristof
On 13 Oct 2016, at 22:34, Kristof Provost wrote:
Author: kp
Date: Thu Oct 13 20:34:44 2016
New Revision: 307235
URL: https://svnweb.freebsd.org/changeset/base/307235
Log:
p
41 matches
Mail list logo