Author: ngie
Date: Thu Oct 23 06:42:53 2014
New Revision: 273525
URL: https://svnweb.freebsd.org/changeset/base/273525
Log:
Port t_mmap.c to FreeBSD
- Add needed headers for the testcases
- Omit mmap_block on non-NetBSD OSes
- Use "security.bsd.map_at_zero" instead of "vm.user_va0_disab
Author: ngie
Date: Thu Oct 23 06:35:19 2014
New Revision: 273524
URL: https://svnweb.freebsd.org/changeset/base/273524
Log:
Add sys/socket.h #include for struct sockaddr_in
Sponsored by: EMC / Isilon Storage Division
Modified:
head/contrib/netbsd-tests/lib/libc/sys/t_listen.c
Modified:
Author: ngie
Date: Thu Oct 23 06:25:52 2014
New Revision: 273523
URL: https://svnweb.freebsd.org/changeset/base/273523
Log:
Add limits.h #include for LINE_MAX
Sponsored by: EMC / Isilon Storage Division
Modified:
head/contrib/netbsd-tests/lib/libc/sys/t_link.c
Modified: head/contrib/net
Author: ngie
Date: Thu Oct 23 06:24:36 2014
New Revision: 273522
URL: https://svnweb.freebsd.org/changeset/base/273522
Log:
- Mark unused parameters __unused in handler
- Call sigqueue with getpid() instead of 0 -- the latter idiom appears to only
be valid on NetBSD
In collaboration wit
Author: ngie
Date: Thu Oct 23 06:21:10 2014
New Revision: 273521
URL: https://svnweb.freebsd.org/changeset/base/273521
Log:
Convert "fcntl(n, F_CLOSEM)" to "closefrom(n)"
Submitted by: pho
Sponsored by: EMC / Isilon Storage Division
Modified:
head/contrib/netbsd-tests/lib/libc/sys/t_so
Author: ngie
Date: Thu Oct 23 06:18:28 2014
New Revision: 273520
URL: https://svnweb.freebsd.org/changeset/base/273520
Log:
Port t_pipe2.c to FreeBSD
- Omit the pipe2_nosigpipe testcase on FreeBSD (FreeBSD doesn't have
O_NOSIGPIPE).
- Convert "fcntl(n, F_CLOSEM)" to "closefrom(n)".
Author: ngie
Date: Thu Oct 23 05:58:02 2014
New Revision: 273517
URL: https://svnweb.freebsd.org/changeset/base/273517
Log:
Expect getgroups_err to fail on FreeBSD
PR: 189941
Submitted by: pho
Sponsored by: EMC / Isilon Storage Division
Modified:
head/contrib/netbsd-tests/lib/libc/sy
Author: ngie
Date: Thu Oct 23 05:46:10 2014
New Revision: 273516
URL: https://svnweb.freebsd.org/changeset/base/273516
Log:
Add netinet/in.h for struct sockaddr_in
Sponsored by: EMC / Isilon Storage Division
Modified:
head/contrib/netbsd-tests/lib/libc/sys/t_stat.c
Modified: head/contri
Author: bryanv
Date: Thu Oct 23 04:47:32 2014
New Revision: 273515
URL: https://svnweb.freebsd.org/changeset/base/273515
Log:
Add VirtIO console driver
Support for the multiport feature is mostly implemented, but currently
disabled due to some potential races in the hot plug code paths.
Author: ian
Date: Thu Oct 23 03:13:14 2014
New Revision: 273514
URL: https://svnweb.freebsd.org/changeset/base/273514
Log:
Unconditionally enable the clocks for all imx6 devices that we have drivers
for, or that are required to run the chip (such as busses). Turn off all
the devices we don'
2003, 2004, 2006 Matthew R. Green
@@ -158,7 +158,7 @@ static suffixes_t suffixes[] = {
#define NUM_SUFFIXES (sizeof suffixes / sizeof suffixes[0])
#define SUFFIX_MAXLEN 30
-static const char gzip_version[] = "FreeBSD gzip 20111009";
+static const char gzip_version[] = "
Author: delphij
Date: Thu Oct 23 00:40:56 2014
New Revision: 273498
URL: https://svnweb.freebsd.org/changeset/base/273498
Log:
MFV r273494: xz 5.0.7.
MFC after:2 weeks
Modified:
head/contrib/xz/ChangeLog
head/contrib/xz/THANKS
head/contrib/xz/TODO
head/contrib/xz/src/liblzma/ap
Author: delphij
Date: Thu Oct 23 00:31:26 2014
New Revision: 273493
URL: https://svnweb.freebsd.org/changeset/base/273493
Log:
MFV r273492: remove gettext files.
Deleted:
head/contrib/xz/po/
Modified:
head/contrib/xz/FREEBSD-Xlist
Directory Properties:
head/contrib/xz/ (props changed)
On 10/22/14 16:35, Colin Percival wrote:
> Author: cperciva
> Date: Wed Oct 22 23:35:32 2014
> New Revision: 273487
> URL: https://svnweb.freebsd.org/changeset/base/273487
>
> Log:
> Avoid leaking data from the kernel environment: When we convert the
> initial static environment to a dynamic o
Author: cperciva
Date: Wed Oct 22 23:41:15 2014
New Revision: 273489
URL: https://svnweb.freebsd.org/changeset/base/273489
Log:
Populate the GELI passphrase cache with the kern.geom.eli.passphrase
variable (if any) provided in the boot environment. Unset it from
the kernel environment after
Author: markj
Date: Wed Oct 22 23:35:56 2014
New Revision: 273488
URL: https://svnweb.freebsd.org/changeset/base/273488
Log:
Fix some buglets in the error-handling of getdevice(). In particular, report
an error if the argument to pciconf -a doesn't have a unit number, rather
than triggering
Author: cperciva
Date: Wed Oct 22 23:35:32 2014
New Revision: 273487
URL: https://svnweb.freebsd.org/changeset/base/273487
Log:
Avoid leaking data from the kernel environment: When we convert the
initial static environment to a dynamic one, zero the static environment
buffer, and zero indivi
On 22 October 2014 16:47, Rick Macklem wrote:
> Author: rmacklem
> Date: Wed Oct 22 20:47:11 2014
> New Revision: 273481
> URL: https://svnweb.freebsd.org/changeset/base/273481
>
> Log:
> Clip the settings for the NFS rsize, wsize mount options
> to a power of 2.
For what it's worth, I fixed
Author: rmacklem
Date: Wed Oct 22 22:27:51 2014
New Revision: 273486
URL: https://svnweb.freebsd.org/changeset/base/273486
Log:
Clip the settings for the NFS rsize, wsize mount options
to a power of 2. For non-power of 2 settings, intermittent
page faults have been reported. Although the bug
Author: rmacklem
Date: Wed Oct 22 21:57:35 2014
New Revision: 273485
URL: https://svnweb.freebsd.org/changeset/base/273485
Log:
Revert r273481 so it can be recoded using fls(), which
some feel will make it more readable.
Modified:
head/sys/fs/nfsclient/nfs_clvfsops.c
Modified: head/sys/fs/
Author: melifaro
Date: Wed Oct 22 21:20:37 2014
New Revision: 273483
URL: https://svnweb.freebsd.org/changeset/base/273483
Log:
Rename log2 to tal_log2.
Submitted by: luigi
Modified:
head/sys/netpfil/ipfw/ip_fw_table_algo.c
Modified: head/sys/netpfil/ipfw/ip_fw_table_algo.c
Author: ngie
Date: Wed Oct 22 21:04:54 2014
New Revision: 273482
URL: https://svnweb.freebsd.org/changeset/base/273482
Log:
The NetBSD libc tests use several definitions/macros that aren't available in
FreeBSD
Add the missing compat definitions/macros to lib/libnetbsd so the testcases
c
Author: rmacklem
Date: Wed Oct 22 20:47:11 2014
New Revision: 273481
URL: https://svnweb.freebsd.org/changeset/base/273481
Log:
Clip the settings for the NFS rsize, wsize mount options
to a power of 2. For non-power of 2 settings, intermittent
page faults have been reported. Although the bug
Author: np
Date: Wed Oct 22 18:55:44 2014
New Revision: 273480
URL: https://svnweb.freebsd.org/changeset/base/273480
Log:
cxgbe/iw_cxgbe: wake up waiters after flushing the qp.
Obtained from:Chelsio
Modified:
head/sys/dev/cxgbe/iw_cxgbe/qp.c
Modified: head/sys/dev/cxgbe/iw_cxgbe
Author: luigi
Date: Wed Oct 22 18:55:36 2014
New Revision: 273479
URL: https://svnweb.freebsd.org/changeset/base/273479
Log:
since we cast a pointer, use the correct signedness
(this was already in, and got lost in a recent update).
Modified:
head/sys/net/radix.c
Modified: head/sys/net/rad
Author: ngie
Date: Wed Oct 22 18:11:10 2014
New Revision: 273478
URL: https://svnweb.freebsd.org/changeset/base/273478
Log:
Fix linking static test binaries with atf.test.mk
Check for -static in LDFLAGS or LDFLAGS., then pass in the appropriate
dependency (LIBATF or LDATF)
This unbre
Author: royger
Date: Wed Oct 22 17:09:12 2014
New Revision: 273477
URL: https://svnweb.freebsd.org/changeset/base/273477
Log:
netback: change xnb naming convention
Current FreeBSD netback names the interface with xnb, but
this is not suitable for usage with the Xen toolstack, which expect
Author: royger
Date: Wed Oct 22 17:07:20 2014
New Revision: 273476
URL: https://svnweb.freebsd.org/changeset/base/273476
Log:
xen: implement the privcmd user-space device
This device is only attached to priviledged domains, and allows the
toolstack to interact with Xen. The two functions
Author: royger
Date: Wed Oct 22 16:58:52 2014
New Revision: 273475
URL: https://svnweb.freebsd.org/changeset/base/273475
Log:
xen: add a Xen to BSD error translation
Since Xen and FreeBSD error codes are completely different add a
translation layer in order to convert Xen error codes into
Author: royger
Date: Wed Oct 22 16:57:11 2014
New Revision: 273474
URL: https://svnweb.freebsd.org/changeset/base/273474
Log:
xen: import a proper event channel user-space device
The user-space event channel device is used by applications to receive
and send event channel interrupts. This
Author: royger
Date: Wed Oct 22 16:51:52 2014
New Revision: 273473
URL: https://svnweb.freebsd.org/changeset/base/273473
Log:
xen: allow to register event channels without handlers
This is needed by the event channel user-space device, that requires
registering event channels without unma
Author: royger
Date: Wed Oct 22 16:49:00 2014
New Revision: 273472
URL: https://svnweb.freebsd.org/changeset/base/273472
Log:
xen: fix usage of kern_getenv in PVH code
The value returned by kern_getenv should be freed using freeenv.
Reported by: Coverity
CID: 1248852
Spon
On Oct 22, 2014, at 9:00 AM, Benjamin Kaduk wrote:
> On Wed, Oct 22, 2014 at 10:57 AM, Dag-Erling Smørgrav wrote:
> Is _SUPPORT magic? I didn't know. I guess MK_TESTS_SUPPORT is good
> enough, especially if it's on by default.
>
> Even if it is magic, is that really the kind of magic we want
On Oct 22, 2014, at 8:57 AM, Dag-Erling Smørgrav wrote:
> Warner Losh writes:
>> Dag-Erling Smørgrav writes:
>>> I would prefer calling this MK_ATF than MK_TESTS_SUPPORT, though.
>>> The test framework is probably useful on its own.
>> That would be a nicer name, but then we’d lose the automat
On Wed, Oct 22, 2014 at 11:34 AM, Ian Lepore wrote:
> On Wed, 2014-10-22 at 11:00 -0400, Benjamin Kaduk wrote:
> > On Wed, Oct 22, 2014 at 10:57 AM, Dag-Erling Smørgrav
> wrote:
> >
> > > Is _SUPPORT magic? I didn't know. I guess MK_TESTS_SUPPORT is good
> > > enough, especially if it's on by
On Wed, 2014-10-22 at 11:00 -0400, Benjamin Kaduk wrote:
> On Wed, Oct 22, 2014 at 10:57 AM, Dag-Erling Smørgrav wrote:
>
> > Is _SUPPORT magic? I didn't know. I guess MK_TESTS_SUPPORT is good
> > enough, especially if it's on by default.
>
>
> Even if it is magic, is that really the kind of
On Wed, Oct 22, 2014 at 10:57 AM, Dag-Erling Smørgrav wrote:
> Is _SUPPORT magic? I didn't know. I guess MK_TESTS_SUPPORT is good
> enough, especially if it's on by default.
Even if it is magic, is that really the kind of magic we want to be keeping
around?
-Ben
_
Warner Losh writes:
> Dag-Erling Smørgrav writes:
> > I would prefer calling this MK_ATF than MK_TESTS_SUPPORT, though.
> > The test framework is probably useful on its own.
> That would be a nicer name, but then we’d lose the automatic setting
> when MK_TESTS is enabled (unless we add another sp
On Oct 22, 2014, at 3:48 AM, Dag-Erling Smørgrav wrote:
> Warner Losh writes:
>> I’ll fix this. I think we need to have a MK_TESTS_SUPPORT that builds
>> the libatf stuff when yes, and omits it when no, since we don’t want
>> the tests building when we’re building the 4.3 stage.
>
> I agree, b
Author: trasz
Date: Wed Oct 22 11:30:56 2014
New Revision: 273470
URL: https://svnweb.freebsd.org/changeset/base/273470
Log:
Fix ctl.conf example to use proper paths to ZVOLs.
Sponsored by: The FreeBSD Foundation
Modified:
head/usr.sbin/ctld/ctl.conf.5
Modified: head/usr.sbin/ctld/ctl.c
Author: br
Date: Wed Oct 22 11:30:03 2014
New Revision: 273469
URL: https://svnweb.freebsd.org/changeset/base/273469
Log:
Provide a character device allowing us to access BERI memory regions.
Sponsored by: DARPA, AFRL
Added:
head/sys/dev/beri/beri_mem.c (contents, props changed)
Modifi
Author: trasz
Date: Wed Oct 22 11:09:03 2014
New Revision: 273468
URL: https://svnweb.freebsd.org/changeset/base/273468
Log:
Remove misleading statement. Bump date.
MFC after:1 month
Sponsored by: FreeBSD Foundation
Modified:
head/usr.sbin/ctld/ctl.conf.5
Modified: head/usr.sbin/
Author: trasz
Date: Wed Oct 22 11:06:05 2014
New Revision: 273467
URL: https://svnweb.freebsd.org/changeset/base/273467
Log:
Comment out parts about iSER; it's not implemented.
Sponsored by: The FreeBSD Foundation
Modified:
head/usr.sbin/ctld/ctl.conf.5
Modified: head/usr.sbin/ctld/ctl.
Author: trasz
Date: Wed Oct 22 10:53:25 2014
New Revision: 273466
URL: https://svnweb.freebsd.org/changeset/base/273466
Log:
Remove spurious empty line.
MFC after:1 month
Sponsored by: The FreeBSD Foundation
Modified:
head/usr.sbin/ctld/ctl.conf.5
Modified: head/usr.sbin/ctld/ctl.
On Tue, Oct 21, 2014 at 6:56 PM, Garrett Cooper wrote:
> Modified: head/contrib/netbsd-tests/lib/libc/gen/t_siginfo.c
> ==
> --- head/contrib/netbsd-tests/lib/libc/gen/t_siginfo.c Tue Oct 21 17:17:40
> 2014(r2733
Warner Losh writes:
> I’ll fix this. I think we need to have a MK_TESTS_SUPPORT that builds
> the libatf stuff when yes, and omits it when no, since we don’t want
> the tests building when we’re building the 4.3 stage.
I agree, bundling everything under MK_TESTS does not make much sense.
Automake
Author: trasz
Date: Wed Oct 22 09:40:46 2014
New Revision: 273465
URL: https://svnweb.freebsd.org/changeset/base/273465
Log:
Fix ctld(8) to not show the "auth-group not assigned to any target"
warning for auth-groups assigned to a portal-group.
MFC after:1 month
Sponsored by: The F
Author: trasz
Date: Wed Oct 22 09:17:17 2014
New Revision: 273464
URL: https://svnweb.freebsd.org/changeset/base/273464
Log:
Whitespace fixes.
MFC after:1 month
Sponsored by: The FreeBSD Foundation
Modified:
head/usr.bin/iscsictl/Makefile
head/usr.bin/iscsictl/iscsictl.c
head/u
Author: trasz
Date: Wed Oct 22 08:59:23 2014
New Revision: 273459
URL: https://svnweb.freebsd.org/changeset/base/273459
Log:
Untangle iSCSI authentication code by splitting off the CHAP
implementation.
Reviewed by: mav@
MFC after:1 month
Sponsored by: The FreeBSD Foundation
Adde
On Wed, Oct 22, 2014 at 11:41:38AM +0300, Konstantin Belousov wrote:
> On Wed, Oct 22, 2014 at 10:26:21AM +0200, Mateusz Guzik wrote:
> > On Wed, Oct 22, 2014 at 10:51:31AM +0300, Konstantin Belousov wrote:
> > > On Wed, Oct 22, 2014 at 12:23:44AM +, Mateusz Guzik wrote:
> > > > Author: mjg
> >
Author: mjg
Date: Wed Oct 22 08:56:57 2014
New Revision: 273458
URL: https://svnweb.freebsd.org/changeset/base/273458
Log:
filedesc assert that table size is at least 3 in fdsetugidsafety
Requested by: kib
Modified:
head/sys/kern/kern_descrip.c
Modified: head/sys/kern/kern_descrip.c
===
Author: mav
Date: Wed Oct 22 08:54:10 2014
New Revision: 273457
URL: https://svnweb.freebsd.org/changeset/base/273457
Log:
Document sort_io_queue sysctls/tunables.
MFC after:1 week
Modified:
head/share/man/man4/ada.4
head/share/man/man4/da.4
Modified: head/share/man/man4/ada.4
===
On Wed, Oct 22, 2014 at 10:26:21AM +0200, Mateusz Guzik wrote:
> On Wed, Oct 22, 2014 at 10:51:31AM +0300, Konstantin Belousov wrote:
> > On Wed, Oct 22, 2014 at 12:23:44AM +, Mateusz Guzik wrote:
> > > Author: mjg
> > > Date: Wed Oct 22 00:23:43 2014
> > > New Revision: 273441
> > > URL: https
On Wed, Oct 22, 2014 at 10:51:31AM +0300, Konstantin Belousov wrote:
> On Wed, Oct 22, 2014 at 12:23:44AM +, Mateusz Guzik wrote:
> > Author: mjg
> > Date: Wed Oct 22 00:23:43 2014
> > New Revision: 273441
> > URL: https://svnweb.freebsd.org/changeset/base/273441
> >
> > Log:
> > filedesc: c
On Wed, Oct 22, 2014 at 12:23:44AM +, Mateusz Guzik wrote:
> Author: mjg
> Date: Wed Oct 22 00:23:43 2014
> New Revision: 273441
> URL: https://svnweb.freebsd.org/changeset/base/273441
>
> Log:
> filedesc: cleanup setugidsafety a little
>
> Rename it to fdsetugidsafety for consistency w
Author: hselasky
Date: Wed Oct 22 07:50:19 2014
New Revision: 273456
URL: https://svnweb.freebsd.org/changeset/base/273456
Log:
Actually change the USB_PORT_ROOT_RESET_DELAY definition as stated in
the r241987 commit message, instead of having users locally overriding
the value using tunable
Author: hselasky
Date: Wed Oct 22 07:16:46 2014
New Revision: 273455
URL: https://svnweb.freebsd.org/changeset/base/273455
Log:
Allow overspecification of SYSCTL type in external kernel modules.
PR: 194523
MFC after:3 days
Modified:
head/sys/sys/sysctl.h
Modified: head/s
57 matches
Mail list logo