On Tue, May 03, 2011 at 01:53:20AM +0200, Marc-André Lureau wrote:
> We have these various channel types for main_channel_foo()
> argument/return value, would be nice to make some changes:
>
The main reasons for using RedChannelClient in those few apis (net_start
and ping) is that they are used f
We have these various channel types for main_channel_foo()
argument/return value, would be nice to make some changes:
- Channel *main_channel_init()
reds->main_channel_factory = main_channel_init();
Should we rename main_channel_init() to main_channel_factory_new()?
and perhaps rename Channel to
use MainChannel* instead of Channel* for a many functions in main_channel.h
(affects main_channel.c and reds.c).
some one liner fixes are hidden in here too.
---
server/main_channel.c | 124
server/main_channel.h | 42 +---
server/re