ng it one by one.
>
> Colleagues, I'd like to graciously ping regarding this series. Should it
> be merged as is (possibly requiring more R-B's)? Or should I rework it
> adding something like .mode_valid_new() callback which takes const
> argument?
I think your p
On Fri, 21 Jun 2024 15:10:31 +0800, Chen Ni wrote:
> Add check for the return value of drm_cvt_mode() and return the error if
> it fails in order to avoid NULL pointer dereference.
>
>
Applied to misc/kernel.git (drm-misc-next).
Thanks!
Maxime
On Thu, 04 Apr 2024 19:14:48 +0100, Alex Constantino wrote:
> This reverts commit 5a838e5d5825c85556011478abde708251cc0776.
>
> Changes from commit 5a838e5d5825 ("drm/qxl: simplify qxl_fence_wait") would
> result in a '[TTM] Buffer eviction failed' exception whenever it reached a
> timeout.
> Due
On Wed, Mar 27, 2024 at 07:14:12PM +0100, Miguel Ojeda wrote:
> On Wed, Mar 27, 2024 at 6:56 PM Miguel Ojeda wrote:
> >
> > Closes:
> > https://lore.kernel.org/lkml/caniq72mjc5t4n25sqvysroehxxpxypz4ppznesjhenc3qap...@mail.gmail.com/
>
> Should have a [1] at the end.
I added it while committing
Hi,
On Wed, Mar 20, 2024 at 04:25:48PM +0100, Linux regression tracking (Thorsten
Leemhuis) wrote:
> On 08.03.24 02:08, Alex Constantino wrote:
> > Fix OOM scenario by doing multiple notifications to the OOM handler through
> > a busy wait logic.
> > Changes from commit 5a838e5d5825 ("drm/qxl: si
Hi Miguel,
On Tue, Mar 26, 2024 at 07:04:34PM +0100, Miguel Ojeda wrote:
> Hi,
>
> In today's next, I got:
>
> drivers/gpu/drm/qxl/qxl_cmd.c:424:6: error: variable 'count' set
> but not used [-Werror,-Wunused-but-set-variable]
>
> `count` seems to be there since commit f64122c1f6ad ("drm: a
On Fri, 10 Nov 2023 13:50:31 +0800, heminhong wrote:
> Some functions are never used by the driver,
> removing the functions declaration, it can be reducing program size,
> and improving code readability and maintainability.
>
>
Applied to drm/drm-misc (drm-misc-next).
Thanks!
Maxime
On Tue, 01 Aug 2023 10:53:09 +0800, Zongmin Zhou wrote:
> The allocated memory for qdev->dumb_heads should be released
> in qxl_destroy_monitors_object before qxl suspend.
> otherwise,qxl_create_monitors_object will be called to
> reallocate memory for qdev->dumb_heads after qxl resume,
> it will c
e cleanly powered off at system shutdown time.
>
>
> [ ... ]
Acked-by: Maxime Ripard
Thanks!
Maxime
On Thu, Jul 13, 2023 at 04:14:55PM +0100, Tvrtko Ursulin wrote:
>
> On 13/07/2023 16:09, Thomas Zimmermann wrote:
> > Hi
> >
> > Am 13.07.23 um 16:41 schrieb Sean Paul:
> > > On Thu, Jul 13, 2023 at 9:04 AM Uwe Kleine-König
> > > wrote:
> > > >
> > > > hello Sean,
> > > >
> > > > On Wed, Jul 1
On Wed, Jul 12, 2023 at 03:38:03PM +0200, Uwe Kleine-König wrote:
> Hello Maxime,
>
> On Wed, Jul 12, 2023 at 02:52:38PM +0200, Maxime Ripard wrote:
> > On Wed, Jul 12, 2023 at 01:02:53PM +0200, Uwe Kleine-König wrote:
> > > > Background is that this makes merge con
On Wed, Jul 12, 2023 at 01:02:53PM +0200, Uwe Kleine-König wrote:
> > Background is that this makes merge conflicts easier to handle and detect.
>
> Really?
FWIW, I agree with Christian here.
> Each file (apart from include/drm/drm_crtc.h) is only touched once. So
> unless I'm missing something
On Tue, Apr 06, 2021 at 10:29:38AM +0200, Thomas Zimmermann wrote:
> The implementation of drm_driver.dumb_map_offset is the same for several
> TTM-based drivers. Provide a common function in GEM-TTM helpers.
For the series:
Acked-by: Maxime Ripard
Maxime
signature.asc
Descriptio
old_s;
@@
func(struct drm_plane *plane, struct drm_plane_state *old_s)
{
+ struct drm_plane_state *new_s = plane->state;
<+...
- plane->state
+ new_s
...+>
}
Reviewed-by: Laurent Pinchart
Signed-off-by: Maxime Ripard
---
Changes from v1:
- Wrappin
de
@ no_include depends on !include && adds_new_state @
@@
+ #include
#include
Reviewed-by: Laurent Pinchart
Signed-off-by: Maxime Ripard
---
Changes from v1:
- Rewording and removal of a coccinelle rule suggested by Laurent
---
drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_d
Reviewed-by: Ville Syrjälä
Signed-off-by: Maxime Ripard
---
drivers/gpu/drm/arc/arcpgu_crtc.c | 4 +++-
drivers/gpu/drm/arm/hdlcd_crtc.c| 3 ++-
drivers/gpu/drm/arm/malidp_planes.c | 3 ++-
drivers/gpu/drm/armada/armada_overlay.c | 3 ++-
drivers/
Hi Thomas,
Thanks for your review!
On Fri, Feb 19, 2021 at 03:49:22PM +0100, Thomas Zimmermann wrote:
> > diff --git a/drivers/gpu/drm/imx/ipuv3-plane.c
> > b/drivers/gpu/drm/imx/ipuv3-plane.c
> > index 075508051b5f..1873a155bb26 100644
> > --- a/drivers/gpu/drm/imx/ipuv3-plane.c
> > +++ b/drive
;
}
Reviewed-by: Laurent Pinchart
Signed-off-by: Maxime Ripard
---
Changes from v1:
- Updated the variable name in the comment in omapdrm
---
.../gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 13 +++---
.../gpu/drm/arm/display/komeda/komeda_plane.c | 11 ++---
drivers/gpu/drm/arm/hdlcd_crtc.c
->state
+ state
...+>
}
Reviewed-by: Laurent Pinchart
Signed-off-by: Maxime Ripard
---
Changes from v1:
- Reintroduce the old_plane_state check in zynqmp_disp_crtc_atomic_disable
---
drivers/gpu/drm/arc/arcpgu_crtc.c | 2 +-
drivers/gpu/drm/arm/disp
te->state
+ state
...+>
}
Signed-off-by: Maxime Ripard
---
Changes from v1:
- Reintroduce the old_plane_state check in zynqmp_disp_crtc_atomic_disable
---
drivers/gpu/drm/arc/arcpgu_crtc.c | 2 +-
drivers/gpu/drm/arm/display/komeda/komeda_plane.c | 2 +-
Signed-off-by: Maxime Ripard
---
drivers/gpu/drm/arc/arcpgu_crtc.c | 4 +++-
drivers/gpu/drm/arm/hdlcd_crtc.c| 3 ++-
drivers/gpu/drm/arm/malidp_planes.c | 3 ++-
drivers/gpu/drm/armada/armada_overlay.c | 3 ++-
drivers/gpu/drm/armada/armada_plane.c
old_s;
@@
func(struct drm_plane *plane, struct drm_plane_state *old_s)
{
+ struct drm_plane_state *new_s = plane->state;
<+...
- plane->state
+ new_s
...+>
}
Reviewed-by: Laurent Pinchart
Signed-off-by: Maxime Ripard
---
Changes from v1:
- Wrappin
;
}
Reviewed-by: Laurent Pinchart
Signed-off-by: Maxime Ripard
---
Changes from v1:
- Updated the variable name in the comment in omapdrm
---
.../gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 13 +++---
.../gpu/drm/arm/display/komeda/komeda_plane.c | 11 ++---
drivers/gpu/drm/arm/hdlcd_crtc.c
de
@ no_include depends on !include && adds_new_state @
@@
+ #include
#include
Reviewed-by: Laurent Pinchart
Signed-off-by: Maxime Ripard
---
Changes from v1:
- Rewording and removal of a coccinelle rule suggested by Laurent
---
drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_d
lt;+...
- plane_state->state
+ state
...+>
}
Signed-off-by: Maxime Ripard
---
drivers/gpu/drm/arc/arcpgu_crtc.c | 2 +-
.../gpu/drm/arm/display/komeda/komeda_plane.c | 2 +-
drivers/gpu/drm/arm/hdlcd_crtc.c | 2 +-
drivers/gpu/drm/arm/malidp_planes.c
Signed-off-by: Maxime Ripard
---
drivers/gpu/drm/arc/arcpgu_crtc.c | 4 +++-
drivers/gpu/drm/arm/hdlcd_crtc.c| 3 ++-
drivers/gpu/drm/arm/malidp_planes.c | 3 ++-
drivers/gpu/drm/armada/armada_overlay.c | 3 ++-
drivers/gpu/drm/armada/armada_plane.c
}
Signed-off-by: Maxime Ripard
---
.../gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 13 +++---
.../gpu/drm/arm/display/komeda/komeda_plane.c | 11 ++---
drivers/gpu/drm/arm/hdlcd_crtc.c | 18
drivers/gpu/drm/arm/malidp_planes.c | 36
drive
s on !include && adds_new_state @
@@
+ #include
#include
Signed-off-by: Maxime Ripard
---
drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 4 +++-
drivers/gpu/drm/arm/display/komeda/komeda_plane.c | 4 +++-
drivers/gpu/drm/arm/hdlcd_crtc.c | 4 +++-
drivers/gpu/dr
old_s;
@@
func(struct drm_plane *plane, struct drm_plane_state *old_s)
{
+ struct drm_plane_state *new_s = plane->state;
<+...
- plane->state
+ new_s
...+>
}
Signed-off-by: Maxime Ripard
---
drivers/gpu/drm/arc/arcpgu_crtc.c | 7 ++-
29 matches
Mail list logo