Some graphics APIs differentiate between out-of-graphics-memory and
out-of-host-memory (system memory). Add a device init flag to
have -ENOSPC propagated from the resource managers instead of being
converted to -ENOMEM, to aid driver stacks in determining what
error code to return or whether correc
The ttm_device_init funcition uses multiple bool arguments. That means
readability in the caller becomes poor, and all callers need to change if
yet another bool is added.
Instead use a struct with multiple single-bit flags. This addresses both
problems. Prefer it over using defines or enums with
Some graphics APIs differentiate between out-of-graphics-memory and
out-of-host-memory (system memory). Add a device init flag to
have -ENOSPC propagated from the resource managers instead of being
converted to -ENOMEM, to aid driver stacks in determining what
error code to return or whether correc
Hi,
thank you very much for your reply. Of course I understand that
non-compiling/crashing code should not be merged into main.
Unfortunately I have not been able to reproduce this so far. Here's a
list of the systems I have tested on:
- Ubuntu server 20.04 LTS
AMD EPYC 7742
Intel Flex 14