On 17/05/18 18:15, Jonathon Jongsma wrote:
> Fine with me.
>
Thanks, I fixed a typo in header before pushing.
s/spice_marshalller_intem_free_func/spice_marshaller_item_free_func
> Acked-by: Jonathon Jongsma
>
>
> On Thu, 2018-05-17 at 12:56 -0300, Eduardo Lima (Etrunko) wrote:
>> Building w
Fine with me.
Acked-by: Jonathon Jongsma
On Thu, 2018-05-17 at 12:56 -0300, Eduardo Lima (Etrunko) wrote:
> Building with gcc 8.0.1 from Fedora 28 gives the following error:
>
> FAILED: common/common@@spice-common@sta/marshaller.c.o
> ../common/marshaller.c: In function 'spice_marshaller_reser
On Wed, 2018-05-16 at 11:52 +0200, Christophe de Dinechin wrote:
> >
> >
> > save_errno as proposed or err_no ?
>
> :-) [Note to Jonathon: wouldn't this be read as "err… no!" ???]
>
No, not really ;)
I don't really feel strongly about any of the options here.
Jonathon
_
Even though commit df4ec5c3186e796624e4bbf2dc4a269faf2823f6 commented
out most of smartcard code which triggered this error, it still might
happen if a new message is added with an array member.
The reason is a missing declaration of mem_size, which is fixed simply
by checking if the attribute 'no
On 17/05/18 14:08, Frediano Ziglio wrote:
>>
>> Even though commit df4ec5c3186e796624e4bbf2dc4a269faf2823f6 commented
>> out most of smartcard code which triggered this error, it still might
>> happen if a new message is added with an array member.
>>
>> The reason is a missing declaration of mem_s
>
> Even though commit df4ec5c3186e796624e4bbf2dc4a269faf2823f6 commented
> out most of smartcard code which triggered this error, it still might
> happen if a new message is added with an array member.
>
> The reason is a missing declaration of mem_size, which is fixed simply
> by checking if th
>
> Rename struct VSCMsgReaderAdd field 'reader_name' to 'name', and struct
> VSCMsgATR field 'data' to 'atr' to match their definitions in file
> vscard_common.h.
>
> The error log follows:
>
> generated_server_demarshallers.c:1985:30: note: each undeclared identifier is
> reported only once fo
On Thu, 2018-05-17 at 17:21 +0100, Frediano Ziglio wrote:
> Unnamed structure combined with inheritance is considered a
> bit hard to read, add a name to make more readable.
>
> Signed-off-by: Frediano Ziglio
> ---
> src/spice-streaming-agent.cpp | 2 +-
> 1 file changed, 1 insertion(+), 1 delet
Unnamed structure combined with inheritance is considered a
bit hard to read, add a name to make more readable.
Signed-off-by: Frediano Ziglio
---
src/spice-streaming-agent.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Changes since v1:
- changed the name
diff --git a/src/spice-str
Building with gcc 8.0.1 from Fedora 28 gives the following error:
FAILED: common/common@@spice-common@sta/marshaller.c.o
../common/marshaller.c: In function 'spice_marshaller_reserve_space':
../common/marshaller.c:311:27: error: cast between incompatible function types
from 'void (*)(void *)' to
On 17/05/18 12:11, Frediano Ziglio wrote:
>>
>> Here is an example of a successful run:
>>
>> https://gitlab.freedesktop.org/etrunko/spice-common/-/jobs/549
>>
>
> Stupid question. Is it worth doing giving that spice-common is compiled
> and tested from both spice-server and spice-gtk?
>
Not a s
>
> Here is an example of a successful run:
>
> https://gitlab.freedesktop.org/etrunko/spice-common/-/jobs/549
>
Stupid question. Is it worth doing giving that spice-common is compiled
and tested from both spice-server and spice-gtk?
> On 17/05/18 11:29, Eduardo Lima (Etrunko) wrote:
> > Signe
Rename struct VSCMsgReaderAdd field 'reader_name' to 'name', and struct
VSCMsgATR field 'data' to 'atr' to match their definitions in file
vscard_common.h.
The error log follows:
generated_server_demarshallers.c:1985:30: note: each undeclared identifier is
reported only once for each function it
Even though commit df4ec5c3186e796624e4bbf2dc4a269faf2823f6 commented
out most of smartcard code which triggered this error, it still might
happen if a new message is added with an array member.
The reason is a missing declaration of mem_size, which is fixed simply
by checking if the attribute 'no
Here is an example of a successful run:
https://gitlab.freedesktop.org/etrunko/spice-common/-/jobs/549
On 17/05/18 11:29, Eduardo Lima (Etrunko) wrote:
> Signed-off-by: Eduardo Lima (Etrunko)
> ---
> .gitlab-ci.yml | 18 ++
> 1 file changed, 18 insertions(+)
> create mode 10064
Signed-off-by: Eduardo Lima (Etrunko)
---
.gitlab-ci.yml | 18 ++
1 file changed, 18 insertions(+)
create mode 100644 .gitlab-ci.yml
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 000..1d61805
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,18 @@
+imag
On Thu, 2018-05-17 at 09:26 -0400, Frediano Ziglio wrote:
> >
> > On Thu, 2018-05-17 at 05:24 -0400, Frediano Ziglio wrote:
> > > >
> > > > On Wed, 2018-05-16 at 12:47 -0400, Frediano Ziglio wrote:
> > > > > >
> > > > > > Signed-off-by: Lukáš Hrázký
> > > > > > ---
> > > > > > src/unittests/.g
On 17/05/18 11:09, Frediano Ziglio wrote:
> This causes errors if Valgrind or sanitizer or similar memory
> leak checkers are used.
>
> Signed-off-by: Frediano Ziglio
> ---
> tests/test-overflow.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/tests/test-overflow.c b/tests/test-overfl
This causes errors if Valgrind or sanitizer or similar memory
leak checkers are used.
Signed-off-by: Frediano Ziglio
---
tests/test-overflow.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/tests/test-overflow.c b/tests/test-overflow.c
index 0a5bdd2..c972a25 100644
--- a/tests/test-overflow
>
> This hack is now made obsolete by the previous commit. We can safely
> remove those defines and the code now builds fine for both spice server
> and spice-gtk.
>
> commit df4ec5c3186e796624e4bbf2dc4a269faf2823f6
> Author: Frediano Ziglio
> Date: Fri May 11 16:59:46 2018 +0100
>
> Fix
This hack is now made obsolete by the previous commit. We can safely
remove those defines and the code now builds fine for both spice server
and spice-gtk.
commit df4ec5c3186e796624e4bbf2dc4a269faf2823f6
Author: Frediano Ziglio
Date: Fri May 11 16:59:46 2018 +0100
Fix generation of Smartca
>
> On Thu, 2018-05-17 at 05:24 -0400, Frediano Ziglio wrote:
> > >
> > > On Wed, 2018-05-16 at 12:47 -0400, Frediano Ziglio wrote:
> > > > >
> > > > > Signed-off-by: Lukáš Hrázký
> > > > > ---
> > > > > src/unittests/.gitignore | 1 +
> > > > > src/unittests/Makefile.am |
>
> Hi
>
> On Thu, May 17, 2018 at 1:50 PM, Frediano Ziglio wrote:
> >>
> >> On Wed, May 16, 2018 at 3:54 PM, Frediano Ziglio
> >> wrote:
> >> >>
> >> >> On Wed, May 16, 2018 at 10:46:35AM +0200, Christophe Fergeau wrote:
> >> >> > On Wed, May 16, 2018 at 10:43:20AM +0200, Christophe Fergeau wr
Hi
On Thu, May 17, 2018 at 1:50 PM, Frediano Ziglio wrote:
>>
>> On Wed, May 16, 2018 at 3:54 PM, Frediano Ziglio wrote:
>> >>
>> >> On Wed, May 16, 2018 at 10:46:35AM +0200, Christophe Fergeau wrote:
>> >> > On Wed, May 16, 2018 at 10:43:20AM +0200, Christophe Fergeau wrote:
>> >> > > On Wed, M
Code that handled client and server messages check was the same, just
changed some variable names.
Instead use a class to store same information and reuse the code.
This allows easier extension of the 2 path of code.
Signed-off-by: Frediano Ziglio
---
python_modules/ptypes.py | 68 ++
On Thu, 2018-05-17 at 08:40 -0400, Frediano Ziglio wrote:
> >
> > On Thu, 2018-05-17 at 07:36 -0400, Frediano Ziglio wrote:
> > > >
> > > > On Wed, 2018-05-16 at 16:35 +0100, Frediano Ziglio wrote:
> > > > > Code that handled client and server messages check was the same, just
> > > > > changed s
>
> On Thu, 2018-05-17 at 07:36 -0400, Frediano Ziglio wrote:
> > >
> > > On Wed, 2018-05-16 at 16:35 +0100, Frediano Ziglio wrote:
> > > > Code that handled client and server messages check was the same, just
> > > > changed some variable names.
> > > > Instead use a class to store same informat
On Thu, 2018-05-17 at 07:36 -0400, Frediano Ziglio wrote:
> >
> > On Wed, 2018-05-16 at 16:35 +0100, Frediano Ziglio wrote:
> > > Code that handled client and server messages check was the same, just
> > > changed some variable names.
> > > Instead use a class to store same information and reuse t
>
> On Wed, May 16, 2018 at 3:54 PM, Frediano Ziglio wrote:
> >>
> >> On Wed, May 16, 2018 at 10:46:35AM +0200, Christophe Fergeau wrote:
> >> > On Wed, May 16, 2018 at 10:43:20AM +0200, Christophe Fergeau wrote:
> >> > > On Wed, May 16, 2018 at 10:23:01AM +0300, Snir Sheriber wrote:
> >> > > Yes
>
> On Wed, 2018-05-16 at 16:35 +0100, Frediano Ziglio wrote:
> > Code that handled client and server messages check was the same, just
> > changed some variable names.
> > Instead use a class to store same information and reuse the code.
> > This allows easier extension of the 2 path of code.
> >
On Thu, 2018-05-17 at 05:24 -0400, Frediano Ziglio wrote:
> >
> > On Wed, 2018-05-16 at 12:47 -0400, Frediano Ziglio wrote:
> > > >
> > > > Signed-off-by: Lukáš Hrázký
> > > > ---
> > > > src/unittests/.gitignore | 1 +
> > > > src/unittests/Makefile.am | 9 -
> > > > s
On Wed, 2018-05-16 at 16:35 +0100, Frediano Ziglio wrote:
> Code that handled client and server messages check was the same, just
> changed some variable names.
> Instead use a class to store same information and reuse the code.
> This allows easier extension of the 2 path of code.
>
> Signed-off-
Acked-by: Christophe Fergeau
On Wed, May 16, 2018 at 06:00:35PM +0100, Frediano Ziglio wrote:
> The Smartcard channel definition has been always broken.
> Multiple client messages with the same ID are defined in the channel.
> This cause on server demarshaller to only have last message defined,
>
> On Wed, 2018-05-16 at 12:47 -0400, Frediano Ziglio wrote:
> > >
> > > Signed-off-by: Lukáš Hrázký
> > > ---
> > > src/unittests/.gitignore | 1 +
> > > src/unittests/Makefile.am | 9 -
> > > src/unittests/test-stream-port.cpp | 69
> > >
On Thu, May 10, 2018 at 10:34:11AM -0300, Eduardo Lima (Etrunko) wrote:
> Ping.
>
> The meson port depends on this patch. I tried the testing procedure
> described in the link below, but could not make it work. Has anyone ever
> made it work? I could use some help here.
Last time I tried it was w
On Wed, 2018-05-16 at 12:47 -0400, Frediano Ziglio wrote:
> >
> > Signed-off-by: Lukáš Hrázký
> > ---
> > src/unittests/.gitignore | 1 +
> > src/unittests/Makefile.am | 9 -
> > src/unittests/test-stream-port.cpp | 69
> > ++
> > 3 f
36 matches
Mail list logo