If one can infer the usage of unix sockets from other parameters passed
anyway, then there may be no point having it in the first place. For the
VNC URI, we could have gone with vnc+ssh://, or vnc+ssl:// (for stunnel),
but there were ssh-related and stunnel parameters we could infer from so it
beca
On Thu, Feb 15, 2018 at 04:04:57PM +0100, Christophe de Dinechin wrote:
>
> This style guide only indicates what we aim to achieve. It does not
> necessarily reflect the current state of the code.
>
> What about adding:
>
> Consistency matters. It may be preferable to ignore a style
From: Christophe de Dinechin
The sentence explaining that example makes no real sense,
the mentioned style is not used by the current code,
and the coding style suggestion is horrendous.
Not to mention that it flies in the face of all automatic indentation
tools I know of.
Change since v3:
- Ma
From: Christophe de Dinechin
Signed-off-by: Christophe de Dinechin
---
docs/spice_style.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/docs/spice_style.txt b/docs/spice_style.txt
index 996c5cd9..9e6536e4 100644
--- a/docs/spice_style.txt
+++ b/docs/spice_style.txt
@@ -1
From: Christophe de Dinechin
Historically, the coding style was created in the server component, and
that's where it's built from. However, it applies also to other components,
and is presently being reworked in large part because of the introduction of
a large amount of C++ in the streaming agen
From: Christophe de Dinechin
Changes in v4:
- Integrate the many comments made on list
Details in the respective commit logs
Changes in v3:
- Integrated clarification regarding headers
- Added external references as a starting point
- Changed [source,h] annotations (unsure if that's accepted)
From: Christophe de Dinechin
Change since v3:
- This particular aspect is controversial, so it was put in a separate patch.
Signed-off-by: Christophe de Dinechin
---
docs/spice_style.txt | 2 ++
1 file changed, 2 insertions(+)
diff --git a/docs/spice_style.txt b/docs/spice_style.txt
index 13b
From: Christophe de Dinechin
The objective of these guidelines is that:
- We avoid introducing new warnings
- We know how to fix old ones
Changes since v3:
- Put 'controversial' whitespace proposal in separate patch
Signed-off-by: Christophe de Dinechin
---
docs/spice_style.txt | 7 +++
1
From: Christophe de Dinechin
As written, the headers style guide looks quite wrong. In particular,
it places headers in an order that makes it hard to detect hidden
dependencies in SPICE headers.
These rules can be enforced by the .clang-format proposed in earlier patch,
locally if you use the E
From: Christophe de Dinechin
Note that we don't have .m files in the repository yet, but some files
actually require building as Objective-C on some platformsdue to
system header dependencies (e.g. . This is currently worked
around by passing the CFLAGS=-ObjC command-line option explicitly.
Chan
From: Christophe de Dinechin
The indent of the rephrasing is that:
- If you have a single constant, use const, e.g. (visible in debugger)
const unsigned max_stuff = 42;
- If you have multiple constants, prefer enums over #define, as
already suggested later in the guide:
enum {
From: Christophe de Dinechin
Changes since v3:
- Integrate comments about performance impact and solution
- Integrate comments about impact of a failed assertion
- Add prohibition against side effects
Signed-off-by: Christophe de Dinechin
---
docs/spice_style.txt | 36 +
From: Christophe de Dinechin
There are two use cases for this .clang-format:
1. Local reformatting of source code, e.g. using Emacs clang-format.el package.
This is basically a wawy to accelerate routine reformatting actions during
heavy editing or refactoring.
2. Global reformatting of t
From: Christophe de Dinechin
This attempts to find a wording that takes into account the existing
practice, notably in the server.
Signed-off-by: Christophe de Dinechin
---
docs/spice_style.txt | 16 +---
1 file changed, 13 insertions(+), 3 deletions(-)
diff --git a/docs/spice_sty
From: Christophe de Dinechin
Changes since v3:
- Clarify that the guidelines are an objective, not the state of the code
- Clarify that we try to have a unique style between C and C++
- Clarify that existing practice and code consistency matter
Signed-off-by: Christophe de Dinechin
---
docs/sp
On Thu, 2018-02-15 at 13:03 +0100, Christophe de Dinechin wrote:
> > On 15 Feb 2018, at 11:51, Lukáš Hrázký wrote:
> >
> > On Wed, 2018-02-14 at 22:13 +0100, Christophe de Dinechin wrote:
> > > I cut quite a bit for clarity. What I cut I agree with ;-)
> > >
> > >
> > > > On 14 Feb 2018, at 14:
> On 15 Feb 2018, at 15:55, Christophe Fergeau wrote:
>
> On Thu, Feb 15, 2018 at 03:25:23PM +0100, Christophe de Dinechin wrote:
>>
>>
>>> On 15 Feb 2018, at 13:41, Christophe Fergeau wrote:
>>>
>>> On Thu, Feb 15, 2018 at 11:55:44AM +0100, Christophe de Dinechin wrote:
Now, Christoph
On Thu, Feb 15, 2018 at 03:25:08PM +0100, Christophe de Dinechin wrote:
> > And then I made concrete suggestions
> > as how I would move forward with this patch…
>
> Sorry, I saw your push back, but I did not see the concrete suggestion for
> moving forward… Would you please be kind enough to rep
> On 15 Feb 2018, at 15:25, Frediano Ziglio wrote:
>
>>> On 15 Feb 2018, at 11:00, Frediano Ziglio wrote:
>>>
>>> From: Christophe de Dinechin
>>>
>>> In file included from mjpeg-fallback.cpp:8:
>>> ./mjpeg-fallback.hpp:28:25: warning: 'VideoCodecType' overrides a member
>>> function but is
On Thu, Feb 15, 2018 at 03:25:23PM +0100, Christophe de Dinechin wrote:
>
>
> > On 15 Feb 2018, at 13:41, Christophe Fergeau wrote:
> >
> > On Thu, Feb 15, 2018 at 11:55:44AM +0100, Christophe de Dinechin wrote:
> >> Now, Christophe’s arguments are that
> >>
> >> 1) we should not write guideli
>
> > On 15 Feb 2018, at 11:59, Frediano Ziglio wrote:
> >
> >>>
> >>> On 15 Feb 2018, at 10:07, Christophe Fergeau wrote:
> >>>
> >>> On Wed, Feb 14, 2018 at 10:29:25PM +0100, Christophe de Dinechin wrote:
>
>
> > On 14 Feb 2018, at 17:34, Christophe Fergeau
> > wrote:
>
>
> > On 15 Feb 2018, at 11:04, Frediano Ziglio wrote:
> >
> >>
> >> From: Christophe de Dinechin
> >>
> >> This lets us get rid of C-style 'goto done' in do_capture.
> >>
> >> Signed-off-by: Christophe de Dinechin
> >
> > I honestly prefer the "defer" style way.
>
> The standard C++ prac
While looking at some warnings, I came across this in sw_canvas.c:
#include “canvas_base.c"
So we include a .c in another one. Apparently, this was inherited from some
Cairo canvas. Is that something we care to keep as is?
canvas_base.c by itself does compile, but with warnings about unused sta
> On 15 Feb 2018, at 13:41, Christophe Fergeau wrote:
>
> On Thu, Feb 15, 2018 at 11:55:44AM +0100, Christophe de Dinechin wrote:
>> Now, Christophe’s arguments are that
>>
>> 1) we should not write guidelines that are inconsistent with existing code.
>> 2) this is in the server codebase, so w
> > On 15 Feb 2018, at 11:00, Frediano Ziglio wrote:
> >
> > From: Christophe de Dinechin
> >
> > In file included from mjpeg-fallback.cpp:8:
> > ./mjpeg-fallback.hpp:28:25: warning: 'VideoCodecType' overrides a member
> > function but is not marked 'override' [-Winconsistent-missing-override]
> On 15 Feb 2018, at 13:47, Christophe Fergeau wrote:
>
> On Thu, Feb 15, 2018 at 01:14:43PM +0100, Christophe de Dinechin wrote:
>>
>>
>>> On 15 Feb 2018, at 10:19, Christophe Fergeau wrote:
>>>
>>> On Wed, Feb 14, 2018 at 11:24:50PM +0100, Christophe de Dinechin wrote:
> O
On Thu, 2018-02-15 at 13:29 +0100, Christophe de Dinechin wrote:
> From: Christophe de Dinechin
>
> Signed-off-by: Christophe de Dinechin
> ---
> src/mjpeg-fallback.cpp | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/src/mjpeg-fallback.cpp b/src/mjpeg-fallback.cpp
> in
On 02/15/2018 02:29 PM, Christophe de Dinechin wrote:
From: Christophe de Dinechin
Signed-off-by: Christophe de Dinechin
---
src/mjpeg-fallback.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/mjpeg-fallback.cpp b/src/mjpeg-fallback.cpp
index 74682f3..8238233 100
On Thu, Feb 15, 2018 at 01:14:43PM +0100, Christophe de Dinechin wrote:
>
>
> > On 15 Feb 2018, at 10:19, Christophe Fergeau wrote:
> >
> > On Wed, Feb 14, 2018 at 11:24:50PM +0100, Christophe de Dinechin wrote:
> >>
> >>
> >>> On 14 Feb 2018, at 14:35, Christophe Fergeau wrote:
> >>>
> >>>
On Thu, Feb 15, 2018 at 11:55:44AM +0100, Christophe de Dinechin wrote:
> Now, Christophe’s arguments are that
>
> 1) we should not write guidelines that are inconsistent with existing code.
> 2) this is in the server codebase, so we should server rules
>
> Problem is with 2, really.
>
> We star
> On 15 Feb 2018, at 11:00, Frediano Ziglio wrote:
>
> From: Christophe de Dinechin
>
> Signed-off-by: Christophe de Dinechin
> ---
> Change since v1:
> - do not clash with possible short 'b' option.
> ---
> src/spice-streaming-agent.cpp | 14 ++
> 1 file changed, 10 insertions(+)
> On 15 Feb 2018, at 11:00, Frediano Ziglio wrote:
>
> From: Christophe de Dinechin
>
> In file included from mjpeg-fallback.cpp:8:
> ./mjpeg-fallback.hpp:28:25: warning: 'VideoCodecType' overrides a member
> function but is not marked 'override' [-Winconsistent-missing-override]
>SpiceV
From: Christophe de Dinechin
Signed-off-by: Christophe de Dinechin
---
src/mjpeg-fallback.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/mjpeg-fallback.cpp b/src/mjpeg-fallback.cpp
index 74682f3..8238233 100644
--- a/src/mjpeg-fallback.cpp
+++ b/src/mjpeg-fallback.c
> On 15 Feb 2018, at 10:19, Christophe Fergeau wrote:
>
> On Wed, Feb 14, 2018 at 11:24:50PM +0100, Christophe de Dinechin wrote:
>>
>>
>>> On 14 Feb 2018, at 14:35, Christophe Fergeau wrote:
>>>
>>> This one sounds more like an RFC to me
>>
>> Well, this is really a bug fix in the documen
> On 15 Feb 2018, at 11:51, Lukáš Hrázký wrote:
>
> On Wed, 2018-02-14 at 22:13 +0100, Christophe de Dinechin wrote:
>> I cut quite a bit for clarity. What I cut I agree with ;-)
>>
>>
>>> On 14 Feb 2018, at 14:45, Lukáš Hrázký wrote:
>>>
>>> On Tue, 2018-02-13 at 17:10 +0100, Christophe de
>
> > On 15 Feb 2018, at 11:43, Frediano Ziglio wrote:
> >
> >>
> >> On Thu, Feb 15, 2018 at 10:56:49AM +0100, Lukáš Hrázký wrote:
> >>> On Wed, 2018-02-14 at 22:43 +0100, Christophe de Dinechin wrote:
> > On 14 Feb 2018, at 17:29, Christophe Fergeau
> > wrote:
> >
> > This ch
On Wed, 2018-02-14 at 23:24 +0100, Christophe de Dinechin wrote:
> > On 14 Feb 2018, at 14:35, Christophe Fergeau wrote:
> >
> > This one sounds more like an RFC to me
>
> Well, this is really a bug fix in the documentation more than a RFC.
>
> > , as from a quick look in server/,
> > this is n
> On 15 Feb 2018, at 11:59, Frediano Ziglio wrote:
>
>>>
>>> On 15 Feb 2018, at 10:07, Christophe Fergeau wrote:
>>>
>>> On Wed, Feb 14, 2018 at 10:29:25PM +0100, Christophe de Dinechin wrote:
> On 14 Feb 2018, at 17:34, Christophe Fergeau wrote:
>
> On Wed, Feb 14,
> On 15 Feb 2018, at 11:04, Frediano Ziglio wrote:
>
>>
>> From: Christophe de Dinechin
>>
>> This lets us get rid of C-style 'goto done' in do_capture.
>>
>> Signed-off-by: Christophe de Dinechin
>
> I honestly prefer the "defer" style way.
The standard C++ practice for resource managem
>
> > On 15 Feb 2018, at 10:07, Christophe Fergeau wrote:
> >
> > On Wed, Feb 14, 2018 at 10:29:25PM +0100, Christophe de Dinechin wrote:
> >>
> >>
> >>> On 14 Feb 2018, at 17:34, Christophe Fergeau wrote:
> >>>
> >>> On Wed, Feb 14, 2018 at 10:45:56AM -0500, Frediano Ziglio wrote:
> >
> On 15 Feb 2018, at 11:43, Frediano Ziglio wrote:
>
>>
>> On Thu, Feb 15, 2018 at 10:56:49AM +0100, Lukáš Hrázký wrote:
>>> On Wed, 2018-02-14 at 22:43 +0100, Christophe de Dinechin wrote:
> On 14 Feb 2018, at 17:29, Christophe Fergeau
> wrote:
>
> This changes the suggested
On Wed, 2018-02-14 at 22:13 +0100, Christophe de Dinechin wrote:
> I cut quite a bit for clarity. What I cut I agree with ;-)
>
>
> > On 14 Feb 2018, at 14:45, Lukáš Hrázký wrote:
> >
> > On Tue, 2018-02-13 at 17:10 +0100, Christophe de Dinechin wrote:
> > > Hi Lukas,
> > >
> >
> > For your c
> On 15 Feb 2018, at 10:07, Christophe Fergeau wrote:
>
> On Wed, Feb 14, 2018 at 10:29:25PM +0100, Christophe de Dinechin wrote:
>>
>>
>>> On 14 Feb 2018, at 17:34, Christophe Fergeau wrote:
>>>
>>> On Wed, Feb 14, 2018 at 10:45:56AM -0500, Frediano Ziglio wrote:
>
> Shouldn't thi
>
> On Thu, Feb 15, 2018 at 10:56:49AM +0100, Lukáš Hrázký wrote:
> > On Wed, 2018-02-14 at 22:43 +0100, Christophe de Dinechin wrote:
> > > > On 14 Feb 2018, at 17:29, Christophe Fergeau
> > > > wrote:
> > > >
> > > > This changes the suggested style to what is currently used in
> > > > spice-s
>
> This series introduces a C++ unit test framework called Catch to the
> codebase, adds a simple unit test for the options parsing for the mjpeg
> plugin and improves on the option parsing code.
>
> Since we more or less agreed we can solve the Catch package in RHEL one
> way or another, I supp
On Thu, Feb 15, 2018 at 10:56:49AM +0100, Lukáš Hrázký wrote:
> On Wed, 2018-02-14 at 22:43 +0100, Christophe de Dinechin wrote:
> > > On 14 Feb 2018, at 17:29, Christophe Fergeau wrote:
> > >
> > > This changes the suggested style to what is currently used in
> > > spice-server codebase. This al
>
> From: Christophe de Dinechin
>
> This lets us get rid of C-style 'goto done' in do_capture.
>
> Signed-off-by: Christophe de Dinechin
I honestly prefer the "defer" style way.
Beside that you correctly pointed out that there's a race condition
on cursor thread which could lead the cursor
Updated some proposed patches for the "Minor improvements and coding
style changes to the streaming agent" series.
See relative patches.
Rebase also on master.
Christophe de Dinechin (4):
Rename 'quit' to 'quit_requested' for consistency with
'streaming_requested'
Remove clang warning on m
From: Christophe de Dinechin
Otherwise, clang complains:
spice-streaming-agent.cpp:414:66: warning: format specifies type 'unsigned
long' but the argument has type 'uint64_t' (aka 'unsigned long long') [-Wformat]
fprintf(f_log, "%lu: Frame of %zu bytes:\n", get_time(),
fram
From: Christophe de Dinechin
Signed-off-by: Christophe de Dinechin
Acked-by: Frediano Ziglio
---
Change since v1:
- fixed bracket of changed line.
---
src/spice-streaming-agent.cpp | 15 ---
1 file changed, 8 insertions(+), 7 deletions(-)
diff --git a/src/spice-streaming-agent.cpp
From: Christophe de Dinechin
In file included from mjpeg-fallback.cpp:8:
./mjpeg-fallback.hpp:28:25: warning: 'VideoCodecType' overrides a member
function but is not marked 'override' [-Winconsistent-missing-override]
SpiceVideoCodecType VideoCodecType() const;
^
../i
From: Christophe de Dinechin
Signed-off-by: Christophe de Dinechin
---
Change since v1:
- do not clash with possible short 'b' option.
---
src/spice-streaming-agent.cpp | 14 ++
1 file changed, 10 insertions(+), 4 deletions(-)
diff --git a/src/spice-streaming-agent.cpp b/src/spice-
On Wed, 2018-02-14 at 22:43 +0100, Christophe de Dinechin wrote:
> > On 14 Feb 2018, at 17:29, Christophe Fergeau wrote:
> >
> > This changes the suggested style to what is currently used in
> > spice-server codebase. This also removes a few sentences which
> > are not really related to how one s
> >
> > From: Christophe de Dinechin
> >
> > Otherwise, clang complains:
> >
> > spice-streaming-agent.cpp:414:66: warning: format specifies type 'unsigned
> > long' but the argument has type 'uint64_t' (aka 'unsigned long long')
> > [-Wformat]
> > fprintf(f_log, "%lu: Frame
On Wed, Feb 14, 2018 at 10:43:26PM +0100, Christophe de Dinechin wrote:
>
>
> > On 14 Feb 2018, at 17:29, Christophe Fergeau wrote:
> >
> > This changes the suggested style to what is currently used in
> > spice-server codebase. This also removes a few sentences which
> > are not really related
On Wed, Feb 14, 2018 at 11:24:50PM +0100, Christophe de Dinechin wrote:
>
>
> > On 14 Feb 2018, at 14:35, Christophe Fergeau wrote:
> >
> > This one sounds more like an RFC to me
>
> Well, this is really a bug fix in the documentation more than a RFC.
>
> > , as from a quick look in server/,
On Wed, Feb 14, 2018 at 10:29:25PM +0100, Christophe de Dinechin wrote:
>
>
> > On 14 Feb 2018, at 17:34, Christophe Fergeau wrote:
> >
> > On Wed, Feb 14, 2018 at 10:45:56AM -0500, Frediano Ziglio wrote:
> >>>
> >>> Shouldn't this go with a Makefile rule? A few lines in the log what this
> >>
On Wed, Feb 14, 2018 at 10:53:04PM +0100, Christophe de Dinechin wrote:
>
>
> > On 14 Feb 2018, at 14:37, Christophe Fergeau wrote:
> >
> > On Thu, Feb 08, 2018 at 12:25:30PM +0100, Christophe de Dinechin wrote:
> >> From: Christophe de Dinechin
> >>
> >> The objective of these guidelines is
From: Victor Toso
For VA-API cable drivers at least, this should set the video codecs
order based on hw capabilities.
We can use this to improve/set limitation on possible streams too, like
don't send 4K stream if we _know_ that HW can support only Full HD...
but we lack protocol for that yet.
From: Victor Toso
By using the detection of which video codecs (and profiles!) the
hardware supports with VA-API capable driver in previous commit.
Signed-off-by: Victor Toso
---
src/channel-display.c | 33 -
1 file changed, 28 insertions(+), 5 deletions(-)
dif
From: Victor Toso
Libva is an implementation for VA-API.
This can be used to automatically send to the server the
preferred video codecs as the client would prefer streams
with video codecs that can be decoded with gpu support.
We can also use the profiles to detect and set upper limit for
vide
61 matches
Mail list logo