These style are used by other SPICE projects like spice-streaming-agent.
See discussion "Coding style and naming conventions for C++" at
https://lists.freedesktop.org/archives/spice-devel/2018-January/041562.html.
Signed-off-by: Frediano Ziglio
---
docs/spice_style.txt | 38 +
On Tue, 2018-02-06 at 05:06 -0500, Frediano Ziglio wrote:
> >
> > On Thu, 2018-02-01 at 16:40 +, Frediano Ziglio wrote:
> > > Check if the current server is active or not and stream only if active.
> > > This will allow to support multiple servers running.
> > > When multiple servers are runni
On Tue, 2018-02-06 at 06:08 -0500, Frediano Ziglio wrote:
> >
> > On Thu, 2018-02-01 at 16:40 +, Frediano Ziglio wrote:
> > > This allows to manage properly multiple servers (currently only Xorg).
> > > The executable will run as a service forking the proper agent.
> > > The agent will then ma
On Mon, 2018-02-05 at 18:05 +0100, Christophe de Dinechin wrote:
> > On 2 Feb 2018, at 18:34, Lukáš Hrázký wrote:
> >
> > On Thu, 2018-02-01 at 16:40 +, Frediano Ziglio wrote:
> > > This allows to manage properly multiple servers (currently only Xorg).
> > > The executable will run as a servi
On Tue, 2018-02-06 at 12:02 +0100, Christophe de Dinechin wrote:
> > On 25 Jan 2018, at 11:29, Lukáš Hrázký wrote:
> >
> > It's a good practice to consistently use std::string in C++ when there
> > are no special needs for a char *.
>
> OK. Catching up on past e-mail here. FWIW, I disagree with
On Tue, Feb 06, 2018 at 04:40:18AM -0500, Frediano Ziglio wrote:
> >
> > On Tue, 2018-01-30 at 11:50 +0100, Christophe de Dinechin wrote:
> > >
> > > Let’s first share our preference on existing styles to see
> > > if we agree on anything…
> > > As for me, I have a slight preference for the LLVM
>
> On Thu, 2018-02-01 at 16:40 +, Frediano Ziglio wrote:
> > This allows to manage properly multiple servers (currently only Xorg).
> > The executable will run as a service forking the proper agent.
> > The agent will then manage the active server.
> > The server receive just minimal informat
> On 25 Jan 2018, at 11:29, Lukáš Hrázký wrote:
>
> It's a good practice to consistently use std::string in C++ when there
> are no special needs for a char *.
OK. Catching up on past e-mail here. FWIW, I disagree with the rationale and
therefore the change. std::string represents dynamic str
On Tue, 2018-02-06 at 04:53 -0500, Frediano Ziglio wrote:
> >
> > On Tue, 2018-02-06 at 04:35 -0500, Frediano Ziglio wrote:
> > > >
> > > > So that the plugin can later be included in a unit test.
> > > >
> > > > Signed-off-by: Lukáš Hrázký
> > > > ---
> > > > src/mjpeg-fallback.cpp | 26 +
>
> On Thu, 2018-02-01 at 16:40 +, Frediano Ziglio wrote:
> > Check if the current server is active or not and stream only if active.
> > This will allow to support multiple servers running.
> > When multiple servers are running only one have the GPU associated
> > and is writing to the screen
> On 6 Feb 2018, at 10:51, Frediano Ziglio wrote:
>
>>>
>>> On 5 Feb 2018, at 15:29, Lukáš Hrázký wrote:
>>>
>>> The static registration (that is, having a static list of pointers to
>>> static plugin variables and calling a generic function in the main
>>> initialization code path to regist
>
> On Tue, 2018-02-06 at 04:35 -0500, Frediano Ziglio wrote:
> > >
> > > So that the plugin can later be included in a unit test.
> > >
> > > Signed-off-by: Lukáš Hrázký
> > > ---
> > > src/mjpeg-fallback.cpp | 26 ++
> > > src/mjpeg-fallback.hpp | 34 +
>
> > On 5 Feb 2018, at 15:29, Lukáš Hrázký wrote:
> >
> > The static registration (that is, having a static list of pointers to
> > static plugin variables and calling a generic function in the main
> > initialization code path to register them) allows to add plugins without
> > registering each
On Tue, 2018-02-06 at 04:35 -0500, Frediano Ziglio wrote:
> >
> > So that the plugin can later be included in a unit test.
> >
> > Signed-off-by: Lukáš Hrázký
> > ---
> > src/mjpeg-fallback.cpp | 26 ++
> > src/mjpeg-fallback.hpp | 34 ++
>
>
> On Tue, 2018-01-30 at 11:50 +0100, Christophe de Dinechin wrote:
> >
> > Let’s first share our preference on existing styles to see if we agree on
> > anything…
> > As for me, I have a slight preference for the LLVM coding style, but I made
> > modifications in my own clang-format files.
>
>
>
> So that the plugin can later be included in a unit test.
>
> Signed-off-by: Lukáš Hrázký
> ---
> src/mjpeg-fallback.cpp | 26 ++
> src/mjpeg-fallback.hpp | 34 ++
> 2 files changed, 40 insertions(+), 20 deletions(-)
> create mode 1006
16 matches
Mail list logo