Can someone review this patch, please?
Thank you
El 13/04/16 a las 13:42, Javier Celaya escribió:
With scaling enabled, the size request of the widget must be 640x480
(the same as with resize_guest_enable) so that the widget can be
actually scalled down.
---
src/spice-widget.c | 25 +++
On 04/21/16 19:45, Frediano Ziglio-san wrote:
On 04/21/16 01:17, Frediano Ziglio-san wrote:
On Wed, Apr 20, 2016 at 05:37:52PM +0900, Takao Fujiwara wrote:
My understanding is, Virt-Viewer with ImmDisableIME(-1) can send key
events even if the title bar is focused when IME is enabled.
I attac
From: Christophe Fergeau
RedCharDevice implementation had to callback into reds.c in order to let
it know a char device was being destroyed. Now that RedCharDevice is a
gobject, a weak reference can be used instead allowing to remove that
coupling.
---
Changes:
- Renamed reds_on_char_device_stat
---
Changes since last version:
- split from the deprecation patch
Still not sure whether g_critical() is appropriate here vs. just removing the
code or something like that.
server/display-channel.c | 3 +++
server/sound.c | 1 +
2 files changed, 4 insertions(+)
diff --git a/server/d
From: Christophe Fergeau
channels_info->num_of_channels is assigned, its value is not used, and
then it's assigned a different value. The first assignment can be
removed.
Acked-by: Jonathon Jongsma
---
server/reds.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/server/reds.c b/server/reds
From: Christophe Fergeau
---
Changes since last version:
- split out debug warnings from this patch
server/spice-migration.h | 6 +++---
server/spice-server.h| 12 +++-
2 files changed, 10 insertions(+), 8 deletions(-)
diff --git a/server/spice-migration.h b/server/spice-migratio
From: Christophe Fergeau
This variable belongs to SpiceServerConfig rather than being a static
global variable hidden in sound.c
Acked-by: Jonathon Jongsma
---
Changes since last version:
- change commit log from playback_state to playback_compression
server/reds.c | 8
server/red
From: Christophe Fergeau
Acked-by: Jonathon Jongsma
---
server/inputs-channel.c | 8
server/reds.c | 8
server/reds.h | 2 +-
3 files changed, 9 insertions(+), 9 deletions(-)
diff --git a/server/inputs-channel.c b/server/inputs-channel.c
index d1af9cf..da2
From: Christophe Fergeau
Instead of exporting 2 methods to get number of channels, and to fill
channel information, and use that from the main channel code, it's
better to do everything in one go in reds.c, and call that single method
from the main channel code.
---
Changes since last version:
-
No need to re-implement refcounting in this subclass.
---
Changes since last version:
- remove the dcc/display parameter from the struct since the previous patch
was added that stored a display pointer in the Drawable struct.
server/dcc.c | 16 +---
server/display-cha
From: Christophe Fergeau
It's more natural to do things this way with glib, and this allows to
remove some coupling between Reds and RedCharDeviceVDIPort. Before this
commit, the RedCharDeviceVDIPort has to provide a on_free_self_token()
because Reds needs to know about it. With a signal, RedChar
From: Christophe Fergeau
This wraps/groups the various parameters that can be set by spice-server
users through the spice_server_set_xxx public API.
---
Changes since last version:
- free the config struct in spice_server_destroy()
server/reds-private.h | 34 +-
server/reds.c | 32
Following internal type naming conventions
---
No changes since last patch
server/cache-item.h | 2 +-
server/cache-item.tmpl.c | 2 +-
server/char-device.c | 22 +--
server/char-device.h | 6 +--
server/cursor-channel.c | 22 +--
server/dcc-send.c| 22 +++
If the Drawable keeps a pointer to the Display channel that it is
associated with, we can unref it directly and not need to pass the
'display' parameter separately to the unref function
---
NEW PATCH. This prepares for the UpgradeItem change as discussed on the
previous review.
server/dcc.c
Several patches from the last set were merged and dropped from the set, several
were reviewd per review, and one new one was added.
Christophe Fergeau (9):
Replace RedCharDevice::on_free_self_token with a signal
Use GQueue for RedCharDevice::send_queue
Use weak gobject ref instead of reds_on
From: Christophe Fergeau
There was an extra RedCharDeviceMsgToClientItem type whose only
purpose was to manage a linked list of items to send. GQueue has the
same purpose as this type in addition to being generic. As the length of
the send queue is tracked, a GQueue is more appropriate than a GLi
From: Lukas Venhoda
When stopping the service, automatically disconnect shared folder on
windows. Not dismounting could lead to multiple shared folders.
---
Fixup
The last one didnt have the change from ServiceData * to gpointer
Changes since v5:
- fixed indentation
- fixed * indentaion
- rem
From: Lukas Venhoda
When stopping the service, automatically disconnect shared folder on
windows. Not dismounting could lead to multiple shared folders.
---
Changes since v5:
- fixed indentation
- fixed * indentaion
- removed return from void functions
- changed ServiceData * to gpointer, so
From: Lukas Venhoda
Check whether Spice Folder is already mapped.
If yes, don't try to map another one.
---
Changes since v4:
- fixed indentation
- fixed * indentaion
Changes since v4:
- Moved some variables around
- Better debug message
- Fixed bug, that would cause the folder not to mount
From: Lukas Venhoda
Try to connect to shared folder automatically on Windows.
On each loop of run_service(), run a GTask, that waits for half a second.
If read_thread() returns, it means, that sharing is not yet connected,
and the map_drive task is cancelled.
If the map_drive task is NOT cancel
>
> On Thu, 2016-04-21 at 12:41 +0100, Frediano Ziglio wrote:
> > From: Jonathon Jongsma
> >
> > No need to re-implement refcounting in this subclass. However, I needed
> > to add a new 'dcc' member to UpgradeItem to be able to unref properly.
> > ---
> > server/dcc.c | 18 +
On Thu, 2016-04-21 at 12:41 +0100, Frediano Ziglio wrote:
> From: Jonathon Jongsma
>
> No need to re-implement refcounting in this subclass. However, I needed
> to add a new 'dcc' member to UpgradeItem to be able to unref properly.
> ---
> server/dcc.c | 18 +-
> serv
>
> From: Jonathon Jongsma
>
> No need to re-implement refcounting in this subclass. However, I needed
> to add a new 'dcc' member to UpgradeItem to be able to unref properly.
Sorry, now it's "a new 'display' member".
Frediano
> ---
> server/dcc.c | 18 +-
> serve
From: Jonathon Jongsma
No need to re-implement refcounting in this subclass. However, I needed
to add a new 'dcc' member to UpgradeItem to be able to unref properly.
---
server/dcc.c | 18 +-
server/display-channel.c | 4 +---
server/display-channel.h | 7 ++-
s
>
> On Wed, 2016-04-20 at 04:18 -0400, Frediano Ziglio wrote:
> > >
> > > No need to re-implement refcounting in this subclass. However, I needed
> > > to add a new 'dcc' member to UpgradeItem to be able to unref properly.
> > > ---
> > > Change since last patch: take ref on dcc
> > >
> > > ser
>
> On 04/21/16 01:17, Frediano Ziglio-san wrote:
> >>
> >> On Wed, Apr 20, 2016 at 05:37:52PM +0900, Takao Fujiwara wrote:
> >>> My understanding is, Virt-Viewer with ImmDisableIME(-1) can send key
> >>> events even if the title bar is focused when IME is enabled.
> >>> I attached the screenshot
26 matches
Mail list logo