On Tue, Feb 9, 2016 at 4:30 PM, Christophe Fergeau wrote:
> On Tue, Feb 09, 2016 at 03:56:42PM +0200, Yedidyah Bar David wrote:
>> On Tue, Feb 9, 2016 at 3:44 PM, Christophe Fergeau
>> wrote:
>> > On Mon, Feb 08, 2016 at 07:57:42PM +0200, Yedidyah Bar David wrote:
>> >> From: Sandro Bonazzola
>
On Thu, 2015-10-29 at 17:27 +0200, Dmitry Fleytman wrote:
> From: Kirill Moizik
>
> On Windows when using usbdk, opening and closing USB device handle,
> i.e. calling libusb_open()/libusb_unref_device() can block for a few
> seconds (3-5 second more specifically on patch author's HW).
>
> libusb
On Thu, 2015-10-29 at 17:27 +0200, Dmitry Fleytman wrote:
> From: Kirill Moizik
>
> This commit adds locking to ensure thread safety required
> after start/stop redirection flows moved to separate threads.
>
> Signed-off-by: Kirill Moizik
> Signed-off-by: Dmitry Fleytman
> ---
> src/channel-u
On Thu, 2015-10-29 at 17:26 +0200, Dmitry Fleytman wrote:
> From: Kirill Moizik
>
> This commit introduces channel mutex to allow usage of
> channel objects in mutithreaded environments.
>
> This mutex will be used to protect non thread safe
> usbredir functions and data structures.
>
> Signed-
On Tue, Feb 09, 2016 at 03:56:42PM +0200, Yedidyah Bar David wrote:
> On Tue, Feb 9, 2016 at 3:44 PM, Christophe Fergeau
> wrote:
> > On Mon, Feb 08, 2016 at 07:57:42PM +0200, Yedidyah Bar David wrote:
> >> From: Sandro Bonazzola
> >>
> >> Avoid suffix in iso labeling: release number with the
>
Hey,
On Tue, Feb 09, 2016 at 10:02:09AM +0100, Fabian Grünbichler wrote:
> Thanks for your feedback! Yes, that sums it up quite nicely. Filed #1305785
> (https://bugzilla.redhat.com/show_bug.cgi?id=1305785), and am available for
> testing if there are any updates.
I've 'moved' this bug to
https:/
>
> See the related protocol changes for message details.
>
> 2 new functions are exported:
> - spice_gl_scanout() to specify the current scanout. The server will
> then own the given fd. It will keep the most recent version to set
> upcoming clients scanout with the up to date version.
> - s
On Tue, Feb 9, 2016 at 3:56 PM, Yedidyah Bar David wrote:
> On Tue, Feb 9, 2016 at 3:44 PM, Christophe Fergeau
> wrote:
>> On Mon, Feb 08, 2016 at 07:57:42PM +0200, Yedidyah Bar David wrote:
>>> From: Sandro Bonazzola
>>>
>>> Avoid suffix in iso labeling: release number with the
>>> full suffix
On Tue, Feb 9, 2016 at 3:44 PM, Christophe Fergeau wrote:
> On Mon, Feb 08, 2016 at 07:57:42PM +0200, Yedidyah Bar David wrote:
>> From: Sandro Bonazzola
>>
>> Avoid suffix in iso labeling: release number with the
>> full suffix exceeds the maximum length allowed.
>
> What does the full suffix lo
On Mon, Feb 08, 2016 at 07:57:42PM +0200, Yedidyah Bar David wrote:
> From: Sandro Bonazzola
>
> Avoid suffix in iso labeling: release number with the
> full suffix exceeds the maximum length allowed.
What does the full suffix look like in your builds?
The label in the Makefile is ovirt-wgt-$(DI
See the related protocol changes for message details.
2 new functions are exported:
- spice_gl_scanout() to specify the current scanout. The server will
then own the given fd. It will keep the most recent version to set
upcoming clients scanout with the up to date version.
- spice_gl_draw_asyn
Create an async, and marshall the GL_DRAW message. Count number of
clients, and wait until gl_draw_async_count is 0 to complete the async.
The count is going to be updated in the following patch when the client
is done with the draw.
Signed-off-by: Marc-André Lureau
[removed unused sent field; mo
When a client is done with drawing and sends
SPICE_MSGC_DISPLAY_GL_DRAW_DONE, or when it ends, update the number of
async counts.
Signed-off-by: Marc-André Lureau
[reduce critical message to a warning; do not reset gl_draw_ongoing
- Frediano Ziglio]
Signed-off-by: Frediano Ziglio
---
server/dc
Go through dispatcher and marshall scanout message. Since the marshaller
and the QXL state are manipulated from different threads, add a mutex to
protect the current scanout.
Signed-off-by: Marc-André Lureau
---
server/dcc-send.c| 25 +
server/dcc.c |
- spice_gl_scanout() to take the current scanout
- spice_gl_draw_async() to draw the scanout, is like other Spice async
functions, it takes a cookie and will return in the
QXLInterface.async_complete()
Two new fields are also added to QXLState, in order to save the current
scanout, and the pe
Signed-off-by: Marc-André Lureau
---
server/dcc.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/server/dcc.c b/server/dcc.c
index eb63ce6..58ae55c 100644
--- a/server/dcc.c
+++ b/server/dcc.c
@@ -445,6 +445,7 @@ void dcc_start(DisplayChannelClient *dcc)
{
DisplayChannel *
This is useful in the following patches to count the number of replies
to wait for.
Signed-off-by: Marc-André Lureau
---
server/red-channel.c | 19 +--
server/red-channel.h | 2 +-
2 files changed, 14 insertions(+), 7 deletions(-)
diff --git a/server/red-channel.c b/server/red-
>
> Hi
>
> On Thu, Feb 4, 2016 at 4:29 PM, Frediano Ziglio wrote:
> >> +{
> >> +spice_return_if_fail(qxl != NULL);
> >> +spice_return_if_fail(qxl->st->gl_draw_async == NULL);
> >
> > Here you need to close fd on error or you will get a file
> > descriptor leak.
>
> >> +
> >> +SPICE_GNUC
>
> Hi
>
> On Thu, Feb 4, 2016 at 4:25 PM, Frediano Ziglio wrote:
> > Here you can have a race condition.
> > If red_dispatcher_async_complete wake up the Qemu thread before reset
> > gl_draw_async it could be possible Qemu will try to send another draw
> > finding gl_draw_async not NULL and ret
Hi
On Thu, Feb 4, 2016 at 4:25 PM, Frediano Ziglio wrote:
> Here you can have a race condition.
> If red_dispatcher_async_complete wake up the Qemu thread before reset
> gl_draw_async it could be possible Qemu will try to send another draw
> finding gl_draw_async not NULL and returning without do
Hi
On Thu, Feb 4, 2016 at 4:29 PM, Frediano Ziglio wrote:
>> +{
>> +spice_return_if_fail(qxl != NULL);
>> +spice_return_if_fail(qxl->st->gl_draw_async == NULL);
>
> Here you need to close fd on error or you will get a file
> descriptor leak.
>> +
>> +SPICE_GNUC_VISIBLE
>> +void spice_gl_
Hi,
G_SOURCE_REMOVE was introduced in glib2.32
Pavel
On Tue, 2016-02-09 at 10:27 +, Frediano Ziglio wrote:
> Make code more readable.
> Value is exactly the same.
>
> Signed-off-by: Frediano Ziglio
> ---
> server/event-loop.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> di
>
> From: Jonathon Jongsma
>
> Various functions were still using the global 'reds' variable rather
> than the local argument of type RedsState
I think we decided to rename all variable/argument to reds at the end
so this patch is not doing the right thing.
> ---
> server/reds.c | 68
> +
> From: Jonathon Jongsma
>
> ---
> server/main-dispatcher.c | 2 +-
> server/reds.c| 2 +-
> server/reds.h| 2 +-
> 3 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/server/main-dispatcher.c b/server/main-dispatcher.c
> index 132a693..777a44f 100644
> ---
>
> From: Jonathon Jongsma
>
> ---
> server/reds.c | 13 +++--
> 1 file changed, 7 insertions(+), 6 deletions(-)
>
> diff --git a/server/reds.c b/server/reds.c
> index 6467c7e..7b8848a 100644
> --- a/server/reds.c
> +++ b/server/reds.c
> @@ -2265,7 +2265,7 @@ static void reds_handle_ss
>
> From: Jonathon Jongsma
>
> Also add reds_get_core_interface() accessor for external use.
> ---
> server/char-device.c| 32 ---
> server/inputs-channel.c | 7 ---
> server/main-channel.c | 13 +++--
> server/reds-private.h | 2 ++
> server/re
>
> From: Jonathon Jongsma
>
> Since this is technically a RedsState method, name it as such.
> ---
> server/reds.c | 8
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/server/reds.c b/server/reds.c
> index 4ad8b0f..bff64d6 100644
> --- a/server/reds.c
> +++ b/serve
---
server/cursor-channel.c | 7 ---
1 file changed, 7 deletions(-)
diff --git a/server/cursor-channel.c b/server/cursor-channel.c
index 4c15582..bbaac34 100644
--- a/server/cursor-channel.c
+++ b/server/cursor-channel.c
@@ -45,13 +45,6 @@ typedef struct CursorItem {
G_STATIC_ASSERT(sizeof
CommonChannel does not need to know about RedWorker.
This reduce a bit dependencies between objects.
Signed-off-by: Frediano Ziglio
---
server/cursor-channel.c | 2 +-
server/dcc-encoders.c| 3 +--
server/display-channel.c | 5 ++---
server/red-worker.c | 12 ++--
server/red
It was not clear when req_cmd_notification was called.
This code reproduce just the old behavior but is easier to read.
Steps are:
// original
if (worker->display_poll_tries < CMD_RING_POLL_RETRIES) {
worker->display_poll_tries++;
worker->event_timeout = MIN(worker->event_timeout, CMD_RI
Signed-off-by: Frediano Ziglio
---
server/red-worker.c | 7 ---
server/red-worker.h | 1 -
2 files changed, 8 deletions(-)
diff --git a/server/red-worker.c b/server/red-worker.c
index 1757b8e..05d6af3 100644
--- a/server/red-worker.c
+++ b/server/red-worker.c
@@ -92,13 +92,6 @@ struct RedWor
Signed-off-by: Frediano Ziglio
---
server/red-worker.c | 1 -
server/red-worker.h | 1 -
2 files changed, 2 deletions(-)
diff --git a/server/red-worker.c b/server/red-worker.c
index 5d6512f..3bb8227 100644
--- a/server/red-worker.c
+++ b/server/red-worker.c
@@ -469,7 +469,6 @@ CommonChannelClien
Some cleanups and style changes.
Frediano Ziglio (11):
dispatcher: remove unused async_commands ring
worker: simplify process loops
event loop: use G_SOURCE_REMOVE instead of FALSE
channel: rename misleading functions
dcc: remove group_id from compression functions
remove unused struct
The only usage of this ring was to have a message when there was no
commands on the list.
Signed-off-by: Frediano Ziglio
---
server/red-dispatcher.c | 15 ---
1 file changed, 15 deletions(-)
diff --git a/server/red-dispatcher.c b/server/red-dispatcher.c
index 374d5a9..19fbf61 100644
Signed-off-by: Frediano Ziglio
---
server/red-worker.c | 7 ---
server/red-worker.h | 1 -
2 files changed, 8 deletions(-)
diff --git a/server/red-worker.c b/server/red-worker.c
index ba37b6c..5d6512f 100644
--- a/server/red-worker.c
+++ b/server/red-worker.c
@@ -99,13 +99,6 @@ QXLInstance*
Signed-off-by: Frediano Ziglio
---
server/cache-item.tmpl.c | 2 +-
server/dcc.c | 2 +-
server/red-channel.c | 6 +++---
server/red-channel.h | 2 +-
4 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/server/cache-item.tmpl.c b/server/cache-item.tmpl.c
index 09add
Make code more readable.
Value is exactly the same.
Signed-off-by: Frediano Ziglio
---
server/event-loop.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/server/event-loop.c b/server/event-loop.c
index 9eae913..9ef7a46 100644
--- a/server/event-loop.c
+++ b/server/event-loop
These automatic variable are used just inside the function.
Signed-off-by: Frediano Ziglio
---
server/dcc.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/server/dcc.c b/server/dcc.c
index 99aadf0..4f458ec 100644
--- a/server/dcc.c
+++ b/server/dcc.c
@@ -792,9 +792,9 @
The parameter was not used.
Signed-off-by: Frediano Ziglio
---
server/dcc.c | 26 --
1 file changed, 8 insertions(+), 18 deletions(-)
diff --git a/server/dcc.c b/server/dcc.c
index 8fe7fc3..99aadf0 100644
--- a/server/dcc.c
+++ b/server/dcc.c
@@ -725,7 +725,7 @@ glz:
> Christophe Fergeau hat am 8. Februar 2016 um 18:05
> geschrieben:
>
>
> Hey Fabian,
>
> On Mon, Feb 01, 2016 at 10:37:54AM +0100, Fabian Grünbichler wrote:
> > Hello,
> >
> > I noticed a rather strange (IMHO) behavior of spice-gtk regarding SSL
> > certificate verification, and am wondering
40 matches
Mail list logo