On Wed, 2015-11-11 at 09:48 +0100, Victor Toso wrote:
> Hi,
>
> On Tue, Nov 10, 2015 at 05:44:05PM +0100, Pavel Grunt wrote:
> > Hi,
> >
> > this series adds new public function for changing the preferred image
> > compression.
> > The new function is used in spicy under Option -> Preferred Image
According to vdagent fileXfer, it requires a
VD_AGENT_FILE_XFER_STATUS_CANCELLED
msg when user cancel a file transfer. Currently our code only
send VD_AGENT_FILE_XFER_STATUS_ERROR,
this will cause the vdagent lock the file until it restart, you can't
remove the broken file.
diff --git a/src/channe
---
server/red_worker.c | 22 +++---
1 file changed, 11 insertions(+), 11 deletions(-)
diff --git a/server/red_worker.c b/server/red_worker.c
index 8e3be51..4f1d481 100644
--- a/server/red_worker.c
+++ b/server/red_worker.c
@@ -289,7 +289,7 @@ static void red_freeze_glz(DisplayCha
There wasn't as much to split as I thought there would be, but I think it's
still worth considering these changes separately.
Jonathon Jongsma (2):
Rename red_display_free_* to dcc_free_*
Don't abort if encoder cannot be created
Marc-André Lureau (1):
worker: move encoders to dcc-encoders
From: Marc-André Lureau
Author:Marc-André Lureau
---
server/Makefile.am | 2 +
server/dcc-encoders.c| 419
server/dcc-encoders.h| 153 +
server/display-channel.c | 6 +-
server/display-channel.h | 74 ++-
server/red_wor
Instead of using spice_critical() when an encoder cannot be created, use
a warning so that the server doesn't abort.
---
server/dcc-encoders.c | 24 +---
1 file changed, 5 insertions(+), 19 deletions(-)
diff --git a/server/dcc-encoders.c b/server/dcc-encoders.c
index 35edd41..
This commit mostly just moves code to a separate file, but it also includes a
couple changes:
Converts several critical messages to warnings. moves some data from RedWorker
to DisplayChannelClient (e.g. jpeg_data). As such, I think it's worth splitting
this into separate commits so that we can rev
On Tue, 2015-11-17 at 16:37 +, Frediano Ziglio wrote:
> From: Marc-André Lureau
>
> Make sure an allocated buffer is correctly referenced by the marshaller,
> and can't be free and reused by mistake. Simplify the code by using
> GSlice
> ---
> server/display-channel.h | 3 --
> server/red_
Alternate version of this patch sent (and ACKed) in the earlier thread. see
http://lists.freedesktop.org/archives/spice-devel/2015-November/023703.html
On Tue, 2015-11-17 at 16:37 +, Frediano Ziglio wrote:
> From: Marc-André Lureau
>
> ---
> server/display-channel.c | 526 +
I think Fabiano already ACKed this one. It just has a slightly more explicit
commit log subject now.
On Tue, 2015-11-17 at 16:37 +, Frediano Ziglio wrote:
> From: Jonathon Jongsma
>
> ---
> server/display-channel.h | 5 +
> server/red_worker.c | 375 +
ACK
On Tue, 2015-11-17 at 16:37 +, Frediano Ziglio wrote:
> From: Marc-André Lureau
>
> ---
> server/display-channel.h | 2 +
> server/red_worker.c | 178 +-
> -
> server/stream.c | 174 +
ACK
We can revisit the print_stats() issue later if necessary.
On Tue, 2015-11-17 at 13:20 -0500, Frediano Ziglio wrote:
> ---
> server/display-channel.c | 538
> server/display-channel.h | 11 +
> server/red_worker.c | 566 ++--
ACK
On Tue, 2015-11-17 at 18:55 +0100, Marc-André Lureau wrote:
> "path" points to "uri" memory, move free(uri) later.
>
> Found thanks to valgrind :)
>
> Signed-off-by: Marc-André Lureau
> ---
> src/spice-session.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/src/
See related protocol changes.
Signed-off-by: Marc-André Lureau
---
common/messages.h | 16
1 file changed, 16 insertions(+)
diff --git a/common/messages.h b/common/messages.h
index 5f5de54..2a5fabb 100644
--- a/common/messages.h
+++ b/common/messages.h
@@ -634,6 +634,22 @@ type
The marshaller can't serialize fd in memory stream. Instead, append the
fd to the marshaller structure. The marshaller user is responsible for
sending the fd when the message is sent. The fd to send can be retrieved
with spice_marshaller_get_fd().
Note: only a single fd is supported with this API,
---
server/display-channel.c | 538
server/display-channel.h | 11 +
server/red_worker.c | 566 ++-
server/red_worker.h | 1 +
4 files changed, 570 insertions(+), 546 deletions(-)
diff --git a/s
I generated a diff without the move, see
http://pastebin.com/4G6BtBff
>
> On Fri, 2015-11-13 at 10:29 -0600, Jonathon Jongsma wrote:
> > From: Marc-André Lureau
> >
> > ---
> > server/display-channel.c | 526
> >
> > server/display-channel.h | 15
Add a new type, "unix_fd", used to describe file descriptor sharing via
socket ancillary data (these messages are local only).
The marshaller/demarshaller can't serialize this in memory (consume_fd
implementation is empty), so it is the responsability of the marshaller
user to handle sending and r
Add 2 new messages to the display channel to stream pre-rendered GL
images of the display. This is only possible when the client supports
SPICE_DISPLAY_CAP_GL_SCANOUT capability.
The first message, SPICE_MSG_DISPLAY_GL_SCANOUT_UNIX, sends a gl image
file handle via socket ancillary data, and can b
"path" points to "uri" memory, move free(uri) later.
Found thanks to valgrind :)
Signed-off-by: Marc-André Lureau
---
src/spice-session.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/spice-session.c b/src/spice-session.c
index c673fa2..a36dcea 100644
--- a/src/spice-s
ACK
On Tue, 2015-11-17 at 12:07 -0500, Frediano Ziglio wrote:
> Also rename some functions slightly:
> __find_shadow -> tree_item_find_shadow()
> __contained_by -> tree_item_contained_by()
> ring_of -> tree_item_container_items();
>
> Acked-by: Fabiano Fidêncio
> ---
> server/red
Also rename some functions slightly:
__find_shadow -> tree_item_find_shadow()
__contained_by -> tree_item_contained_by()
ring_of -> tree_item_container_items();
Acked-by: Fabiano Fidêncio
---
server/red_worker.c | 62 ++---
server/tr
Hmm, it doesn't seem that this patch changed since the last version you sent.
Except some of the context is slightly different, perhaps because of re
-ordering? (e.g. exclude_region has a RedWorker* as the first parameter in this
patch. In the previous patch, it had DisplayChannel* as the first par
From: Marc-André Lureau
Author:Marc-André Lureau
---
server/Makefile.am | 2 +
server/dcc-encoders.c| 405 +
server/dcc-encoders.h| 153 +
server/display-channel.c | 6 +-
server/display-channel.h | 74 ++
server/red_worker.
From: Marc-André Lureau
Make sure an allocated buffer is correctly referenced by the marshaller,
and can't be free and reused by mistake. Simplify the code by using
GSlice
---
server/display-channel.h | 3 --
server/red_worker.c | 111 +++
2 fil
From: Jonathon Jongsma
---
server/display-channel.h | 5 +
server/red_worker.c | 375 +--
server/stream.c | 359 +
server/stream.h | 9 ++
4 files changed, 378 insertions(+), 370 de
From: Marc-André Lureau
---
server/display-channel.c | 526 +++
server/display-channel.h | 15 +-
server/red_worker.c | 566 ++-
server/red_worker.h | 1 +
4 files changed, 560 insertions(+), 548 del
From: Marc-André Lureau
---
server/display-channel.h | 2 +
server/red_worker.c | 178 +--
server/stream.c | 174 +
server/stream.h | 3 +
4 files changed, 180 insertions(+), 177 de
From: Jonathon Jongsma
Also rename some functions slightly:
__find_shadow -> tree_item_find_shadow()
__contained_by -> tree_item_contained_by()
ring_of -> tree_item_container_items();
Acked-by: Fabiano Fidêncio
---
server/red_worker.c | 62 ++-
This patchset supersedes last patchset.
Changes:
- rebased;
- added "worker: move stream_agent_stop and friends" and
merged with "Move dcc_create_stream to display channel";
- merged "Add red_worker_get_clockid()" back;
- added back some patches waiting for some author confirmation.
I removed n
On Tue, 2015-11-17 at 08:59 -0500, Frediano Ziglio wrote:
> >
> > On Mon, 2015-11-16 at 15:02 +0100, Fabiano Fidêncio wrote:
> > > On Mon, Nov 16, 2015 at 12:06 PM, Frediano Ziglio
> > > wrote:
> > > > From: Jonathon Jongsma
> > > >
> > > > ---
> > > > server/display-channel.h | 5 +
> > > >
On Tue, 2015-11-17 at 15:50 +0100, Christophe Fergeau wrote:
> On Tue, Nov 17, 2015 at 07:27:22AM -0500, Frediano Ziglio wrote:
> > Cfr https://en.wikipedia.org/wiki/Spaghetti and
> > https://en.wikipedia.org/wiki/Spaghetti_code!
> >
> > As today part of the team involved in the refactoring review
>
> On Mon, 2015-11-16 at 13:20 +0100, Pavel Grunt wrote:
> > Hi,
> >
> > it is not moved, it is just making it public. Can it be moved from
> > red_worker.c?
>
>
> Yeah, this is another commit that I debated whether to separate or not, and
> also
> debated whether to actually move the implemen
On Tue, Nov 17, 2015 at 07:27:22AM -0500, Frediano Ziglio wrote:
> Cfr https://en.wikipedia.org/wiki/Spaghetti and
> https://en.wikipedia.org/wiki/Spaghetti_code!
>
> As today part of the team involved in the refactoring review is on holiday I
> started looking at the average direction and state o
Remove some nested blocks using else if.
Signed-off-by: Frediano Ziglio
---
server/red_worker.c | 34 +++---
1 file changed, 15 insertions(+), 19 deletions(-)
diff --git a/server/red_worker.c b/server/red_worker.c
index 3a718fd..986908d 100644
--- a/server/red_worker
>
> On Mon, 2015-11-16 at 15:02 +0100, Fabiano Fidêncio wrote:
> > On Mon, Nov 16, 2015 at 12:06 PM, Frediano Ziglio
> > wrote:
> > > From: Jonathon Jongsma
> > >
> > > ---
> > > server/display-channel.h | 5 +
> > > server/red_worker.c | 376
> > > +
make sure code compile with statistics enabled or disabled.
Dummy (empty) structures and functions are used instead of preprocessor.
Also fix a problem as stat_compress_init did not initialize clock
field.
Signed-off-by: Frediano Ziglio
---
server/display-channel.c | 2 --
server/display-channe
Mainly this set of patches try to reduce usage of preprocessor
and retaining optimization.
This make possible to check code (beside code that print
statistics) with single set of configure options.
Patch is still RFC for different reasons:
- compress and normal statistics are not separate
and st
Make sure code compile with and without statistics enabled (beside
printing functions).
Signed-off-by: Frediano Ziglio
---
server/tests/.gitignore | 5 +++
server/tests/Makefile.am | 35
server/tests/stat-main.c | 49
server/tests/stat-test.c |
Cfr https://en.wikipedia.org/wiki/Spaghetti and
https://en.wikipedia.org/wiki/Spaghetti_code!
As today part of the team involved in the refactory review is on holiday I
started looking at the average direction and state of this refactory.
I looked at different angles like:
1- where we are;
2- wha
40 matches
Mail list logo