Re: [Spice-devel] [spice-gtk Win32 v4 00/17] usbredir support for Windows (mingw)

2012-07-08 Thread Uri Lublin
Hi Hans, On 07/06/2012 09:53 AM, Hans de Goede wrote: I've reviewed all of the patches, I've comments to a few of them, see my individual replies to them. Overall the patchset looks good. Thanks for reviewing this patch-set. I've fixed most/all of your comments in V5. Although I hope in the

Re: [Spice-devel] [spice-gtk Win32 v4 00/17] usbredir support for Windows (mingw)

2012-07-08 Thread Uri Lublin
On 07/06/2012 01:38 AM, Marc-André Lureau wrote: Hi Thanks for the update, it would be nice if you could rebase, putting the trivial patch first, so we could ack them and any further iteration would have less patches. Or alternatively, send those patches as a seperate series if you prefer. This

Re: [Spice-devel] [spice-gtk Win32 v4 06/17] Windows mingw: usb: Dynamically install a libusb driver for USB devices

2012-07-08 Thread Uri Lublin
On 07/06/2012 09:46 AM, Hans de Goede wrote: Hi, On 07/05/2012 10:43 PM, Uri Lublin wrote: - Added win-usb-driver-install.[ch] - Added win-usb-clerk.h Operation (on Windows, spice-gtk point of view): - After some sanity checks, just before redir'ing a USB device a libusb driver needs to be

Re: [Spice-devel] [spice-gtk Win32 v4 06/17] Windows mingw: usb: Dynamically install a libusb driver for USB devices

2012-07-08 Thread Uri Lublin
On 07/06/2012 01:28 AM, Marc-André Lureau wrote: some remarks below On Thu, Jul 5, 2012 at 10:43 PM, Uri Lublin wrote: @@ -635,7 +649,7 @@ static void spice_usb_device_manager_add_dev(SpiceUsbDeviceManager *self, spice_usb_device_manager_connect_device_async(self,

Re: [Spice-devel] [spice-gtk Win32 v4 03/17] Make SpiceUsbDevice a box for SpiceUsbDeviceInfo, instead of a box for libusb_device

2012-07-08 Thread Uri Lublin
On 07/06/2012 09:40 AM, Hans de Goede wrote: -if (guest_filter_rules && -usbredirhost_check_device_filter( +if (guest_filter_rules) { +gboolean filter_ok; +libusb_device *ldev; +ldev = spice_usb_device_manager_device_to_libdev(self, device); +

Re: [Spice-devel] [spice-gtk Win32 v4 03/17] Make SpiceUsbDevice a box for SpiceUsbDeviceInfo, instead of a box for libusb_device

2012-07-08 Thread Uri Lublin
On 07/06/2012 12:46 AM, Marc-André Lureau wrote: On Thu, Jul 5, 2012 at 11:26 PM, Marc-André Lureau wrote: On Thu, Jul 5, 2012 at 10:43 PM, Uri Lublin wrote: +gboolean filter_ok = FALSE; Actually, I think "auto_ok" was a more readable name here, since it affects only the "auto" code pat

Re: [Spice-devel] [spice-gtk Win32 v4 03/17] Make SpiceUsbDevice a box for SpiceUsbDeviceInfo, instead of a box for libusb_device

2012-07-08 Thread Uri Lublin
On 07/06/2012 12:26 AM, Marc-André Lureau wrote: On Thu, Jul 5, 2012 at 10:43 PM, Uri Lublin wrote: +gboolean filter_ok = FALSE; Actually, I think "auto_ok" was a more readable name here, since it affects only the "auto" code path. I renamed it "filter_ok" as it checks the filter. Now

Re: [Spice-devel] [spice-gtk Win32 v4 02/17] Introduce SpiceUsbDeviceInfo to be kept instead of a libusb_device

2012-07-08 Thread Uri Lublin
On 07/06/2012 09:30 AM, Hans de Goede wrote: Looking at the next patch in the series, I've one more remark on this one: On 07/05/2012 10:43 PM, Uri Lublin wrote: +static SpiceUsbDeviceInfo *spice_usb_device_set_info(libusb_device *libdev) +{ +SpiceUsbDeviceInfo *info; +struct libusb_d

Re: [Spice-devel] [spice-gtk Win32 v4 02/17] Introduce SpiceUsbDeviceInfo to be kept instead of a libusb_device

2012-07-08 Thread Uri Lublin
On 07/06/2012 09:26 AM, Hans de Goede wrote: On 07/05/2012 10:43 PM, Uri Lublin wrote: +typedef struct _SpiceUsbDeviceInfo { +#ifdef USE_USBREDIR +guint8 busnum; +guint8 devaddr; +guint16 vid; +guint16 pid; +int ref; +#endif +} SpiceUsbDeviceInfo; + #ifdef USE_USBRED

Re: [Spice-devel] [spice-gtk Win32 v4 02/17] Introduce SpiceUsbDeviceInfo to be kept instead of a libusb_device

2012-07-08 Thread Uri Lublin
On 07/06/2012 12:21 AM, Marc-André Lureau wrote: On Thu, Jul 5, 2012 at 10:43 PM, Uri Lublin wrote: +ref = atomic_dec(&info->ref); +if (ref == 0) { +memset(info, 0, sizeof(*info)); +g_free(info); +} we should really be using the g_atomic operations. g_atomic_int_dec

[Spice-devel] spicy usbredir with USB mass storage device spend 30~60 seconds

2012-07-08 Thread Lv Basen
HI all: I have setup a box running spicy with usb redirection, when pulg-in a usb mass storage device( 200GB ) in the box, It shoud spend 60 seconds, then we can found the usb device in virtual machine os. I enabled the debug log with --enable-debug-log=yes when configure libus

Re: [Spice-devel] [PATCH] server/red_worker: death to spice_printerr, too verbose by far

2012-07-08 Thread Alon Levy
On Sat, Jul 07, 2012 at 03:26:22PM -0500, Jeremy White wrote: > On 07/06/2012 01:47 PM, Jeremy White wrote: > > On 07/05/2012 04:38 AM, Alon Levy wrote: > >> Replaced mostly with spice_debug, but spice_warning & spice_error as > >> well where appropriate. > > > > Boy, I do like this patch, but odd

[Spice-devel] Failure to compile spice-gtk : desktop-integration.c:175:30: error: unused variable 'self'

2012-07-08 Thread Yaniv Kaul
Git hash 2157ea0bf87989ccc29814aece3fa7f434f25840: CC spice-widget-enums.lo desktop-integration.c: In function 'spice_desktop_integration_dispose': desktop-integration.c:175:30: error: unused variable 'self' [-Werror=unused-variable] ___ Spice-d