Module Name:src
Committed By: rillig
Date: Sat Aug 29 07:05:12 UTC 2020
Modified Files:
src/usr.bin/make: main.c
Log Message:
make(1): rename confusing function ReadAllMakefiles
The old name implied that the function would read multiple files, which
was not the case.
The
Module Name:src
Committed By: rillig
Date: Sat Aug 29 07:13:17 UTC 2020
Modified Files:
src/usr.bin/make: main.c
Log Message:
make(1): clean up code in make.c
Var_Subst never returns NULL.
In Main_ExportMAKEFLAGS, don't compare ints with booleans.
In MainParseArgs, use
Module Name:src
Committed By: maxv
Date: Sat Aug 29 07:14:17 UTC 2020
Modified Files:
src/sys/dev/nvmm: nvmm.c
Log Message:
nvmm: explicitly include atomic.h
To generate a diff of this commit:
cvs rdiff -u -r1.36 -r1.37 src/sys/dev/nvmm/nvmm.c
Please note that diffs are
Module Name:src
Committed By: maxv
Date: Sat Aug 29 07:14:50 UTC 2020
Modified Files:
src/sys/net: if_tun.c
Log Message:
Correct my rev1.159, it was incomplete, the check must be done later
because the value can change in the meantime (and get set to zero).
To generate a
Module Name:src
Committed By: maxv
Date: Sat Aug 29 07:16:04 UTC 2020
Modified Files:
src/sys/arch/amd64/amd64: spl.S
Log Message:
'doreti_checkast' isn't global anymore, localify.
To generate a diff of this commit:
cvs rdiff -u -r1.46 -r1.47 src/sys/arch/amd64/amd64/spl
Module Name:src
Committed By: maxv
Date: Sat Aug 29 07:17:23 UTC 2020
Modified Files:
src/sys/arch/aarch64/aarch64: locore_el2.S
src/sys/arch/aarch64/include: hypervisor.h
Log Message:
Slightly clarify, and style.
To generate a diff of this commit:
cvs rdiff -u -
Module Name:src
Committed By: tih
Date: Sat Aug 29 07:22:49 UTC 2020
Modified Files:
src/tests/net/if_wg: t_misc.sh t_tunnel.sh
Log Message:
Update the if_wg tests for the human readable 'latest-handshake'
output of wgconfig.
To generate a diff of this commit:
cvs rdiff
Module Name:src
Committed By: rillig
Date: Sat Aug 29 07:52:56 UTC 2020
Modified Files:
src/usr.bin/make: main.c make.h nonints.h parse.c str.c var.c
Log Message:
make(1): allow for strict type checking for Boolean
Having Boolean aliased to int creates ambiguities since i
Module Name:src
Committed By: rillig
Date: Sat Aug 29 08:09:07 UTC 2020
Modified Files:
src/usr.bin/make: compat.c make.h
Log Message:
make(1): add another Boolean variant to check during development
To generate a diff of this commit:
cvs rdiff -u -r1.132 -r1.133 src/usr
Module Name:src
Committed By: rillig
Date: Sat Aug 29 08:59:08 UTC 2020
Modified Files:
src/usr.bin/make: main.c
Log Message:
make(1): fix null pointer dereference when sys.mk is not found
This is quite hard to trigger in a real-life scenario since it requires
precise tim
Module Name:src
Committed By: rillig
Date: Sat Aug 29 09:30:10 UTC 2020
Modified Files:
src/usr.bin/make: arch.c cond.c dir.c lst.c lst.h main.c
Log Message:
make(1): start replacing Lst_Find with Lst_FindB
Lst_Find is called with a "comparison" function that returns the
Module Name:src
Committed By: nia
Date: Sat Aug 29 09:57:46 UTC 2020
Update of /cvsroot/src/share/terminfo
In directory ivanova.netbsd.org:/tmp/cvs-serv8914
Log Message:
Import terminfo-20200606.src
Status:
Vendor Tag: NCURSES
Release Tags: terminfo-20200606
Module Name:src
Committed By: rillig
Date: Sat Aug 29 10:06:23 UTC 2020
Modified Files:
src/usr.bin/make: lst.c lst.h meta.c suff.c
Log Message:
make(1): migrate remaining Lst_Find to Lst_FindB
While here, rename SuffSuffIsSuffix to SuffSuffGetSuffix since a
function name
Module Name:src
Committed By: rillig
Date: Sat Aug 29 10:12:06 UTC 2020
Modified Files:
src/usr.bin/make: arch.c cond.c dir.c lst.c lst.h main.c meta.c suff.c
Log Message:
make(1): rename Lst_FindB back to Lst_Find
The migration from "comparison function" to "match functi
Module Name:src
Committed By: rillig
Date: Sat Aug 29 10:32:00 UTC 2020
Modified Files:
src/usr.bin/make: for.c
Log Message:
make(1): remove duplicate code for allocation a substring
To generate a diff of this commit:
cvs rdiff -u -r1.65 -r1.66 src/usr.bin/make/for.c
Pl
Module Name:src
Committed By: rillig
Date: Sat Aug 29 10:35:03 UTC 2020
Modified Files:
src/usr.bin/make: job.c
Log Message:
make(1): clean up indentation, comments and variable scope in job.c
To generate a diff of this commit:
cvs rdiff -u -r1.221 -r1.222 src/usr.bin/ma
Module Name:src
Committed By: rillig
Date: Sat Aug 29 10:41:13 UTC 2020
Modified Files:
src/usr.bin/make: dir.c job.c lst.c lst.h main.c meta.c suff.c
Log Message:
make(1): rename LstNode functions to match their type
To generate a diff of this commit:
cvs rdiff -u -r1.1
Module Name:src
Committed By: rillig
Date: Sat Aug 29 10:52:47 UTC 2020
Modified Files:
src/usr.bin/make/unit-tests: Makefile opt-debug-g1.exp
Log Message:
make(1): fix test opt-debug-g1
Including the directory cache made the test output fragile.
To generate a diff of t
Module Name:src
Committed By: rillig
Date: Sat Aug 29 11:13:43 UTC 2020
Modified Files:
src/usr.bin/make: hash.h parse.c suff.c
Log Message:
make(1): merge duplicate code for bmake_strldup
To generate a diff of this commit:
cvs rdiff -u -r1.18 -r1.19 src/usr.bin/make/has
Module Name:src
Committed By: rillig
Date: Sat Aug 29 11:24:54 UTC 2020
Modified Files:
src/usr.bin/make: make_malloc.c make_malloc.h parse.c suff.c var.c
Log Message:
make(1): add bmake_strsedup for duplicating a substring
To generate a diff of this commit:
cvs rdiff -u
Module Name:src
Committed By: rillig
Date: Sat Aug 29 12:01:47 UTC 2020
Modified Files:
src/usr.bin/make: nonints.h suff.c
Log Message:
make(1): clean up comments in suff.c, small refactorings
In SuffParseTransform, the parameter names have been renamed to make the
"side
Module Name:src
Committed By: rillig
Date: Sat Aug 29 12:20:17 UTC 2020
Modified Files:
src/usr.bin/make: arch.c job.c job.h make.h parse.c
Log Message:
make(1): remove ReturnStatus, SUCCESS and FAILURE
These are used in so few places now that it is easier to use a simple
Module Name:src
Committed By: rillig
Date: Sat Aug 29 12:27:10 UTC 2020
Modified Files:
src/usr.bin/make: var.c
Log Message:
make(1): split ApplyModifier_To into paragraphs
To generate a diff of this commit:
cvs rdiff -u -r1.474 -r1.475 src/usr.bin/make/var.c
Please not
Module Name:src
Committed By: rillig
Date: Sat Aug 29 12:36:20 UTC 2020
Modified Files:
src/usr.bin/make: compat.c
Log Message:
make(1): clean up documentation for CompatInterrupt and Compat_Run
To generate a diff of this commit:
cvs rdiff -u -r1.133 -r1.134 src/usr.bin/
Module Name:src
Committed By: rillig
Date: Sat Aug 29 12:39:32 UTC 2020
Modified Files:
src/usr.bin/make: dir.c
Log Message:
make(1): clean up comments in dir.c
To generate a diff of this commit:
cvs rdiff -u -r1.123 -r1.124 src/usr.bin/make/dir.c
Please note that diffs
Module Name:src
Committed By: rillig
Date: Sat Aug 29 12:48:17 UTC 2020
Modified Files:
src/usr.bin/make: var.c
Log Message:
make(1): add comments for ModifyWord_Subst
Without any comments, the code is unnecessarily hard to follow.
To generate a diff of this commit:
cvs
Module Name:src
Committed By: rillig
Date: Sat Aug 29 13:04:30 UTC 2020
Modified Files:
src/usr.bin/make: main.c
Log Message:
make(1): make getBoolean simpler
This function is so seldom used that there is no point having
complicated code for it.
To generate a diff of th
Module Name:src
Committed By: rillig
Date: Sat Aug 29 13:16:55 UTC 2020
Modified Files:
src/usr.bin/make: main.c make.c meta.c suff.c var.c
Log Message:
make(1): trust that Var_Subst never returns NULL
It really never does, and it doesn't even report errors. It just
retu
Module Name:src
Committed By: fcambus
Date: Sat Aug 29 13:32:27 UTC 2020
Modified Files:
src/share/man/man5: remote.5
src/share/man/man7: setuid.7
src/share/man/man8/man8.sandpoint: altboot.8
src/share/man/man8/man8.sparc: boot.8
src/share/ma
Module Name:src
Committed By: rillig
Date: Sat Aug 29 13:38:48 UTC 2020
Modified Files:
src/usr.bin/make: arch.c cond.c parse.c suff.c var.c
Log Message:
make(1): trust that Var_Parse never returns NULL
That function is quite long, but all its return paths lead either to
Module Name:src
Committed By: rillig
Date: Sat Aug 29 14:47:26 UTC 2020
Modified Files:
src/distrib/sets/lists/tests: mi
src/usr.bin/make: compat.c
src/usr.bin/make/unit-tests: Makefile
Added Files:
src/usr.bin/make/unit-tests: archive-suffix.exp arc
Module Name:src
Committed By: christos
Date: Sat Aug 29 15:05:33 UTC 2020
Modified Files:
src/external/bsd/libpcap: Makefile.inc
Log Message:
PR/55599: Valery Ushakov: libpcap gets SIGBUS on strictly aligned CPUs
Define LBL_ALIGN as suggested
To generate a diff of this c
Module Name:src
Committed By: rillig
Date: Sat Aug 29 15:06:33 UTC 2020
Modified Files:
src/usr.bin/make/unit-tests: depsrc-ignore.exp depsrc-ignore.mk
Log Message:
make(1): add test for the special .IGNORE dependency source
To generate a diff of this commit:
cvs rdiff -
Module Name:src
Committed By: thorpej
Date: Sat Aug 29 15:16:12 UTC 2020
Modified Files:
src/sys/arch/alpha/alpha: prom.c
Log Message:
Make sure init_prom_interface() only runs once, otherwise we initialize
a mutex twice, and that upsets LOCKDEBUG. But instead of seeing a
Module Name:src
Committed By: rillig
Date: Sat Aug 29 15:25:57 UTC 2020
Modified Files:
src/lib/libc/stdio: stdio.3
Log Message:
stdio(3): fix typos in the manual page
fputc cannot read characters, it can only write them.
To generate a diff of this commit:
cvs rdiff -u
Module Name:src
Committed By: thorpej
Date: Sat Aug 29 15:29:30 UTC 2020
Modified Files:
src/sys/arch/alpha/alpha: interrupt.c
Log Message:
In ipl2psl_table[], use IPL_SCHED instead of IPL_CLOCK (the legacy name),
and add a comment noting that this is the level IPIs come i
Module Name:src
Committed By: thorpej
Date: Sat Aug 29 16:00:36 UTC 2020
Modified Files:
src/sys/arch/alpha/conf: GENERIC
Log Message:
Enable DIAGNOSTIC by default in -current. Should be commented out
in release branches. Add commented-out LOCKDEBUG option.
To generate
Module Name:src
Committed By: christos
Date: Sat Aug 29 16:07:11 UTC 2020
Modified Files:
src/external/mpl/bind/dist/lib/isc/unix: socket.c
Log Message:
Locking protocol changed again, unlock after send/recv
To generate a diff of this commit:
cvs rdiff -u -r1.17 -r1.18 s
Module Name:src
Committed By: rillig
Date: Sat Aug 29 16:13:27 UTC 2020
Modified Files:
src/usr.bin/make/unit-tests: depsrc-ignore.mk
Log Message:
make(1): explain the shuffled messages in the test output
To generate a diff of this commit:
cvs rdiff -u -r1.3 -r1.4 src/us
Module Name:src
Committed By: rillig
Date: Sat Aug 29 16:47:45 UTC 2020
Modified Files:
src/usr.bin/make: make_malloc.c make_malloc.h
Log Message:
make(1): fix build with -DUSE_EMALLOC
To generate a diff of this commit:
cvs rdiff -u -r1.16 -r1.17 src/usr.bin/make/make_ma
Module Name:src
Committed By: martin
Date: Sat Aug 29 17:00:28 UTC 2020
Modified Files:
src/sys/dev/nvmm [netbsd-9]: nvmm.c nvmm_ioctl.h
src/sys/dev/nvmm/x86 [netbsd-9]: nvmm_x86.c nvmm_x86_svm.c
nvmm_x86_svmfunc.S nvmm_x86_vmx.c nvmm_x86_vmxfunc.S
Log
Module Name:src
Committed By: martin
Date: Sat Aug 29 17:02:36 UTC 2020
Modified Files:
src/sys/arch/alpha/alpha [netbsd-9]: prom.c
Log Message:
Pull up following revision(s) (requested by thorpej in ticket #1069):
sys/arch/alpha/alpha/prom.c: revision 1.52
Make
Module Name:src
Committed By: martin
Date: Sat Aug 29 17:03:39 UTC 2020
Modified Files:
src/doc [netbsd-9]: CHANGES-9.1
Log Message:
Tickets #1068 and #1069
To generate a diff of this commit:
cvs rdiff -u -r1.1.2.104 -r1.1.2.105 src/doc/CHANGES-9.1
Please note that diff
Module Name:src
Committed By: rillig
Date: Sat Aug 29 17:34:21 UTC 2020
Modified Files:
src/usr.bin/make/unit-tests: depsrc-silent.exp depsrc-silent.mk
deptgt-begin.exp deptgt-begin.mk deptgt-end.exp deptgt-end.mk
Log Message:
make(1): add tests for .SILENT, .B
Module Name:src
Committed By: christos
Date: Sat Aug 29 17:41:14 UTC 2020
Modified Files:
src/sys/netinet: in.c
Log Message:
Partially revert previous: set RTF_HOST regardless of mask for point-to-point
links. Unbreaks IPSEC/L2TP configurations.
To generate a diff of thi
Module Name:src
Committed By: rillig
Date: Sat Aug 29 18:50:25 UTC 2020
Modified Files:
src/distrib/sets/lists/tests: mi
src/usr.bin/make/unit-tests: Makefile directive-else.exp
directive-else.mk
Added Files:
src/usr.bin/make/unit-tests: directiv
Module Name:src
Committed By: christos
Date: Sat Aug 29 18:54:33 UTC 2020
Modified Files:
src/share/misc: acronyms
Log Message:
add WGACA
To generate a diff of this commit:
cvs rdiff -u -r1.305 -r1.306 src/share/misc/acronyms
Please note that diffs are not public domain
Module Name:src
Committed By: jakllsch
Date: Sat Aug 29 19:06:18 UTC 2020
Modified Files:
src/sys/arch/arm/nvidia: files.tegra tegra_xusb.c
src/sys/arch/evbarm/conf: mk.generic
Removed Files:
src/sys/arch/arm/nvidia: tegra_xusb-fw.mk
Log Message:
tegra_xusb
Module Name:src
Committed By: thorpej
Date: Sat Aug 29 19:06:33 UTC 2020
Modified Files:
src/sys/arch/alpha/alpha: machdep.c
src/sys/arch/alpha/include: cpu.h
Log Message:
- cpu_need_resched(): Explicitly cover each RESCHED_* case, and add a
comment explaining wh
Module Name:src
Committed By: rillig
Date: Sat Aug 29 19:07:32 UTC 2020
Modified Files:
src/usr.bin/make/unit-tests: Makefile directive-ifmake.exp
directive-ifmake.mk
Log Message:
make(1): add test for the .ifmake directive
To generate a diff of this commit:
Module Name:src
Committed By: christos
Date: Sat Aug 29 19:27:08 UTC 2020
Modified Files:
src/sbin/route: route.8
Log Message:
Document 'L'
To generate a diff of this commit:
cvs rdiff -u -r1.61 -r1.62 src/sbin/route/route.8
Please note that diffs are not public domain;
Module Name:src
Committed By: christos
Date: Sat Aug 29 19:27:40 UTC 2020
Modified Files:
src/sbin/route: rtutil.c
Log Message:
Instead of defining RTF_LLINFO, use RTF_LLDATA
To generate a diff of this commit:
cvs rdiff -u -r1.10 -r1.11 src/sbin/route/rtutil.c
Please no
Module Name:src
Committed By: christos
Date: Sat Aug 29 19:28:32 UTC 2020
Modified Files:
src/sbin/route: show.c
Log Message:
Make the "interesting" flags match the netstat ones, so:
route show -inet
netstat -r -f inet
outputs match.
To generate a diff of this
Module Name:src
Committed By: rillig
Date: Sat Aug 29 19:35:39 UTC 2020
Modified Files:
src/usr.bin/make/unit-tests: Makefile sh-dots.exp
Log Message:
make(1): fix sh-dots test
The exact output depends on the shell. Some shells prefix the error
message with their name, s
Module Name:src
Committed By: thorpej
Date: Sat Aug 29 20:07:00 UTC 2020
Modified Files:
src/sys/arch/alpha/alpha: cpu.c ipifuncs.c pmap.c vm_machdep.c
src/sys/arch/alpha/include: cpu.h intr.h pmap.h
Log Message:
- Centralize per-CPU pmap initialization into a new
Module Name:src
Committed By: thorpej
Date: Sat Aug 29 20:08:08 UTC 2020
Modified Files:
src/sys/arch/alpha/include: vmparam.h
Log Message:
Bump UBC_WINSHIFT to 16 (64KB), and UBC_NWINS to 4096 (256MB total).
Alpha has plenty of KVA to use for this.
To generate a diff of
Module Name:src
Committed By: rillig
Date: Sat Aug 29 20:20:44 UTC 2020
Modified Files:
src/usr.bin/make: targ.c
Log Message:
make(1): use loops instead of Lst_ForEach for propagating to cohorts
For one-liners, Lst_ForEach creates a lot of overhead, both at runtime
and fo
Module Name:src
Committed By: uwe
Date: Sat Aug 29 21:42:25 UTC 2020
Modified Files:
src/share/man/man8: compat_bsdos.8
Log Message:
Minor wording tweaks from Dan Plassche.
To generate a diff of this commit:
cvs rdiff -u -r1.3 -r1.4 src/share/man/man8/compat_bsdos.8
Ple
Module Name:src
Committed By: macallan
Date: Sat Aug 29 22:33:53 UTC 2020
Modified Files:
src/sys/dev/adb: adb_keymap.h
Log Message:
properly map left Command to Meta_L and left Option to Alt_L
Mostly for correctness, should help non-US layouts
To generate a diff of this
Module Name:src
Committed By: macallan
Date: Sat Aug 29 22:42:53 UTC 2020
Modified Files:
src/sys/dev/hid: hidkbdmap.c
src/sys/dev/wscons: wsksymdef.h
Log Message:
provide KB_APPLE layout variant which uses Command-F* to switch console screens
mostly for consistent
Module Name:src
Committed By: thorpej
Date: Sat Aug 29 22:50:27 UTC 2020
Modified Files:
src/sys/arch/alpha/include: asm.h
Log Message:
G/C GET_IDLE_PCB -- it hasn't been used for some time.
To generate a diff of this commit:
cvs rdiff -u -r1.38 -r1.39 src/sys/arch/alpha
Module Name:src
Committed By: macallan
Date: Sat Aug 29 23:00:10 UTC 2020
Modified Files:
src/sys/arch/macppc/conf: std.macppc
Log Message:
make us.apple the default USB keyboard layout
To generate a diff of this commit:
cvs rdiff -u -r1.24 -r1.25 src/sys/arch/macppc/con
Module Name:src
Committed By: mrg
Date: Sun Aug 30 04:51:03 UTC 2020
Modified Files:
src/distrib/sets/lists/xcomp: mi
src/external/mit/xorg/include/xorgproto: Makefile
Log Message:
install dmxproto.pc and dpmsproto.pc
To generate a diff of this commit:
cvs rdiff
Module Name:xsrc
Committed By: mrg
Date: Sun Aug 30 04:53:28 UTC 2020
Modified Files:
xsrc/external/mit/libX11/dist/man: XCreateGC.man
xsrc/external/mit/libX11/dist/modules/im/ximcp: imRmAttr.c
Log Message:
merge libX11 1.6.12.
To generate a diff of this commit:
Module Name:xsrc
Committed By: mrg
Date: Sun Aug 30 04:52:49 UTC 2020
Update of /cvsroot/xsrc/external/mit/libX11/dist
In directory ivanova.netbsd.org:/tmp/cvs-serv8560
Log Message:
initial import of libX11-1.6.12
Status:
Vendor Tag: xorg
Release Tags: libX11-1-6-12
65 matches
Mail list logo