Module Name:src
Committed By: maxv
Date: Wed Feb 7 08:12:25 UTC 2018
Modified Files:
src/sys/netinet: ip_input.c
Log Message:
Remove null check on ip, it can't be null. (Confuses code scanners.)
To generate a diff of this commit:
cvs rdiff -u -r1.373 -r1.374 src/sys/net
Module Name:src
Committed By: ozaki-r
Date: Wed Feb 7 08:50:13 UTC 2018
Modified Files:
src/sys/ufs/chfs: ebh.c
Log Message:
Remove unnecessary assertions
KASSERT(!rw_lock_held()) just before rw_destroy() is useless because
rw_destroy does more strict check and provides
Module Name:src
Committed By: maxv
Date: Wed Feb 7 09:53:09 UTC 2018
Modified Files:
src/sys/netinet6: frag6.c
Log Message:
Rename back to ip6af_mff. It was actually clearer than ip6af_more.
To generate a diff of this commit:
cvs rdiff -u -r1.65 -r1.66 src/sys/netinet6/
Module Name:src
Committed By: martin
Date: Wed Feb 7 09:55:35 UTC 2018
Modified Files:
src/lib/libc/atomic: atomic_ops.3
Log Message:
Fix typo, from Eitan Adler.
To generate a diff of this commit:
cvs rdiff -u -r1.5 -r1.6 src/lib/libc/atomic/atomic_ops.3
Please note th
Module Name:src
Committed By: martin
Date: Wed Feb 7 09:59:56 UTC 2018
Modified Files:
src/lib/libc/atomic: atomic_ops.3
Log Message:
Bump date for previous
To generate a diff of this commit:
cvs rdiff -u -r1.6 -r1.7 src/lib/libc/atomic/atomic_ops.3
Please note that di
Module Name:src
Committed By: maxv
Date: Wed Feb 7 10:22:00 UTC 2018
Modified Files:
src/sys/netinet6: in6_proto.c
Log Message:
Change ip6_hdrnestlimit to be 15 instead of 50. I couldn't find any
reference in RFCs about what a correct limit should be, but FreeBSD already
Module Name:src
Committed By: maxv
Date: Wed Feb 7 10:52:20 UTC 2018
Modified Files:
src/sys/netinet6: in6_proto.c
Log Message:
Style, and localify IPV6FORWARDING. No functional change.
To generate a diff of this commit:
cvs rdiff -u -r1.120 -r1.121 src/sys/netinet6/in6
Module Name:src
Committed By: pgoyette
Date: Wed Feb 7 11:16:06 UTC 2018
Modified Files:
src/lib/libc/gen: getgrent.3 getpwent.3
src/lib/libc/net: resolver.3
src/lib/libc/stdlib: ptsname.3
src/lib/libc/time: ctime.3 getdate.3
src/lib/libc/yp
Module Name:src
Committed By: maxv
Date: Wed Feb 7 11:42:58 UTC 2018
Modified Files:
src/sys/netinet: igmp.c ip_mroute.c ip_mroute.h
Log Message:
Remove RSVP_ISI, that's mostly dead code. FreeBSD and OpenBSD too removed
it; FreeBSD kept some pieces but they are mostly no-
Module Name:src
Committed By: maxv
Date: Wed Feb 7 12:04:50 UTC 2018
Modified Files:
src/sys/netinet: ip_mroute.c
Log Message:
Style and remove unused macros. More to come.
To generate a diff of this commit:
cvs rdiff -u -r1.149 -r1.150 src/sys/netinet/ip_mroute.c
Plea
Module Name:src
Committed By: maxv
Date: Wed Feb 7 12:09:55 UTC 2018
Modified Files:
src/sys/netinet: ip_mroute.c
Log Message:
Remove parentheses in return statements. No functional change.
To generate a diff of this commit:
cvs rdiff -u -r1.150 -r1.151 src/sys/netinet/
Module Name:src
Committed By: maxv
Date: Wed Feb 7 12:15:32 UTC 2018
Modified Files:
src/sys/netinet: ip_mroute.c
Log Message:
More style. No functional change.
To generate a diff of this commit:
cvs rdiff -u -r1.151 -r1.152 src/sys/netinet/ip_mroute.c
Please note that
Module Name:src
Committed By: christos
Date: Wed Feb 7 13:16:50 UTC 2018
Modified Files:
src/usr.sbin/racoon: Makefile
Log Message:
needs the OpenSSL-1.1 api to build
To generate a diff of this commit:
cvs rdiff -u -r1.30 -r1.31 src/usr.sbin/racoon/Makefile
Please note
Module Name:src
Committed By: christos
Date: Wed Feb 7 13:16:25 UTC 2018
Modified Files:
src/crypto/external/bsd/openssl.old/dist/crypto/dh: dh.h
Log Message:
add set0_key needed by racoon
To generate a diff of this commit:
cvs rdiff -u -r1.7 -r1.8 \
src/crypto/exte
Module Name:src
Committed By: christos
Date: Wed Feb 7 13:18:33 UTC 2018
Modified Files:
src/tests/lib/libc/hash: t_hmac.c
Log Message:
md2 has been deprecated in OpenSSL-1.1
To generate a diff of this commit:
cvs rdiff -u -r1.1 -r1.2 src/tests/lib/libc/hash/t_hmac.c
P
Module Name:src
Committed By: maxv
Date: Wed Feb 7 13:22:42 UTC 2018
Modified Files:
src/sys/netinet: ip_mroute.c
Log Message:
Style and constify.
To generate a diff of this commit:
cvs rdiff -u -r1.152 -r1.153 src/sys/netinet/ip_mroute.c
Please note that diffs are not
Module Name:src
Committed By: maxv
Date: Wed Feb 7 14:03:18 UTC 2018
Modified Files:
src/lib/libkvm: kvm.c
Log Message:
Keep /dev/ksyms open in _kvm_open(). This way /dev/ksyms can be put into
$g_kmem without breaking the tools that need kmem+ksyms.
Discussed on tech-ker
Module Name:src
Committed By: bouyer
Date: Wed Feb 7 14:42:07 UTC 2018
Modified Files:
src/sys/dev/sdmmc: sdmmc_mem.c
Log Message:
Fix uninitialized variable use:
if there is an error, or if we are using a SPI controller,
sdmmc_mem_send_op_cond() doens't assign a value to
Module Name:src
Committed By: manu
Date: Wed Feb 7 15:51:35 UTC 2018
Modified Files:
src/sys/kern: subr_tftproot.c
Log Message:
Fix md(4) double attachment in TFTPROOT option
The mdattach() call in tftproot_dhcpboot() has probably always been
useless, but it seems it bec
Module Name:src
Committed By: prlw1
Date: Wed Feb 7 15:55:58 UTC 2018
Modified Files:
src/sys/dev/usb: xhci.c
Log Message:
xhci.c: avoid unused variable in non-DIAGNOSTIC build
To generate a diff of this commit:
cvs rdiff -u -r1.85 -r1.86 src/sys/dev/usb/xhci.c
Please
Module Name:src
Committed By: jmcneill
Date: Wed Feb 7 20:42:17 UTC 2018
Modified Files:
src/sys/arch/arm/cortex: gic.c
Log Message:
PR# port-evbarm/49468: Cortex GIC assertion triggered on Allwinner A80 SoC
The priority level is changed by writing to GICC_PMR with inter
Module Name:src
Committed By: maya
Date: Wed Feb 7 22:49:32 UTC 2018
Modified Files:
src/sys/arch/x86/x86: identcpu.c
Log Message:
stopgap fix: restrict XSAVEOPT to Intel CPUs
The current code causes floating point miscalculations on AMD Ryzen.
PR port-amd64/52966: amd64
Module Name:src
Committed By: christos
Date: Wed Feb 7 22:51:31 UTC 2018
Modified Files:
src/lib/libradius: Makefile
Log Message:
Oops forgot one openssl version name change
To generate a diff of this commit:
cvs rdiff -u -r1.14 -r1.15 src/lib/libradius/Makefile
Please
Module Name:src
Committed By: jmcneill
Date: Thu Feb 8 00:10:26 UTC 2018
Removed Files:
src/sys/arch/arm/rockchip: files.rockchip obio.c obio_com.c
rockchip_board.c rockchip_cpufreq.c rockchip_crureg.h
rockchip_dma.c rockchip_dwcmmc.c rockchip_dwctm
Module Name:src
Committed By: pgoyette
Date: Thu Feb 8 02:29:37 UTC 2018
Modified Files:
src/share/man/man7: ascii.7
Log Message:
Since this is describing the ASCII character set, use the correct
ASCII abbreviation for character 012. All references I can find
which seem
Module Name:src
Committed By: pgoyette
Date: Thu Feb 8 02:30:08 UTC 2018
Modified Files:
src/share/man/man7: ascii.7
Log Message:
Bump date for previous
To generate a diff of this commit:
cvs rdiff -u -r1.9 -r1.10 src/share/man/man7/ascii.7
Please note that diffs are n
Module Name:src
Committed By: pgoyette
Date: Thu Feb 8 02:37:43 UTC 2018
Modified Files:
src/share/misc: ascii
Log Message:
Since this is the ASCII charactger set, use the ASCII name for the
012 character - "lf" for "line feed", not "nl" for "new line".
Follow-on from PR
Module Name:src
Committed By: pgoyette
Date: Thu Feb 8 02:51:57 UTC 2018
Modified Files:
src/share/man/man7: ascii.7
src/share/misc: ascii
Log Message:
While here, also update 014 - it's name is "ff" ("form feed"), and not
"np" ("new page").
To generate a diff o
Module Name:src
Committed By: pgoyette
Date: Thu Feb 8 03:18:38 UTC 2018
Modified Files:
src/share/man/man7: ascii.7
src/share/misc: ascii
Log Message:
Revert previous changes due to popular demand. Instead, add a note at
the bottom of each document to provide th
Module Name:src
Committed By: christos
Date: Thu Feb 8 03:27:51 UTC 2018
Modified Files:
src/distrib/sets: mkvars.mk sets.subr
src/distrib/sets/lists/base: shl.mi
src/distrib/sets/lists/comp: mi
src/distrib/sets/lists/debug: mi shl.mi
src/di
Module Name:src
Committed By: maxv
Date: Thu Feb 8 06:50:38 UTC 2018
Modified Files:
src/sys/netinet: udp_usrreq.c
Log Message:
Fix three pretty bad mistakes in NAT-T:
* If we got a keepalive packet, we need to call m_freem, not m_free.
Here the next mbufs in the cha
Module Name:src
Committed By: maxv
Date: Thu Feb 8 07:11:20 UTC 2018
Modified Files:
src/sys/netinet: udp_usrreq.c
Log Message:
Style, and remove printfs.
To generate a diff of this commit:
cvs rdiff -u -r1.237 -r1.238 src/sys/netinet/udp_usrreq.c
Please note that diff
Module Name:src
Committed By: mrg
Date: Thu Feb 8 07:48:19 UTC 2018
Modified Files:
src/sys/dev/nand: nand_bbt.c
Log Message:
update for GCC 6:
- nand_bbt_block_mark() has a left-shift of negative value issue.
this change avoids it, but reviewers indicate this function
Module Name:src
Committed By: mrg
Date: Thu Feb 8 07:53:47 UTC 2018
Modified Files:
src/sys/dev/pci: if_et.c
Log Message:
update for GCC 6:
- fix an array bounds violation and pass the right address to ether_crc32_be().
(i assume this actually makes et(4) multicast work
34 matches
Mail list logo