On Fri, 30 Aug 2024 07:37:35 GMT, Thomas Stuefe wrote:
>> make/Images.gmk line 135:
>>
>>> 133: #
>>> 134: # Param1 - VM variant (e.g., server, client, zero, ...)
>>> 135: # Param2 - _nocoops, _coh, _nocoops_coh, or empty
>>
>> The -XX:+UseCompactObjectHeaders ssems to incompatible withe zero v
On Fri, 20 Sep 2024 16:56:58 GMT, Matias Saavedra Silva
wrote:
>> Roman Kennke has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix bit counts in GCForwarding
>
> src/hotspot/share/cds/archiveUtils.cpp line 348:
>
>> 346: old_tag = (i
On Thu, 22 Aug 2024 20:08:43 GMT, Roman Kennke wrote:
>> This is the main body of the JEP 450: Compact Object Headers (Experimental).
>>
>> It is also a follow-up to #20640, which now also includes (and supersedes)
>> #20603 and #20605, plus the Tiny Class-Pointers parts that have been
>> prev
On Wed, 18 Sep 2024 12:35:28 GMT, Roman Kennke wrote:
>> Thinking about this a bit more, maybe _mark needs to be a MetadataField
>> rather than CInt. This is a kind of odd situation. Basically we have a CInt
>> field that is more than just simple bits used as flags or small integers. It
>> als
On Mon, 9 Sep 2024 19:04:13 GMT, Chris Plummer wrote:
>> I pulled your changes and I see one slight difference in the output. The
>> following line is missing:
>>
>> `_metadata._compressed_klass: InstanceKlass for
>> java/util/concurrent/locks/AbstractQueuedSynchronizer$ConditionObject`
>>
>>
On Mon, 9 Sep 2024 16:01:10 GMT, Coleen Phillimore wrote:
>> src/hotspot/share/oops/compressedKlass.hpp line 43:
>>
>>> 41:
>>> 42: // Tiny-class-pointer mode
>>> 43: static int _tiny_cp; // -1, 0=true, 1=false
>>
>> Suggestion:
>>
>> static int _tiny_cp; // -1 = uninitialized, 0 = true
On Tue, 10 Sep 2024 07:53:23 GMT, Roman Kennke wrote:
>> src/hotspot/share/gc/shared/collectedHeap.cpp line 232:
>>
>>> 230: }
>>> 231:
>>> 232: // With compact headers, we can't safely access the class, due
>>
>> Suggestion:
>>
>> // With compact headers, we can't safely access the kla
On Mon, 9 Sep 2024 14:08:53 GMT, Roman Kennke wrote:
>> Yes, I'm interested in it. Thanks for raising the discussion. :)
>
> If anybody is doing it, please send me a patch, or we can do it as a
> follow-up PR.
Thanks. I'll send it to you if I finish it in time, otherwise I will do it in a
sepa
On Mon, 9 Sep 2024 10:21:54 GMT, Thomas Schatzl wrote:
>> Roman Kennke has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix bit counts in GCForwarding
>
> src/hotspot/share/gc/shared/collectedHeap.cpp line 232:
>
>> 230: }
>> 231:
>>
On Mon, 9 Sep 2024 10:16:24 GMT, Thomas Schatzl wrote:
>> Roman Kennke has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix bit counts in GCForwarding
>
> src/hotspot/share/gc/shared/gcForwarding.hpp line 41:
>
>> 39: * bits (to indicat
On Mon, 9 Sep 2024 10:02:53 GMT, Thomas Schatzl wrote:
>> Roman Kennke has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix bit counts in GCForwarding
>
> src/hotspot/share/oops/compressedKlass.hpp line 43:
>
>> 41:
>> 42: // Tiny-cla
On Mon, 9 Sep 2024 18:34:10 GMT, Chris Plummer wrote:
>> I've been looking into this. It's a bit hard to follow but I think you do
>> need to do something more here. Can you run ClhsdbInspect.java and send me
>> the output. In specific I need to know if the log includes the following:
>>
>>
>
On Mon, 9 Sep 2024 16:51:35 GMT, Chris Plummer wrote:
>> There is no dedicated klass field anymore, the Klass* is encoded in the
>> mark, and we would need to extract it. What is the purpose of the visitors?
>> Do they need to see the klass/compressedKlass, or is it sufficient to visit
>> the
On Mon, 9 Sep 2024 14:32:49 GMT, Roman Kennke wrote:
>> src/jdk.hotspot.agent/share/classes/sun/jvm/hotspot/oops/Oop.java line 169:
>>
>>> 167: } else {
>>> 168: visitor.doMetadata(klass, true);
>>> 169: }
>>
>> Why is there no `visitor.doMetadata()` call for the compa
On Mon, 26 Aug 2024 21:30:51 GMT, Chris Plummer wrote:
>> Roman Kennke has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix bit counts in GCForwarding
>
> src/jdk.hotspot.agent/share/classes/sun/jvm/hotspot/oops/Oop.java line 85:
>
>> 83
On Mon, 9 Sep 2024 14:47:28 GMT, Stefan Karlsson wrote:
>> src/hotspot/share/cds/filemap.cpp line 2508:
>>
>>> 2506:
>>> 2507: if (compact_headers() != UseCompactObjectHeaders) {
>>> 2508: log_info(cds)("The shared archive file's UseCompactObjectHeaders
>>> setting (%s)"
>>
>> Printing
On Fri, 30 Aug 2024 08:06:31 GMT, Stefan Karlsson wrote:
>> Roman Kennke has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix bit counts in GCForwarding
>
> src/hotspot/share/cds/filemap.cpp line 2507:
>
>> 2505: }
>> 2506:
>> 2507:
On Mon, 26 Aug 2024 21:52:58 GMT, Chris Plummer wrote:
>> Roman Kennke has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix bit counts in GCForwarding
>
> src/jdk.hotspot.agent/share/classes/sun/jvm/hotspot/oops/Oop.java line 169:
>
>> 1
On Tue, 27 Aug 2024 07:43:07 GMT, Hamlin Li wrote:
>> @Hamlin-Li : AFAIK, porting to linux-riscv platform has NOT been started
>> yet. To avoid duplicate work, please let me know if anyone is interested or
>> has been working on it :-)
>
> Yes, I'm interested in it. Thanks for raising the discu
On Fri, 23 Aug 2024 11:38:39 GMT, Hamlin Li wrote:
>> Roman Kennke has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix bit counts in GCForwarding
>
> src/hotspot/share/oops/oop.inline.hpp line 94:
>
>> 92:
>> 93: void oopDesc::init_mar
On Thu, 22 Aug 2024 20:08:43 GMT, Roman Kennke wrote:
>> This is the main body of the JEP 450: Compact Object Headers (Experimental).
>>
>> It is also a follow-up to #20640, which now also includes (and supersedes)
>> #20603 and #20605, plus the Tiny Class-Pointers parts that have been
>> prev
On Thu, 22 Aug 2024 20:08:43 GMT, Roman Kennke wrote:
>> This is the main body of the JEP 450: Compact Object Headers (Experimental).
>>
>> It is also a follow-up to #20640, which now also includes (and supersedes)
>> #20603 and #20605, plus the Tiny Class-Pointers parts that have been
>> prev
On Fri, 23 Aug 2024 16:23:19 GMT, Leonid Mesnik wrote:
>> Roman Kennke has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix bit counts in GCForwarding
>
> make/Images.gmk line 135:
>
>> 133: #
>> 134: # Param1 - VM variant (e.g., server,
On Thu, 29 Aug 2024 09:28:50 GMT, Stefan Karlsson wrote:
>> Roman Kennke has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix bit counts in GCForwarding
>
> src/hotspot/share/cds/archiveHeapWriter.cpp line 214:
>
>> 212: oopDesc::s
On Thu, 22 Aug 2024 20:08:43 GMT, Roman Kennke wrote:
>> This is the main body of the JEP 450: Compact Object Headers (Experimental).
>>
>> It is also a follow-up to #20640, which now also includes (and supersedes)
>> #20603 and #20605, plus the Tiny Class-Pointers parts that have been
>> prev
On Thu, 22 Aug 2024 20:08:43 GMT, Roman Kennke wrote:
>> This is the main body of the JEP 450: Compact Object Headers (Experimental).
>>
>> It is also a follow-up to #20640, which now also includes (and supersedes)
>> #20603 and #20605, plus the Tiny Class-Pointers parts that have been
>> prev
On Tue, 27 Aug 2024 05:37:30 GMT, Fei Yang wrote:
>> src/hotspot/cpu/riscv/c1_MacroAssembler_riscv.cpp line 170:
>>
>>> 168: mv(tmp1, (int32_t)(intptr_t)markWord::prototype().value());
>>> 169: sd(tmp1, Address(obj, oopDesc::mark_offset_in_bytes()));
>>> 170: // Todo UseCompactObjectHeaders
On Fri, 23 Aug 2024 18:42:28 GMT, Hamlin Li wrote:
>> Roman Kennke has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix bit counts in GCForwarding
>
> src/hotspot/cpu/riscv/c1_MacroAssembler_riscv.cpp line 170:
>
>> 168: mv(tmp1, (int3
On Thu, 22 Aug 2024 20:08:43 GMT, Roman Kennke wrote:
>> This is the main body of the JEP 450: Compact Object Headers (Experimental).
>>
>> It is also a follow-up to #20640, which now also includes (and supersedes)
>> #20603 and #20605, plus the Tiny Class-Pointers parts that have been
>> prev
On Fri, 23 Aug 2024 19:03:19 GMT, Leonid Mesnik wrote:
>> Roman Kennke has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix bit counts in GCForwarding
>
> test/hotspot/jtreg/runtime/cds/appcds/TestZGCWithCDS.java line 59:
>
>> 57: pu
On Thu, 22 Aug 2024 20:08:43 GMT, Roman Kennke wrote:
>> This is the main body of the JEP 450: Compact Object Headers (Experimental).
>>
>> It is also a follow-up to #20640, which now also includes (and supersedes)
>> #20603 and #20605, plus the Tiny Class-Pointers parts that have been
>> prev
On Thu, 22 Aug 2024 20:08:43 GMT, Roman Kennke wrote:
>> This is the main body of the JEP 450: Compact Object Headers (Experimental).
>>
>> It is also a follow-up to #20640, which now also includes (and supersedes)
>> #20603 and #20605, plus the Tiny Class-Pointers parts that have been
>> prev
On Thu, 22 Aug 2024 20:08:43 GMT, Roman Kennke wrote:
>> This is the main body of the JEP 450: Compact Object Headers (Experimental).
>>
>> It is also a follow-up to #20640, which now also includes (and supersedes)
>> #20603 and #20605, plus the Tiny Class-Pointers parts that have been
>> prev
On Thu, 22 Aug 2024 20:08:43 GMT, Roman Kennke wrote:
>> This is the main body of the JEP 450: Compact Object Headers (Experimental).
>>
>> It is also a follow-up to #20640, which now also includes (and supersedes)
>> #20603 and #20605, plus the Tiny Class-Pointers parts that have been
>> prev
> This is the main body of the JEP 450: Compact Object Headers (Experimental).
>
> It is also a follow-up to #20640, which now also includes (and supersedes)
> #20603 and #20605, plus the Tiny Class-Pointers parts that have been
> previously missing.
>
> Main changes:
> - Introduction of the (
35 matches
Mail list logo