On Thu, 29 Feb 2024 01:50:02 GMT, Alex Menkov wrote:
> Many NSK tests create socket channel for test/target interprocess
> communication.
> The change updates server side to listen only on loopback interface.
>
> Testing - all tests that use then functionality:
> - test/hotspot/jtreg/vmTestbas
On Wed, 28 Feb 2024 01:18:50 GMT, Kim Barrett wrote:
> Please review this change that renames some test .h files to .hpp. These
> files contain C++ code and should be named accordingly. Some of them contain
> uses of NULL, which we change to nullptr.
>
> The renamed files are:
>
> test/hotspo
On Thu, 29 Feb 2024 00:16:28 GMT, Kim Barrett wrote:
>> Please review this change that renames some test .h files to .hpp. These
>> files contain C++ code and should be named accordingly. Some of them contain
>> uses of NULL, which we change to nullptr.
>>
>> The renamed files are:
>>
>> test
On Thu, 29 Feb 2024 01:50:02 GMT, Alex Menkov wrote:
> Many NSK tests create socket channel for test/target interprocess
> communication.
> The change updates server side to listen only on loopback interface.
>
> Testing - all tests that use then functionality:
> - test/hotspot/jtreg/vmTestbas
On Thu, 29 Feb 2024 01:50:02 GMT, Alex Menkov wrote:
> Many NSK tests create socket channel for test/target interprocess
> communication.
> The change updates server side to listen only on loopback interface.
>
> Testing - all tests that use then functionality:
> - test/hotspot/jtreg/vmTestbas
> The implementation of the JVM TI `GetCurrentContendedMonitor()` does not
> match the spec. It can sometimes return an incorrect information about the
> contended monitor. Such a behavior does not match the function spec.
> With this update the `GetCurrentContendedMonitor()` is returning the mo
> The implementation of the JVM TI `GetObjectMonitorUsage` does not match the
> spec.
> The function returns the following structure:
>
>
> typedef struct {
> jthread owner;
> jint entry_count;
> jint waiter_count;
> jthread* waiters;
> jint notify_waiter_count;
> jthread
On Thu, 22 Feb 2024 19:46:58 GMT, Alex Menkov wrote:
> The change updates the test to throw an exception if expected
> AgentLoadException is not thrown
Marked as reviewed by sspitsyn (Reviewer).
-
PR Review: https://git.openjdk.org/jdk/pull/17971#pullrequestreview-1907875498
On Thu, 29 Feb 2024 01:50:02 GMT, Alex Menkov wrote:
> Many NSK tests create socket channel for test/target interprocess
> communication.
> The change updates server side to listen only on loopback interface.
>
> Testing - all tests that use then functionality:
> - test/hotspot/jtreg/vmTestbas
On Wed, 28 Feb 2024 22:04:16 GMT, Chris Plummer wrote:
> I can see that the synchronized for interruptorThread.interrupt() call will
> end up deadlocking...
It is one of the reasons I tried to suggest to get rid of the
`interruptorThread.interrupt()`. :-)
-
PR Review Comment: htt
On Wed, 28 Feb 2024 22:26:52 GMT, Chris Plummer wrote:
>> ok
>
> Actually there are quite a few cases of this in this test, and most are
> pre-existing. The test consistently does not use a space, and I see this is
> pretty common in other JDI tests. Do we have an official policy on this?
One
On Thu, 29 Feb 2024 00:16:28 GMT, Kim Barrett wrote:
>> Please review this change that renames some test .h files to .hpp. These
>> files contain C++ code and should be named accordingly. Some of them contain
>> uses of NULL, which we change to nullptr.
>>
>> The renamed files are:
>>
>> test
Many NSK tests create socket channel for test/target interprocess communication.
The change updates server side to listen only on loopback interface.
Testing - all tests that use then functionality:
- test/hotspot/jtreg/vmTestbase/nsk/jdb,
test/hotspot/jtreg/vmTestbase/nsk/jdi, test/hotspot/jtre
On Wed, 28 Feb 2024 14:15:25 GMT, Coleen Phillimore wrote:
>> test/hotspot/jtreg/serviceability/jvmti/vthread/FollowReferences/libVThreadStackRefTest.cpp
>> line 26:
>>
>>> 24: #include
>>> 25: #include
>>> 26: #include
>>
>> Should this be in quotes rather than <> ?
>
> Suggestion:
>
> #i
On Wed, 28 Feb 2024 14:18:58 GMT, Coleen Phillimore wrote:
>> Kim Barrett has updated the pull request incrementally with two additional
>> commits since the last revision:
>>
>> - add Oracle copyright
>> - fix busted copyright text
>
> test/hotspot/jtreg/vmTestbase/nsk/jvmti/GetClassStatus/g
On Wed, 28 Feb 2024 04:06:08 GMT, Guoxiong Li wrote:
>> Kim Barrett has updated the pull request incrementally with two additional
>> commits since the last revision:
>>
>> - add Oracle copyright
>> - fix busted copyright text
>
> test/hotspot/jtreg/serviceability/jvmti/thread/GetStackTrace/G
On Wed, 28 Feb 2024 14:11:49 GMT, Coleen Phillimore wrote:
>> test/hotspot/jtreg/serviceability/jvmti/events/SingleStep/singlestep01/libsinglestep01.cpp
>> line 28:
>>
>>> 26: #include
>>> 27: #include
>>> 28: #include "jvmti_common.hpp"
>>
>> The copyright of this file is wrong.
>>
>>> *
> Please review this change that renames some test .h files to .hpp. These
> files contain C++ code and should be named accordingly. Some of them contain
> uses of NULL, which we change to nullptr.
>
> The renamed files are:
>
> test/hotspot/jtreg/vmTestbase/nsk/share/aod/aod.h
> test/hotspot/j
On Wed, 28 Feb 2024 05:37:23 GMT, Chris Plummer wrote:
>> test/jdk/com/sun/jdi/InterruptHangTest.java line 134:
>>
>>> 132:
>>> 133: if (interruptorThread != null) {
>>> 134: synchronized(InterruptHangTarg.sync) {
>>
>> Nit: A space is missed after `synchronized` keyword.
>
On Wed, 28 Feb 2024 07:11:52 GMT, Serguei Spitsyn wrote:
>> Using the interrupt is carried over from the original version of the test. I
>> did consider replacing it, but opted to keep it in so there was one less
>> change in the test to review. I can do as you suggested if you wish.
>>
>> I d
> Fix numerous debug agent issues and testing deficiencies related to
> Thread.interrupt(). As a first read you should look at the description in the
> CR. More details in first comment below.
>
> Also, this PR is dependent on the fix for
> [JDK-8325187](https://bugs.openjdk.org/browse/JDK-8325
> Compiler Control (https://openjdk.org/jeps/165) provides method-context
> dependent control of the JVM compilers (C1 and C2). The active directive
> stack is built from the directive files passed with the
> `-XX:CompilerDirectivesFile` diagnostic command-line option and the
> Compiler.add_dir
On Thu, 22 Feb 2024 19:46:58 GMT, Alex Menkov wrote:
> The change updates the test to throw an exception if expected
> AgentLoadException is not thrown
Marked as reviewed by lmesnik (Reviewer).
-
PR Review: https://git.openjdk.org/jdk/pull/17971#pullrequestreview-1907369772
On Fri, 9 Feb 2024 18:40:04 GMT, Sebastian Lövdahl wrote:
>>> I'll still fix this. So, I should change the PR title to match JDK-8226919,
>>> and issue an `/issue remove` command for JDK-8307977, is that correct?
>>
>> Yes exactly, thanks.
>
> Thank you @kevinjwalls and @jerboaa for reviewing a
On Fri, 23 Feb 2024 21:55:15 GMT, Chris Plummer wrote:
> PerfMapTest.java issues the Compiler.perfmap jcmd with a filename argument to
> write the perfmap to. It does this in 3 different modes. 2 of the modes
> result in a perfmap file being left in the tmp directory that is not removed
> afte
On Fri, 23 Feb 2024 21:55:15 GMT, Chris Plummer wrote:
> PerfMapTest.java issues the Compiler.perfmap jcmd with a filename argument to
> write the perfmap to. It does this in 3 different modes. 2 of the modes
> result in a perfmap file being left in the tmp directory that is not removed
> afte
On Wed, 28 Feb 2024 01:18:50 GMT, Kim Barrett wrote:
> Please review this change that renames some test .h files to .hpp. These
> files contain C++ code and should be named accordingly. Some of them contain
> uses of NULL, which we change to nullptr.
>
> The renamed files are:
>
> test/hotspo
On Fri, 23 Feb 2024 21:55:15 GMT, Chris Plummer wrote:
> PerfMapTest.java issues the Compiler.perfmap jcmd with a filename argument to
> write the perfmap to. It does this in 3 different modes. 2 of the modes
> result in a perfmap file being left in the tmp directory that is not removed
> afte
On Wed, 28 Feb 2024 03:58:39 GMT, Guoxiong Li wrote:
>> Please review this change that renames some test .h files to .hpp. These
>> files contain C++ code and should be named accordingly. Some of them contain
>> uses of NULL, which we change to nullptr.
>>
>> The renamed files are:
>>
>> test
On Wed, 28 Feb 2024 01:18:50 GMT, Kim Barrett wrote:
> Please review this change that renames some test .h files to .hpp. These
> files contain C++ code and should be named accordingly. Some of them contain
> uses of NULL, which we change to nullptr.
>
> The renamed files are:
>
> test/hotspo
On Wed, 28 Feb 2024 14:13:58 GMT, Coleen Phillimore wrote:
>> Please review this change that renames some test .h files to .hpp. These
>> files contain C++ code and should be named accordingly. Some of them contain
>> uses of NULL, which we change to nullptr.
>>
>> The renamed files are:
>>
>
On Wed, 28 Feb 2024 07:32:47 GMT, RacerZ wrote:
>> Volker Simonis has updated the pull request incrementally with one
>> additional commit since the last revision:
>>
>> Fixed whitepspace in flag documentation
>
> Will this feature be incorporated into a lower version of JDK, like JDK 8?
@Ra
On Fri, 23 Feb 2024 21:55:15 GMT, Chris Plummer wrote:
> PerfMapTest.java issues the Compiler.perfmap jcmd with a filename argument to
> write the perfmap to. It does this in 3 different modes. 2 of the modes
> result in a perfmap file being left in the tmp directory that is not removed
> afte
On Fri, 26 Jan 2024 13:14:57 GMT, Volker Simonis wrote:
>> Currently we don't record dependencies on redefined methods (i.e.
>> `evol_method` dependencies) in JIT compiled methods if none of the
>> `can_redefine_classes`, `can_retransform_classes` or
>> `can_generate_breakpoint_events` JVMTI c
34 matches
Mail list logo