Re: RFR: JDK-8321565: [REDO] Heap dump does not contain virtual Thread stack references

2023-12-11 Thread David Holmes
On Tue, 12 Dec 2023 00:19:15 GMT, Alex Menkov wrote: >> src/hotspot/share/services/heapDumper.cpp line 1984: >> >>> 1982: // user space. >>> 1983: void DumpMerger::merge_file(char* path) { >>> 1984: assert(!SafepointSynchronize::is_at_safepoint(), "merging happens >>> outside safepoint"); >>

Re: RFR: JDK-8321565: [REDO] Heap dump does not contain virtual Thread stack references

2023-12-11 Thread Yi Yang
On Fri, 8 Dec 2023 22:29:12 GMT, Alex Menkov wrote: > Original fix for JDK-8299426 (Heap dump does not contain virtual Thread stack > references, #16665) caused failures of new test (added while #16665 was under > review): > test/hotspot/jtreg/compiler/c2/TestReduceAllocationAndHeapDump.java in

Re: RFR: 8311306: Test com/sun/management/ThreadMXBean/ThreadCpuTimeArray.java failed: out of expected range

2023-12-11 Thread Serguei Spitsyn
On Mon, 11 Dec 2023 11:33:08 GMT, Kevin Walls wrote: > Trivial test update to run in "othervm". This test has failed due to > interrupted threads: the interruption interferes with timing, but also the > test is designed to fail if interrupted. > > Other tests in the same directory have the s

Re: RFR: JDK-8319382: com/sun/jdi/JdwpAllowTest.java shows failures on AIX if prefixLen of mask is larger than 32 in IPv6 case

2023-12-11 Thread Alex Menkov
On Mon, 11 Dec 2023 14:38:08 GMT, Matthias Baesken wrote: >> A colleague contacted IBM about the different behavior of getaddrinfo on >> AIX (compared to Linux/macOS); maybe we have to adjust the result of the >> getaddrinfo call on AIX. > >> A colleague contacted IBM about the different beha

Re: RFR: JDK-8321565: [REDO] Heap dump does not contain virtual Thread stack references

2023-12-11 Thread Alex Menkov
On Mon, 11 Dec 2023 06:05:52 GMT, David Holmes wrote: >> Original fix for JDK-8299426 (Heap dump does not contain virtual Thread >> stack references, #16665) caused failures of new test (added while #16665 >> was under review): >> test/hotspot/jtreg/compiler/c2/TestReduceAllocationAndHeapDump.j

Re: RFR: 8314029: Add file name parameter to Compiler.perfmap [v8]

2023-12-11 Thread Yi-Fan Tsai
> `jcmd Compiler.perfmap` uses the hard-coded file name for a perf map: > `/tmp/perf-%d.map`. This change adds an optional argument for specifying a > file name. > > `jcmd PID help Compiler.perfmap` shows the following usage. > > > Compiler.perfmap > Write map file for Linux perf tool. > > Im

Re: RFR: 8314029: Add file name parameter to Compiler.perfmap [v7]

2023-12-11 Thread Chris Plummer
On Thu, 7 Dec 2023 22:49:55 GMT, Yi-Fan Tsai wrote: >> `jcmd Compiler.perfmap` uses the hard-coded file name for a perf map: >> `/tmp/perf-%d.map`. This change adds an optional argument for specifying a >> file name. >> >> `jcmd PID help Compiler.perfmap` shows the following usage. >> >> >>

Re: RFR: 8309271: A way to align already compiled methods with compiler directives [v14]

2023-12-11 Thread Dmitry Chuyko
> Compiler Control (https://openjdk.org/jeps/165) provides method-context > dependent control of the JVM compilers (C1 and C2). The active directive > stack is built from the directive files passed with the > `-XX:CompilerDirectivesFile` diagnostic command-line option and the > Compiler.add_dir

Re: RFR: 8321729: Remove 'orb' field in RMIConnector

2023-12-11 Thread Daniel Fuchs
On Mon, 11 Dec 2023 12:50:38 GMT, Kevin Walls wrote: > Tidyup change, looks like this field was not removed when IIOP was removed > from RMIConnector. > > The field is not required for interoperability: > with the field removed, I can still connect an older JMX client to a running > app with

Re: RFR: 8321729: Remove 'orb' field in RMIConnector

2023-12-11 Thread Roger Riggs
On Mon, 11 Dec 2023 12:50:38 GMT, Kevin Walls wrote: > Tidyup change, looks like this field was not removed when IIOP was removed > from RMIConnector. > > The field is not required for interoperability: > with the field removed, I can still connect an older JMX client to a running > app with

Re: RFR: JDK-8319382: com/sun/jdi/JdwpAllowTest.java shows failures on AIX if prefixLen of mask is larger than 32 in IPv6 case

2023-12-11 Thread Matthias Baesken
On Mon, 13 Nov 2023 11:43:08 GMT, Matthias Baesken wrote: > A colleague contacted IBM about the different behavior of getaddrinfo on AIX > (compared to Linux/macOS); maybe we have to adjust the result of the > getaddrinfo call on AIX. Haven't heard from them so far, hopefully we get an update

Re: RFR: 8321713: Harmonize executeTestJvm with create[Limited]TestJavaProcessBuilder [v3]

2023-12-11 Thread Leo Korinth
On Mon, 11 Dec 2023 14:06:43 GMT, Stefan Karlsson wrote: >> [JDK-8315097](https://bugs.openjdk.org/browse/JDK-8315097): 'Rename >> createJavaProcessBuilder' changed the name of the ProcessTools helper >> functions used to create `ProcessBuilder`s used to spawn new java test >> processes. >> >

Re: RFR: 8321713: Harmonize executeTestJvm with create[Limited]TestJavaProcessBuilder [v3]

2023-12-11 Thread Stefan Karlsson
> [JDK-8315097](https://bugs.openjdk.org/browse/JDK-8315097): 'Rename > createJavaProcessBuilder' changed the name of the ProcessTools helper > functions used to create `ProcessBuilder`s used to spawn new java test > processes. > > We now have `createTestJavaProcessBuilder` and > `createLimite

Re: RFR: 8321713: Harmonize executeTestJvm with create[Limited]TestJavaProcessBuilder [v2]

2023-12-11 Thread Stefan Karlsson
> [JDK-8315097](https://bugs.openjdk.org/browse/JDK-8315097): 'Rename > createJavaProcessBuilder' changed the name of the ProcessTools helper > functions used to create `ProcessBuilder`s used to spawn new java test > processes. > > We now have `createTestJavaProcessBuilder` and > `createLimite

RFR: 8321729: Remove 'orb' field in RMIConnector

2023-12-11 Thread Kevin Walls
Tidyup change, looks like this field was not removed when IIOP was removed from RMIConnector. The field is not required for interoperability: with the field removed, I can still connect an older JMX client to a running app with the updated JDK. Since the JDK9 change https://hg.openjdk.org/jdk9

RFR: 8311306: Test com/sun/management/ThreadMXBean/ThreadCpuTimeArray.java failed: out of expected range

2023-12-11 Thread Kevin Walls
Trivial test update to run in "othervm". This test has failed due to interrupted threads: the interruption interferes with timing, but also the test is designed to fail if interrupted. Other tests in the same directory have the same requirement that threads/sleeps are not interrupted, and the

RFR: 8321713: Harmonize executeTestJvm with create[Limited]TestJavaProcessBuilder

2023-12-11 Thread Stefan Karlsson
[JDK-8315097](https://bugs.openjdk.org/browse/JDK-8315097): 'Rename createJavaProcessBuilder' changed the name of the ProcessTools helper functions used to create `ProcessBuilder`s used to spawn new java test processes. We now have `createTestJavaProcessBuilder` and `createLimitedTestJavaProcess