On Thu, 26 Jan 2023 18:07:42 GMT, Mikael Vidstedt wrote:
>> Xue-Lei Andrew Fan has updated the pull request incrementally with one
>> additional commit since the last revision:
>>
>> incorrect use of sizeof
>
> test/jdk/sun/management/windows/exerevokeall.c line 102:
>
>> 100:
>> 101: /
> The sprintf is deprecated in Xcode 14 because of security concerns. The issue
> was addressed in
> [JDK-8296812](https://bugs.openjdk.org/browse/JDK-8296812)/[JDK-8299378](https://bugs.openjdk.org/browse/JDK-8299378)/[JDK-8299635](https://bugs.openjdk.org/browse/JDK-8299635),
> but the test wa
> PR adds fix "8284027: vmTestbase/nsk/jvmti/GetAllThreads/allthr001/ is
> failing" to new test and remove duplication.
Leonid Mesnik has updated the pull request incrementally with two additional
commits since the last revision:
- cleanup
- used get_thread_name
-
Changes:
- a
PR adds fix "8284027: vmTestbase/nsk/jvmti/GetAllThreads/allthr001/ is failing"
to new test and remove duplication.
-
Commit messages:
- cp
- fix
Changes: https://git.openjdk.org/jdk/pull/12240/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=12240&range=00
Issue: https:/
On Fri, 27 Jan 2023 02:13:28 GMT, David Holmes wrote:
> > I'd expect that at least java.util.Date and java.lang.ProcessBuilder have
> > the same verification requirement.
>
> Generally speaking yes - they are both loaded by bootstrap loader and so
> would both have verification disabled by def
On Wed, 25 Jan 2023 04:14:24 GMT, Alex Menkov wrote:
>I'd expect that at least java.util.Date and java.lang.ProcessBuilder have the
>same verification requirement.
Generally speaking yes - they are both loaded by bootstrap loader and so would
both have verification disabled by default. Bt as y
On Thu, 26 Jan 2023 15:02:54 GMT, Johan Sjölen wrote:
>> Do the conversion in the share/services/ sub-directory and all of its files.
>
> Johan Sjölen has updated the pull request incrementally with one additional
> commit since the last revision:
>
> plummercj's fixes
Marked as reviewed by
On Thu, 26 Jan 2023 12:34:18 GMT, Roman Kennke wrote:
>> This change adds a fast-locking scheme as an alternative to the current
>> stack-locking implementation. It retains the advantages of stack-locking
>> (namely fast locking in uncontended code-paths), while avoiding the overload
>> of the
On Tue, 24 Jan 2023 20:50:00 GMT, Damon Nguyen wrote:
> Open l10n drop. Files have been updated with translated versions. Whitespace
> tool has been ran on files.
> All tests passed
This pull request has now been integrated.
Changeset: a67b1e77
Author:Damon Nguyen
Committer: Naoto Sato
U
On Thu, 26 Jan 2023 06:38:00 GMT, Xue-Lei Andrew Fan wrote:
> The sprintf is deprecated in Xcode 14 because of security concerns. The issue
> was addressed in
> [JDK-8296812](https://bugs.openjdk.org/browse/JDK-8296812)/[JDK-8299378](https://bugs.openjdk.org/browse/JDK-8299378)/[JDK-8299635](ht
On Wed, 25 Jan 2023 11:45:47 GMT, Johan Sjölen wrote:
> Hi, this PR changes all occurrences of NULL to nullptr for the subdirectory
> share/memory/. Unfortunately the script that does the change isn't perfect,
> and so we
> need to comb through these manually to make sure nothing has gone wrong
On Thu, 26 Jan 2023 16:11:14 GMT, Johan Sjölen wrote:
>> Hi, this PR changes all occurrences of NULL to nullptr for the subdirectory
>> share/prims/. Unfortunately the script that does the change isn't perfect,
>> and so we
>> need to comb through these manually to make sure nothing has gone wr
Hi, this PR changes all occurrences of NULL to nullptr for the subdirectory
share/prims/. Unfortunately the script that does the change isn't perfect, and
so we
need to comb through these manually to make sure nothing has gone wrong. I also
review these changes but things slip past my eyes somet
On Wed, 25 Jan 2023 11:47:05 GMT, Johan Sjölen wrote:
> Hi, this PR changes all occurrences of NULL to nullptr for the subdirectory
> share/prims/. Unfortunately the script that does the change isn't perfect,
> and so we
> need to comb through these manually to make sure nothing has gone wrong.
> Hi, this PR changes all occurrences of NULL to nullptr for the subdirectory
> share/memory/. Unfortunately the script that does the change isn't perfect,
> and so we
> need to comb through these manually to make sure nothing has gone wrong. I
> also review these changes but things slip past my
On Thu, 26 Jan 2023 15:04:06 GMT, Johan Sjölen wrote:
>> src/hotspot/share/memory/metaspace/blockTree.hpp line 228:
>>
>>> 226: DEBUG_ONLY(check_node(insertion_point);)
>>> 227: if (n->_word_size == insertion_point->_word_size) {
>>> 228: add_to_list(n, insertion_point); // p
On Thu, 26 Jan 2023 09:48:06 GMT, Thomas Stuefe wrote:
>Small nit. Do we have a unified naming scheme for comments?
Yeah, I forgot to update the PR message with all of the info. If you check now
you can see what's been decided upon. The discussions can be found in previous
PRs, I can link to t
On Wed, 25 Jan 2023 18:30:00 GMT, Chris Plummer wrote:
>> Johan Sjölen has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> plummercj's fixes
>
> Changes requested by cjplummer (Reviewer).
Thanks @plummercj , I've pushed your fixes.
---
> Do the conversion in the share/services/ sub-directory and all of its files.
Johan Sjölen has updated the pull request incrementally with one additional
commit since the last revision:
plummercj's fixes
-
Changes:
- all: https://git.openjdk.org/jdk/pull/12189/files
- new: h
On Thu, 19 Jan 2023 12:09:27 GMT, Roman Kennke wrote:
> > I always change the flags in code for the reasons David state and I can't
> > forget to add any flags.
> > (Test batch is stilling running, no failures except
> > MonitorInflationTest.java)
>
> Ok, right.
>
> I just re-ran tier1-3 with
On Wed, 25 Jan 2023 15:56:49 GMT, Coleen Phillimore wrote:
> We thought we didn't need the keep-alive call but we do for heap walking.
> Tested with failing test case locally, and tier1-4 in progress.
This pull request has now been integrated.
Changeset: 3f633814
Author:Coleen Phillimore
U
On Wed, 25 Jan 2023 15:56:49 GMT, Coleen Phillimore wrote:
> We thought we didn't need the keep-alive call but we do for heap walking.
> Tested with failing test case locally, and tier1-4 in progress.
Thanks Erik and Robbin!
-
PR: https://git.openjdk.org/jdk/pull/12202
On Wed, 25 Jan 2023 15:56:49 GMT, Coleen Phillimore wrote:
> We thought we didn't need the keep-alive call but we do for heap walking.
> Tested with failing test case locally, and tier1-4 in progress.
Thanks!
-
Marked as reviewed by rehn (Reviewer).
PR: https://git.openjdk.org/jdk
> This change adds a fast-locking scheme as an alternative to the current
> stack-locking implementation. It retains the advantages of stack-locking
> (namely fast locking in uncontended code-paths), while avoiding the overload
> of the mark word. That overloading causes massive problems with Li
On Mon, 23 Jan 2023 20:58:20 GMT, Chris Plummer wrote:
> Remove removeListener() methods. They are not called.
Marked as reviewed by kevinw (Committer).
-
PR: https://git.openjdk.org/jdk/pull/12151
The sprintf is deprecated in Xcode 14 because of security concerns. The issue
was addressed in
[JDK-8296812](https://bugs.openjdk.org/browse/JDK-8296812)/[JDK-8299378](https://bugs.openjdk.org/browse/JDK-8299378)/[JDK-8299635](https://bugs.openjdk.org/browse/JDK-8299635),
but the test was not fu
On Wed, 25 Jan 2023 11:45:47 GMT, Johan Sjölen wrote:
> Do the conversion in the share/memory/ sub-directory and all of its files.
Metaspace changes are good.
src/hotspot/share/memory/metaspace/blockTree.hpp line 228:
> 226: DEBUG_ONLY(check_node(insertion_point);)
> 227: if (n->_w
On Wed, 25 Jan 2023 11:45:47 GMT, Johan Sjölen wrote:
> Do the conversion in the share/memory/ sub-directory and all of its files.
Marked as reviewed by stefank (Reviewer).
src/hotspot/share/memory/guardedMemory.hpp line 196:
> 194:*/
> 195: void* wrap_with_guards(void* base_ptr, size_t
28 matches
Mail list logo