Re: RFR: JDK-8325189: Enable this-escape javac warning in java.base

2024-02-02 Thread Joe Darcy
On Fri, 2 Feb 2024 23:38:41 GMT, Joe Darcy wrote: > In its initial form, the changes are tested on Linux. Later on, I'll do > cross-platform builds to make sure there aren't any, say, windows-specific > changes that are needed as well. > PS Builds pass on all platforms (linux, mac, and window

RFR: JDK-8325189: Enable this-escape javac warning in java.base

2024-02-02 Thread Joe Darcy
After the "this-escape" lint warning was added to javac (JDK-8015831), the base module was not updated to be able to compile with this warning enabled. This PR makes the necessary changes to allow the base module to build with the warning enabled. - Commit messages: - JDK-8325189:

Re: RFR: JDK-8325189: Enable this-escape javac warning in java.base

2024-02-02 Thread Joe Darcy
On Fri, 2 Feb 2024 23:36:41 GMT, Joe Darcy wrote: > After the "this-escape" lint warning was added to javac (JDK-8015831), the > base module was not updated to be able to compile with this warning enabled. > This PR makes the necessary changes to allow the base module to build with > the warni

Re: RFR: 8321274: Rename ZipEntry.extraAttributes to ZipEntry.externalAttributes [v2]

2024-02-02 Thread Lance Andersen
On Fri, 2 Feb 2024 20:19:51 GMT, Eirik Bjørsnøs wrote: > > I think the change is OK, any reason to not make it > > `externalFileAttributes`? > > None other than length / verbosity. But since this refers to the _attributes > of the external file_, dropping any name element also loses some seman

Re: RFR: 8320362: Load anchor certificates from Keychain keystore [v5]

2024-02-02 Thread Alexey Bakhtin
On Thu, 1 Feb 2024 21:07:32 GMT, Weijun Wang wrote: >> Alexey Bakhtin has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Update CheckMacOSKeyChainTrust test > > test/jdk/java/security/KeyStore/CheckMacOSKeyChainTrust.java line 41: > >> 39:

Re: RFR: 8320362: Load anchor certificates from Keychain keystore [v6]

2024-02-02 Thread Alexey Bakhtin
> Please review the proposed fix. > > The patch loads system root certificates from the MacOS Keychain with > TrustSettings. > It allows to build a trusted certificate path using the MacOS Keychain store > only. Alexey Bakhtin has updated the pull request incrementally with one additional comm

Re: RFR: 8320362: Load anchor certificates from Keychain keystore [v5]

2024-02-02 Thread Alexey Bakhtin
On Fri, 2 Feb 2024 19:37:18 GMT, Alexey Bakhtin wrote: > Will KEYCHAINSTORE-ROOT contains trusted certs inside KEYCHAINSTORE? I tried > on my machine and there are some items not in `security dump-trust-settings > -s`. `security dump-trust-settings -s` returns only predefined root certificates.

Re: RFR: 8321274: Rename ZipEntry.extraAttributes to ZipEntry.externalAttributes [v2]

2024-02-02 Thread Lance Andersen
On Tue, 30 Jan 2024 16:17:13 GMT, Eirik Bjørsnøs wrote: >> Please consider this PR which suggests we rename `ZipEntry.extraAttributes` >> to `ZipEntry.externalAttributes`. >> >> This field was introduced in >> [JDK-8218021](https://bugs.openjdk.org/browse/JDK-8218021), originally under >> the

Re: RFR: 8320362: Load anchor certificates from Keychain keystore [v5]

2024-02-02 Thread Alexey Bakhtin
On Thu, 1 Feb 2024 21:36:51 GMT, Weijun Wang wrote: > Will KEYCHAINSTORE-ROOT contains trusted certs inside KEYCHAINSTORE? I tried > on my machine and there are some items not in `security dump-trust-settings > -s`. I've found an issue in the original implementation that prevents adding diffe

Re: RFR: 8324648: Avoid NoSuchMethodError when instantiating NativePRNG

2024-02-02 Thread Weijun Wang
On Wed, 24 Jan 2024 15:42:05 GMT, Oli Gillespie wrote: > A typical call to `new SecureRandom()` is slowed down by looking for a > constructor in NativePRNG which takes `java.security.SecureRandomParameters`. > NativePRNG does not have such a constructor, so the search fails > [here](https://gi

Re: RFR: 8320362: Load anchor certificates from Keychain keystore [v5]

2024-02-02 Thread Weijun Wang
On Thu, 1 Feb 2024 22:08:16 GMT, Alexey Bakhtin wrote: >> test/jdk/java/security/KeyStore/CheckMacOSKeyChainTrust.java line 55: >> >>> 53: // check user and admin trustsettings to find distrusted >>> certs >>> 54: loadUser(false); >>> 55: loadAdmin(false); >>

Integrated: JDK-8318105 [jmh] the test java.security.HSS failed with 2 active threads

2024-02-02 Thread Mark Powers
On Tue, 31 Oct 2023 18:16:11 GMT, Mark Powers wrote: > https://bugs.openjdk.org/browse/JDK-8318105 This pull request has now been integrated. Changeset: 38c01971 Author:Mark Powers URL: https://git.openjdk.org/jdk/commit/38c01971ff1c440d8c7ef4bc3432e5b9797ae708 Stats: 224 lines