Re: RFR: 8265372: Simplify PKCS9Attribute [v2]

2024-01-09 Thread Valerie Peng
On Wed, 3 Jan 2024 20:39:57 GMT, Ben Perez wrote: >> Refactored PKCS9Attribute to use a hash map instead of multiple arrays. The >> key for the hash map is an `ObjectIdentifier` and the values are a record >> `AttributeInfo` that stores the information previously contained in the >> arrays `PK

Re: RFR: 8265372: Simplify PKCS9Attribute [v2]

2024-01-09 Thread Valerie Peng
On Thu, 4 Jan 2024 21:04:12 GMT, Sean Mullan wrote: >> Ben Perez has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Minor fixes to make the code more readable, inlined init(), removed >> PKCS9Attributes.getAttributes() > > src/java.base/sh

Re: RFR: 8265372: Simplify PKCS9Attribute [v2]

2024-01-09 Thread Valerie Peng
On Wed, 3 Jan 2024 20:39:57 GMT, Ben Perez wrote: >> Refactored PKCS9Attribute to use a hash map instead of multiple arrays. The >> key for the hash map is an `ObjectIdentifier` and the values are a record >> `AttributeInfo` that stores the information previously contained in the >> arrays `PK

Re: RFR: 8265372: Simplify PKCS9Attribute [v2]

2024-01-09 Thread Valerie Peng
On Wed, 3 Jan 2024 20:39:57 GMT, Ben Perez wrote: >> Refactored PKCS9Attribute to use a hash map instead of multiple arrays. The >> key for the hash map is an `ObjectIdentifier` and the values are a record >> `AttributeInfo` that stores the information previously contained in the >> arrays `PK

Re: RFR: 8265372: Simplify PKCS9Attribute [v2]

2024-01-09 Thread Valerie Peng
On Thu, 21 Dec 2023 16:46:54 GMT, Weijun Wang wrote: >> Ben Perez has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Minor fixes to make the code more readable, inlined init(), removed >> PKCS9Attributes.getAttributes() > > src/java.base/s

Re: RFR: 8265372: Simplify PKCS9Attribute [v2]

2024-01-09 Thread Valerie Peng
On Thu, 4 Jan 2024 20:44:01 GMT, Sean Mullan wrote: >> Ben Perez has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Minor fixes to make the code more readable, inlined init(), removed >> PKCS9Attributes.getAttributes() > > src/java.base/sh

Re: RFR: 8322971: KEM.getInstance() should check if a 3rd-party security provider is signed

2024-01-09 Thread Valerie Peng
On Wed, 3 Jan 2024 20:41:06 GMT, Weijun Wang wrote: > `KEM.getInstance` now checks if the implementation is from a signed provider > if it's not builtin to JDK. > > Several adjustments to the test: > 1. Put one impl in `SunEC` to pretend it's builtin. This is necessary to test > for provider s

Re: RFR: JDK-8319122: Improve documentation of various Zip-file related APIs [v3]

2024-01-09 Thread Yakov Shafranovich
> The various Zip/Jar-file related Java APIs have some long-standing > differences or peculiarities with respect to the ZIP-file specification or > compared to other implementations which should be documented in the API-doc. > This documents the following: > - Cache of JAR files in JarURLConnect

Re: RFR: JDK-8319122: Improve documentation of various Zip-file related APIs [v2]

2024-01-09 Thread Yakov Shafranovich
On Mon, 13 Nov 2023 18:11:12 GMT, Alan Bateman wrote: >> That would probably also involve taking existing documentation such as the >> note about not opening entries with "."/"..", and the POSIX permissions >> mappings? Would it make sense to split the rest of the changes in this PR >> from th

Re: RFR: JDK-8319122: Improve documentation of various Zip-file related APIs [v2]

2024-01-09 Thread Yakov Shafranovich
On Wed, 22 Nov 2023 22:23:18 GMT, Yakov Shafranovich wrote: >> src/java.base/share/classes/java/util/zip/ZipInputStream.java line 77: >> >>> 75: * >>> 76: * Whenever possible, {@linkplain ZipFile} should be used for parsing >>> ZIP >>> 77: * archives since it correctly reads data from the ce

Re: RFR: 8322971: KEM.getInstance() should check if a 3rd-party security provider is signed

2024-01-09 Thread Sean Mullan
On Wed, 3 Jan 2024 20:41:06 GMT, Weijun Wang wrote: > `KEM.getInstance` now checks if the implementation is from a signed provider > if it's not builtin to JDK. > > Several adjustments to the test: > 1. Put one impl in `SunEC` to pretend it's builtin. This is necessary to test > for provider s

Re: RFR: 8275338: Add JFR events for notable serialization situations [v12]

2024-01-09 Thread Daniel Fuchs
On Tue, 9 Jan 2024 10:42:58 GMT, Raffaello Giulietti wrote: >> src/java.base/share/classes/java/io/SerializationMisdeclarationChecker.java >> line 87: >> >>> 85: } >>> 86: if (cl.isEnum()) { >>> 87: commitEvent(cl, SUID_NAME + " in an enum class is not >>> effectiv

Re: RFR: 8310813: Simplify and modernize equals, hashCode, and compareTo for BigInteger [v10]

2024-01-09 Thread Roger Riggs
On Tue, 2 Jan 2024 14:37:27 GMT, Pavel Rappo wrote: >> Please review this PR to use modern APIs and language features to simplify >> equals, hashCode, and compareTo for BigInteger. If you have any performance >> concerns, please raise them. >> >> This PR is cherry-picked from a bigger, not-yet

Re: RFR: 8310813: Simplify and modernize equals, hashCode, and compareTo for BigInteger [v10]

2024-01-09 Thread Raffaello Giulietti
On Tue, 2 Jan 2024 14:37:27 GMT, Pavel Rappo wrote: >> Please review this PR to use modern APIs and language features to simplify >> equals, hashCode, and compareTo for BigInteger. If you have any performance >> concerns, please raise them. >> >> This PR is cherry-picked from a bigger, not-yet

Re: RFR: 8275338: Add JFR events for notable serialization situations [v12]

2024-01-09 Thread Raffaello Giulietti
On Mon, 8 Jan 2024 18:38:52 GMT, Roger Riggs wrote: >> Raffaello Giulietti has updated the pull request with a new target base due >> to a merge or a rebase. The incremental webrev excludes the unrelated >> changes brought in by the merge/rebase. The pull request contains 15 >> additional comm

Re: RFR: 8275338: Add JFR events for notable serialization situations [v12]

2024-01-09 Thread Raffaello Giulietti
On Mon, 8 Jan 2024 18:15:36 GMT, Roger Riggs wrote: >> Raffaello Giulietti has updated the pull request with a new target base due >> to a merge or a rebase. The incremental webrev excludes the unrelated >> changes brought in by the merge/rebase. The pull request contains 15 >> additional comm