Re: RFR: 8308453: Convert JKS test keystores in test/jdk/javax/net/ssl/etc to PKCS12 [v7]

2023-10-26 Thread Kevin Driver
> JDK-8308453: JSSE regression test keystore migration from JKS to PKCS12 Kevin Driver has updated the pull request incrementally with one additional commit since the last revision: Security Manager won't let you explicitly set the type here for some reason - Changes: - all:

Integrated: 8318096: Introduce AsymmetricKey interface with a getParams method

2023-10-26 Thread Weijun Wang
On Tue, 17 Oct 2023 15:30:03 GMT, Weijun Wang wrote: > Create a parent interface `AsymmetricKey` for `PublicKey` and `PrivateKey` > and add a `getParams` method there. This makes it available to all current > and future public and private keys. > > No test. Might add one. This pull request ha

Re: RFR: 8318096: Introduce AsymmetricKey interface with a getParams method [v6]

2023-10-26 Thread Anthony Scarpino
On Thu, 26 Oct 2023 17:37:01 GMT, Weijun Wang wrote: >> Create a parent interface `AsymmetricKey` for `PublicKey` and `PrivateKey` >> and add a `getParams` method there. This makes it available to all current >> and future public and private keys. >> >> No test. Might add one. > > Weijun Wang

Re: RFR: 8308453: Convert JKS test keystores in test/jdk/javax/net/ssl/etc to PKCS12 [v6]

2023-10-26 Thread Kevin Driver
> JDK-8308453: JSSE regression test keystore migration from JKS to PKCS12 Kevin Driver has updated the pull request incrementally with one additional commit since the last revision: additional updates to explicitly use PKCS12 - Changes: - all: https://git.openjdk.org/jdk/pull/1

Re: RFR: 8311596: Add separate system properties for TLS server and client for maximum chain length [v7]

2023-10-26 Thread Hai-May Chao
> Please review the enhancement for JDK-8311596 and its CSR JDK-8313236. Thank > you. Hai-May Chao has updated the pull request incrementally with one additional commit since the last revision: Change property names to clearly indicate client side and server side - Changes: -

Re: RFR: 8318096: Introduce AsymmetricKey interface with a getParams method [v6]

2023-10-26 Thread Sean Mullan
On Thu, 26 Oct 2023 17:37:01 GMT, Weijun Wang wrote: >> Create a parent interface `AsymmetricKey` for `PublicKey` and `PrivateKey` >> and add a `getParams` method there. This makes it available to all current >> and future public and private keys. >> >> No test. Might add one. > > Weijun Wang

Re: RFR: 8318096: Introduce AsymmetricKey interface with a getParams method [v6]

2023-10-26 Thread Weijun Wang
> Create a parent interface `AsymmetricKey` for `PublicKey` and `PrivateKey` > and add a `getParams` method there. This makes it available to all current > and future public and private keys. > > No test. Might add one. Weijun Wang has updated the pull request incrementally with one additional

Re: RFR: 8318096: Introduce AsymmetricKey interface with a getParams method [v5]

2023-10-26 Thread Weijun Wang
On Thu, 26 Oct 2023 17:08:27 GMT, Sean Mullan wrote: >> Weijun Wang has updated the pull request incrementally with one additional >> commit since the last revision: >> >> use @inheritDoc > > src/java.base/share/classes/java/security/interfaces/RSAPrivateKey.java line > 74: > >> 72: */

Re: RFR: 8318096: Introduce AsymmetricKey interface with a getParams method [v5]

2023-10-26 Thread Sean Mullan
On Thu, 26 Oct 2023 17:23:26 GMT, Weijun Wang wrote: >> src/java.base/share/classes/java/security/interfaces/RSAPrivateKey.java line >> 74: >> >>> 72: */ >>> 73: @Override >>> 74: default AlgorithmParameterSpec getParams() { >> >> What is the benefit of overriding this method if i

Re: RFR: 8318096: Introduce AsymmetricKey interface with a getParams method [v5]

2023-10-26 Thread Sean Mullan
On Thu, 26 Oct 2023 02:43:14 GMT, Weijun Wang wrote: >> Create a parent interface `AsymmetricKey` for `PublicKey` and `PrivateKey` >> and add a `getParams` method there. This makes it available to all current >> and future public and private keys. >> >> No test. Might add one. > > Weijun Wang

Integrated: 8318689: jtreg is confused when folder name is the same as the test name

2023-10-26 Thread Weijun Wang
On Mon, 23 Oct 2023 21:07:09 GMT, Weijun Wang wrote: > Rename the test. This pull request has now been integrated. Changeset: a9b31b58 Author:Weijun Wang URL: https://git.openjdk.org/jdk/commit/a9b31b587c7487b773debde1ce2227884959 Stats: 2 lines in 1 file changed: 0 ins; 0 d

Re: RFR: 8318689: jtreg is confused when folder name is the same as the test name

2023-10-26 Thread Sean Mullan
On Mon, 23 Oct 2023 21:07:09 GMT, Weijun Wang wrote: > Rename the test. Marked as reviewed by mullan (Reviewer). - PR Review: https://git.openjdk.org/jdk/pull/16323#pullrequestreview-1700078879

Re: RFR: 8315097: Rename createJavaProcessBuilder [v7]

2023-10-26 Thread Roger Riggs
On Wed, 25 Oct 2023 08:44:29 GMT, Leo Korinth wrote: >> This pull request renames `createJavaProcessBuilder` to >> `createLimitedTestJavaProcessBuilder` and renames `createTestJvm` to >> `createTestJavaProcessBuilder`. Both are implemented through a private >> `createJavaProcessBuilder`. It al

Re: RFR: 8315097: Rename createJavaProcessBuilder [v7]

2023-10-26 Thread Leo Korinth
On Wed, 25 Oct 2023 08:44:29 GMT, Leo Korinth wrote: >> This pull request renames `createJavaProcessBuilder` to >> `createLimitedTestJavaProcessBuilder` and renames `createTestJvm` to >> `createTestJavaProcessBuilder`. Both are implemented through a private >> `createJavaProcessBuilder`. It al

Re: RFR: 8009550: PlatformPCSC should load versioned so [v2]

2023-10-26 Thread Thomas Stuefe
On Thu, 26 Oct 2023 14:19:32 GMT, Andrew John Hughes wrote: >>> > Hi @gnu-andrew, >>> > in your last example, why does it look for both arm and x64 packages? And >>> > why for kFreeBsd? I see you have both hardcoded, why? >>> > I would expect it only to attempt and pick up the architecture and O

Re: RFR: 8009550: PlatformPCSC should load versioned so [v2]

2023-10-26 Thread Andrew John Hughes
On Wed, 30 Aug 2023 06:25:44 GMT, Thomas Stuefe wrote: >>> Changes look fine. I submitted a mach5 test job just in case. Will approve >>> once the test job passes. BTW, I added a noreg-other label since there is >>> no regression test for this change. >> >> Thanks. Yes, I don't see how we can

Re: RFR: 8318486: Rename JavaLangAccess.xxNoRepl to xxReportError [v2]

2023-10-26 Thread Andrey Turbanov
On Fri, 20 Oct 2023 02:29:15 GMT, Chen Liang wrote: >> Please review a patch that renames `JavaLangAccess::xxNoRepl` to >> `xxReportError` to explicitly indicate these APIs report encoding errors. >> >> The old "NoRepl" suffix presumably means "No Replacement", but it has been >> misunderstood