Thank you Mark. I'll contribute to the repo when I find time.
Thanks
Deepak Bala
On Mon, Sep 17, 2012 at 5:45 AM, Mark Phillips wrote:
> Addendum:
>
> In the interest of completeness, it's worth noting that the Erlang
> builtins are here:
>
> https://github.com/basho/riak_kv/blob/master/src/ria
Addendum:
In the interest of completeness, it's worth noting that the Erlang
builtins are here:
https://github.com/basho/riak_kv/blob/master/src/riak_kv_mapreduce.erl
Mark
On Sun, Sep 16, 2012 at 5:08 PM, Mark Phillips wrote:
> Hi Deepak,
>
> I can answer one of two questions here...
>
> On Fr
Hi Deepak,
I can answer one of two questions here...
On Fri, Sep 14, 2012 at 9:42 AM, Deepak Balasubramanyam
wrote:
> Thanks for the tip Russell. I managed to get this done.
>
> I have one more question and a suggestion.
>
> Is the name keyData a misnomer in the mapping function -> function(val
Thanks for the tip Russell. I managed to get this done.
I have one more question and a suggestion.
- Is the name keyData a misnomer in the mapping function -> function(
value, keyData, arg) ? keyData is a String that carries the bucket
name. The value object carries more information.
On 14 Sep 2012, at 14:24, Deepak Balasubramanyam wrote:
> Hi,
>
> I've written a map reduce query on the riak java client like so...
>
> client.mapReduce(BUCKET).addKeyFilter(keyFilter)
> .addLinkPhase(BUCKET, "_", false)
> .addMapPhase(new NamedJSFunctio
Hi,
I've written a map reduce query on the riak java client like so...
client.mapReduce(BUCKET).addKeyFilter(keyFilter)
.addLinkPhase(BUCKET, "_", false)
.addMapPhase(new NamedJSFunction("Riak.mapValuesJson"),
false)
.addReducePhase(phas